• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

General [Moto G Play](2021)(guamna) Stock firmware

Search This thread

residentorca

Senior Member
Jan 24, 2011
270
72
Seattle
Moto G Play
Yes, this was with a T-Mobile phone. You unlock the bootloader, take boot.img from the lolinet link, patch it in Magisk, and flash through fastboot.
Thanks for sharing this. I have created the patched boot image and am ready to flash. Does this device have A/B partition for which the patched boot image needs to be flashed to both partitions? Or just single partition?
 

fddm

Senior Member
Feb 24, 2011
180
127
Thanks for sharing this. I have created the patched boot image and am ready to flash. Does this device have A/B partition for which the patched boot image needs to be flashed to both partitions? Or just single partition?
It uses "boot_a", fastboot will default to it if you flash to "boot". A/B isn't really a concern with stock firmware and I always keep "boot_b" stock as a backup.
 
  • Like
Reactions: residentorca

residentorca

Senior Member
Jan 24, 2011
270
72
Seattle
Moto G Play
It uses "boot_a", fastboot will default to it if you flash to "boot". A/B isn't really a concern with stock firmware and I always keep "boot_b" stock as a backup.
On my device, flashing to "boot" resulted in the patched image going to "boot_b". Upon rebooting, I could not access the lock screen (which may or may not have been related) so I reinstalled the stock OS and re-flashed the patched image to "boot_a", which worked. Thanks again for your help.
 

fddm

Senior Member
Feb 24, 2011
180
127
Which module did you use?
I just make my own depending on what I need. This one disables nondisable, preinstall, tether provisioning, and system upgrades:

I'll usally add some google apps, modified apns-conf.xml, kernel modules, stuff like that. Magisk is really easy and powerful if you spend just a little time learning how to use it.
 

residentorca

Senior Member
Jan 24, 2011
270
72
Seattle
Moto G Play
I just make my own depending on what I need. This one disables nondisable, preinstall, tether provisioning, and system upgrades:

I'll usally add some google apps, modified apns-conf.xml, kernel modules, stuff like that. Magisk is really easy and powerful if you spend just a little time learning how to use it.
Thanks for sharing your custom mod and for the explanation!
 

residentorca

Senior Member
Jan 24, 2011
270
72
Seattle
Moto G Play
I just make my own depending on what I need. This one disables nondisable, preinstall, tether provisioning, and system upgrades:
Thanks again for sharing. I'm having issues trying to install your mod. In Magisk whan I navigate to your zip file and select it to install, nothing happens. The MD5 checksum of the zip file I'm trying to install is 78c6c276205501b417a7f8c3d8de115a.
 

fddm

Senior Member
Feb 24, 2011
180
127
Thanks again for sharing. I'm having issues trying to install your mod. In Magisk whan I navigate to your zip file and select it to install, nothing happens. The MD5 checksum of the zip file I'm trying to install is 78c6c276205501b417a7f8c3d8de115a.
The result should never be nothing, even if you give Magisk a 0 byte zip file. It should always take you to the module installation screen where it prints the results of the install scripts and any error(s) encountered.

You are installing through Magisk(app) -> Modules(puzzle piece bottom right) -> "Install from storage" at the top, right?
 

residentorca

Senior Member
Jan 24, 2011
270
72
Seattle
Moto G Play
The result should never be nothing, even if you give Magisk a 0 byte zip file. It should always take you to the module installation screen where it prints the results of the install scripts and any error(s) encountered.

You are installing through Magisk(app) -> Modules(puzzle piece bottom right) -> "Install from storage" at the top, right?
Yes, that is correct. No installation screen appears after I select the zip file and when I return to the Magisk home tab, it does not show any additional module having been installed. I'm using the latest version of the Magisk app (v.22). I have Magisk Hide enabled to pass Safetynet check if that may be somehow relevant.
 

706trades

New member
Apr 3, 2021
4
2
Yes, that is correct. No installation screen appears after I select the zip file and when I return to the Magisk home tab, it does not show any additional module having been installed. I'm using the latest version of the Magisk app (v.22). I have Magisk Hide enabled to pass Safetynet check if that may be somehow relevant.
Perhaps. I have installed the module as well and had no issues, I was shown the install screen and it shows in magisk's modules list as normal. I did not activate magiskhide, nor did I edit magisk in any way before installation, for what that's worth.
 
  • Like
Reactions: residentorca

residentorca

Senior Member
Jan 24, 2011
270
72
Seattle
Moto G Play
Perhaps. I have installed the module as well and had no issues, I was shown the install screen and it shows in magisk's modules list as normal. I did not activate magiskhide, nor did I edit magisk in any way before installation, for what that's worth.
I reinstalled the stock ROM, re-rooted and tried loading the custom module again. This time it worked.
 
Last edited:
  • Like
Reactions: fddm

HDDDesign

Member
Oct 31, 2017
20
1
44
Alabama
Moto G Play
IMG_20210413_204450.jpg
 

706trades

New member
Apr 3, 2021
4
2
I'm no expert but I think all you need to do is use fastboot to piece-by-piece reflash the phone with stock firmware. You might can get away with only reflashing the part that screwed up, but this for sure should fix it unless someone can correct me.

Flash instructions here.
 

HDDDesign

Member
Oct 31, 2017
20
1
44
Alabama
Moto G Play
I'm no expert but I think all you need to do is use fastboot to piece-by-piece reflash the phone with stock firmware. You might can get away with only reflashing the part that screwed up, but this for sure should fix it unless someone can correct me.

Flash instructions here.
thank you kindly my friend..yes im back fully restored..from Lenovo tool kit... close one..':)
i do appreciate your prompt response...
i beleive i can flash twrp with confidence...root magisk...
proud of unlock bootloader via adb..first time ive accomplished that...moving forward..
NeversettlE~`
take any Technics or advice...on this device.. thank yall in advance
 

Omizuke

Member
Dec 16, 2010
41
12
Samsung Galaxy Tab S7 / S7 Plus
Moto
Model: XT2093-3
Software Variant/Channel: t/T-Mobile
Android: 10 Build number: QZA30.Q4-39-57-2

Kernel: 4.19.95-perf+ #1 SMP PREEMPT Fri Dec 11 23:07:43 CST 2020 aarch64
Bootloader: MBM-3.0-guamna_t-bfe8cf6b47-201211
Radio: HA10_18.534.02.58R GUAMNA_GWLC_CUST

Flashed the
RETUS_10_QZA30.Q4-39-35_subsidy-DEFAULT_regulatory-DEFAULT_CFC_R1_CFC
Created my own .bat file with the servicefile.xml iside for easy double click flashing. (can share)
Still has Software Channel: T-Mobile
Even tho everywhere it says "guamna_retail"
Test everything was working.
Proceed to root using latest Magisk (22100 at the time) and that same boot.img on the folder.

Everything is working great so far or at least the things I could test.
All Bands, band 71 is a must on my area, VoLTE no problems. Haven't try anything Wi-Fi related, VoWIFI or MMS. I don't have home internet.
Hotspot work no prob. But I use PdaNet+ to avoide speed restrictions (T-Mo's 600 Kbps is ridiculous, give us 1-2 Mbps at least)

What else... The modules tested so far work, including App Systemizer, used it on a Fake GPS app, working well. And Debloater (Terminal Emulator) to remove system apps. My old TB 8.3.3 works for freezing apps, also tried back up, uninstall and restore and app and it worked. User app

Not happy with how much has been replace from proprietaries to Google apps. I always liked AOSP/Stock Android apps but not Google app.
Or how ridiculously aggressive they are. I had to freeze services because a game I've always used without "Google Play Games" wouldn't let me move pass the first screen without installing it. Something I just normally ignore/back out and move on. But it wouldn't let me. So I freeze (on TB) Play store and Services and was able to move on without even been asked. What fallowed was a truckload of notifications of how basically the entire phone won't work unless I enable Google Play services. Including Contacts, Messages and Calculator. Calculator like seriously, I need Google stalking my cal app to work? It was BS of course, I open cal and try 2+2 and it still equals 4, didn't try to tell me it was 5. I get stuff like GMail or Contacts Sync. But why must the contacts already on the phone had to magically disapear? This doesn't happens with my other phones, granted are much older. I'm now currently testing alternative to all those apps. I mean, I did re-enable them, was gonna anyway for those apps I understand are needed, and the sync/backup.

I miss when Android had stock ungoogle-apps that got replaced depending on what google apps you installed. Sad is I think Samsung is the only brand that still has propietary apps.

Praying for a LineageOS or similar.

Anyway, cross-flashing works with no issue. But only removed the T-Mo crap, but had a bunch of hidden apps for Metro, Spring and other Carriers that I didn't even knew existed. Just thought I'd share, in case anyone was curious.
 

Top Liked Posts