Question Moto G60 not starting & Flashing Locked

Search This thread


Dec 29, 2022
If the channel is OPENMX, I'd say you should probably stick to that.
Latest available Android 11 build seems to be this one (RRIS31.Q1-42-51-12-4)
If you want a different build, you can choose another one from here.

Now, as far as UI goes...there's not much you can do. That's Android 12. In terms of usability issues...I would first try to see if they're not somehow app related, rather than OS related.

For that, you can try a few simple things, such as:
1. boot into Safe Mode
2. backup and reset the phone (without restoring the backup at first).

These are all easier options than downgrading the OS. Not to mention, it allows you to keep your warranty intact. Which might or might not matter to you. might be useful one day. Personally, I don't care about it too much. Because, stuff I'd like to be covered by warranty (like drops and water damage) are not, and stuff that is covered by warranty (like factory defects) are usually very, very rare. So...after I test the phone for a while, to make sure there are no factory defects, I tend to just unlock the bootloader and test new stuff.

Right now, I'm back on Android 12 stock, with a relocked bootloader. So I've got no warranty. But also...none of the issues you're describing. :))

So, my advice would be: try the troubleshooting steps above. See if they make a difference. The refresh rate never bothered me. And it seems very smooth even with Android 12. But...we're living in different parts of the world, and using different models and different software. could be different. :) But...scrolling through contacts for example seems really smooth. I didn't test it with an FPS meter. But...seems really smooth, so no need to. Also, I don't really care much about refresh rate. I'm not a gamer, and even if I games need a lot more than a high refresh rate to be played smoothly. You need GPU acceleration, you need good internet speed, you need a good server to feed you all that information fast enough so you can't see any lag or stutter. I feel the display refresh rate can and should only be tested in offline apps (like Contacts, app drawer etc), not in games or social media apps. Because those rely on internet to get the information you need. And that increases the number of variables in this ecuation.

However, if you really wanna go back to Android 11, you should be able to. But again, my advice...would be to test it for a little while, with all your apps, just in case it's not actually the OS but one of the apps that's causing you troubles.

In terms of advice would be to get the latest available Android 11 build. Because it will likely not offer you just the security updates going forward. It will try to upgrade to Android 12 altogether. So...if you wanna stay on Android 11, you'll also get the security patch for Android 11. I could be wrong about it...but I think that's how it works. You can't stay on Android 11 and have the latest security patches.

So before locking the bootloader, just test the phone on Android 11, with all the apps, to make sure everything works as expected.
Aight, how do I boot into safe mode in moto g60? And what does this do exactly?

I am not a gamer, at least not a hardcore one, I don't care about 120 Hz in games, it's just that the frame rate of the phone is not working correctly, not in games only, but everywhere. In the home screen, while navigating on the net, YouTube, social apps, etc. Also the problem is that even if I turn the refresh rate down to 60 Hz, it still keeps lagging and seeming lower than it should.

If I manage to make it work properly, I obviously won't downgrade to 11.


Senior Member
Apr 28, 2011
Motorola One Action
Moto G40 / G60
Aight, how do I boot into safe mode in moto g60? And what does this do exactly?

I am not a gamer, at least not a hardcore one, I don't care about 120 Hz in games, it's just that the frame rate of the phone is not working correctly, not in games only, but everywhere. In the home screen, while navigating on the net, YouTube, social apps, etc. Also the problem is that even if I turn the refresh rate down to 60 Hz, it still keeps lagging and seeming lower than it should.

If I manage to make it work properly, I obviously won't downgrade to 11.
Safe Mode allows the phone to boot without third party apps. To boot into Safe Mode, hold down the Power button, hold down the Reboot option on the screen, confirm it (there should be a pop-up), then wait for the phone to reboot.
Test, then reboot normally to exit Safe Mode.


Dec 29, 2022
Safe Mode allows the phone to boot without third party apps. To boot into Safe Mode, hold down the Power button, hold down the Reboot option on the screen, confirm it (there should be a pop-up), then wait for the phone to reboot.
Test, then reboot normally to exit Safe Mode.
Alright, I've been using the phone for a while now, and at least until now, the crashes have stopped, the battery still drains fast as hell, and the frame rate is as inconsistent as always. I really don't like at all this android 12 thing, but I'll stick to it, I don't wanna mess up my phone.


New member
Mar 13, 2023
Moto G40 / G60
I have a mobile phone, moto g60 xt2135-2, after I installed the original android 12, I forgot that I had also installed twrp.img before and when I try to open it, it is stuck in the bootloader, but when I turn it on, it tells me on the screen that it does not have any valid and signed operating system, please help me, I have noticed that many people who like to install customized android operating systems have experienced something like this, thank you very much


New member
Nov 11, 2016
Bom dia caro amigo, também tive o mesmo erro e lamento informar que não há resolução sem o uso de determinado equipamento no momento, a única forma possível de resolver esse problema no momento seria através de um JTAG BOX tipo MEDUSA PRO 2 ou OCTOPLUS, vou explicar porque, recentemente com a atualização para o android 12, veio também um patch de segurança com ele, com o mesmo problema, acontece que as estruturas de boot que estão com o android 11, não são compatíveis com o 12 e acaba que não dá pra voltar atrás, esse erro parece proposital, a única forma de estar resolvendo mesmo porque o bootloader está bloqueado seria você usar uma caixa para reescrever o sistema nas memórias UFS do aparelho direto pelo JTAG que é a conexão direta da caixa com a placa mãe do aparelho,outra solução seria mandar para a própria motorola, que segundo eles é necessário trocar toda a placa mãe do aparelho e o concerto custa em torno de 181,71 Dólares, se você tiver sorte e encontrar um técnico em sua cidade que opere com jtag, o show custa em torno de 40 dólares, sou brasileiro então pra mim a troca da placa veio com um orçamento de R$ 920,00 e o show por JTAG R$ 200,00

Desde já um abraço e se precisar é só chamar.
Olá amigo, onde você conseguiu esse conserto com JTAG a 200 reais, estou com o mesmo problema


New member
Sep 13, 2017
So, to summarise the video:
1. phone says flashing_locked
flashing fails, phone fails to boot
2. magic happens in the background
3. phone now says oem_locked
flashing succeeds.
4. all good

Tool used in the video:

Not sure it's all about the tool though.

Also, it seems to make a difference whether it's flashing_locked or oem_locked.

I'm just wondering, has everyone with this issue used fastboot flashing lock instead of fastboot oem lock to lock their bootloader?
can i get this software if possible

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Hello Guys,

    I have Moto G60. I have unlocked boot loader and downgrade with Stock Android 11 and Locked boot loader again.
    After flashing locked, when I started my phone, it shows me error "No Valid Operating System could be Found. The device will not boot."

    I have tried Lenovo RSA tool to rescue my phone but it gets failed, same in RSD Lite.
    Now, I am trying to unlock boot loader again using ADB tools and it gives me error that "Check 'OEM unlocking' in Android Settings > Developer"
    Can anyone help me?

    Thanks in advance.
    Did you boot the phone to make sure everything's ok before locking the bootloader?
    I see a lot of people with this issue. Locking the bootloader should be the absolute last step you do. After you make sure everything works fine.

    The problem is you don't have USB debugging on anymore, so no adb. Bootloader is locked, and you've got no access to the OS, so you can't either enable or disable OEM unlocking.

    I'll look around to see if there's any way to fix this at home. But I'm afraid the only way might be to bring the phone to a repair center.
    @arsradu Thanks for sharing all your thoughts here. I am thinking to unlock bootloader of my 4 days old Moto G52 but after seeing these I am afraid to unlock because at some point I need to relock it.

    You don't need to be afraid to try new things. You just need to be prepared to fail, while also taking all the necessary measures for that not to happen. :)

    You already asked here. So that's one step in the right direction.

    Don't be afraid to try new things. In fact, you should be able to unlock and relock the bootloader with no issues, IF you pay attention to a few basic things:
    1. DO NOT (EVER) lock the bootloader on a custom ROM.
    2. use LMSA when restoring to stock ROM. That should be enough to give you a clean environment.
    3. always test if the ROM is booting after flashing back stock ROM

    Just be aware that, as far as Motorola phones are concerned, the second you request an unlock code, your warranty is void. You don't need to actually use the code for that. Simply requesting it is enough to void your warranty. If you're ok with that, go ahead.

    Some people said that with that flashing_locked you can't use any flash tool like LMSA. Is it fine flashing with LMSA for you with locked bootloader having flashing_locked?

    I haven't tested that. I don't think the fact that it says "flashing_locked" is the problem. I think the state of the software in that moment is the problem. Because, people are trying (and failing) to flash their phones with LMSA AFTER the phone is already unbootable. So the problem is not the fact that the bootloader is locked. It's the fact that the phone is in an unbootable state. But I could be wrong of course.

    Personally, I don't think anything wrong would happen if you would reflash your stock ROM with a perfectly bootable system. But again, I haven't tried that (or at least I don't remember; I tested a lot of scenarios, but I don't remember trying that), so can't confirm.

    It is because SafetyNet fails with unlocked bootloader right?

    Yes, SafetyNet will fail with an unlocked bootloader, on stock ROMs.

    What I am thinking is people are locking bootloader with another region ROM or they fails to restore stock ROM fully.
    I think so too... But could be something else, too.
    I was afraid to lock my bootloader after reading all these comments from different people.

    Also, I was afraid to do that because my OEM Unlocking option was greyed out (normal) and turned OFF (weird, but apparently that could happen, as well, and it's not as bad as it looks).

    But after a couple of emails with the Moto support team, in which they said the position of that on/off switch is not relevant, I decided to give it a try and lock the bootloader. And, to my surprise, it worked! I was able to successfully lock the bootloader (twice, actually), and I had no issues whatsoever. The phone works perfectly fine.

    I am new to this Moto, A/B and Qualcomm but after reading about these I found that in flashfile.xml, I can't able to find commands for flashing to both the slots! Am I wrong? If it is right then one of the slot may have custom partitions like many people when trying to flash GSI by following many guides in Internet will flash vbmeta, vbmeta_system with --disable flags.

    You're right. Newer phones (at least phones with so-called "super" partitions) don't seem to flash to both slots. I noticed this on phones with "system" partitions. Otherwise, the ROM will be flashed on the active partition. That can be A or B. In my experience with this, it doesn't seem to make a difference, as long as that partition is also bootable! However, if you want to be extra cautious, you should be able to force flash to the other slot. Or, while bootloader UNlocked (you won't be able to do that with a locked bootloader, so all the cleaning needs to happen BEFORE locking the bootloader), switch from one slot to the other (you can do that from command line, from TWRP, and probably other methods as well) and flash again.

    The vbmeta flags are usually in order to downgrade, if I'm not mistaken. But yeah, I read a couple of those tutorials, as well. And also tried a few GSI ROMs (with pretty low success rate). I find them notoriously buggier than regular ROMs. But you can definitely test some, if you really want.

    My advices:
    1. be prepared to make mistakes. Cause you likely will.
    And that's ok. That's how we learn. It's not a bad thing. That doesn't mean you can throw away your brain and start making stupid mistakes. But what I'm trying to say is don't stress too hard if you make mistakes. Your safety net (no pun intended) is your bootloader being UNlocked. As long as your bootloader is unlocked, you can still recover the phone, in case you make a mistake. Don't be overconfident. And always double/triple check to make sure everything is ok.

    2. keep your phone as clean and organised as possible. Being organised as a human being should help to keep your stuff organised, as well, and making less mistakes in the process. Analytical/logical thinking helps, as well.

    3. don't flash stuff you don't know, or that don't need to be flashed.
    For example, in my case, you don't need to flash TWRP to flash a custom ROM. You can just BOOT TWRP and flash a custom ROM like that. In the case of PixelExperience ROMs for example, they also come with their own PixelExperience Recovery. So....if you're not doing complex stuff in recovery, that should be just fine for regular use.

    4. only lock the bootloader when you're 110% sure everything is back the way it should be.

    You're most welcome. :)
    Yes, when I have unlocked bootloader and downgrade from Android 12 to Android 11 and every thing was working perfectly.
    To, install banking apps on my mobile, I thought it will be good to relock the bootloader.
    Once I locked the bootloader and reboot my phone, I get this error.

    I have also bring my phone to mobile shops to get it repaired but no luck.

    For banking apps to work, you only need the device to be non-rooted. Bootloader status doesn't matter, for as far as I know. But I guess it depends on the app.

    Anyway, I'm guessing OEM unlocking was not checked before you locked the bootloader, right? Otherwise it shouldn't have complained about it when you tried to unlock again.

    Weird thing. I don't know where you got the bootloader unlocking procedure, but on the official Motorola site that I used to unlock the bootloader, it said to use:

    fastboot oem unlock [UNLOCK_CODE]

    But Google's documentation mentioned something about newer devices using "fastboot flashing" command. Kinda confusing...

    They're probably the same. But I never used this command. Also, when you try to unlock using "fastboot flashing" don't you also need to provide the unlock code...?

    I don't know man... I don't know what to say. I was thinking of going back to stock Android 12 just to test this theory, but now I'm not so sure. :))

    I have unlocked and locked bootloader before, on other Motorola phones. Successfully of course. :)) So...I'm not sure why so many people keep getting into this issue.

    By the way, what is the exact error you get with RSA when trying to restore your device? That should have worked...even with a locked bootloader. After all, it asumes the bootloader is locked. Can you boot into fastboot mode? Is the device recognised in fastboot mode?

    I remember I had a failure with RSA one time, but just restarting the process made it go away, and flashing finished successfully.

    Anyway, to check fastboot status, while in fastboot mode, do the following command:
    fastboot devices

    It should display your device underneath. After that, you can go restore your device with RSA.
    Yeah, looks like there are a lot of Motorola users with this exact issue.

    So, the problem here is that, when you flash the ROM with bootloader unlocked, OEM Unlocking is in the Off position, and greyed out. Showing "bootloader is already unlocked". So you can't change that.

    Then you try to relock the bootloader, data gets erased, and you can't boot. No idea why it's showing "no valid operating system could be found". That's the first problem.

    Also, when you try to unlock again, it complains about the OEM Unlocking switch not being ON, which...well, you couldn't turn on to begin with, cause it was inactive/greyed out, saying bootloader is already unlocked (which it was).

    What's interesting is that, according to Google, that option should be persistent to factory resets. I guess it's persistent to user triggered factory resets, but not when bootloader is being locked and triggers the erase userdata on its own. Which I guess makes sense. But with the OS not booting, that option being likely's becoming a huge pain in the butt.

    Some people said to wait 7 days and then try to reflash using RSA.

    In the meantime, I've found an awesome guide here.
    And some technical details from google here.
    Also this about boot flow.

    I've reverted to stock Android 12 myself, for the time being. But I did not lock the bootloader. For multiple reasons. This being only one of them. And I'm not planning to, until I find out more about this issue.

    I'll let you know if I find anything more.


    Ok, so apparently the switch being in the off position doesn't really have any effect on the software functionality after relocking the bootloader. You CAN relock the bootloader, even with the switch greyed out and in the OFF position. It should be ok, as long as you don't try to lock the bootloader on a custom ROM.

    So, my advice would be using LMSA to flash the stock ROM, make sure it boots, lock the bootloader, and without rebooting the system, go into recovery and do a wipe data/factory reset. Then reboot to system.

    It worked fine for me. Already did this operation twice. All good. Just make sure everything is clean (LMSA should take care of this).