MTCD - Verified Cross compatible MCUs

Search This thread

Ctx57

Member
Mar 1, 2021
10
0
Poland
??
 

Attachments

  • 20191029_193143.jpg
    20191029_193143.jpg
    516.1 KB · Views: 146
  • 20191029_193121.jpg
    20191029_193121.jpg
    600.5 KB · Views: 148

stale86

Member
Mar 18, 2019
21
1
Hi all,
i have PX5 headunit with MCU MTCE_HZC_V2.70_7,
the newest MCU that i found is :
MTCE-HZC-2.94bp+by+cs-x and MTCE_HZC_V2.74,
unfortunately I did not find a newer version.
it safe to try to install the version of HA,
at worst go roll back to the versions I mentioned above.

I am currently running Android 6, and want to update to versions 9,10.
 

typos1

Senior Member
Apr 3, 2007
9,492
1,739
UK
Go into factory settings and export them to get your config before you do anything.

Have you read the thread to see what different manufacturers MCUs are compatible with HZC units ?
 

stale86

Member
Mar 18, 2019
21
1

typos1,​

yes , sure i will make a backup,

i read the most of the thread,
and i think to flash HA mcu,
since they update the MCU frequently,
and i also see that android 6 rom
snce their version of Android 6 is compatible with the version I currently have in the context of fixes and changes.

so i need to know of sure that,
i can downgrade to the original MCU that i mentioned earlier,
in case the process goes wrong.
 

typos1

Senior Member
Apr 3, 2007
9,492
1,739
UK
Forget ROMs, the MCU has nothing to do with ROMs - ALL ROMs from any MTCD/E manufacturer are compatible with ALL MTCD/E PX5 units.

You need to read the thread and see if any others have gone from CHZ to HA, if no one has successfully done it then you are the first. Have you found anyone who started out with CHZ and gone to another manufacturer ?
 

stale86

Member
Mar 18, 2019
21
1
I have not found any information about changing from CHZ to HA, if it can be upgraded and after it,
I can still downgrade if the HU are not stable in case of mismatch problem,
I do not see a risk here.

I understand right? Im missing something? ?
 

typos1

Senior Member
Apr 3, 2007
9,492
1,739
UK
You need to read ALL the thread and see what MCUs anyone has flashed on their CHZ unit FIRST, if no one has then you will have to be the first to try.
 

typos1

Senior Member
Apr 3, 2007
9,492
1,739
UK
Xtorns just a reseller, they buy units from several manufacturers and sell them as their own, so their are Xtrons units with different MCUs, you can ONLY identify a unit by the MCU, not by manufacturer. Sometime the resellers model number can help also (assuming all units with that number are bought from the same manufacturer.

It is this thread you need to read, not another one, this one !
 

coromonadalix

Member
Mar 25, 2010
31
4
The Eonon ga9263b mcu MTCE_HT_v3.03_1 is compatible with an Xtrons tq709ipl MTCE_gs_v3.67_3 for an SOM exchange

Took the Xtrons Px6 and put it in the Eonon ... no reprogrammation needed in my case, not fully tested
Just done an factory reset ...

My 2 cents ;)
 
  • Like
Reactions: marchnz

typos1

Senior Member
Apr 3, 2007
9,492
1,739
UK
No need for a factory reset - theyre all HCT SoMs and are therefore all interchangeable, this applies to all MTCD/E SoMs.
 
  • Like
Reactions: marchnz

argus357

Member
Jul 22, 2008
26
3
I have a new PX5 head unit that reports a mcu that I have not seen before, does anyone have any information they can share on this MCU please?
MF1-px5_c54_whd01a-aAaAaA_7708-B4_20210408-14:45
 

jhony benitez

Senior Member
Mar 9, 2008
55
5
I would need some help to understand how MCU cross compatibility work, and if I can upgrade my unit.

I have MTCD GS V3.40 on my head unit.

I've been searching in cross compatibility forum thread... if I understood correctly (I would like to know your opinion) it seems that GS MCUs are compatible with MX MCUs and not only but also with MTCE MCUs.

Searching I have found some options that apparently seem valid to use without breaking my head unit:
- A MX MCU found here https://forum.xda-developers.com/attachments/mtce_mx_v3-71-rar.5220641/
- Some GS options ,but instead being MTCD are MTCE https://drive.google.com/drive/u/0/folders/1KEUd6JnRmDlXgopyE9LOX7CF51Ujo3WU

Could I install any of them without risk? (of course I will export first the original file) and if so, which one do you recommend me?

PS. I've tried to access to this link http://forum.xda-developers.com/wiki/Hui_Fei_Type that some of you recommend to read ,... but unfortunately doesn't work.

Thx for your help ;)
 

marchnz

Senior Member
Nov 26, 2012
4,562
896
NZ
I would need some help to understand how MCU cross compatibility work, and if I can upgrade my unit.

I have MTCD GS V3.40 on my head unit.

I've been searching in cross compatibility forum thread... if I understood correctly (I would like to know your opinion) it seems that GS MCUs are compatible with MX MCUs and not only but also with MTCE MCUs.

Searching I have found some options that apparently seem valid to use without breaking my head unit:
- A MX MCU found here https://forum.xda-developers.com/attachments/mtce_mx_v3-71-rar.5220641/
- Some GS options ,but instead being MTCD are MTCE https://drive.google.com/drive/u/0/folders/1KEUd6JnRmDlXgopyE9LOX7CF51Ujo3WU

Could I install any of them without risk? (of course I will export first the original file) and if so, which one do you recommend me?

PS. I've tried to access to this link http://forum.xda-developers.com/wiki/Hui_Fei_Type that some of you recommend to read ,... but unfortunately doesn't work.

Thx for your help ;)

Why upgrade? What specific issue are you wanting to resolve?
 
  • Like
Reactions: jhony benitez

typos1

Senior Member
Apr 3, 2007
9,492
1,739
UK
I would need some help to understand how MCU cross compatibility work, and if I can upgrade my unit.

I have MTCD GS V3.40 on my head unit.

I've been searching in cross compatibility forum thread... if I understood correctly (I would like to know your opinion) it seems that GS MCUs are compatible with MX MCUs and not only but also with MTCE MCUs.

Searching I have found some options that apparently seem valid to use without breaking my head unit:
- A MX MCU found here https://forum.xda-developers.com/attachments/mtce_mx_v3-71-rar.5220641/
- Some GS options ,but instead being MTCD are MTCE https://drive.google.com/drive/u/0/folders/1KEUd6JnRmDlXgopyE9LOX7CF51Ujo3WU

Could I install any of them without risk? (of course I will export first the original file) and if so, which one do you recommend me?

PS. I've tried to access to this link http://forum.xda-developers.com/wiki/Hui_Fei_Type that some of you recommend to read ,... but unfortunately doesn't work.

Thx for your help ;)

Why dont you just flash the latest GS MCU ??
 

ThaCo98

New member
May 23, 2016
4
0
Sony Xperia XZ1
Hello guys, i have a PX30 head unit with installed the latest MTCE LY 3.65, i wondered if this kind of mtce was cross compatible with some like maybe GS or MX. Thanks to who will answer me
Cheers:)
 

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    This thread is to document MCUs found to be cross-compatible between MTCD units, which includes PX3 and PX5 variants, which share identical mainboard hardware and MCU Chip STM32F091.

    The following MTCD & MTCE (as of v2.56) MCUs have been validated as cross compatible on 1024x600 units:
    - MLT - 01/07/17 - caution - has resulted in issues for some @leonkernan
    - JY
    - KBT - 08/12/2017 - thanks @abagos
    - KD (v2.40_2 - enables bluetooth hands free in both front speakers)
    - KGL
    - KSP thanks @Overmann
    - GS - Note "version unmatch" error and fix below No issue experienced on MTCE going from JY 2.80 to GS 2.78 and back to HA 2.80 - March 2018
    - GS compatible on MX (see post #513)
    - HA (v2.56 06/07/17 - note v2.52 on enables "shutdown delay when acc off" menu) HA MTCE (30/09/17) V2.65 https://www.sendspace.com/pro/dl/ufie8k
    See this thread for pics where MCU HA and KD has been applied on JY. https://forum.xda-developers.com/showpost.php?p=72737797&postcount=640

    I initially upgraded to KD 2.40, then HA v2.52 after first exporting the MCU settings.
    Note that I had to reapply MCU settings in [factory sertings] to configure radio, LED, bluetooth, hardware keys, volume levels between radio, bluetooth, system etc.

    MCUs were previously thought to be manufacturer specific - e.g. HA, JY, GS, KD, however I have found that they are compatible and of interest where there is either a specific issue with your MCU (e.g. bluetooth out of one speaker, to enable PX5 sleep mode control) or the vendor has long ceased to support & release updates - such as JY.

    MCU cross-compatibility became of interest to me when I upgraded my JY [MCU v2.06_2] PX3 with a HCT PX5 SOM and wanted to enable the MCU specific menu item [shutdown delay when ACC off] to control sleep as found on HA/Dasaita.

    I first noted that from an XDA post listing JY an KD v2.06_2 being identical and on that assumption, upgraded to KDv2.40_2, which successfully applied - but had to reconfigure factory settings.
    Following on, I found a post which has an image of a GS board & MCU chip - noted it was identical to the MTCD JY MCU chip [STM32F091] - then came across a post where a user had inadvertently applied a MTCD GS MCU to a MTCD JY without bricking it.

    I then started comparing same version number firmware files from various manufacturer MCUs with a text compare tool. From this work, I had enough info to compare the latest HA v2.52 and conclude it 'should' be compatible. Indeed it is.

    As always, check first (suggest confirming MTCD, MCU Chip part number, view/compare the fw files, ensure you have original MCU FW, backup MCU settings or document the settings to ensure your hardware controls, volume control, bluetooth, radio, canbus etc are setup correctly). Apply at your own risk.

    Please post your results and I will update this thread.
    Updates:
    UPDATE: 26/06/2017 Users of 800x480 Users must also apply file[dmcu.ext], a text file containing:
    For PX3 --> screen:3
    For PX5 --> screen:1


    01/07/17 - MLT
    06/07/17 - KGL confirmed and new HA v2.56
    30/09/17 - MTCE MCU confimed compatible
    08/03/18 - MTCE JY/GS/HA compatible - No issue experienced on MTCE going from JY 2.80 to GS 2.78 and back to HA 2.80

    GS Specific Notes:
    For all those with a GS: Our unit is compatible with the MTCE MCU but you have to restore your settings and maybe to manually reconfigure your touchscreen and buttons. There is a simple function to do this in the factory settings (126) which is called key study. My touchscreen was also swapped by the x axis. I had to go with the swapped touchscreen into the settings, configure it, reboot the unit and everything was fine. For the buttons you have also the possibility to use short press and long press buttons, which is great because our units (at least mine) has only five buttons and no return button. So I use now the power off button as return in short press mode and power off in long press :)

    Version unmatch see this post where user resolved by reapplying MCU AND Software APK Fix Here
    - Attached Version Unmatch APK fix to this post, thanks @Wadzio

    GS Configuration Settings file:

    Do not dilute this thread by posting "how-to" questions such as - how do I update the MCU, what unit do I have, can I do it, how do I find factory settings, etc. This thread is to document cross-compatible MCUs and the fixes they apply.
    3
    KD --> HA for 800x480 Screen

    I have had quite an experience over the weekend, but am able to report successfully updating a PX3 MTCD_KD unit to a PX5 with the HA2.52 MCU Code.

    For those of us with 800x480 screen sizes, as now noted in the main thread, we need to create the dmcu.ext file with the appropriate screen size to be flashed with the dmcu.img file.

    Just a note that if you run across the issue of not having the appropriate resolution; don't freak out.

    One interesting note I hadn't mentioned before is that after the PX5 started thinking it was 1024, I replaced it with the PX3. The PX3 booted thinking it was 1024 also. After reverting the PX3 to 800 (flashing with screen:3), I replaced the PX5. The PX5 however, did not revert back to 800, but remained at 1024. The PX5 did not revert back to 800 until after I reflashed the MCU, specifically stating it was to be 800 (screen:1).
    2
    And did not show a mismatch message on screen?
    Yes but I used the McuUnmatchUnlock.apk
    2
    I can confirm a cross compatibility as well.

    My Unit is a xtrons device with die MCU firmware GS 2.43 and yesterday i did flash the HA 2.52. But be sure to save your mcu config first. Otherwise the hardware buttons won't do what they were supposed to do. But after flashing the firmware and restoring the config, everything is back to normal.
    2
    Hi, thanks, I have added to post #1. Do you have a screen shot I can add?
    I only have after installing it. Its px3, I'm waiting to px5 board to update it.