MTP options do not show when connected to Laptop

Search This thread

yuvrajsp

Member
Feb 2, 2020
10
1
Hi All,

I hope someone here can help me with the issue I have been facing with my LG G7 from the last two weeks.

Earlier my phone used to show me the MTP options each time I connected it to my laptop using the cable. For some reason, the phone does not show me the MTP options anymore and only charges when connected to the laptop.

I have done the below to try & fix but nothing has helped.

  1. Cleaned the charging port on my phone
  2. Tried a different USB cable
  3. Tried USB debugging
  4. I also did a factory reset on the phone

While researching on the internet, I read about the three dots on the storage tab, I don't have that. Also in developer options the Select USB configuration does not pop-up and when I click it 5 to 6 times a window pops-up and vanishes in a fraction of a second.

Any leads on what needs to done to fix the issue I'm facing?

Screenshot from about the phone attached.
yxXvaqc
 
Last edited:
  • Like
Reactions: Ali Mirza

yuvrajsp

Member
Feb 2, 2020
10
1
No Luck.

Hi.
Go to C:\Windows\INF\wpdmtp.inf, right click the file, then click 'Install' in the menu. See if that helps.
Hi Romkeris,

Thanks for the tip, tried that with both the phone connected to the laptop and without the phone connected to the laptop and it did not help.

Any other suggestion that you want me to try?
 

rcurious

Member
Jul 9, 2011
21
10
Any other suggestion that you want me to try?
That helped me, with same problem some time ago. Also take a look at device manager if there are no devices with the exclamation mark, when you connect phone.
If there is, delete it and do the same as in my previous post. Also you may try to install latest LGMobileDriver_WHQL_Ver_4.4.2.exe.
 

yuvrajsp

Member
Feb 2, 2020
10
1
That helped me, with same problem some time ago. Also take a look at device manager if there are no devices with the exclamation mark, when you connect phone.
If there is, delete it and do the same as in my previous post. Also you may try to install latest LGMobileDriver_WHQL_Ver_4.4.2.exe.
Hi Romkeris,

Thanks for the additional tips. They did not seem to resolve the issue.

I do not have any devices with exclamation marks in my device manager and I have installed the drivers as suggested too. I have also tried using a different laptop and a different cable but both yielded the same output. Just to confirm if it not my laptop, I tried connecting my Pocofone F1 and my laptop was able to detect that but the laptop fails to detect the LG G7 with the same cable as well.

To mention again, I do not even get the MTP options that android devices get when they are connected to computers.
 

rcurious

Member
Jul 9, 2011
21
10
Hi Romkeris,

Thanks for the additional tips. They did not seem to resolve the issue.

I do not have any devices with exclamation marks in my device manager and I have installed the drivers as suggested too. I have also tried using a different laptop and a different cable but both yielded the same output. Just to confirm if it not my laptop, I tried connecting my Pocofone F1 and my laptop was able to detect that but the laptop fails to detect the LG G7 with the same cable as well.

To mention again, I do not even get the MTP options that android devices get when they are connected to computers.

If you can, backup your important documents and try to reset Android to factory defaults. Its seams, it is G7 fault. I think it has big chance to resolve that issue.
This time is the only option I can suggest you.
 

yuvrajsp

Member
Feb 2, 2020
10
1
If you can, backup your important documents and try to reset Android to factory defaults. Its seams, it is G7 fault. I think it has big chance to resolve that issue.
This time is the only option I can suggest you.

Hi Romkeris,

Thanks again but I have done that too and that did not solve the issue either!
 

highfade

New member
Feb 9, 2020
2
0
I have no idea when it stopped working as I don't use the option that often but is must be after some update from LG? I don't know much about this stuff but think the only way to fix this is by LG update or patch?

Also strange that while searching for a solution it's as far as I know just us two having the problem?
 

smariob

Senior Member
Apr 5, 2011
112
38
Mexico City
As you describe the issue seems to be a physical failure in the USB Connection, do you have noticed slow charging or quick charge failure? Any notification about any USB concern? recent moisture? if yes I would suggest replace USB module, If warranty is not an option, ebay is your friend, go buy the spare and replace it.
 

Pouchon514

Member
Dec 9, 2014
46
12
Montreal
I had issue with usb debugging being enabled. Sometimes disabling it helps. Sometimes going from mtp to ptp back to mtp. Or just installing the "standard MTP-device" driver on windows. I had an issue also because my windows was a KN version or N version. You need a media pack thought that didnt help me. I had to install a fresh Windows 10.
 

yuvrajsp

Member
Feb 2, 2020
10
1
As you describe the issue seems to be a physical failure in the USB Connection, do you have noticed slow charging or quick charge failure? Any notification about any USB concern? recent moisture? if yes I would suggest replace USB module, If warranty is not an option, ebay is your friend, go buy the spare and replace it.

Thanks, Smariob.

I think having the USB module replaces may be my last resort as I have tried literally everything apart from this. It was a pain in the A** to have close to 100 GB of data transferred over a memory card as I did not have access to move data directly from the phone to the laptop. Formatting the laptop too did not help.

Thanks anyway, for all your suggestions!
 

washwash

Senior Member
May 29, 2014
263
36
Thanks, Smariob.

I think having the USB module replaces may be my last resort as I have tried literally everything apart from this. It was a pain in the A** to have close to 100 GB of data transferred over a memory card as I did not have access to move data directly from the phone to the laptop. Formatting the laptop too did not help.

Thanks anyway, for all your suggestions!

share a folder on pc and move the files over wifi
 

bryascot

Member
Mar 16, 2020
8
0
I have the same issue. I have tried factory reset, using a different charger, and all the other steps listed in this thread. If you have found any solution please share!
 

washwash

Senior Member
May 29, 2014
263
36
Does this mean I'll not be able to root my device or run adb commands from my PC to the phone?

these two thing are totally different stuff

imho mtp is terrible and sometimes i've lost files, if the phone is ok the problem is in windows, and 90% times is windows problem.
now if i need to transfer files i use lan wifi with a good file manager, like mixplorer (is buggy but wifi transfer works so far) or any other famous file explorer with samba support.
OR remove sd and use a card reader to be 100% sure.
mtp is really disgusting.
 

bryascot

Member
Mar 16, 2020
8
0
Thanks, Smariob.

I think having the USB module replaces may be my last resort as I have tried literally everything apart from this. It was a pain in the A** to have close to 100 GB of data transferred over a memory card as I did not have access to move data directly from the phone to the laptop. Formatting the laptop too did not help.

Thanks anyway, for all your suggestions!

Did you ever find any solution? I replaced my usb port and the problem still continues. I think it may be something with the android software itself and I cannot find anything on how to fix this problem.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hi All,

    I hope someone here can help me with the issue I have been facing with my LG G7 from the last two weeks.

    Earlier my phone used to show me the MTP options each time I connected it to my laptop using the cable. For some reason, the phone does not show me the MTP options anymore and only charges when connected to the laptop.

    I have done the below to try & fix but nothing has helped.

    1. Cleaned the charging port on my phone
    2. Tried a different USB cable
    3. Tried USB debugging
    4. I also did a factory reset on the phone

    While researching on the internet, I read about the three dots on the storage tab, I don't have that. Also in developer options the Select USB configuration does not pop-up and when I click it 5 to 6 times a window pops-up and vanishes in a fraction of a second.

    Any leads on what needs to done to fix the issue I'm facing?

    Screenshot from about the phone attached.
    yxXvaqc
    1
    FIXED! No MTP options when plugged in

    Earlier my phone used to show me the MTP options each time I connected it to my laptop using the cable. For some reason, the phone does not show me the MTP options anymore and only charges when connected to the laptop.
    Hey all!

    I was having the same issue... :crying:
    - Windows would not see my phone when I plugged in the USB cable, but the phone would charge.
    - The USB Configuration screen under Developer Options would not stay open
    - USB Tethering was greyed out

    This seemed to have happened when I got the OTA Android 10 update, but appears to have just been a coincidence. :rolleyes:

    What fixed it for me was...
    - Removed case from the phone
    - Blew out USB port on the phone
    - Connected phone to PC and it WORKED! :D
    - Replaced the case and it still worked

    So, a dirty USB port CAN cause this issue. :highfive: