My PC doesn't recognize my POCO F1 in FASTBOOT mode.

Search This thread


May 15, 2019
Hi, I have a problem that my PC doesn't recognize my POCO F1 in FASTBOOT mode.

I'm running Win 10 64bit (Core i7-3517U), my phone is Global stable 11.6.0. bootloader is NOT unlocked and there is no root.

The main problem: When I try to connect my phone in FASTBOOT mode to my PC and go to System Manager it shows an exclamation mark, not a question mark like it would if you just didn't have the drivers. It also says "The device has been stopped (Code 43) (the other error codes are in the attachments given below) A request for the USB device descriptor failed." I guess this means it's not a simple matter of missing drivers, even if my phone is connected normally, it does not show up or connect to the Mi PC Suite. Normally, if you plug in a new device without drivers, Windows at least recognizes whether it's a printer, headset, mouse or whatever and starts looking for appropriate drivers, but not here.*Whenever I put my phone on FASTBOOT mode, it never gets recognised it just shows an exclamation with a dialogue box that says that "The last USB device you connected to the computer malfunctioned, and Windows does not recognise it" (screenshots provided in the attachments below with normal my phone on normal mode and fastboot mode please go through them)

What I have already tried based on my previous research, but with no success:

different computers, windows and Mac

different usb cords

usb debugging on/off

all usb modes (MTP, file transfer etc.)

usb 2.0 and 3.0 ports

re-installing Mi PC suite

resetting my phone

resetting my Windows 10 pc

and none of the above seem to work.

I also spoke with a friend and tried connecting their phone (Redmi Note 5 Pro) on fastboot mode to my Windows Pc and the Mac and it works!
but my POCO F1 does NOT get recognised.

I live in Pune, Maharashtra in India
and there's a huge lockdown, like there is, all over the world
I can't actually go out and visit a service center and fix this anytime now. i need some serious urgent help on this, I'm willing to do anything to fix this at home. I just need assistance and i need some sort of external guidance. Please, please help me with this matter.

Phone Number : +91 8668606192/ +91 966554769
E-Mail ID : [email protected]

I've provided screenshots of everything and my contact details please read my message and help me with this matter. The feedback form only allows me to attach a maximum of 3 photos so I have sent in a few more feedback form with the same message PLEASE understand my situation and help me accordingly. Consider this a feedback form thread this being

Thank You,
Rahul Singh


Dec 7, 2017
Was it ever resolved ? I had similar issue with my POCO F1. it was working fine in ADB but not getting detected in FASTBOOT. Every time I connected it in fastboot it showed a message USB device not recognized. drivers and all were fine. Code 43 was also there in device manager.

I was able to fix it by using Bugjaeger Premium on my spare Samsung rooted android 10 phone with OTG since my spare phone has micro USB.
POCO F1 was also not getting detected first then I did a factory reset, and MIUI recovery wipe and simply disconnected the cable and rebooted poco f1 using volume down and power button and voila it got detected in my samsung phone then i flashed TWRP.
Last edited: