N1 on Three (3) UK?

Search This thread

gf_gollum

Senior Member
Sep 26, 2007
180
3
I've just moved to 3 in the UK (from vodafone) and I can't get a data connection - I get the error "Data connection lost" reported on several threads here, however my old vodafone SIM (which runs out on Tuesday) runs perfectly fine on 3G

on 3 the phone test (#*#*4636*#*#) shows HSDPA connection and the ping test FAILS (with no response)
on Vodafone I'm also on HSDPA - but the ping test succeeds

I'm on
stock Froyo FrF91 -
rooted and unlocked
32.36.00.28U_4.06.00.12.7 baseband
and 2.6.32.9-27227 kernel

So
Anyone have a clue what the issue might be?
If I can't get this fixed I'll have to move (AGAIN!) , off Three - and onto somewhere else. I'm sure there are other 3 users with N1's!

Graham
 

gf_gollum

Senior Member
Sep 26, 2007
180
3
More bizarre

OK - this gets more bizarre - can anyone explain this?
Take my 3 SIM to 3 Shop - plug it into a 3 branded HTC wildfire - and it works just fine. Use their 3 SIM from the HTC wildfire on my machine - and it work great. Plug my sim back into my N1n- it works just fine now. #*#*4636*#*# actually resolves my pings and get great transfer speed

All smiles

Drive home - check again - no name resolution occuring - no data download. still on HDSPA
:-(
WFT is going on here!!
G.
 

jim29

Member
Jul 1, 2010
13
0
Hello,

I'm on Three with a N1 and unlocked custom Froyo Rom. Works fine for me. Question, are you getting 2g signal, can you make calls etc, is it only 3g you are having problems with?

Are you sure there is Three 3g signal in your area?

  • Settings>Wireless and Networks>Network Operators
  • Can you see it there?

Have you tried resetting your APN settings to default?

  • Settings>Wireless and Networks>Access Point Names>
  • Menu>Reset to Default

Let us know how you get on.

Cheers.
 

gf_gollum

Senior Member
Sep 26, 2007
180
3
I'm on Three with a N1 and unlocked custom Froyo Rom. Works fine for me. Question, are you getting 2g signal, can you make calls etc, is it only 3g you are having problems with?

Are you sure there is Three 3g signal in your area?
Well on the stock froyo rom it doesn't differentiate between 3G and H,but I always get 3G displayed - with 4 bars. Can make calls - no problem
The diagnostics always shows HSDPCA (or whatever!)
however it won't ping or resolve from my house
I drive into town (1 mile) - and it works

I guess its a reception issue??

Phone physically gets hot with the 3 SIM in - at my house - and battery life is appalling (3 hours to flat) - so I guess its trying really hard to connect.

I defaulted the APN again and selected EURO band only - and still no luck. No data connection from my house.

3 network coverage map says I have good coverage - and (as I said) 4 bars in signal strength.
Odd
G.
 

cpm

Senior Member
Jan 12, 2010
745
119
Samsung Galaxy S21 Ultra
Set WCDMA Only the same menu you chose Euro Band from. It's a dropdown box.

It does sound like it could be a reception problem all right. There's also a new radio available which might provide stronger signals. Worth trying that too IMHO http://forum.xda-developers.com/showthread.php?t=723839

Sent from my Nexus One using XDA App
 

jim29

Member
Jul 1, 2010
13
0
If u have 2g to make calls and Wifi for Data, then you might have to settle for that I guess, if your phone works 3g in one area and not another, I would say reception issue, do any of your mates have a Three phone they can test at your house?
 

cpm

Senior Member
Jan 12, 2010
745
119
Samsung Galaxy S21 Ultra
Here's another tip, try the following...

Menu > Settings > Wireless & networks > Network operators

Select "Data roaming"
Choose "Select automatically" instead of 3

See how that goes.

PS I'm now using the new radio 5.08 I linked to above. Looks like I'm getting a stronger signal.

Sent from my Nexus One using XDA App