[N910C/H][DEV] AOSP sources

Search This thread

daashali

Senior Member
Mar 28, 2010
114
17
Chicago
I have a weird (or not!) problem. Every time I try to send an SMS it says the app (no matter messages or hangout) is trying to send a lot of messages and asks me to confirm my action. is there any way I can stop asking the question every single time?
 

erickwill

Senior Member
Nov 30, 2008
2,008
3,625
Anyone willing to try a few fixes, such as ability for camera app to write into external sdcard?

EDITED: Need to use Root Explorer or another similar app..
 
Last edited:

S.Y.

Senior Member
Jan 16, 2015
114
77
Nowhereville
Anyone willing to try a few fixes, such as ability for camera app to write into external sdcard?

EDITED: Need to use Root Explorer or another similar app..

The Dev mentioned on G+ that he had "more important things to take care of" at present.

---------- Post added at 02:33 PM ---------- Previous post was at 02:31 PM ----------

A workaround for those who don't want to use Fast Charging- use a different charger. It is much slower, but the phone does not heat up.
 

Pannam

Senior Member
Nov 4, 2012
367
41
I don't get it.... Most of the guys dual-booted because of the camera problem...... now that's out of the picture and there barely are any bugs left so why would you dual boot.... My suggestion is, now this is just me, if you haven't tried this rom out before, is just back your TW rom and data thru CWM and flash the rom and try it out for a couple of days.... If you didn't like it, flash back to TW....

Hey thnx for the suggestion. However i like to compile the rom from source code. It is not always good so i was talking about the dual boot.
 

erickwill

Senior Member
Nov 30, 2008
2,008
3,625
The Dev mentioned on G+ that he had "more important things to take care of" at present.

---------- Post added at 02:33 PM ---------- Previous post was at 02:31 PM ----------

A workaround for those who don't want to use Fast Charging- use a different charger. It is much slower, but the phone does not heat up.

Someone mentioned a few posts ago that using a custom kernel fix fast charging..
I'm talking about to try a fix for camera to write external sdcard.. it's a know issue, doesn't it?

Edited...
I'm addressing people that have problems with camera to write to external sdcard.. anyone here to test a fix?
 
Last edited:

mailme2nani

Member
Jul 18, 2015
47
14

andrew.mackew

Senior Member
Mar 25, 2011
1,649
1,274
Someone mentioned a few posts ago that using a custom kernel fix fast charging..
I'm talking about to try a fix for camera to write external sdcard.. it's a know issue, doesn't it?

Edited...
I'm addressing people that have problems with camera to write to external sdcard.. anyone here to test a fix?
I can only save to internal sdcard.. could yo please share your fix?

---------- Post added at 11:10 AM ---------- Previous post was at 11:03 AM ----------

Someone mentioned a few posts ago that using a custom kernel fix fast charging..
I'm talking about to try a fix for camera to write external sdcard.. it's a know issue, doesn't it?

Edited...
I'm addressing people that have problems with camera to write to external sdcard.. anyone here to test a fix?

I already sent you a PM, I wish to test the fix.
 

arbi97

Senior Member
Sep 13, 2012
598
223
23
Astana
Someone mentioned a few posts ago that using a custom kernel fix fast charging..
I'm talking about to try a fix for camera to write external sdcard.. it's a know issue, doesn't it?

Edited...
I'm addressing people that have problems with camera to write to external sdcard.. anyone here to test a fix?

Please, bro, give the fix here! Really want to check it :)
 

andrew.mackew

Senior Member
Mar 25, 2011
1,649
1,274
Please, bro, give the fix here! Really want to check it :)

Arbi, I was allowed to share this fix, so here you go..
Actually @erickwill changed a few lines in platform.xml file that made the trick to fix Write do External SD and Google now (both working flawlessly now so far)
Just to make it easy, I will upload my entire platform.xml already edited by @erickwill, so you just need to replace that file into /etc/permissions and set the correct permissions.
Once more, credits and thanks to @erickwill for this fix. It would be good to submit this fix into @RaymanFX git so in the next build it will became available.
 

Attachments

  • platform.xml.zip
    2.2 KB · Views: 70

Anderew

Member
Jan 19, 2012
15
7
I'm running into an issue I haven't seen mentioned here. When I try to install any build of this ROM, either in dual boot or as a normal flash, it freezes at the 'finishing boot' part of the initial android is upgrading screen. If I try to restart it boots to a blank screen showing only the stock EOS wallpaper. I had it running fine a few weeks ago but now I can't get it to boot correctly no matter what! Thanks if anyone has an idea.
 

harisptma

Senior Member
May 24, 2015
65
9
I'm running into an issue I haven't seen mentioned here. When I try to install any build of this ROM, either in dual boot or as a normal flash, it freezes at the 'finishing boot' part of the initial android is upgrading screen. If I try to restart it boots to a blank screen showing only the stock EOS wallpaper. I had it running fine a few weeks ago but now I can't get it to boot correctly no matter what! Thanks if anyone has an idea.

Install it with twrp 2.8.7.0 maybe will fix your problem
 

SirHydarnes

Senior Member
Nov 13, 2013
1,980
2,259
22
I have a weird (or not!) problem. Every time I try to send an SMS it says the app (no matter messages or hangout) is trying to send a lot of messages and asks me to confirm my action. is there any way I can stop asking the question every single time?

Yeah I had that problem... Change the SMS limit per minute in security back to normal
 

Bahaa.Aly

Member
Jun 14, 2015
19
5
Hi there.
Has any one noticed that hw video decoder runs videos with like low frame rate while sw decoder runs it well smooth!!!!! In the 208 built
The built-in player uses hw while in mxplayer when you change the decoder to sw the videos run smooth.

---------- Post added at 06:14 PM ---------- Previous post was at 06:01 PM ----------

Navigation bar hw button temporary fix
I noticed that when you enable navigation bar ,the hw buttons takes a strange behaviour . sometimes disabled and sometimes still work.
To fix that you have to disable the hw buttons manually like we do in tw. But the difference here is that in this aosp the navigation buttons is put in separate file that is present in system/use/key layout /sec_touchkey.kl
You have to put # before the 2 hw button configuration lines inside this file using text editor .
Enjoy
 
Last edited:

SirHydarnes

Senior Member
Nov 13, 2013
1,980
2,259
22
Arbi, I was allowed to share this fix, so here you go..
Actually @erickwill changed a few lines in platform.xml file that made the trick to fix Write do External SD and Google now (both working flawlessly now so far)
Just to make it easy, I will upload my entire platform.xml already edited by @erickwill, so you just need to replace that file into /etc/permissions and set the correct permissions.
Once more, credits and thanks to @erickwill for this fix. It would be good to submit this fix into @RaymanFX git so in the next build it will became available.

Thanks man.. Didn't fix the Google problem but at least fixed the camera.... Thanks a lot
 
  • Like
Reactions: andrew.mackew

Bahaa.Aly

Member
Jun 14, 2015
19
5
Hi

Hi there.
Has any one noticed that hw video decoder runs videos with like low frame rate while sw decoder runs it well smooth!!!!! In the 208 built
The built-in player uses hw while in mxplayer when you change the decoder to sw the videos run smooth. Is it a known bug or just me facing this!!.

---------- Post added at 06:14 PM ---------- Previous post was at 06:01 PM ----------

Navigation bar hw button temporary fix
I noticed that when you enable navigation bar ,the hw buttons takes a strange behaviour . sometimes disabled and sometimes still work.
To fix that you have to disable the hw buttons manually like we do in tw. But the difference here is that in this aosp the navigation buttons is put in separate file that is present in system/usr/key layout /sec_touchkey.kl
You have to put # before the 2 hw button configuration lines inside this file using text editor .
Enjoy.
thank you
 

SirHydarnes

Senior Member
Nov 13, 2013
1,980
2,259
22
Hi there.
Has any one noticed that hw video decoder runs videos with like low frame rate while sw decoder runs it well smooth!!!!! In the 208 built
The built-in player uses hw while in mxplayer when you change the decoder to sw the videos run smooth.

---------- Post added at 06:14 PM ---------- Previous post was at 06:01 PM ----------

Navigation bar hw button temporary fix
I noticed that when you enable navigation bar ,the hw buttons takes a strange behaviour . sometimes disabled and sometimes still work.
To fix that you have to disable the hw buttons manually like we do in tw. But the difference here is that in this aosp the navigation buttons is put in separate file that is present in system/use/key layout /sec_touchkey.kl
You have to put # before the 2 hw button configuration lines inside this file using text editor .
Enjoy

Nice... Thanks.... I used the method I did on TouchWiz in the same folder but with a different file.....
 

SirHydarnes

Senior Member
Nov 13, 2013
1,980
2,259
22
Guys there a fix for the SMS bugs yet?? It happens to me often that I don't receive a text for a while and will after a reboot maybe and sometimes never
 

Top Liked Posts

  • There are no posts matching your filters.
  • 122
    *omg, thread updating needed*

    Hey guys, as some of you might know, I was donated a Galaxy Note 4 (N910C) and am now working on AOSP for it.
    The sources required to build a ROM are hosted at GitHub currently:

    device: https://github.com/teameos/device_samsung_treltexx/
    kernel: https://github.com/raymanfx/kernel_samsung_trelte/
    vendor: https://github.com/raymanfx/vendor_samsung_treltexx/

    If you want to give this a shot, you should be familiar with git and repo and be able to sync the TeamEos source yourself.

    If anybody feels brave enough, give it a try yourself, all the required bits are posted above :)

    TODO/BROKEN:
    • Bluetooth headset calls (RX works, TX is broken)
    • Open source AVC (H.264) Encoder is broken (Videos recorded in portrait are rotated by 90° counter clockwise, and there's artifacts all over the place)

    Everything else should be pretty much working.
    37
    Fixed the problem, we're booting again. I'm setting up automated builds right now so people can watch the development progress.
    The nightly builds are by no means usable as daily drivers though.
    31
    The next snapshot build has a few changes worth mentioning:

    • Tre3g/Tre3gxx (N910H) is officially supported by now. No need to change the updater script anymore.
    • Bluetooth should be fixed. I was able to transfer files via OBEX push withing a range of 10 meters without any issues.
    • The force close of the camera app has been fixed. This would occur when you tried to switch between the front/back cameras.
    • Upstream Linux kernel 3.10.85
    30
    Ok, still battling the RIL, but at least that's on Lollipop now ;)
    Everything which was working on cm-11 now works on cm-12 as well.
    30
    Fixed microphone and NFC, and closing in on GPS as well.
    I'm done for the night though, will see if I manage to put up a new alpha tomorrow (with working phone calls hopefully).
    The patches are here: http://review.teameos.org/ (open and merged sections).
    The Gerrit instance serves as a platform to contribute and share fixes for us, so if you have any ideas, feel free to push something :)
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone