• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Nabi 2 Root and Gapps Install

Search This thread

alexbobspoons2

Senior Member
Jun 18, 2018
70
0
Thank you so much. I will give this a shot. I have a spare nabi I am using as a tester before doing iit on the main one. Thanks you!

JUst so people know if they visit with this question:
Its an "Install" via twrp and you can keep it in the zip format to do this. Its essential that a good wipe is done first though otherwise it retains chunks of nabis-desktop and then tries re-downloading the missing bits.
So after making a full backup just in case.
So go into TWRP with the zip file on your sd card. Do a really good wipe in the advanced wipe settings (dont wipe external sd card). Use twrps "install" to browse to the zip and install it. Then reboot. THats what worked for me.

You still get the awful blue nabi lockscreen, not sure yet how to remove that.
 

texastig

Member
Aug 19, 2009
11
1
Hello everyone. I'm really late to the game for the Nabi 2. I was barely able to get past the "Looking for updates" to get the USB Debugging enabled.
Here are the specs of it:
Android version: 6.0
Android security patch level: October 5, 2016
Kernel version: 3.18.22+ [email protected] #2 Tue Sep 27 18:52:25 CST 2016
Build number: MRA58K release-keys
Custom build version: ABD7TY20160927A00
Product Version: 3.0-release keys.
Will JIMZ's root sotware work on this?
 

mehtuus

Senior Member
Aug 20, 2011
52
31
tomely.org
Last edited:

texastig

Member
Aug 19, 2009
11
1
  • Like
Reactions: mehtuus

alexbobspoons2

Senior Member
Jun 18, 2018
70
0
Will this allow me to bypass ask mom?

If you cannot get into the parents mode there is a default password of zxcv6789 which will get you into adults mode and then you can go into the settings and set the adult mode as default and it will not go back into kids mode on reboot.
The actual nabi servers are gone, so some of the ask mom things will no longer work, but having it in adult mode things are generally okay.
Hope that helps.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 68
    Code:
    #include /* * Your warranty is now void. * * I am not responsible for bricked devices, dead SD cards, * thermonuclear war, or you getting fired because the alarm app failed. Please * do some research if you have any concerns about features included in this ROM * before flashing it! YOU are choosing to make these modifications, and if * you point the finger at me for messing up your device, I will laugh at you. */


    Here comes the root for the Nabi 2 and how to install fully work GApps.

    You must have a basic working knowledge of adb and have it installed. http://forum.xda-developers.com/showthread.php?t=1590800
    Also ensure you have fastboot installed and working

    attachment.php

    1. Ensure you have latest updates
    2. Download jmzrootpackage.zip from here
    3. Extract files to desktop
    4. Plug in phone
    5. Choose from which option you want

    Recovery was built by me but Dees_Troy pointed me in the right direction a couple times
    12
    This thread has slowed down...

    Got a new tool for you guys to play with.

    Nabi Lab!

    EDIT: I found a bug today. During lock screen modding the 1st prompt tells you image must be 1440x903, and the second 1400x903. The proper size is 1440 x 903

    haha

    Drivers.
    Root, backup, gapps,
    Return to stock condition.
    TWRP recoveries.(new symlinked partitions) see if this fixes some of the last of the TWRP errors for different Nabi's
    General Information display
    Lockscreen modding(Saves the zip to folder besides installing, hopefully makes it easier for people to do it, and we can get some sharing of lockscreens)

    This is very much alpha. If you play with it you have to have a backup, until bugs are worked out.

    There is a lite version and a full version. Only difference is lite doesn't have a full 1.9.37 stock backup, so it's 100MB, versus 1.2GB. Any fixes will be small patches 1MB at the most. Full version is really only for those needing to go back to stock and don't have a backup.

    Lite: https://www.box.com/s/z8f6ibz05h22jzm4uxx4 93MB
    Lite: https://docs.google.com/open?id=0B024tOntNFbbMU95N1g3c2tXSHc 93MB
    Full: https://docs.google.com/open?id=0B024tOntNFbbU0E5cm1GdFUxRFE 1.2GB


    I have worked through a restore to stock, flash Gapps, Root, and make backup. Installed TWRP. Changed lockscreen. Installed drivers. So I believe it's safe at this point to have a few people test. Read the directions. I'll upload a video showing it in action if you're hesitant. I'd like a few testers to work through the screens. Plug in multiple Android devices and see if it detects the conflict. It doesn't always stop you if you have 2 devices plugged in, just see if it's warning you. Try a few things out and see what bugs there are.

    You Tube video http://www.youtube.com/watch?v=pvrooV9aPyI

    nabilab.png

    nabilab1.png

    nabilab2.png

    nabilab3.png

    nabilab4.png
    11
    Well this is a HUGE mess now is it! Are we all bathing in children's tears... :p

    I think most of the 2nd OTA issues stem from either TWRP deleting some files to protect it's self, or the fact people have taken ROM restores, which unlike going the OTA route don't deal with any changes to the addon partition, and the 2nd OTA is not seeing the files on that partition it expects.

    For those that completed the first OTA but not the second this might get around the issues, by deleting recovery checks, and copying the full apks to addon. Use TWRP to "install it"

    OTA2mod

    --------------------------------------------------------------------------------------------------------------------------------------------------------------

    The second method might help people that have a complete disaster going on.

    Download the first file. It is the stock rom for 2.3.11. You need to put it in TWRP/BACKUPS/XXX/folder where "XXX "is your serial and "folder" is a name of your choice. "Restore" from this folder boot and system

    This will give you the stock ROM but it will not be bootable because you are still on ICS bootloader, and you have made no proper changes to addon. So BEFORE reboot take the second file addonfix and "install" it. It should install stock 2.3.11 addons, update the bootloader and perform some Nabi setup magic. Now reboot.

    2311stockROM

    addonfix.zip

    Keep in mind the need to switch TWRP version afterward. http://forum.xda-developers.com/showpost.php?p=47306565&postcount=67

    Hopefully this helps the normal US users straight. Still have a couple people with partition mods that need to be undone, and I'm not sure what to do about the UK users. I have someone who said they would give me a stock UK image, but I haven't got it yet, and I'm not sure how that is going to help with those that want this update on a UK version, but it could at least get them back to where they started if this isnt working for them.
    10
    You all get the new update v2.4.6?

    States as Google Security Fixes. I uploaded it for you all if you need or want it. Pulled it from my Nabi2. Have not installed it yet. Want to check it out first.

    Download : v2.4.6 OTA ( 165 MB )


    Yep. Seems a rather simple update when peeking inside. Does another bootloader update though. TWRP still works fine.

    Here is the full stock Nabi 2.4.6 image. system, boot, addon, recovery

    246stock.zip

    Here is a flashable bootloader update

    JB246bootloader

    With those 2 files it should allow any Nabi in any condition to return to stock 2.4.6. Like the previous procedure extract the images to your TWRP backup folder and restore all, then before reboot "install" the JB246bootloader.zip. Basically this http://forum.xda-developers.com/showpost.php?p=51037177&postcount=21 but with 246stock.zip in place of 2311stock and 2311addon zips, and the 246 bootloader zip instead of the old JBbootloader zip

    Then here are some TWRP flashable OTA's, we are all kind of all over the map so making an update for everyone isn't so easy.

    First TWRP flashable zip is for anyone that has rooted, has done a lock screen mod, used the 4 way reboot menu, or edited the build.prop. It will undo those changes and then do OTA

    2311to246.zip

    The second I have no idea if will even work. It's for anyone that applied the minimal Nabi zip awhile back. I can't test it but it ignores all those files. DONT use this one unless you know you flashed the minimal Nabi and even then it may not work.

    2311to246minimal.zip

    Finally I new TWRP

    Nabi Specific: Add 2.4.6 kernel

    TWRP Changes

    Add GUI option to change or repair file systems on individual partitions. The change is destructive so backup your data including internal sdcard first. This option should make it a little easier to migrate a device from ext4 -> f2fs, for instance. You will find this option under Wipe -> Advanced Wipe, then select only one partition and then press the Repair or Change File System button. If a developer has added f2fs support for your device and we don't have it in TWRP, please contact me via PM to arrange for it to be added.
    Various bugfixes to backup and restore
    Improvements to USB storage handling
    Added a class to search for files to make finding the correct brightness file automatic in most cases
    Various other bugfixes and tweaks

    NABI2JBTWRP271.zip (fastboot)

    twrp-recovery-JBNV7AUS-271.zip (flashable)

    Latest device tree for building recovery with Omni 4.4.4 as base with 2.4.6 kernel

    https://github.com/aicjofs/android_device_fuhu_mt799_omni

    There ya go just enough to cause a lot of chaos. It's been too quite around here anyway... :p
    10
    Ok I managed to fit everything in the recovery(exfat/super user) at 8MB and changed the color space so that Aroma works but the colors aren't all crazy. Added the Nabi theme back in.

    3.0.13 users can flash 285 for KK

    Everyone else(Disney, Nick, UK, original 2.4.6 and below) should use 285 for JB
    EDIT: Note Disney and Nick have received KK update since this post was made.