• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Question Navifly 7862 Wifi and Bluetooth Issues

Search This thread

uberNoobZA

Senior Member
Oct 10, 2008
561
340
Oxford
My Navifly 7862 is having issues with wifi and bluetooth. I am able to connect wifi on the unit to my phone hotspot, but when I try to connect it to the wifi on my Blackvue Dashcam, it connects, but once connected shows an X in the wifi symbol (see picture) and the Blackvue software cannot communicate with the dashcam.

For bluuetooth, it seems to work if I connect my phone to the device, but if I want to connect it to the OBDLink OBD2 reader in my car, it fails. I can search for the OBDLink in the Bluetooth app on the headunit, and select it and click connect, but nothing seems to happen. in addition if I go into the OBDLink software, and try to connect, it says the device is not paired with any OBD readers. I found a video on youtube that says I should use an app call "Bluetooth Pair" to pair the device with the OBD reader, but this also does nothing

Any advice that gets wifi and bluetooth working as I want would be really appreciated, as connecting to webcams and OBD reader are 2 of the main reasons I got this device
 

Attachments

  • 20210708_123634.jpg
    20210708_123634.jpg
    718.4 KB · Views: 33
The "x" in the wifi means it's not getting internet. This happens when tethered to my phone and theres' no cell coverages. I have noticed that when this happens it does try to connect to other wifi until internet returns. Perhaps that is causing your communication with your dashcam. bring up the wifi settings window and leave it up when you connect, see if it's toggling.

Bluetooth device issues abound with these things, it's well documented here, I am not surprised.

as cool as these things are, there is some very "janky" code in there.
 
  • Like
Reactions: uberNoobZA

Allan_Hun

Senior Member
Mar 11, 2014
456
201
Gl.Rye
Does your Blackvue have LTE?
I'm using my 7862 and a black use 750X PLUS with LTE connectivity module and it works quite well. Since both headunit and dashcam have LTE I normally doesn't connect HU and cam through wifi -I prefer using blackvue's sky function so I get notifications on my phone.
When I tried the wifi connection I did have some problems but I fixed that by enabling a developer setting to keep mobile data on while connected through wifi.

Sadly the 7862 BT is limited to headset mode (used to connect with phones) + Chinese elm OBD clones. So BT doesn't work with "real brand" OBD dongles like scanmaster. So if Noname elm clones doesn't work for you I recommend a USB obd dongle.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    The "x" in the wifi means it's not getting internet. This happens when tethered to my phone and theres' no cell coverages. I have noticed that when this happens it does try to connect to other wifi until internet returns. Perhaps that is causing your communication with your dashcam. bring up the wifi settings window and leave it up when you connect, see if it's toggling.

    Bluetooth device issues abound with these things, it's well documented here, I am not surprised.

    as cool as these things are, there is some very "janky" code in there.