• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Need help to increase the SMS limit !

Search This thread

bubonik

Senior Member
Apr 19, 2006
348
6
Portland
Why did the mods move this? This is more android development than the live wallpaper request. This at least modifys things at the OS level. Sorry ass mods.

Have you tried multiple programs? I dont even have 100 contacts to test this.
 
Last edited:

Exodeity

Senior Member
Oct 21, 2009
77
4
Orlando
anynamhere.ath.cx
I'm no dev. but I do believe if your phone is rooted, you should be able to simply do adb pull, make the changes, then push the file back?

Leme' know if that works, just a thought :D
 

romeovn

Member
Jan 18, 2007
39
1
Well, I have the answer from Christopher
Like I mentioned, needing to remove the check is probably indicative that there's a better way to do things, but that answer pretty much covered the steps:

1. Obtain a device that has root access
2. Enter the device shell (the "adb shell" command) 3. Use the command line tools to alter the settings database 4. Reboot

For more details, check Google or try asking on StackOverflow.com as it's an official Android support channel.

Trying now
 
F

flybyme

Guest
lol if you dont like the mods here...try androidoverdrive.com. they are pretty helpful there. I'm also interested in seeing if you get this to work.
 

matthenry87

Senior Member
Feb 24, 2009
144
37
Denver
I got it to work! Heres how(taken from link above):

Open Command Terminal and enter the following:
adb shell
sqlite3 /data/data/com.android.providers.settings/databases/settings.db

Then you'll see: sqlite>

Then enter the following to alter the limit

INSERT INTO gservices (name, value) VALUES('sms_outgoing_check_max_count', 101);

(change 101 to your new limit)

I didnt try altering the limit so I hope it works for you guys.. but I can confirm this next one works. It completely turns off the limit altogether.

To turn off the limit enter:
INSERT INTO gservices (name, value) VALUES('sms_outgoing_check_interval_ms', 0);

It worked right away for me.. (SMS Bomber >)) Id reboot to be safe.
 

skanndelus

Senior Member
Dec 21, 2007
654
196
could anyone help me out? i get "sqlite3 permission denied" when i try to access the db i'm positive i'm doing something wrong because i am new at this.... i plug the phone in, open cmd prompt, cd to the tools on my hd... typed in what was listed and that error came up let me know...! thx
 

Jus10o

Senior Member
Mar 11, 2010
1,431
5
could anyone help me out? i get "sqlite3 permission denied" when i try to access the db i'm positive i'm doing something wrong because i am new at this.... i plug the phone in, open cmd prompt, cd to the tools on my hd... typed in what was listed and that error came up let me know...! thx

type

adb shell
mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system

then sqite3 and so on...
 

DancinDirk

Senior Member
Mar 15, 2009
55
2
Ok, I"m having trouble doing this on my EVO.

Here's what I've done so far:
1. Rooted with UnrEVOked
2. Installed SDK,
3. Added to path,
4. turned on usb debugging
5. connected with usb, drives did install
6. tested with adb devices, serial showed up
7. adb shell
mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system
mount: Operation not permitted
8. sqlite3 /data/data/com.android.providers.settings/databases/settings.db
sqlite3: permission denied
 

mejorguille

Senior Member
Dec 14, 2009
828
45
Florida
Ok, I"m having trouble doing this on my EVO.

Here's what I've done so far:
1. Rooted with UnrEVOked
2. Installed SDK,
3. Added to path,
4. turned on usb debugging
5. connected with usb, drives did install
6. tested with adb devices, serial showed up
7. adb shell
mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system
mount: Operation not permitted
8. sqlite3 /data/data/com.android.providers.settings/databases/settings.db
sqlite3: permission denied
Are you sure you have superuser access then? Go into terminal and type in "su" and tell me what you get.
 

dsMA

Senior Member
Jun 4, 2010
427
6
Sacramento
When I try:
INSERT INTO gservices('sms_outgoing_check_interval_ms', 0);

SQL error: near "0": syntax error

I am using a rooted HTC (Sprint) Hero running the Aolysuis 2.1 rom.
 

dsMA

Senior Member
Jun 4, 2010
427
6
Sacramento
Disregard everyone. Apperently you have to enter that whole command as written. I thought maybe he was giving a general syntax structure and then provoding us with specific values....that is what it looked like to me but no

INSERT INTO gservices (name, value) VALUES ('sms_outgoing_check_interval_ms', 0);

is the whole command...kind of silly looking if you ask me.
 

jerry43812

Senior Member
Feb 27, 2010
929
28
www.market4android.com
Disregard everyone. Apperently you have to enter that whole command as written. I thought maybe he was giving a general syntax structure and then provoding us with specific values....that is what it looked like to me but no

INSERT INTO gservices (name, value) VALUES ('sms_outgoing_check_interval_ms', 0);

is the whole command...kind of silly looking if you ask me.

May look silly, but that's how Structured Query Language is written. Don't be intimidated or embarrassed by the mistake, no worries!

Also, I have added this how-to guide on my website, located in my signature. OP, excellent find and great guide.
 

Israel777

New member
May 31, 2010
3
0
New York, NY
Are you sure you have superuser access then? Go into terminal and type in "su" and tell me what you get.

I have tried everything from the steps above to just typing


C:\Users\Israel David>cde C:\android-sdk-windows\tools
'cde' is not recognized as an internal or external command,
operable program or batch file.

C:\Users\Israel David>cd C:\android-sdk-windows\tools

C:\android-sdk-windows\tools>sqlite3 /data/data/com.android.providers.settings/d
atabases/settings.db sqlite3 /data/data/com.android.providers.settings/databases
/settings.db
sqlite3: Error: too many options: "/data/data/com.android.providers.settings/dat
abases/settings.db"
Use -help for a list of options.

C:\android-sdk-windows\tools>sqlite3 /data/data/com.android.providers.settings/d
atabases/settings.db
SQLite version 3.6.22
Enter ".help" for instructions
Enter SQL statements terminated with a ";"
sqlite> INSERT INTO gservices (name, Value)
...> VALUES('sms_outgoing_check_interval_ms',0);
Error: unable to open database "/data/data/com.android.providers.settings/databa
ses/settings.db": unable to open database file


SECOND WAY ......

C:\android-sdk-windows\tools>sqlite3 /data/data/com.android.providers.settings/d
atabases/settings.db
SQLite version 3.6.22
Enter ".help" for instructions
Enter SQL statements terminated with a ";"
sqlite> INSERT INTO gservices (name, value) VALUES('sms_outgoing_check_interval_
ms',0);
Error: unable to open database "/data/data/com.android.providers.settings/databa
ses/settings.db": unable to open database file


IN BOTH WAY THEY SAY UNABLE TO OPEN DATABASE FILE AND I DO HAVE ROOT ACCESS I HAVE CHECKED :)
 

Israel777

New member
May 31, 2010
3
0
New York, NY
I am using a Sprint Hero! Flash 2.1 ROM I need to find a way to erase the LIMIT because I have 4 groups with over 200 people that receive daily txts and I have tried using Command Prompt and Terminal and on Command Prompt it says that sqlite3: not found and on Terminal adb: not found or permission denied

I have su permission
 

DancinDirk

Senior Member
Mar 15, 2009
55
2
Just tried to do this on my newly updated 2.2 evo (OMJ build) and I got

SQL Error: no such table: gservices

Has this hack/fix changed in 2.2 or did they remove the limit?
 
  • Like
Reactions: Difusal

eXDee

Senior Member
Mar 23, 2009
155
12
I cant get SQLite3 to work at all:
sh-3.2# sqlite3
sh: sqlite3: command not found
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    I got it to work! Heres how(taken from link above):

    Open Command Terminal and enter the following:
    adb shell
    sqlite3 /data/data/com.android.providers.settings/databases/settings.db

    Then you'll see: sqlite>

    Then enter the following to alter the limit

    INSERT INTO gservices (name, value) VALUES('sms_outgoing_check_max_count', 101);

    (change 101 to your new limit)

    I didnt try altering the limit so I hope it works for you guys.. but I can confirm this next one works. It completely turns off the limit altogether.

    To turn off the limit enter:
    INSERT INTO gservices (name, value) VALUES('sms_outgoing_check_interval_ms', 0);

    It worked right away for me.. (SMS Bomber >)) Id reboot to be safe.
    1
    Just tried to do this on my newly updated 2.2 evo (OMJ build) and I got

    SQL Error: no such table: gservices

    Has this hack/fix changed in 2.2 or did they remove the limit?