Need help with my mtk6589 device

Search This thread

OSI007

Senior Member
May 9, 2014
84
13
Port Harcourt
Hey all, I was updating the system apps of my mtk6589 device (infinix X451 - RBoltQ, android 4.2.1) device ie calender, email , deskclock, launcher etc to that of the android 4.4Kkat . Thay all worked perfectly it felt cool. I then updated my camera to that android 4.2.2 (all done with root explorer and link2SD ). Later on I came across the google camera. It always FC so I thought maybe making it a system app (using Link2SD) & deleting my other camera apps will resolve the issue. This didn't work . I even changed some lib files like I saw on a blog (libjn...mosaic,liblightcycle, lib..google.. - backed them all manually 1st though) still no avail. Now I restored the normal camera and the lib files, with their required permissions (root explorer) but ALL CAMERA apps installed FC ..even with a hard reset, the camera icon is NO LONGER there , only the gallery (for the stock camera). Apps like Antutu BM and Dx toolbox can't detect the camera (front and rear) or say Not supported. Same with apps that use Cam or flash or both. Flashlight too is no longer available while I noticed that the Glauncher now FC when I want to change wallpaper and the STOCK RECOVERY now shows an android with a red exclamaition mark. Gone 3 weeks without the camera, FL and now going through blogs and forums & I just don't know what to do.. Please any help will be appreciated as I don't want to loose my mtk device or its camera - even as my joy of getting my first android smartphone last year (dec 29) is turning into a nightmare. Thanks in advance.
(Sorry mods if I posted in the wrong section, kindly help me move it to the right place if possible, thanks)