• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Need to root an Android 8.1 mirror

Search This thread

F0L

Member
May 27, 2012
35
7
www.ultimateamiga.co.uk
I have a Junsun A103JS. Ever since I had it, it had played up with camera locking up. I just lived with it. However, I ended up bricking it, by installing magisk directly. Luckly the Manufacturer gave me firmware. I reflashed it and all working perfect, no longer locking up, :).

Anyway, I have spent hours trying to root and every time I get closer, some thing screws it up.
Im currently at the point, where I have a patched boot.img but am unable to flash it back, due to magisk altering size. It will not fit in boot partition. Anyone else had this issue. As I have never come across this issue before.

To get magisk to install directly, you need to kingo root (from PC). Once it roots it, you will have temp root. If you restart, root is gone. You have kingoroot remove root and then re root with kingo root.

Im so close. Its annoying.

Reason I want root, is to due to these firmware not being optimised. They are slow and sluggish. It takes forever to change functions and while temp rooted.

Running Kernel Audit, you can alter a few things, like read ahead etc etc which help. Also I notice, the CPU's are run at fullspeed all the time. Governors do nothing, you can only alter speed to fixed amount.
 

luis iturriaga

New member
May 16, 2021
4
0
60
Hello, good afternoon, I need the generous help of the forum, I have a 4G ADAS CMIRROR 10 inches, I had a problem with the 4G network, it is working without any problem and from one moment to another it stopped working, to recover its operation I require the Bluavido firmware to I installed 10 inches of version 12 and the icons were very large and its operating system is Android 8.1, whoever could help solve this problem would be eternally grateful, thanks greetings
 

Spastro

Member
Feb 18, 2020
46
0
Hey all been looking at getting of these.
They all mention only transmitting via FM to the car. Any way to transmit via Bluetooth so I can have Spotify /maps going and have the sound come out of my car speakers.
 

pindonga123

Senior Member
May 28, 2015
51
1
Does anyone know how to navigate the recovery mode? I can enter recovery mode but I get the android doll with the exclamation point. I saw in another forum that by pressing the power key the commands come out but I couldn't do it. I press the power key and the switch that is hidden in the A / V input but nothing, at the end of much testing it turns off. What happens in these devices in which they do not have a volume key? Thank you for your help because I have been investigating for a week and I still cannot solve the problem
 

Rickyrajput88

New member
Aug 20, 2021
1
0
Hi,
I have tried to install the firmware through Researchdownload. It's getting stuck on _repartition_. Please help me out.
adas mirror error.PNG
 
System partition is not protected by the locked bootloader.

Only boot and recovery are
Drivers and firmware and a lot more information is available at
?ttps://4pda.ru/forum/index.php?showtopic=979700&st=1580
It's in Russian. So use Google translate in chrome.
the long read get ready for 107 pages in very broken English.
But there is a lot of useful information.
Look for links to something called the "research download tool" "research upload tool" something like that I can't remember.

There's a hidden button inside one of the external connectors that puts into programming mode. in this mode you can dump and write anything to the firmware as long as you don't modify the boot or recovery partitions. You use the research tool to dump the existing firmware as "PAC" file. You can then use the research tool to replace ,add or remove files from the system.img. you can also swap cellular modem firmwares, etc.
You can also flash back to the device



All the system files are signed with the default key from the Android SDK.

There was a drop-in file replacement for gaining root , on page 81 I think. The download link is now dead.

---------- Post added at 06:34 AM ---------- Previous post was at 06:19 AM ----------

There's a pre-rooted rooted rom in there somewhere.
By Compare the differences, maybe we can figure out what they did to achieve root, so that we can perform a similar stitching on our own vendor ROMs.
Yes, it's page 81 (post #1612). The link is not dead, login details are needed to download. Problem is you can't register if you can't complete the russian captcha. Any russian fellow with access there could repost the "root.7z" file here? That one seems to root most Android 8.1 mirrors.
 

Attachments

  • root.zip
    6.3 MB · Views: 58

jeszied

New member
Aug 28, 2021
1
0
can any one here has the firmware for 12 inches ekleva 8.1 android. I think this is the firmware: MZL_V80E_M8_188_Media_Sleep_2021062321
but i dont have the download for it..
 

gogi2021

New member
Oct 6, 2021
1
0
4 g ADAS MIROR 2-32 8.1. android при включение появляетс надпись андроид и больше нечего не запускайетмя если сможете помагите или помагите как можно зайти в recovery
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hello all,
    I have an Android 8.1 based DVR mirror for my car and I need some assistance gaining root access into it. The mirror was bought on Amazon and has an ASN of B07QM1RHC6 and is described as TOOGOO 219865. In the software it says it is a QcTech HMSA5E. Here is what I know about the device:
    - It is based on a Spreadtrum SC9832e
    - The software version is QC_HMSA5E_A5_966_Media_Sleep_2019090919
    - OTA update is provided by fota.redstone.net.cn
    - when I open an adb shell my prompt is sp8541e_srvm

    I also have the partition layout. Under the developer menu there is an option to enable root over adb, it is protected by a four digit pin.

    I would appreciate any help gaining root access either via the pin via some hack door.

    Hi, did you have any luck rooting your mirror? It sounds like I have basically the same mirror although mine is sold under the name Bluavido. I've tried several apps and adb to root mine and all have failed so far. My guess is its the same four digit adb root privileges pin that is locking out the root process. In my case I'm just wanting to replace the awful bootanimation.zip with my own images.

    Cheers Rich