Netflix app crashes after login details are entered

Search This thread

gopichandpai

Senior Member
Jan 9, 2010
57
5
Hi,

I just got my Fire TV set up. Used Smart DNS Proxy as part of wifi set up. Installed Netflix. When I open netflix and login using login credentials, the app crashes. I can't go beyond login screen.

I can stream Prime videos, crackle etc but not Netflix.

1 click settings is correctly set on Amazon account. I have tried deleting data and cache of all the apps installed and restarted the fire tv but couldn't succeed. I even tried resetting the fire tv but it didn't help either.

Any help is appreciated.
 

dbdoshi

Senior Member
Jul 23, 2014
173
37
Found 2 error lines related to Netflix. I searched for those and both lines are sometimes related to orientation issues. Might not be related to your issue, but figured I will throw this out to you:

Do you have any apps loaded to change orientation on your FTV?
 

gopichandpai

Senior Member
Jan 9, 2010
57
5
Found 2 error lines related to Netflix. I searched for those and both lines are sometimes related to orientation issues. Might not be related to your issue, but figured I will throw this out to you:

Do you have any apps loaded to change orientation on your FTV?
No, it is a new box. I have tried resetting the box and installed only Netflix. Even then it didn't work.
 

gopichandpai

Senior Member
Jan 9, 2010
57
5
Netflix is updated to 1.1.1 build 125. I am facing the same issue on this version of Netflix as well. Raised a ticket with Amazon. It's been a week. Doesn't look like they have been progressing much on my issue.

I hope some one here will be able to help me fix the netflix issue.
 

gopichandpai

Senior Member
Jan 9, 2010
57
5
As expected, Amazon and Netflix said they don't support the issues when Netflix is accessed outside US, UK and Germany. Looks like I just need to wait for new firmware releases on Fire TV and/or new version of Netflix to see if it ever works.

I hope some one from here can help me with the issue that I am seeing. Or some one finds a way to root the latest version of the firmware so that I can install some custom firmware or older version of the firmware to fix the Netflix issue.
 

dony71

Senior Member
Dec 1, 2010
277
14
you're not alone
i'm in US and just receive my amazon fire tv stick
software update being done automatically during setup, so it's up to date
netflix is not pre-installed, so i install from store ver.1.1.1 build 125
the app crashses straight away after login using login credentials
 

gopichandpai

Senior Member
Jan 9, 2010
57
5
Thanks for your reply. It worked for me couple of times but 99% of the time it didn't work me. Raising a ticket with Amazon didn't help either. They are clueless!
The status as of today is it is not working.
 

dony71

Senior Member
Dec 1, 2010
277
14
I sideload latest netflix ver.3.8.3 from google playstore and netflix working
However since this netflix version for tablet, then fire remote won't work on this version
I'm going to call netflix and escalate this issue
 
  • Like
Reactions: gopichandpai

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    This issue was because of HDMI-CEC issue!

    I disabled the HDMI-CEC and restarted the Fire TV and Netflix is working like a charm.
    1
    I sideload latest netflix ver.3.8.3 from google playstore and netflix working
    However since this netflix version for tablet, then fire remote won't work on this version
    I'm going to call netflix and escalate this issue
    1
    I manage to find the problem. It's related to DNS rebind in router.
    There is some type of attack called a "dns rebind" attack that dnsmasq can protect you against.
    For some reason streaming netflix is causing the protection to kick in and that is why it does not work.
    I have router with DD-WRT firmware which can disable DNS rebind protection in dnsmasq.
    I'm not sure about your router whether has feature to disable this.
    Anyway for further information, please read DD-WRT forum below
    http://www.dd-wrt.com/phpBB2/viewtopic.php?t=77831&postdays=0&postorder=asc&start=0