Nethunter Kernel (Immensity Kernel)

Search This thread

redx4

Member
May 9, 2021
5
0
i flashed your zip file but HID still not working. and i granted 666 permissions.
Screenshot_2021-05-09-18-15-56-792_com.offsec.nethunter.jpg
 

redx4

Member
May 9, 2021
5
0
Did you follow the instructions in the first post? (In the USB Arsenal section of the Nethunter app select hid USB function, disable adb and then click set USB function)
Yes, I did. hid interface was already giving a not found error before that. I did that and started seeing "/dev/hidg2" in the HID interface section.
 

moto-john

Member
Nov 18, 2016
37
22
Please try again and make sure the adb toggle under USB function is on disable. It is really important for it to be disabled. Then sent another screenshot after you do that.
 

moto-john

Member
Nov 18, 2016
37
22
Ok, it still seems like adb still is enabled. We can try some things. 1. Select the reset USB function and then try again, 2. Reboot and then try again (I suppose you've done this already but you never know), 3. If you are trying this while you're connected with a USB cable try disconnecting it and repeating the steps again (and vise versa if you're not using a USB cable try plugging one). 4. Try one of the other USB Functions that have also have his enabled (rndis and hid or hid and mass storage is I remember correctly). 5. Maybe try disabling adb from the developer menu in settings. Let me know if any of this worked
 

redx4

Member
May 9, 2021
5
0
Ok, it still seems like adb still is enabled. We can try some things. 1. Select the reset USB function and then try again, 2. Reboot and then try again (I suppose you've done this already but you never know), 3. If you are trying this while you're connected with a USB cable try disconnecting it and repeating the steps again (and vise versa if you're not using a USB cable try plugging one). 4. Try one of the other USB Functions that have also have his enabled (rndis and hid or hid and mass storage is I remember correctly). 5. Maybe try disabling adb from the developer menu in settings. Let me know if any of this worked
I tried them all, and they all failed. Is there a problem with the kernel I'm using?
 

David_#27

Senior Member
Mar 11, 2017
572
152
I'm sorry but how did you put your external Wi-Fi adapter in monitor mode? Which command did you use? I tried the custom command the app offers and also "airmon-ng start wlan1" but in both ways it enables monitor mode on wlan0.
 

moto-john

Member
Nov 18, 2016
37
22
I'm sorry but how did you put your external Wi-Fi adapter in monitor mode? Which command did you use? I tried the custom command the app offers and also "airmon-ng start wlan1" but in both ways it enables monitor mode on wlan0.
The adapter is probably wlan2 so try changing the command to that one
 

David_#27

Senior Member
Mar 11, 2017
572
152
The adapter is probably wlan2 so try changing the command to that one
It's not because I run "iwconfig" and wlan2 doesn't show up... I also tried what you're saying but it didn't work. I am trying with an adapter with the same chip as yours on the OP thread.
It's an Alfa AWUS036NHA.
 

moto-john

Member
Nov 18, 2016
37
22
I tried them all, and they all failed. Is there a problem with the kernel I'm using?
Will try to pm you a nethunter kernel that I have with a different base
It's not because I run "iwconfig" and wlan2 doesn't show up... I also tried what you're saying but it didn't work. I am trying with an adapter with the same chip as yours on the OP thread.
It's an Alfa AWUS036NHA.
Could you open a terminal, plug in the adaptor, immediately after run dmesg and then send the output here?
 

David_#27

Senior Member
Mar 11, 2017
572
152
Try to install this magisk module from inside the magisk app. It should probably work afterwards
Dude you are awesome!!
It works great!
Though, its name varies from wlan1 to wlan2 sometimes... For example, when I was trying to connect to it the first time I flashed the magisk module above, it was wlan2 and when I disconnected it and connected it again it went wlan1...
 

Top Liked Posts

  • There are no posts matching your filters.
  • 11
    *ONLY FOR AOSP (Verified working on Evolution X)

    This is my first Nethunter Kernel build. Based on UtsavTheGreat's Immensity Kernel this port provides all the benefits of the original Kernel with the added Nethunter functionality.

    What's tested and working:
    • Internal wifi monitor mode (Use the provided custom command in Nethunter app)
    • Hid support (In the USB Arsenal section of the Nethunter app select hid USB function, disable adb and then click set USB function)
    • External adapter support (TP-LINK TL-WN722N Tested, you may need to manually copy your WiFi card's firmware in "/vendor/firmware" from the provided zip. Also it appears as Wlan2 instead of Wlan1 if that matters)

    Installation:
    *Assuming you already have Magisk (and the BusyBox Magisk module), Nethunter store, Nethunter app, Kali chroot and Nethunter terminal installed.*
    1) Flash the Nethunter_final.zip
    2) Enjoy

    Big thanks to the creator of Immensity Kernel
    Source: https://github.com/Moto-John/kernel_xiaomi_raphael
    3
    Changelog:

    •5/8/20 -> Fixed HID bug
    2
    Was waiting for someone to make this! Thanks!
    Did you think about adding the drivedroid patch too?
    I think you can do the same thing from the USB Arsenal section in the Nethunter App

    Edit: No, wait. You are right. Will try to fix it

    Edit 2: Figured out it works fine as it is. Just booted an iso from it
    1
    *ONLY FOR AOSP (Verified working on Evolution X)

    This is my first Nethunter Kernel build. Based on UtsavTheGreat's Immensity Kernel this port provides all the benefits of the original Kernel with the added Nethunter functionality.

    What's tested and working:
    • Internal wifi monitor mode (Use the provided custom command in Nethunter app)
    • Hid support (In the USB Arsenal section of the Nethunter app select hid USB function, disable adb and then click set USB function)
    • External adapter support (TP-LINK TL-WN722N Tested, you may need to manually copy your WiFi card's firmware in "/vendor/firmware" from the provided zip. Also it appears as Wlan2 instead of Wlan1 if that matters)

    Installation:
    *Assuming you already have Magisk (and the BusyBox Magisk module), Nethunter store, Nethunter app, Kali chroot and Nethunter terminal installed.*
    1) Flash the Nethunter_final.zip
    2) Enjoy

    Big thanks to the creator of Immensity Kernel
    Source: https://github.com/Moto-John/kernel_xiaomi_raphael

    Trying to get a AR9271 chipset to work. Cant load modules with modprobe: modprobe: FATAL: Module ath9k_htc not found in directory /lib/modules/4.14.191-iMMENSITY-NethunterBuild-John//9938110c92
    That is obviosuly no directory. In which directory do i have to copy the firmware? Which folder do you mean with /vendor/firmware?
    Copyied the firmwares to /usr/lib/firmware and /lib/firmware, but still getting from dmesg that it couldnt found a firmware
    1
    Trying to get a AR9271 chipset to work. Cant load modules with modprobe: modprobe: FATAL: Module ath9k_htc not found in directory /lib/modules/4.14.191-iMMENSITY-NethunterBuild-John//9938110c92
    That is obviosuly no directory. In which directory do i have to copy the firmware? Which folder do you mean with /vendor/firmware?
    Copyied the firmwares to /usr/lib/firmware and /lib/firmware, but still getting from dmesg that it couldnt found a firmware
    You just have to copy the whole ath9k_htc folder in /vendor/firmware. Then it should recognize the firmware