• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

New front camera (Omnivision OV13B10) doesn't connect with custom Q, on RN8

Search This thread

Elinx

Senior Member
Jan 5, 2015
121
40
Redmi Note 8
Sorry, I can't try it this time. :( I was convinced I could try the mod, but .....

This phone is in use by my wife and she isn't happy with experimenting again after almost 6 months of use.
She is afraid for a brick again and the need for EDL, which was the case the first time I flashed RR.
She is satified with CR-Droid 7.xx (A11) and has all she wants, so want to stay with it.
 

helloyello

Senior Member
Feb 11, 2020
93
4
Hi,

I own a Xiaomi Redmi Note 8 - EU Model - 11.2020 batch, running the latest LOS 17.1 lineage-17.1-20211011-nightly-ginkgo-signed.zip
The front camera didn't work and I installed the Magisk module presented in this thread, namely:

After the first reboot, the front camera started working, but as soon as I left the phone to enter standby mode (doze mode), upon waking up all the cameras and all the apps I tried were not able to save video recordings - file corrupted / there was a problem saving the recording. I believe the data stream the camera service is providing the camera app is corrupted. Taking photos and saving them works with all the cameras, just the video recording is broken.
A reboot fixed this, but again, as soon as a standby - wake-up cycle happened, I wasn't able to record videos.

I believe the doze mode shuts down the camera service and on wake-up some other camera service init script is launched. I mean, not the one included in this Magisk Module, which looks to be launched only at boot time (when Magisk loads its modules).

Starting the phone with the charger connected all the time, even after a standby - wake-up cycle the cameras still work on recording videos.

Any help appreciated.

Edit: corrections
 
Last edited:

loopypalm

Senior Member
Jul 8, 2016
785
166
Osaka
Hi,

I own a Xiaomi Redmi Note 8 - EU Model - 11.2020 batch, running the latest LOS 17.1 lineage-17.1-20211011-nightly-ginkgo-signed.zip
The front camera didn't work and I installed the Magisk module presented in this thread, namely:

After the first reboot, the front camera started working, but as soon as I left the phone to enter standby mode (doze mode), upon waking up all the cameras and all the apps I tried were not able to save video recordings - file corrupted / there was a problem saving the recording. I believe the data stream the camera service is providing the camera app is corrupted. Taking photos and saving them works with all the cameras, just the video recording is broken.
A reboot fixed this, but again, as soon as a standby - wake-up cycle happened, I wasn't able to record videos.

I believe the doze mode shuts down the camera service and on wake-up some other camera service init script is launched. I mean, not the one included in this Magisk Module, which looks to be launched only at boot time (when Magisk loads its modules).

Starting the phone with the charger connected all the time, even after a standby - wake-up cycle the cameras still work on recording videos.

Any help appreciated.

Edit: corrections
Just an idea (not sure)
Copy the module folder somewhere
uninstall the module
do a recovery backup of system and vendor
mount system and vendor
overwrite the existing files with the module ones (use Ofox recovery because it write files with proper permission
clear cache and dalvik and reboot
 

Top Liked Posts