• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

New StatiXOS OFFICIAL 4.2 build for Essential PH-1

Search This thread

SirDigitalKnight

Senior Member
Jul 12, 2012
576
113
Jardin
Amazon Fire
LG G5
Thanks. Yeah not sure what is going on with mine. Hope it's not the battery starting to go. I have a A52 on its way in a few days so after I get it all setup and running I might have to nuke and pave the PH-1 and see if I can get it to behave again.
 

dankovac1999

Senior Member
Sep 18, 2016
90
21
22
HTC Leo
HTC Wildfire S
For those with the Chrome issue of freezing I have a fix that another user in another ROM thread accidentally found!

If you download
PH1-OTA-PQ1A.190105.090.zip

and then reboot into recovery (TWRP, be sure to disable pin on phone before hand and backup everything) then flash the above (I wiped everything first but DON'T wipe internal storage) then I did a second wipe of everything but internal storage and then I flashed 4.2 of StatiXOS and then I flashed TWRP, then I rebooted phone and set it up from new and restored everything from Cloud backup and I can confirm that I no longer have the Chrome freezing issue.

You can thank seungbaekm over in the Evolution-X 5.4 thread for this fix as he is the one that accidentally flashed the older PH-1 factory image and discovered Chrome then worked again! This should fix the issue for all the new Android 11 ROM 's out there for us folks that have the Chrome browser locking issues.

I did not even test the new 4.2 ROM on its own to see if it happens to fix the Chrome issue but I doubt that it does since it is not mentioned in the release notes. Also I have no idea if any of the other original factory images will also fix the issue, I only downloaded the one they he said he accidentally flashed and used it.

Hope this helps everyone with this issue as I know how frustrating it has been. Sure, there is the Bromite/Brave/Firefox work around, and I have been using and enjoying Bromite since 4.1 but I like having things working the way they are supposed to work.

Im running official LOS 18.1 and want to fix the issue. The problem is I cant flash twrp via fastboot flash:raw boot_a twrp.img, it always reboots to fastboot. Any sugestion what should I do?

Thanks in advance.
 

aamadorj

Senior Member
Im running official LOS 18.1 and want to fix the issue. The problem is I cant flash twrp via fastboot flash:raw boot_a twrp.img, it always reboots to fastboot. Any sugestion what should I do?

Thanks in advance.
You don't need TWRP to install different Essential PH-1 firmwares because most of them can be found as fastboot flashable files. I recommend you take a look a this old thread about firmwares and try out this firmware, which is the most recent I found that fix the Chrome/Chromium freeze issue for my device.
 
  • Like
Reactions: SirDigitalKnight

dankovac1999

Senior Member
Sep 18, 2016
90
21
22
HTC Leo
HTC Wildfire S
You don't need TWRP to install different Essential PH-1 firmwares because most of them can be found as fastboot flashable files. I recommend you take a look a this old thread about firmwares and try out this firmware, which is the most recent I found that fix the Chrome/Chromium freeze issue for my device.
Thank you so much!
I have chrome opened for like 5 minutes so I'm not afraid to say it's working! It took me a while as long as mine fastboot drivers are broken and I had to flash manually from OnePlus in terminal emulator 😂 but the time payed off nicely!
 

Attachments

  • Screenshot_20210706-221406_Terminal_Emulator.png
    Screenshot_20210706-221406_Terminal_Emulator.png
    555.5 KB · Views: 21
  • Screenshot_20210706-221411_Terminal_Emulator.png
    Screenshot_20210706-221411_Terminal_Emulator.png
    549.5 KB · Views: 18

aamadorj

Senior Member
Thank you so much!
I have chrome opened for like 5 minutes so I'm not afraid to say it's working! It took me a while as long as mine fastboot drivers are broken and I had to flash manually from OnePlus in terminal emulator 😂 but the time payed off nicely!
Great news!!! Also, it's good to know LOS 18.1 can be used with mata and PQ1A.190105.112 firmware.
 
  • Like
Reactions: dankovac1999

kt-Froggy

Senior Member
Sep 14, 2012
1,667
728
YVR
Essential Phone
Samsung Galaxy S10e
Looks like they keep messing up the updates... 😕 Just tried the July 14 OTA. The camera crash persisits from the June update. Another problem is that the screen position (or the resolution, not sure) is now set up wrong, cutting off a vertical strip on the right. Screenshot doesn't show this problem, and turns out perfect. But here is a photo of the screen after the update - note the status bar, dock and app icons being cut off on the right. Reboot doesn't help, and I didn't want to do a factory reset, as this phone is my daily driver. So, I am back to May update, the "last known good" setup.

20210715_195350.jpg
 
Last edited:

aamadorj

Senior Member
Looks like they keep messing up the updates... 😕 Just tried the July 14 OTA. The camera crash persisits from the June update. Another problem is that the screen position (or the resolution, not sure) is now set up wrong, cutting off a vertical strip on the right. Screenshot doesn't show this problem, and turns out perfect. But here is a photo of the screen after the update - note the status bar, dock and app icons being cut off on the right. Reboot doesn't help, and I didn't want to do a factory reset, as this phone is my daily driver. So, I am back to May update, the "last known good" setup.

View attachment 5363173
This issue was reported at the Telegram group for Statix OS support, but so far the only response from a dev was do not install Magisk.
 
  • Like
Reactions: kt-Froggy

hedgecore44

Senior Member
Mar 9, 2016
135
32
I couldn't get notification LED to work on the Static June official. Same with PA5 beta. Works fine on Havoc 4.6. weirrrrrd. Does anyone know if this was fixed on Statix July official update?
 

kt-Froggy

Senior Member
Sep 14, 2012
1,667
728
YVR
Essential Phone
Samsung Galaxy S10e
This issue was reported at the Telegram group for Statix OS support, but so far the only response from a dev was do not install Magisk.
Which issue - the camera or the display? Well, anyway... Great advice, LOL. For those who don't need root, sure. BTW, last time I checked, they closed the TG group (I can't access it anymore). Only the announcements are open to the public now.
 
  • Like
Reactions: hedgecore44

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Im running official LOS 18.1 and want to fix the issue. The problem is I cant flash twrp via fastboot flash:raw boot_a twrp.img, it always reboots to fastboot. Any sugestion what should I do?

    Thanks in advance.
    You don't need TWRP to install different Essential PH-1 firmwares because most of them can be found as fastboot flashable files. I recommend you take a look a this old thread about firmwares and try out this firmware, which is the most recent I found that fix the Chrome/Chromium freeze issue for my device.
    1
    Thank you so much!
    I have chrome opened for like 5 minutes so I'm not afraid to say it's working! It took me a while as long as mine fastboot drivers are broken and I had to flash manually from OnePlus in terminal emulator 😂 but the time payed off nicely!
    Great news!!! Also, it's good to know LOS 18.1 can be used with mata and PQ1A.190105.112 firmware.
    1
    Looks like they keep messing up the updates... 😕 Just tried the July 14 OTA. The camera crash persisits from the June update. Another problem is that the screen position (or the resolution, not sure) is now set up wrong, cutting off a vertical strip on the right. Screenshot doesn't show this problem, and turns out perfect. But here is a photo of the screen after the update - note the status bar, dock and app icons being cut off on the right. Reboot doesn't help, and I didn't want to do a factory reset, as this phone is my daily driver. So, I am back to May update, the "last known good" setup.

    View attachment 5363173
    This issue was reported at the Telegram group for Statix OS support, but so far the only response from a dev was do not install Magisk.
    1
    This issue was reported at the Telegram group for Statix OS support, but so far the only response from a dev was do not install Magisk.
    Which issue - the camera or the display? Well, anyway... Great advice, LOL. For those who don't need root, sure. BTW, last time I checked, they closed the TG group (I can't access it anymore). Only the announcements are open to the public now.
    1
    Which issue - the camera or the display? Well, anyway... Great advice, LOL. For those who don't need root, sure. BTW, last time I checked, they closed the TG group (I can't access it anymore). Only the announcements are open to the public now.
    The display issue.
  • 5
    For those with the Chrome issue of freezing I have a fix that another user in another ROM thread accidentally found!

    If you download
    PH1-OTA-PQ1A.190105.090.zip

    and then reboot into recovery (TWRP, be sure to disable pin on phone before hand and backup everything) then flash the above (I wiped everything first but DON'T wipe internal storage) then I did a second wipe of everything but internal storage and then I flashed 4.2 of StatiXOS and then I flashed TWRP, then I rebooted phone and set it up from new and restored everything from Cloud backup and I can confirm that I no longer have the Chrome freezing issue.

    You can thank seungbaekm over in the Evolution-X 5.4 thread for this fix as he is the one that accidentally flashed the older PH-1 factory image and discovered Chrome then worked again! This should fix the issue for all the new Android 11 ROM 's out there for us folks that have the Chrome browser locking issues.

    I did not even test the new 4.2 ROM on its own to see if it happens to fix the Chrome issue but I doubt that it does since it is not mentioned in the release notes. Also I have no idea if any of the other original factory images will also fix the issue, I only downloaded the one they he said he accidentally flashed and used it.

    Hope this helps everyone with this issue as I know how frustrating it has been. Sure, there is the Bromite/Brave/Firefox work around, and I have been using and enjoying Bromite since 4.1 but I like having things working the way they are supposed to work.
    4

    4.2 has been release

    "Introduce our OTA Updater!"
    3
    Following this great insight about the fix of the Chromium issue, I only flashed mata PQ1A.190105.090 NOVENDOR firmware from this old thread, without wiping anything of my current StatiXOS 4.2 installation, and after booting Brave is working perfectly.

    So, it seems the issue was caused not by the ROM system or vendor, but the mata QQ1A.200105.007 firmware.

    As a consequence of flashing this old no system nor vendor firmware, my device baseband was downgraded, but mobile data seems to be working just fine. I guess it's possible to test newer firmware available at the referenced thread, like PQ1A.190105.112, QP1A.190711.107 or QP1A.190711.148, to identify the latest firmware free of the Chromium issue.

    More good news: now Netflix is working fine, also.

    UPDATE: I tried all the these firmwares and Netflix worked fine only with the Pie ones. So, PQ1A.190105.112 is the more recent mata firmware that I can use on my PH-1 with StatiXOS 4.2 in order to keep Chromium browsers and Netflix working.
    2
    You should be able to flash the older Pie firmware without wiping from what I have read but I have not tried that yet. I might try it with the very latest firmware of Pie, PQ1A.190105.112 and see if it screws anything up without wiping the phone. Anyway I always to a backup of the phone to the cloud and also of Whatsapp before I start messing around just in case I have to wipe and so far all my restores have worked perfectly, but yes it is a pain to have to setup wifi's and add back in BT devices and setup security and any double authentication apps you use. Getting used to it now though.
    Flashing the contents of the attached files using fastboot should make your device to use last firmware for Android Pie, without losing your current ROM installation.
    1
    Which issue - the camera or the display? Well, anyway... Great advice, LOL. For those who don't need root, sure. BTW, last time I checked, they closed the TG group (I can't access it anymore). Only the announcements are open to the public now.
    The display issue.