New TS10 UIS7862 6gb ram 128gb head unit q&a's

Search This thread


New member
Nov 29, 2021
Hi all,

Does "Find my phone" app shows this device?

I have 3 devices associated with my google account (Phone, tablet, head unit) , but I only see my phone and tablet.

I have verified Find My Phone option is enabled, internet connection is ok, location is enable..., Any thoughts or alternatives to track my car? :)



Jun 28, 2017
I was troubleshooting this all yesterday and the day before and finally found the solution to this.

I currently have a TS10 from Youmecity from AliExpress and my headunit started doing th is on the second use.

I renamed my headunit hostname, bluetooth host name and hotspot hostname to the same name, once done I restarted the headunit and my phone (its important to unpair both phone and headunit if you have done so previously), once done repair it and it should do the new name.

It's important to note that Zlink, Tlink and Tlink5 software are all different, you have to use the type that came with your headunit otherwise it will ask you to activate the software. So in lamance terms, if your headunit came with Tlink5 (mine did), I cant use Tlink or Zlink without buying an activation code.

My headunit had Zlink installer in the flahs memory of the headunit, despite requiring Tlink5, so not sure what they were thinking in that regards.

Once you are using the correct software, paired your phone (both modules) and have your wifi receiver turned on (on the phone, not the headunit), Tlink5 will turn off any wifi on the headunit and enforce a hotspot, this is what is required to simulate wireless streaming over a 5ghz wifi frequency.

Now my headunit auto connects to android auto within 5-10sec everytime I turn on the car.

Did you ever have it revert back? Your method worked for me for about a week until it started doing it again.

For some additional information, I'm using tlink5 not zlink and whenever the error occurs it doesn't show the "Android auto is available/searching" notification, even though if I check Android auto settings it shows wireless AA is available.


Feb 28, 2023
Did you ever have it revert back? Your method worked for me for about a week until it started doing it again.

For some additional information, I'm using tlink5 not zlink and whenever the error occurs it doesn't show the "Android auto is available/searching" notification, even though if I check Android auto settings it shows wireless AA is available.
Did you did any update that caused it to behave like that? Can you connect to wifi?


Jun 28, 2017
Did you did any update that caused it to behave like that? Can you connect to wifi?
I'm using tlink5 5.3.21 and TS10.2.2_20220830.160400_WINDOW-THEME1, but I downloaded 5.3.21 and I've been using it since the start. Haven't had issues connecting to wifi either. Android auto has been the only part that has been updated, but I've had the issue through a few different updates.

Should I update my head unit firmware and tlink5 first?


Senior Member
May 1, 2021
i have a problem with usb port . after reset to factory my radio all function its ok but THE 3 USB PORT NOT RECOGNIZE KEY OR OTHER DISPOSITIVE. RADIO TS10 C970 HAVE SOME MENU FOR SETTING USB PORT? THANKS.


Mar 17, 2022
My question is that I would like to get a firmware for the 10" Tesla style head unit below. Unfortunately, I uploaded one but I don't like the way it looks and works. I don't have the original, and the owner in front of me can't help.

Thank you in advance for your help

Device - ums512_1h10_NatvCPU -
CPU - Octa-UIS7862 (8 core 2*A75+6*A55 processor, 1.8ghz)
GPU - Dual core ARM Mali-G52 3EE
Sound proc. - ROHM32107
Radio - TDA7708
Bluetooth - 5.0
BaseBand - FM_BASE_19C_W20.33.7
RAM - 4 GB
ROM - 32 GB
Buildszám - QP1A.190711.020 release-keys
CAN - V1.52.009BYPT5
Boot - 1024x768_M8_L8_WD097GHL40AA-A8_90_100
System - TS10.1.2_20220813.103013THEME1-V2
CarSetting - master_Dev.20220617
Android Version: 10.0


  • 1675870194349.jpg
    3.6 MB · Views: 62


New member
Apr 26, 2019
I would like an answer to my question, does anyone know?
TS10 vertical head unit.
Firmware : TS10.2.2_20220915.173424_THEME1-V2
I would like to exchange it for : TS10.2.2_20220525.142926_TW1-V2
It is possible? All parameters match.
The first two are mine.


  • IMG_20230322_083117.jpg
    804.9 KB · Views: 76
  • IMG_20230322_083128.jpg
    3 MB · Views: 69
  • 1.png
    250.8 KB · Views: 65
  • 2.png
    242.9 KB · Views: 77


Senior Member
Aug 30, 2015
Hi the link u provided no longer available... May I know what's is the name of the vendor? Is it sinosmart?


New member
Mar 26, 2023
Guys - I have an andriod headunit that I have fixed in UAE while on a road trip there. I dont know the model number and updated it through the online update feature. Now the screen is split in 2 screens with one the screens mirroring the other and its messy. Please see attached pics for reference. The touch screen functions as if it's displaying the full screen however its split in half. If i use a mouse for it then I click on what I see in the shrunk screen and it works ok. Everything is working fine accept for the screens being shrunk with multiscreen.

Is there a way for me to zoom in and change aspect ratio of screen to match the size of the screen or flash back to the old firmware. I have attached pics of the old system info (which are the pics where the screen is not split into two)


  • PXL_20230326_141738214.MP.jpg
    3.7 MB · Views: 68
  • PXL_20230325_150337912.jpg
    1.1 MB · Views: 68
  • PXL_20230325_145850540.MP.jpg
    3.3 MB · Views: 68
Last edited:


Oct 27, 2010
Does anyone know how to enter in the recover mode? Specifically the head units from cartrimhome’s new knobless units?

I've tried the combinations of resets I found on YouTube and nothing has worked. Thx.

Pic for reference


Senior Member
Apr 27, 2012
Hello all,
Was anyone able to figure out the sound problem when choosing default navigation app? When I choose default navigation app like Waze - the voice guidance is muted for some reason but all other sounds are muted when the navigation tries to speak. I want to have default navigation app in window theme among other things on main display and that is why I cannot unload it from default nav app right now and this must be fixable somehow...

I am using latest TS10.1.2 windows theme firmware...


Senior Member
Apr 27, 2012
Is there any aliexpress 2din version instead of this radio which has Android head unit UIS7862 for Skoda Superb 1 2006? Cannot find specific one for this car, only universal... Thx for help.


  • received_170929985763450.jpeg
    409.2 KB · Views: 21
Last edited:


Mar 17, 2022
What kind of CAN box do you recommend for the Ford Focus mk3.5 facelift? Can it affect the RDS and AF operation of the FM radio?

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    In my TS10 headunit i have software version:
    I would like to update to:
    The update done, but after restarting, I still have the old version of the software.
    What to do? Should I tick the wipe data and format option?
    When updating, I see that it only loads two files out of six.

    View attachment 5912475

    View attachment 5912477

    My headunit specs:
    Platform: TS10
    CAN version: Unknown
    Boot version: 720x1280_M8_3L_ICNL9707_90_99_20210601
    MCU version: Ts10.1.1-100-10-A4C695-211224(MM031)
    System version: TS10.1.2_20210902.095423_WINDOW-THEME1
    Screen resolution: 1280x720
    CarSetting Version: V1.0.0.20210827
    Android Version: 10.0
    CPU: Octa-UIS7862(8 core 2*A75+6*A55 1.8ghz)
    GPU: Dual-core ARM Mali-G52 3EE
    Sound processor: ROHM32107
    Radio: TDA7708
    RAM: 4.0GB
    Storage: 32.0GB

    Uploading a zipped ZIP file to the flash memory helped.

    Any ideea what is the diferente between TS18.2.2_WINDOW-THEME1 and the TS18.2.2_WINDOW-THEME1-V2 ?

    Im on TS18.2.2_WINDOW-THEME1 and i want to kow if is ok to update?
    WINDOW-THEME1 for landscape WINDOW-THEME1-V2 for vertical screen
    I can say that


    This firmware for my TS10 unit is working VERY GREAT so far. I had an issue with my external mic and autokit app that is resolved in this firmware i believe. I also have no bug (that i'm aware of)

    Thanks Timido64 for the upload
    HI @lissics,

    I do it like this on my TS10...

    Logo .png in the USB, then follow the video:

  • 10
    For everyone whos struggles with autostart/autorun an app and still cant decide which launcher to take. Here is a manual how to autostart any app.

    From here: Topway TS10 firmware

    password: TopwayTS10
    Hi everyone! i been continued to test new firmwares and Tlink versions for our "dear" TS10 headunits and I have gone trough over 100s of them and the newer firmwares usually mostly mess up more things than they bring anything useful.

    But this week i installed TS10.1.2_20230220.171000_WINDOW-THEME1 (NOTICE! this is for units with the 1.2 versions of the firmware, NOT for 2.2 or 1.1 or any other versions! and NOT for the vertical window ones).

    And on top of that did i install the new version of Tlink 2.0.18 to get a fully working Android Auto/Carplay.

    Which led to that i for the first time got a almost perfect working TS10. The only thing that was a bit tricky was to connect the phone to TLINK, but by trying several times (i removed the bluetooth connected units on my phone and headunit and re-connected) did it finally work wireless also (it worked directly with cable).

    Here is the links for the daring ones to try it out, all on your own responsibility!


    Tlink 2.0.18

    NOTICE! if you have problems with registration of TLINK, try this version instead (All credits goes to DarkVoid).

    Good luck everyone!
    New firmware is now released for the 1.2 WINDOW-THEME1 version - TS10.1.2_20220721.111654_WINDOW-THEME1 in this release have they now put back the FOTA that was removed in earlier versions.

    Download link:

    I spent this weekend digging deep into my headunit both looking at the hardware which made me think that if the Chinese manufacturers would put as much effort as they do in faking the hardware/software (Android version) and trying to block all software that will show that its not a Android 11 or 12 unit so could this unit be a great one.

    On the software side is the BIG problem that we have a firmware which is made for the chinese market and after that been remade again and again until its so messed up so you have to spend several months trying to find what you looking for and its filled of pincodes to enter settings. They messed up the basic settings for example autostart that will not work or the inbuilt microphone and Google Assistant because the Google settings is crippled. I really wish there will come a CLEAN version of the firmware which is like a Google Pixel phone without all the crap.

    The same with the preinstalled Theme app where that one now lately is called ilauncher and you still need to pay for the extra themes (well if you have the Chinese version so are there free themes monthly but not otherwise) and where most people have no idea that if you upgrade it correctly will you have support now for Spotify where the songs and album cover will show up nicely in the stock theme.

    But there is still no support for the stock theme to use and show song names and covers for example Rocket Music player, PowerAmp, Musicolet, AIMP or Jet Audio Player instead do we need to use the inbuilt music/videoplayer that has a UI that makes me believe im back in the 80s again and just want to make me cry.....
    Could you please give a screenshot of the setting you changed or at least where in the settings the function is.

    As promised, sorry video seems a bit blurry phone failing to focus :)