• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

nexus 5X bootloop

Search This thread


Dec 12, 2016
Dear Xda community,

i could really use your help.

So i had a working cyanogenmod 14.1 rom on my nexus 5X. I wanted to have cyanogenmod 13.0 on it, because of the theme engine.
So i made a backup using twrp. Then i completely wiped my phone. (twrp>wipe>advanced wipe>chose everything>executed).
Then i flashed cm 13.0. thereafter i booted my phone, but i couldnt get past the "google" screen. Then it booted again, but it wouldnt get past the "google" screen. And so on.
I tried wiping my phone and restoring my backup, but the same issue occured again. This issue keeps coming back no matter what I do.

I dont know how the fix this, please help.

thank you in advance. ~Jens

Commodore 64

Senior Member
May 6, 2013
It sounds like a bootloader mismatch problem. Going from CyanogenMod 14 (Android 7) to CyanogenMod 13 (Android 6). This should theoretically solve your problem, although I haven't tried it. Flash marshmallow (Android 6) Factory image from https://developers.google.com/android/images#bullhead. Pick the last marshmallow release, MTC20K, let it boot once, do a factory reset, unlock bootloader, reinstall twrp and then try CM13.

Sent from my Nexus 5X using XDA-Developers mobile app