Nexus 5X bootloop

Search This thread


Senior Member
Jan 11, 2012

I was watching YouTube when my phone froze and wouldn't respond. I detached the battery and reset it but it would freeze on the 'Installing update' screen even though I didn't try to update the phone. I wiped the cache and data but now it just gets stuck on the 'Google' boot screen.

I can get into the fastboot and recovery modes but the phone won't connect to the PC to allow me to try to sideload. In device manager it appears as "Android" with an exclamation mark next to it. I've tried wiping every instance of Google's drivers and tried both Google and LG drivers but neither seem to work.

I can get it to detect the phone in LGUP using download mode but my phone is H798 and I don't want to go flashing H791 TOT files if it's going to brick the phone. I also want to make sure it's a hardware bootloop before trying the hair dryer method.

Any help appreciated,



New member
Mar 29, 2017
my nexus5x randomly shut off and now its completely bricked.
cant acces TWRP and have tried installing stock files but it doesn't seem to work.

Have you found a solution yet?
Anyone know any options?