[NIGHTLY] Cyanogenmod 6 (Froyo) for vendor Bravo (HTC DESIRE)

Status
Not open for further replies.
Search This thread

Pyr0x64

Senior Member
Mar 7, 2010
699
111
Merseyside
Anybody else have a problem with the APNs ?
I've got three of them listed
The first for T-Mobile is correct, but then there's two Virgin APNs listed, the second one isn't even using Virgin servers
 
Last edited:

jonuwz

Member
Mar 21, 2010
8
0
someone posted a link to twitter that said there will be 720P recording in CM6.
But its nowhere on github so assumed it was false

I think i posted the original info.

I've looked in the decompiled Camera.apk and 720p support is in there.

The problem seems to be that getSupportedPreviewSize does not return 1280x720, so the option is filtered out.

Here are the links to github :

Camera strings.xml here :

h**p://github.com/CyanogenMod/android_packages_apps_Camera/blob/froyo/res/values/strings.xml

Relevent section :

<!-- Settings screen, Video quality dialog radio button choices -->
<string name="pref_camera_videosize_entry_0">720P</string>
<string name="pref_camera_videosize_entry_1">WVGA</string>
<string name="pref_camera_videosize_entry_2">VGA</string>
<string name="pref_camera_videosize_entry_3">CIF</string>
<string name="pref_camera_videosize_entry_4">QVGA</string>
<string name="pref_camera_videosize_entry_5">QCIF</string>


Commit here :

h**p://github.com/CyanogenMod/android_packages_apps_Camera/commit/abe4388e6bbdb1a84d2fc81ad677310257d9114c

John
 

DashingGentleman

Senior Member
May 22, 2010
201
32
Still testing obviously.. :p
but I've had no reboots on the last two builds yet while using OC and the interactive scheduler :)

I've had reboots with this combo, several per day. Will now test OC + ondemand I think - I used to be able to oc 1.2GHz under Defrost without any problems. I think the fact that the interactive governor uses the highest speed a lot might be putting more strain on the CPU. (as it's supposed to - as far as I understand it goes to max speed when waking by default and then only ramps down from there)

At the moment, the bugs I have are:
- Wifi goes off when phone is idle, ignoring the "never sleep" setting
- Wifi does not reconnect to known network automatically when on a WPA2 enterprise secured network
- Sometimes the music lockscreen controls behave oddly when using an alternative player - I have not been able to trace down a repeatable behaviour, but it will do things like play the default music player on top of what's already playing when locking/unlocking the screen etc...
- PPTP VPN is not working (server hung up error message)
 

DashingGentleman

Senior Member
May 22, 2010
201
32
I dont have that bug. I can confirm all the others though (+ trackball not working)

No trackball problems at all here - it used to stop working randomly some nightlies ago. Wonder why only some people have the problem.

With the wifi, when the wifi gets dropped due to the sleep bug, most of the time it won't reconnect on my university network (eduroam - 802.1x EAP secured) and I need to toggle the wifi on and off. It reconnects fine on my home WPA2 PSK secured network.
 

Pyr0x64

Senior Member
Mar 7, 2010
699
111
Merseyside
how long does it take for the wifi to drop after the screen blanks and the phone is idle?
i've just left mine for 10 mins and it's still connected according to my router.
swiftp over wifi is still working too, although much slower, taking a few seconds to just display phone directory contents.
if i use filezilla to copy a file from the phone to my desktop, it shows around 50-60KB/s. if i then turn on the screen and unlock the phone, the transfer speed jumps to 3+ MB/s

only problem i've had so far with the included music player is the widget doesn't always change the album art and song info when switching tracks

i've also not had a problem with the trackball/optical joystick yet

[edit]
perhaps the wifi "never sleep" option is reversed?
i've just checked mine and it's set to "when screen turns off"

[edit2] nope... not sure how long it took, but just noticed the wifi connection missing in the router status page
 
Last edited:

MrAdamH

Member
Sep 13, 2009
44
7
Copenhagen
Headset Controls?

Hey guys, i am having some problems getting the headset (stock one) button controls to work when playing music. It's like the trackpad, works only half of the time. And when its defunctional it stacks the commands. If i for example turn off my screen, press some buttons, the phone will only react to the buttons when i press the power button. so i will have to keep turning it on and off all the time to get through all the stacked button pushes.

Anyone else having these issues?
Had them since the nightly from 21.
 

Kali-

Inactive Recognized Developer
Apr 11, 2010
1,633
2,593
Roma
maybe, the battery drain which some one reported was caused by the last few days changes made on 2.6.34 kernel for fix the random Optical Joystick shutdown.
With last changes on 07292010, i'm confident about the battery drain is not caused by Desire kernel stuff.

Please from nightly 07292010, if Optical Joystick dies:

report nighlty version and dmesg.txt (pastebin links preferred)
# adb shell dmesg > dmesg.txt
 
Last edited:

gatsu_1981

Senior Member
Jan 4, 2009
456
15
nerd-tech.it
Never got problem with Headset Controls, and Optical Joystick trackpad died only 2 times in 2 months (hard to find the root cause)
When u loose Headset Controls OJ still works ?

Nope.
I think that they die together.
Yesterday my trackpad wasn't working, but I didn't care to reboot for fixing it, since I use it only for selecting text while browsing.

I was going to watch some anime episode on RockPlayer.
I inserted the headset and fired up one episode... The audio was not routed through headset, but went out from the desire itself.

RC1 for me, but I will update to latest nightly to test it a bit better.
 

stingerpl

Senior Member
Aug 3, 2009
387
0
Warsaw
With the wifi, when the wifi gets dropped due to the sleep bug, most of the time it won't reconnect on my university network (eduroam - 802.1x EAP secured) and I need to toggle the wifi on and off. It reconnects fine on my home WPA2 PSK secured network.

I bet it has something to do with multiple routers in Your university. Some devices don't handle that well :(
 

Pyr0x64

Senior Member
Mar 7, 2010
699
111
Merseyside
Still testing obviously.. :p
but I've had no reboots on the last two builds yet while using OC and the interactive scheduler :)

i spoke too soon,
no reboot, but locked up when ending a call late last night

before dropping the OC altogether, i'm going to switch back to "on demand" and see if that helps
 

lpachuong

Senior Member
Jul 30, 2009
733
52
Nightly 0729

I'm using the latest version 0729, which is running perfectly now. Previously I got reboot at 1.13ghz in the two previous build, but with this build, i have no more reboot with SetCPU. What can I say? Very stable and fast. Got benchmark 1653 and no reboot :)


What are working:

- Stable at 1.13Ghz with Interactive gorven
- Battery drains is okie. For me it is like 20% every ~6hours (autosync every 1 hours and mail push). It is also cooler than Setrom 4.5
- Static Wifi is working now
- WMA is playable

Some issues that we still have (from my device) are:


- OJ dies after screen rotation
- Wifi sometimes go off in sleep mode (ping false after ~4min)
- VPN is not working...maybe bcz of my set up

Expecting:
- D1 Camera is enabled :D
- More option in cam app (sharpness/saturation...)
- Radio lib is included and run with HTC FM app
- Colourful LED XD

Thank you CM and DEV.
 
Last edited:
Status
Not open for further replies.

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    @Kali: I took your odex-script and modified it to run automatically on flash.
    (again unsigned. My signed zip files don't pass the signature verification, don't know what the problem is.)
    I hope it's no problem ;)
    1
    Flashed the cklickon kernel on cm6 final. OJ already died after like 20 min.


    this is one of the reason to not share info on how to reproduce the bug, use your phone as usual


    was using my phone as usual


    Edit: light sensor doesn't seem to work either now.