• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

NO AUDIO INPUT AND OUTPUT

Search This thread

dyoliya

Member
May 2, 2021
10
0
Hello!
My problem is my device doesnt have audio. i tried calling using my device and mute is disabled. I cant also voice record. No audio from playing videos (youtube, netflix, spotify, chrome, etc). I cant record videos too.

What is wrong with my device? Do we have audio patch for this? I have also custom rom my phone with DotOS v.5.0.1 thru TWRP.. tell me if im missing a system app..
 
Last edited:

zgfg

Senior Member
Oct 10, 2016
5,847
3,322
Hello!

i’m very new with having custom ROM. And I flashed my device with DotOS v5.0.1 thru TWRP. (Also tried diffrent custom rom)

My problem is my device doesnt have audio. i tried calling using my device and mute is disabled. I cant also voice record. No audio from playing videos. I cant record videos too.

did i miss something? Im sorry im really new with this. I dont know if there is a patch that i should use...
Not familiar with your custom ROM but many people don't properly install custom ROMs

Did you FORMAT (not Wipe - it's completely different thing) Data partition (!) when you switched the ROM? If you didn't, you must do it

Assuming you had audio with the official MIUI (otherwise, you may have hardware issue)
 
  • Like
Reactions: Jamespaul2u

dyoliya

Member
May 2, 2021
10
0
Not familiar with your custom ROM but many people don't properly install custom ROMs

Did you FORMAT (not Wipe - it's completely different thing) Data partition (!) when you switched the ROM? If you didn't, you must do it

Assuming you had audio with the official MIUI (otherwise, you may have hardware issue)
ive done that. after flashing a ROM, I format data..


My audio was working before I custom ROM too. idk if i should just go back to stock rom
 

dyoliya

Member
May 2, 2021
10
0
UPDATE:

I've tried several custom ROMs now, also stock ROM. But no luck. How am I supposed to know if this is a hardware issue??

WHAT'S NOT WORKING:
- Built-in speakers
- Video recording
- Screen recording
- Voice recording
- Headphones/Earphones
- Bluetooth earphones/speakers
- No audio calls, no ringtones
- Unable to disable/enable mute button during call
- During call, speakers are enabled but cant be disabled (still no sound)

WHAT'S WORKING:
- Adjusting volume sliders


I'm not sure if this has something to do with hardware since I dont recall it falling, etc.. It suddenly stopped working at all.
 
Last edited:

swaggyp01

Member
Mar 10, 2017
20
0
man we have the same issues. my device has no audio source since i switched on custom rom. i tried to back again on stock rom but it doesent work again. the technician recommend to replace the audio ic which is hardware issues. anyone can help us on this problem? my device is mi 9t
 

dyoliya

Member
May 2, 2021
10
0
Try to wipe all, including recovery. Don't install newest rom, try older like android 10 and then if it doesn't work, you can try editing propsconfig
I’ve tried going back to android 10 but the Original problem of my phone goes back again. It lags big time!! So i dont have a choice but to switch to a custom ROM.

i havent tried editing propsconfig yet. How do you do that?
 

zgfg

Senior Member
Oct 10, 2016
5,847
3,322
how can i edit the props config? hoping for help . big thanks. i want to try it so bad. but i dont know how to do that.
If you have Magisk, use Magisk Hide Props Config module to add/edit/remove any prop

Otherwise, from TWRP, Advanced, File Manager (for e.g. build.prop file) go to /system and copy the file build.prop to /sdcard.
Reboot to Android, edit your copy of build.prop saved to Internal memory.
Reboot again to TWRP, mount System as writable, copy build.prop to e.g. build.bak and copy your edited build.prop from /sdcard to /system

If anyting goes wrong, reboot to TWRP, remove your build prop and rename your build.bak back to build.prop

You can also copy build prop from TWRP to PC, edit it there and copy back

Google for details if you are unfamiliar with, this is just general idea

If using TWRP, make sure you make a backup file (like build.bak) to be able to resolve possible brick or something

If using Magisk and that MHCP module, changes will be systemless (google if not familiar with the term) and you can simply disable the module (and automatically all your changes on props) if anything goes wrong

Generally, it's not for beginners to play with props
 

swaggyp01

Member
Mar 10, 2017
20
0
If you have Magisk, use Magisk Hide Props Config module to add/edit/remove any prop

Otherwise, from TWRP, Advanced, File Manager (for e.g. build.prop file) go to /system and copy the file build.prop to /sdcard.
Reboot to Android, edit your copy of build.prop saved to Internal memory.
Reboot again to TWRP, mount System as writable, copy build.prop to e.g. build.bak and copy your edited build.prop from /sdcard to /system

If anyting goes wrong, reboot to TWRP, remove your build prop and rename your build.bak back to build.prop

You can also copy build prop from TWRP to PC, edit it there and copy back

Google for details if you are unfamiliar with, this is just general idea

If using TWRP, make sure you make a backup file (like build.bak) to be able to resolve possible brick or something

If using Magisk and that MHCP module, changes will be systemless (google if not familiar with the term) and you can simply disable the module (and automatically all your changes on props) if anything goes wrong

Generally, it's not for beginners to play with props
 

swaggyp01

Member
Mar 10, 2017
20
0
Thanks for explaining everything brother. Now I will do a research about editing audio or sound on build prop. Hopefully this is not a hardware issues.
 

mhnarfth

Member
Oct 5, 2019
32
0
Redmi K20 / Xiaomi Mi 9T
Same issue encountered with me also. I am in a great distress right now. Tried more than 30+ roms (including recover, fastboot, custom, and stock), but nothing helps.

IF you find anything please update here.. THat'll be a great help indeed!!
 

mhnarfth

Member
Oct 5, 2019
32
0
Redmi K20 / Xiaomi Mi 9T
UPDATE:

I've tried several custom ROMs now, also stock ROM. But no luck. How am I supposed to know if this is a hardware issue??

WHAT'S NOT WORKING:
- Built-in speakers
- Video recording
- Screen recording
- Voice recording
- Headphones/Earphones
- Bluetooth earphones/speakers
- No audio calls, no ringtones
- Unable to disable/enable mute button during call
- During call, speakers are enabled but cant be disabled (still no sound)

WHAT'S WORKING:
- Adjusting volume sliders


I'm not sure if this has something to do with hardware since I dont recall it falling, etc.. It suddenly stopped working at all.
Exactly same thing happened with me, at that time I was on Miui global stable 12.0.9.0.. It happened all on a sudden. Now I am phoneless :(
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hello!

    i’m very new with having custom ROM. And I flashed my device with DotOS v5.0.1 thru TWRP. (Also tried diffrent custom rom)

    My problem is my device doesnt have audio. i tried calling using my device and mute is disabled. I cant also voice record. No audio from playing videos. I cant record videos too.

    did i miss something? Im sorry im really new with this. I dont know if there is a patch that i should use...
    Not familiar with your custom ROM but many people don't properly install custom ROMs

    Did you FORMAT (not Wipe - it's completely different thing) Data partition (!) when you switched the ROM? If you didn't, you must do it

    Assuming you had audio with the official MIUI (otherwise, you may have hardware issue)