• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

No auto-rotate on any custom rom

Search This thread

Tomek0000

Senior Member
Jun 14, 2015
389
101
It has had a name change in Android 11 i think it is now in Vendor.
Is it for devices released with android 10 or only 11. But not for released with android 8 and 9 for sure.
So do not clear or format /Vendor.
No need. When you Install custom rom vendor is formated and installed automatic every time.
I am using the March release of Lineage with NikGapps and have no issues.
True. I have only problem with modem, but it can be my provider is using 3G only ... sad, but it is free.
Newer versions of Lineage have had many issues.
18.1 ? but only on pad , it works excelent on my mi 9.
 

stereo007

Member
Sep 25, 2013
32
8
My persist backup from TWRP.
No EU or Global stock for mi pad 4. It was never been released outside of China. All rom released are china versions.
Wifi does not work now after the restore. How did you create the. I still have a Pad 4 here which works. How do I make a backup? Mine looks like this?
img.PNG
 

Tomek0000

Senior Member
Jun 14, 2015
389
101
Did you fixed your problems?
I did backup in 2019 using China twrp which existed this time. It was stock room. I am checking with actual and size is different. I installed the newest kernel never released by Xiaomi. It can be source of differences.
 

pndwal

Senior Member
Guys, for all hardware to work properly since Pie, you need at least late developer (weekly) firmware, the latest of which is 9.8.29 (2019-08-29, = MIUI 10.5) version, NOT latest Stable 10.3.2 MIUI.

Note that both fw only (Firmware) and fw-vendor (Vendor) as well as full stock ROM (MIUI) are available from xiaomifirmwareupdater.com, and that Fastboot ROMs contain the complete set of factory images unlike recovery ROMs. See here for insight and link:
https://forum.xda-developers.com/t/...al-mi-pad-4-plus-clover.4178757/post-84656233

Late developer (weekly) fw-vendor (Vendor) images may help with rotation problems too, so try flashing in case of problems.

Nb. Both fw only (Firmware) and fw-vendor (Vendor) can be flashed to upgrade (or downgrade if desired) independently of full stock ROM (MIUI) to fix / eliminate problems. NO need to flash full stock at all (AFAIK).

Nb.2. After flashing Vendor you may get bootloop. Simply re-flashing (dirty) ROM + GApps [+ Magisk] fixed updated installation for me. 😀 PW
 
Last edited:
  • Like
Reactions: pnin

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    When I bought the tablet from the alixpress seller it had a shady version of MoKee on it and given I in general don't like Mokee very much I decided to reflash to other roms, but none of them had auto-rotate.
    I've tried MoKee (flashing my own file), LineageOS, and am now running Carbon.

    I'm wondering if I'm the only one with the problem - and if not, if anyone was able to figure out how to fix it?
    Using the "Sensor Test" app it's as if there is no accelerometer/gyroscope within the device at all (No Input Data).


    Software wise I'm at:
    TWRP & CarbonROM (from here)
    rid18kG.png
    1
    Please help

    I tried flashing the china developer and stable stock roms via fastboot with 'clean all' and the problem of auto rotation persists. when I hold my tablet portrait the screen turns landscape, is there maybe a setting in the build.prop I can change to fix this?


    I have the same problem. Did you find a solution? :( :( :(
    1
    Do not clear or format the Persistence folder

    Do not clear or format the Persistence folder or you will lose - tada - autorotation. Plus you risk losing your IMEI.

    If you have done this already then re-flash a stock ROM, confirm all is well, then put your ROM of choice back and in the process when using TWRP leave the persistence folder alone.
    1
    Thanks for your answer. I can't find the persist.img for MI Pad 4 though, any idea where I could get it from? Instead I tried flashing an official ROM again, verified the rotation is working and then made a backup of the Persist partition in TWRP. Then I installed the Pixel Plus Rom again and restored persist from backup, but again the sensors are not working. Any idea what I made wrong? Or where can I get the persist.img from?
    You should not need to restore the /persistence partition - just do not format it. It has had a name change in Android 11 i think it is now in Vendor. So do not clear or format /Vendor. Someone else can verify that. I am using the March release of Lineage with NikGapps and have no issues. Newer versions of Lineage have had many issues.
    1
    You should not need to restore the /persistence partition - just do not format it. It has had a name change in Android 11 i think it is now in Vendor. So do not clear or format /Vendor. Someone else can verify that. I am using the March release of Lineage with NikGapps and have no issues. Newer versions of Lineage have had many issues.

    Well that was interesting... So after your mention of LOS I installed the current version from xda after wiping Dalvrik/Cache/Data and System). Rotation now worked! But in LOS, my external DAC does not work so I tried isntalling Pixel Plus again, wiping the same stuff as before and now it suddenly worked! Strange why it didn't after installing the official ROM. Nevertheless it works now, thanks a lot :)