No BOS descriptor, Partial boot.

Search This thread


New member
Jul 29, 2012
I had my kfire rommed to 4.0 and was loving it, when my mom asked if she should get one. i decided to flash in back to stock kindle OS to show her what it would be like and i took the process too lightly, and didn't have 85%+ battery. Obviously, it failed. Now i can turn it on, and it will try to boot for 20 minutes, then for 5 seconds it'll go into the setup screen but i'll get an error: [Process android.acore has stopped working] and have to force quit it, which, no matter what i do, sends it back to the kindle fire screen without ever powering off. every once in a while it will boot ok, i tried playing angry birds and it worked for 15 seconds then back to kfire screen. Then i took it apart, and unplugged the battery, left it that way for a day, plugged it back in. now i don't even get good boots. a friend said "hold down the power while the battery's off" and it did nothing. i tried Firekit again and eventually got it going (ubuntu 12.04).
Firekit found here:
I tried the non-usb_xxxxx_xxxxx methods first, and nothing. i then used the boot shorting trick (paperclip from point-cage) and tried all of the usb_xxx_xxxxxx commands. they all came up with "No BOS descriptor" or something along those lines. i learned that it likely means Boot OS which makes sense as it probably only has 1/2 of an OS on it presently.

What I Know:
Not much of actual adb but i understand the concept and know how to run it.
A small amount of fastboot, mainly how to activate it but it's worthless as it's unrecognizable.

Ubuntu 12.04; most comfortable with this
Mint Maya
Debian 6.05
Windows 7 (slightly broken but usable)
Fedora 17

Any solutions would be great, nothing i tried worked, i've listed all above.