• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

No ringtone with incoming calls

Search This thread

stoerebink

Member
Mar 12, 2007
35
13
Strange problem:
After i booted the Oneplus3 (with OxygenOS 3.0.2) i get no ringtone when someone is calling me.

After deep research i found out that moving the "silent-slider" up and down again (forcing the OPO3 to switch from "all" to "silent" back to "all" again), ringtones do sound again.

Anyone else?
 

stoerebink

Member
Mar 12, 2007
35
13
Ah, found the solution on a different (oneplus) forum.
Its a bug.
Solution:
Put notification-slider to: "Priority only"
Go to settings -> slidersettings.
Go to Priority-settings
Change Messages to "from everyone"
Change Calls to "from everyone".
Put slider back to "all"

Strange bug. But this should solve it, for now that is.
 

Im.

New member
Jun 26, 2016
2
0
Ringtone issue

I have just the same problem and contacted Oneplus. They told me to perform a hard reset, although I told them moving the ¨silent slider¨ up en down solved the problem, but only for a short period of time. So I did as they told me, which of course took me a lot of time, and after a few hours again there was no ringtone for incoming call. So I have send them another mail on friday and am waiting for a reply.

After moving the ¨silent slide¨ a few more times on fridaynight, the problem did not reoccur over the weekend, but I just don´t trust the phone in doing what it should do: ring when somebody is calling me :(



QUOTE=stoerebink;67451532]Strange problem:
After i booted the Oneplus3 (with OxygenOS 3.0.2) i get no ringtone when someone is calling me.

After deep research i found out that moving the "silent-slider" up and down again (forcing the OPO3 to switch from "all" to "silent" back to "all" again), ringtones do sound again.

Anyone else?[/QUOTE]
 

shrijith1

Member
Mar 1, 2009
45
7
Bangalore
I have just the same problem and contacted Oneplus. They told me to perform a hard reset, although I told them moving the ¨silent slider¨ up en down solved the problem, but only for a short period of time. So I did as they told me, which of course took me a lot of time, and after a few hours again there was no ringtone for incoming call. So I have send them another mail on friday and am waiting for a reply.

After moving the ¨silent slide¨ a few more times on fridaynight, the problem did not reoccur over the weekend, but I just don´t trust the phone in doing what it should do: ring when somebody is calling me :(



QUOTE=stoerebink;67451532]Strange problem:
After i booted the Oneplus3 (with OxygenOS 3.0.2) i get no ringtone when someone is calling me.

After deep research i found out that moving the "silent-slider" up and down again (forcing the OPO3 to switch from "all" to "silent" back to "all" again), ringtones do sound again.

Anyone else?
The workaround @stoerebink has posted should work. Please try it out. I had a chat with a Support staff who mentioned that the fix is coming in next update (probably 3.1.4).
 

stoerebink

Member
Mar 12, 2007
35
13
I take a deep bow. So much honor from my simple discovery.

Thank you, thank you.

BTW: I use 3.1.3 (the beta of the forthcoming 3.1.4) some days now. I'll let you know if the problem is gone. Haven't had it yet, which is hopegiving.
 

Im.

New member
Jun 26, 2016
2
0
I have to say thank you as well. Your solution has made the ringtone sound ever since.
Now slowly I start to think the oneplus 3 is maybe not so bad after all :)



I take a deep bow. So much honor from my simple discovery.

Thank you, thank you.

BTW: I use 3.1.3 (the beta of the forthcoming 3.1.4) some days now. I'll let you know if the problem is gone. Haven't had it yet, which is hopegiving.
 

flybiker

Member
Feb 28, 2012
8
0
No ring tone after alert slider tiggle

Problem still persists on OOS 3.2.1.. Come on OnePlus.. Missing important calls here.. Please fix alert slider bugs
 

sn0warmy

Senior Member
Jul 26, 2010
3,381
1,635
Boulder, CO
Problem still persists on OOS 3.2.1.. Come on OnePlus.. Missing important calls here.. Please fix alert slider bugs

Same here. I was about to post a thread about this. I am on 3.2.1 and I keep missing calls and incoming texts because the notification sounds just randomly stop working. Switching to "Priority Notifications" and back to "All Notifications" solves the problem for a little while but over time the issue comes right back. I've also noticed that occasionally I'll get the "Priority Notifications" notification next to the cell signal indicator in the status bar, even when the slider is set to "All Notifications".

It's quite annoying.
 

sandeep.warrier

New member
Jul 14, 2016
1
0
No ring tone after alert slider tiggle

I too face this issue from time to time (on 3.2.1). At times if the Alert Slider toggle doesn't work, post making changes suggested by stoerebink, and toggling the alert slider between the three settings, I reboot the phone, which seems to temporarily solve the issue.

Hope Oneplus comes up with a fix for this soon.
 

mamasnya

Member
Dec 5, 2008
16
2
In my case all sound gets disabled (media player, notifications, alarm, ring tone). Haven't tried the slider trick..usually reboot the phone, but it's getting on my last nerve...not a fun feeling going to bed, not knowing if the alarm will wake me up for work.
 

m_usmanayub

Senior Member
Dec 17, 2010
113
19
Now people at xda have started to talk about bugs in OP3...these have been discussed numerously in oneolus forums but the oneplus team is not doing anything about these issues.
 

monyps

New member
Dec 20, 2016
1
0
Model A3003. OS version 3.2.8;latest version updated yday. Ring vol has become silent. Done reboot, changed priority setting to anyone for calls n messages, changed ringtone, tried every single thing. I changed the settings to vibrate for calls. Even that doesn't work.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    Ah, found the solution on a different (oneplus) forum.
    Its a bug.
    Solution:
    Put notification-slider to: "Priority only"
    Go to settings -> slidersettings.
    Go to Priority-settings
    Change Messages to "from everyone"
    Change Calls to "from everyone".
    Put slider back to "all"

    Strange bug. But this should solve it, for now that is.