• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

"No signal" after applying official security update

Search This thread
Apr 26, 2021
3
0
Bought new Pixel 4a (model G025J) a few months ago. It worked well for a few weeks until I installed March security update. After reboot the phone stopped detecting SIM card and lost cell signal. Even emergency numbers like 911 doesn't work.
I already tried:
  • Change SIM card to eSIM and back to new physical.
  • Flash almost all official ROMs and one unofficial.
  • Check debugging menu *#*#4636#*#*.
Right now i bring phone to local unofficial repair service. Unfortunately they still don't have a result.
What can I do to fix it or at least diagnose the problem?
I still hope it's a software error and can be solved without replacing the phone.
 

bik2101

Senior Member
Feb 14, 2011
1,192
121
get the phone replaced.

you're gonna get the same issue after any and every update you apply.
time (unpredictable) eventually returns your phone to working, though. but no software fix for it.
it's a weird problem, but you're not alone. thankfully my phone was still under warranty so I just sent it in and had it replaced. even though the replacement is a refurb, better that than never being able to confidently take an update.

I had the same exact problem.
First time, I took the andoird 11 update. I ended up leaving my phone with ubreakiFix (google's official authorized repair service) who had it for about a week and literally replaced every part and worked with google's service to deem the phone unrepairable. had an RMA for it and was ready to send it out, but gave it a shot stciking in my SIM card and it was working.

then the same thing happened again a few weeks later after applying a security update. this one returned to normal after a few hours

then last week had the same thing again with another security update. this time I quickly hopped on chat with google and sent my phone out and just received replacement yesterday