No sound after HU wakes from sleep

Search This thread

The_Chowder

New member
Jul 4, 2022
4
0
I'm a newbie to this site so apols if I have contravened any site rules!

Hoping someone might be able to help. I bought a 12.3inch HU on AliExpress. Its model number is uis8581a2h10_Automotive, which I think is a FYT HU. It's coded specifically for BMW.

After a full boot everything on the HU works fine. But then if I stop the car, for example to grab something from a shop, when I start the car again the head unit starts up instantly but there's no sound despite Zlink5/Spotify appearing to run properly on the screen. The only option to get sound back is to reboot the head unit and wait for Zlink5 to reestablish a connection with my phone (a Galaxy S10). Interestingly though, even when the music fails to play through the speakers, if I press the microphone button, Google Assistant plays sound and can properly make a phone call played through the car's front left speaker.

Also, when I'm getting no sound after the HU wakes, if I switch to the DAB app, I can hear a millisecond of Spotify music before it cuts off, and then the DAB app also fails to play sound - although it too, like Zlink5/Sportify, responds properly onscreen. So the HU seem to be playing music after waking from sleep, but just not routing it to the amp.

Apparently this unit is supposed to output sound via an aux cable which plugs into the BMW stereo's aux port. However, my unit plays music through the speakers on the aux setting whether or not the aux cable is plugged in. Not sure if that's affecting things?

The final issue is that Zlink5 won't work with bluetooth and WLAN/hotspot at the same time. It switches off WLAN while connecting to my phone via Bluetooth. If I then enable WLAN and set up a hot spot, Zlink5 either switches WLAN off and reconnects via Bluetooth, or else it will connect to WLAN, after which music pauses every second or so.

The sellers have sent me an MCU update file, which I have applied, and I have also tried every option in the HU settings for Car Aux Switch Mode. I can't think of anything else to try.

Can anyone advise whether these problems are likely to be software or hardware related? And has anyone any ideas how they might be resolved?

Many thanks!
 
Last edited:

deadeye920

Member
Apr 30, 2022
41
5
In regards to not being able to use Wi-Fi and Bluetooth together when you use zlink it uses the wifi to connect to you phone in the background. If you manually turn it back on it will disconnect from your phone. My advice would be to put a SIM card in your unit.
 
  • Like
Reactions: The_Chowder

The_Chowder

New member
Jul 4, 2022
4
0
In regards to not being able to use Wi-Fi and Bluetooth together when you use zlink it uses the wifi to connect to you phone in the background. If you manually turn it back on it will disconnect from your phone. My advice would be to put a SIM card in your unit.
Thanks Deadeye, that explains that one, and also explains why it eats my phone's battery :)
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    In regards to not being able to use Wi-Fi and Bluetooth together when you use zlink it uses the wifi to connect to you phone in the background. If you manually turn it back on it will disconnect from your phone. My advice would be to put a SIM card in your unit.