no usb file transfer option when connecting my fold 2 to pc or mac. only charging.

Search This thread

sahirhussain

Senior Member
Jul 30, 2010
109
8
hi. my phone does not let me initiate the file transfer option when i connect it via data cable to pc or my mac. it only charges the phone and that too extremely slowly. i have tried different cables (original cable that came with my phone, original cable from my wife's note 20 ultra, original cable from my spare oneplus 7 pro. nothing works. i have factory resetted. i have enabled usb debugging. i have enabled file transfer mode in developer options. the is just not recognised. when i run the diagnosis from the samsung members app, it says all ok. what do i do?
 

blackhawk

Senior Member
Jun 23, 2020
10,442
4,153
Samsung Galaxy Note 10+
Check Windows Event Viewer for error messages. Reload/check driver.
Turn off Developer options then turn back on.
Double check USB options.
Will a otg flashstick work in the phone?
 

arjun_m4

Senior Member
Jul 20, 2017
79
14
Sony Xperia 1 II
You have to replace the USB connector. Charging is happening in different pins and data transfer require another set of pins.

I suggest you to clean it with a brush and isopropyl alcohol. If still doesn't work take it to service center and get it replaced.