No wifi after going back to stock rom

Mike845

Member
Nov 30, 2019
21
1
0
Hi! I had installed leage OS but decided to go back to stock rom. I downloaded and installed the correct firmware, but when it turned on it seems like wifi is not working anymore. I read that this happens sometimes when going back to stock rom, as something related to persist.img gets lost, but I don't know much about this topic. I just found I have to somehow flash persist.img, but I already downloaded two different versions of the firmware and that file is not included. Any help would be appreciated! Thanks!
 

chrisb22

Member
Jan 10, 2007
24
2
23
Did you ever find a fix to this? I am having similar issues. I went back to stock and cannot get wifi to turn on. I checked my /persist/wifi/ folder and it is empty. Can someone with a working wifi tell me what's located in that folder. Thanks!
 

KtownJeff

Senior Member
Mar 18, 2019
179
130
43
In Space
If you downgraded when you went back to stock from a previous stock you had before the custom ROM you may have deleted your modem files....either you can restore efs only from a previous TWRP backup or run these lines in fastboot from the latest updated firmware....
fastboot flash modem NON-HLOS.bin
fastboot erase modemst1
fastboot erase modemst2
fastboot flash fsg fsg.mbn
Reboot and should be great....use twrp and get a backup of efs if u haven't already and save it for when it ever happens again and you may not have PC access so u can fix from TWRP
 
  • Love
Reactions: chrisb22

chrisb22

Member
Jan 10, 2007
24
2
23
If you downgraded when you went back to stock from a previous stock you had before the custom ROM you may have deleted your modem files....either you can restore efs only from a previous TWRP backup or run these lines in fastboot from the latest updated firmware....
fastboot flash modem NON-HLOS.bin
fastboot erase modemst1
fastboot erase modemst2
fastboot flash fsg fsg.mbn
Reboot and should be great....use twrp and get a backup of efs if u haven't already and save it for when it ever happens again and you may not have PC access so u can fix from TWRP
Thanks!!!!! This worked like a charm.
 
  • Like
Reactions: KtownJeff