NORDICTRACK ELITE 9500 PRO Treadmill w/ 10" Android Tablet

Search This thread

ntsteele

New member
Aug 16, 2009
4
0
Delton
I recently purchased a Nordic Track 9500 Elite Pro. This bad boy has a 10" android tablet built in. They really don't want you messing with the android part much, but I am sure there are plenty of other users out there like me that want to do more!

This is my first post so I am unable to show the pictures via the link. Hopefully you can copy and past the text to view the images. I will try to repost on my website so it all flows.

I don't see where a post like this would go, I am not sure if at some point it would gain it's own device forum... That would be exciting. So for now I will post here. I will also post my initial findings for others in the community that may want to purchase this treadmill and can't find any information regarding the built in Android Tablet with WiFi.

This image shows the version information. From what I can tell it looks like they purchase an APAD from someone and then stick it inside of their device. They also must have wrote some special drivers and software to interface with the equipment and hardware. I was very happy to see a mainstream current android OS.
Android OS 2.2

hungrykzoo.com/wp-content/uploads/2011/01/IMAG0027.jpg

Here are the pre-installed apps. Pretty basic. (note: I was able to find an APK and install Last.FM that wasn't included) Also a major bummer to see was that there wasn't a market application.

hungrykzoo.com/wp-content/uploads/2011/01/IMAG0026.jpg

This is the typical workout screen you see.
hungrykzoo.com/wp-content/uploads/2011/01/IMAG0024.jpg

I also noticed that the device doesn't have very much memory. This could be due to the built in applications taking up so much space. It only had about 57MB of internal memory free, but it had a built in 2GB SD Card. I have not gotten to the point where I have needed to take it apart yet to see if there is a replaceable SD card. I may wait another 5 years for my warranty to end to do that.

I have tried to install some apps but have not had very much luck. The only app that was I was able to install was the Last.FM.

I tried the follow apps, and they didn't install:
1. Market
2. Angry Birds
3. Pandora

Other disappointments:
1. Designed to not be in the Android Interface. They have an application that runs, and makes it tricky to get to the android desktop. It takes about 3 clicks to get from the main workout screen back to the Android Desktop.

2. The screen is not capacitive, it is resistive. I don't know how much more I need to say about that.

3. Only 3 buttons. Back, Menu, Home. Home takes you to their software not the android home screen. Long press on home does nothing.

4. When i go to the desktop the Time is all over the place. I have tried changing settings in every spot possible but something is telling it what time to think it is, occasionally it is correct... Just don't get it.

Even with the disappointments this thing is sweet. I wish i could install more apps, stream videos from a PC over the WiFi connection and stream music from a PC over the WiFi connection. Maybe with the help of the community we will figure some of these items out... Or I will be the only one who has this that knows about this website!
 

bypod

Senior Member
Dec 1, 2010
91
23
Logan
ntsteele,

How is your experience up to now with your 9500? I am looking at getting the c1250, which is the same as the 9500, but with a smaller motor and no decilne. Is the 10" screen worth it? The rep at Nordictrack told me the only differcence between the 7" screen is the web browser, the google maps display, and some basic apps. But overall the workout system is the same as the 7' display of the 1750 commercial and that you can view the google maps by logging in on ifit.com. Thanks for the info and screen shots.
 

bobkumar

New member
Jul 25, 2010
1
0
iFit Android App

Have you or has anyone else been able to pull the apk files off of the NordicTrack Elite 9500 Treadmill. I would be interested to see if it works on any adroid phone to view the menu system.
 

ecspike

New member
Aug 11, 2010
2
1
I played with this today at Google IO. The rep said that the integrated tablet was rev 1 and that they wanted to eventually let users connect their own devices.
 

stacld87

Member
Feb 7, 2011
15
2
knoxville, tn
Where I work at there is a Proform Trailrunner 4.0 treadmill that has 10" Android tablet screen. From what I have been told nordic track and proform are made by the same manufacture or something. It was returned because of a broken display unit. Of course I wasn't going to let them throw the old one away so they let me keep it. I trashed the main display and now I have the 10" tablet but cannot power it because the treadmill doesn't operate without a magnetic key. How could I power this thing and see if it works?
 

gpship

New member
Dec 20, 2009
1
0
I got the new incline trainer x9i which has the 10 inch android interface. I am interested to get in and try installing apps as you have but I am unable to even get to the android home screen. The only time I see it is when I turn the machine on and it is booting up, the screen comes up for a few seconds to where I can hit on the applications button and see what is on it. But within a second after I see the apps it automatically gets routed into the machine exercise interface and I have not figured how to get back to the android home screen from there. How did you do it? It would sure be nice to install a different browser. I hate the fact that I cannot create my own shortcuts. Anyway, love the machine.
 

ikhnatonx

New member
Jan 13, 2012
1
0
How to get to the Android Home Screen

Any luck finding out how to get to the Android Home Screen? I am wanting to do that also. I was able to get to it one time accidentally, but haven't figure out how to stop the machine interface from loading since.
 

CleverDog

New member
Jan 15, 2012
1
0
Home Screen

Ok, same question. I just got a C2150 which is a similar model to the 9500. Slightly smaller motor and belt, but same basic thing with the 10" tablet. I believe it's capacitive now, but still not great as far as that goes.

I too have hit the setup icon when it's booting and it goes to the Android setup screen for a second and then continues to boot into the Nordictrack IFit proprietary stuff.

So I can't believe the posts with the images and no explanation of how you got there? Please share with the rest of us.

Also, my console has a USB connector at the top of the thing. Any idea what if anything that'll let me do?

Thanks!
 

tpapa

Senior Member
Jul 18, 2008
274
58
Charlotte, NC
Anyone figure this out? Seems a shame to have a 10' screen and not be able to install apps on it. There must be some button combination that the Icon service team would use to stop the auto load of the iFit interface.
 

graphdarnell

Senior Member
Jan 25, 2012
714
158
Internal Pictures

I took the tablet apart to see what information can be gathered. Apparently, HANNSTAR (TAIWAN) manufactures the board (HANNSTAR J MV-7); which uses a Samsung ARM8 CPU(5PV210AH-A0 1044); has 512MB; and a 4GB SANDISK FLASH (SDIN2C2-4G).

I haven't been able to find sufficient info to track a compatible ROM, yet I can't imagine for the life of me that HANNSTAR would design this just for Nordic. I am posting some pics hoping that someone might be able to id the hardware, which in turn might help point to a more fruitful search for a workable ROM.

Try to upload pics but not sure if it worked. It's late, and I can't figure out how to do it smoothly yet.
 

Attachments

  • LCD.jpg
    LCD.jpg
    40.1 KB · Views: 1,459
  • LCDB.jpg
    LCDB.jpg
    50.1 KB · Views: 1,445
  • MBA.jpg
    MBA.jpg
    74 KB · Views: 1,399
  • MBB.jpg
    MBB.jpg
    81.5 KB · Views: 1,453

GazaIan

Senior Member
Dec 27, 2010
1,570
404
Your basement
twitter.com
I'm gonna do another bump. I have a similar treadmill (or maybe the exact same one, I lost the the manual with product name). It is of the X9i series and when I saw it in the store, I had to go for it. I was a bit irritated to see that you are locked to the iFit application and you cannot return to the launcher. I need a male to male USB cable to see if I can get a bit of ADB on it.

From the (crappy) performance of it, I can tell it has about 512 MB RAM, a dated CPU clocked at around 600-800MHz, the screen looks like a crappy TFT display at 1280x700. Lastly, this thing runs Froyo. Mine features a full USB port and an Audio in port. Not much to screw around with. Downloads are disabled in the browser, and the Menu key does nothing.

I think something can be done though. The application that controls the treadmill can't crash as it is, and if it ever does FC, the motor shouldn't stop. NordicTrack doesn't have a recovery image up for some reason (thanks, NordicTrack -_-) so that's even less to work with.

Nevertheless, something can be done. It's not really a fun thing for an Android enthusiast to pick up an Android device with such dated hardware (the tredmill itself, as just tredmill is amazing).. Plus, it was $2,100 at Sears.

---------- Post added at 08:48 PM ---------- Previous post was at 08:43 PM ----------

here is a video of the Treadmill and the board;

http://www.youtube.com/watch?v=eKyf6MHIefk

USB and Audio in is on the right side of the console.
 

wingsfan

New member
Feb 4, 2008
1
0
I've had my Nordictrack 9500 Pro for about a year now. Still working well for the most part (I do have messed up deck tension adjuster that I need to call support about).

Would love to be able to unlock the Android device to at least install Netflix, Pandora, etc.

I have had one over the air firmware upgrade that went pretty smoothly. Was hoping more updates would come from Nordictrack, but it has been a long time since that one.

Has anyone else noticed that the Speed Calibration utility under the iFit controls says that it isn't enabled yet? Maybe there's hope for future updates.
 

devmo32

New member
Feb 16, 2012
1
0
fanVrARCHITECT

Greetings,
I have been following this thread as a 9500 owner as well, and looking at what has been posted and see if there is any follow up.

1.) like everyone else what startup combinations may have disabled Nordic Tracks proprietary software.

2.) the usb socket on the top of the console, has anyone had anyluck attempting a usb male to male connection on a laptop? If so what has been tried?

3.) any idea of maybe porting something over via the Ifit updates or account? I noticed the HDvideo inside of the program is pretty descent from what I've seen, and looks like the video plays in the center of main app..just a thought.

I'm looking at getting the male to male usb cable and trying to interface it with the below. .. at least curious if the cable will talk, and most likely this unit is not root so view only but maybe a start if it works.

//www*howtogeek*com/howto/42491/how-to-remote-view-and-control-your-android-phone/

Cheers,
devmo
 
J

jsteelm

Guest
I read somebody was able to email themselves an apk and install it? The tablet enables sideloading? Ding ding ding! I'm going to try sideloading launcherpro or any other replacement launcher to attempt to hijack the home screen

Update: Didn't work on my c2150's tablet. Bastards.... I did however get my c2150's to boot into "safe mode" which I have no idea what that entails. While it was powering on, I held down home and back I believe was the combo.

Update: SUCESS!!! So by booting into "safe" mode, you can hit the preferences launcher while the device is booting to interrupt the ifit loading. From there, go enable unknown sources. Then launch the browser and google "z4 apk" and download it and run it. Did permanent root on mine and it worked.

ENJOY
 
Last edited:
J

jsteelm

Guest
I forgot. Once you get the device into safe mode, install "smart taskbar" by sideloading. It'll make you able to view a task bar over ifit.

EDIT: Since we don't have a custom recovery, or for that matter even a recovery at all it seems, I've not attempted gapps. Could anyone give a detailed response on how to install this? I assume just unzip it in the root directory? I'm worried about permissions, I always forget what to set there. Also, the device comes pre-bundled with busybox, fyi :) Another must have for this is adbWireless. I tried editing the init.rc but it seems those changes were for nothing. I'll keep people updated as I discover things etc. I'm by no means a dev, but do know a little.
 
Last edited:

tpapa

Senior Member
Jul 18, 2008
274
58
Charlotte, NC
I forgot. Once you get the device into safe mode, install "smart taskbar" by sideloading. It'll make you able to view a task bar over ifit.

EDIT: Since we don't have a custom recovery, or for that matter even a recovery at all it seems, I've not attempted gapps. Could anyone give a detailed response on how to install this? I assume just unzip it in the root directory? I'm worried about permissions, I always forget what to set there. Also, the device comes pre-bundled with busybox, fyi :) Another must have for this is adbWireless. I tried editing the init.rc but it seems those changes were for nothing. I'll keep people updated as I discover things etc. I'm by no means a dev, but do know a little.

Sorry - can you tell me the exact steps involved here. How do I get to safe mode and then what? I tried Home Back while powering on and it still goes to the ifit screen
 
J

jsteelm

Guest
You know I'm really not sure what trick it is to make it stay. I had good luck getting it to stay in android rubbing home/back/menu while it booted and as soon as I saw the android home screen, hit the preferences launcher and then grabbed the top menubar and half pulled it down. All I know is that when you get it to stick in android, its always in safe mode which is triggered by some combination of those buttons on boot. Even then it will boot into iFit, but if you go to the settings first, in safe mode, it wont exit that screen.
 

seh4fredom

New member
Apr 24, 2012
2
1
Nordictrack commercial 2150 Android Safemode

Very simple folks. Turn treadmill on and once you see ANDROID appear in the center of the screen, begin pressing the dashes button that is between the home and back buttons on the console. Not sure if holding down works any better. An "unable to load widget" will be seen in middle of screen once the I-FIT software has stopped and safe mode will appear at the lower left hand corner. You'll then be able to check out the various Android options etc for your tablet. Be careful in editing anything unless you know what you are doing! Wouldn't want to brick your treadmill unnecessarily. It took awhile to find the key to safe mode access, due to limited info out there, but I hope users will continue to make some progress on exploiting this device and maybe we'll be able to use it to our liking. I would like to stream my dish television to the tablet like I do on my i phone or i pad. Being able to install the dish app via google app store is what I'm looking forward to. I want to be able to watch tv on my treadmill while exercising. Please keep this thread going! I'm sure that future software updates may allow for a better user interface. The challenge is certainly in the storage capabilities in the tablet itself and the sd card inside.
 
  • Like
Reactions: Aqua1ung

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    So it turns out on the newest ones there's a very easy easy to get into it.

    Go to the settings mode, go to maintenance - then in the spot below the options there is a bunch of grey space.

    Tap the same spot 10 times.
    Wait 5-7 seconds
    Tap the same spot 10 more times.

    It will then pop up that "privileged mode is enabled"

    When you enable it, you can drag down from the top and get access to the menu bar and go into android settings. You can also swipe up from the bottom and get to the default apps - it has a browser, camera, ifit admin, and the ifit cardio.

    USB debugging was already enabled for me as was unknown sources - I'm not sure if that's because I activated privileged mode or not.

    You can pair Bluetooth devices with it from the settings - I think it only works to send OUT sounds - it would be nice if you could connect audio to it via Bluetooth (they added that in the latest models, mind still just has aux in)

    Sent from my Pixel 2 XL using Tapatalk
    2
    Got me a brand new NordicTrack Elliptical Commercial 14.9 (NTEL71517). Followed instructions, installed Smart Taskbar. Big thanks to whomever discovered this hack! Currently looking to tweak some of the built-in workout routines. Looks like they're all hosted on s3.amazonaws.com. I am guessing, however, that they should be downloaded/cached somewhere locally, as I cannot imagine one needs an internet connection to do one's workout. Any idea where these might be hosted locally?

    Anyway, thank you all for your pioneering work! Someone should post a quick tutorial in the OP with steps on how to hack this machine. Here's a beginning:
    1. Turn on machine.
    2. Once you see ANDROID appear in the center of the screen, hold the menu button pressed ("the dashes button that is between the home and back buttons on the console") until you see "Unable to load widget" on the screen. This launches safe mode, hence bypasses the loading of the iFit application that steals focus.
    3. Go to settings, and enable side loading.
    4. Launch browser and download Smart Taskbar (or plug in a USB dongle containing the Smart Taskbar apk file to the USB port).
    5. Install Smart Taskbar.
    6. Reboot after installing Smart Taskbar.
    7. Allow normal boot up, no safe mode required. You'll notice the trademark Smart Taskbar arrow on the screen. Launch Smart Taskbar. You're in. Feel free to kill the iFit process to restore Android desktop.
    8. Next: root (how?) + install apps to USB dongle (how?). Someone else, please detail these steps.

    Many thanks again!
    2
    Ok, it gets _even better_

    after running nmap on my device's IP address, I saw it had 3 ports opened... 5009, 5555, 5000...

    On a hunch, I decided to check if 5555 was setup for ADB in tcp mode... turns out it is.

    `adb connect #.#.#.#:5555` (where the #'s are the IP address) works like a charm.

    then `adb shell` - comes back with a _root shell_

    `|[email protected]_t_crv2:/ # `

    I'm sure 5555 was open before I did the tapping-on-the-window thing, so it looks like these things _ship_ with TCP ADB enabled into a root shell for you.
    2
    I bought a Freemotion 770 treadmill last week and upon setting it up, I came to realize that I can't access the Android desktop. I called ICON Fitness, (they own Nordic Trac, Freemotion and a plethora of other names), and after the rude customer "service" monkey registers my new machine, I ask her about how I can get to the desktop. She tells me to tap on the "gears" to change what I need to change. I again, tell her I'm trying to access the desktop. She tells me that I need to sign up for an ifit account before I can access the android desktop. :silly:

    I start asking her how registering with an ifit account will allow me to get to the desktop. She of course has no clear answer. Again, tell her that I am trying to NOT use ifit and this is why I'm trying to stop it from loading (a little lie, but eh).

    Then she tells me to "hit the little globe". I was surprised at how she knew I had a globe on my desk, but I hit it. It flew across the computer desk and I said "ok, I hit the globe, now what?"... silence on her end. I then said "What does the "globe" have to do with the android desktop? That's just the web browser... silence... She then tells me she has to put me on hold.

    She comes back a few minutes later and AGAIN, she tries to tell me to "hit the gears if I want to calibrate the incline"... HUH? Once I realized I was getting nowhere, I finally asked her if she was in the retarded section of the call center. I then told her I wanted to speak with a supervisor. She tells me that I would have to call back. I asked her "Why, doesn't the retarded CS section you're in have a supervisor?"

    We go a few more rounds and she finally tells me "There is no way to do that". I told her to forget it, I'll just find the info on the Internet. She tells me that she will note the serial number and void the warranty because I told her I was going to modify the treadmill. I told her to go right on ahead, I actually happen to have a good friend who is a Consumer Product attorney in Utah (These clowns are based out of Logan UT). I then bid her a good day and sincerely hoped she would do something to improve her brain cell count because as it stood, it was quite low. It seemed to be less than my 5 brain cells.

    Anyways, now I've got it rooted and installed smart task bar. I can now access the Android Desktop through the Smart task bar app. Thanks to the people who suggested the apps.

    adsbar - Alan, install the z4root and task bar app mentioned on page 2 while in safe mode. Then, reboot the treadmill and let it load ifit. You will notice a little arrow on the side on the screen. Tap it and viola! you will see your app menu. I haven't played with it much past that aside from verifying root and installing Root Explorer.

    What a useless story that contributes nothing to the thread, but shows us all that you think you are pretty tough because you can call someone that didn't understand the intricacies of hacking Android a retard. I hope no one ever treats you the same way you treated this person. Let me be the first to say I am not impressed.
    2
    Sorry for resurrecting a zombie thread but I just wanted to say thanks.

    My brand new X9i incline trainer is a whole lot more fun now. I got the Smart task bar installed. I just got Kindle up and running which was my primary reason for doing this. Next, maybe gapps to get Google music to stream? And maybe Nexflix and Amazon Video so wifey can watch her shows. More tinkering tomorrow.

    Thanks guys!
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone