Question Not able to tether via Hotspot?

Search This thread

ss4rob

Senior Member
Sep 4, 2010
208
65
I'm upgrading from an old Pixel to the 6 on Sprint (now T-Mobile. On my previous phone, rooted with Magisk I used:
settings put global tether_dun_required=0
net.tethering.noprovisioning=true
...to use the hotspot with no problems. Now, I still have the old grandfathered Sprint plan, but I'm on the T-Mobile network via the 6's eSIM. I tried adding the two above items via Magisk Canary (SN passes BTW) and tether but LTE nor 5G work. I also tried making a duplicate of my existing T-Mobile APN, added a ,dun to the type, and tethering still does not work. Has anyone gotten this to work on T-Mobile? Am I missing a step other than the three I outlined above? I don't think this phone works on Sprint, but if it does, any success there?
Having the ability to tether has been extremely helpful over the years - I hope someone can help me get that capability back now that I'm rooted. Thank you.
 
  • Like
Reactions: roirraW "edor" ehT

sensui123

Senior Member
Jul 16, 2012
128
44
I'm upgrading from an old Pixel to the 6 on Sprint (now T-Mobile. On my previous phone, rooted with Magisk I used:
settings put global tether_dun_required=0
net.tethering.noprovisioning=true
...to use the hotspot with no problems. Now, I still have the old grandfathered Sprint plan, but I'm on the T-Mobile network via the 6's eSIM. I tried adding the two above items via Magisk Canary (SN passes BTW) and tether but LTE nor 5G work. I also tried making a duplicate of my existing T-Mobile APN, added a ,dun to the type, and tethering still does not work. Has anyone gotten this to work on T-Mobile? Am I missing a step other than the three I outlined above? I don't think this phone works on Sprint, but if it does, any success there?
Having the ability to tether has been extremely helpful over the years - I hope someone can help me get that capability back now that I'm rooted. Thank you.

Works fine for me with Verizon adding custom prop of net.tethering.noprovisioning=true with magiskhide props config module.
 

ss4rob

Senior Member
Sep 4, 2010
208
65
Works fine for me with Verizon adding custom prop of net.tethering.noprovisioning=true with magiskhide props config module.
What method did you use to insert net.tethering.noprovisioning=true? I followed these steps for here (https://forum.xda-developers.com/goto/post?id=80055304):


Install Magisk module: MagiskHide Props Config and Reboot
adb shell
settings put global tether_dun_required 0
su props

Enter 5, Add/edit custom props
Enter n, New custom prop
Enter net.tethering.noprovisioning
Enter true
Enter 2, post-fs-data
Enter y
Enter y to reboot

If I type "getprop | grep tether" I get:
[net.tethering.noprovisioning]: [true]

If I type "settings list global | grep dun" I get:
tether_dun_required=0

...so the values are there. When I duplicate APN, all I added was ,dun to the end to APN type, keeping it a duplicate of the original. I even tried this Magisk module which, after looking at the script directly, does the same thing but also adjusts TTLs:

My PC connects to the my phone when I tap hotspot and I can ping the IP of the phone, but that's it. On the phone itself in hotspot mode, I can ping external IPs.
USB tether doesn't work either - I get an IP on my PC but can't reach external sites.

I really don't know what else to do here. Any other Sprint / T-Mobile folks get this working on Android 12 / Pixel 6 / Pro?
 

sensui123

Senior Member
Jul 16, 2012
128
44
What method did you use to insert net.tethering.noprovisioning=true? I followed these steps for here (https://forum.xda-developers.com/goto/post?id=80055304):


Install Magisk module: MagiskHide Props Config and Reboot
adb shell
settings put global tether_dun_required 0
su props

Enter 5, Add/edit custom props
Enter n, New custom prop
Enter net.tethering.noprovisioning
Enter true
Enter 2, post-fs-data
Enter y
Enter y to reboot

If I type "getprop | grep tether" I get:
[net.tethering.noprovisioning]: [true]

If I type "settings list global | grep dun" I get:
tether_dun_required=0

...so the values are there. When I duplicate APN, all I added was ,dun to the end to APN type, keeping it a duplicate of the original. I even tried this Magisk module which, after looking at the script directly, does the same thing but also adjusts TTLs:

My PC connects to the my phone when I tap hotspot and I can ping the IP of the phone, but that's it. On the phone itself in hotspot mode, I can ping external IPs.
USB tether doesn't work either - I get an IP on my PC but can't reach external sites.

I really don't know what else to do here. Any other Sprint / T-Mobile folks get this working on Android 12 / Pixel 6 / Pro?

That looks correct to me although I use a different terminal....I also don't specify when to activate prop and just use the default (which I believe is 1 instead of you using 2 in your use). But it seems like your props are activated upon boot.

could you post the link to guide how to make this work. please.

The above basically outlines it.....but here it is summarized:

1) Root your phone with magisk.
2) Install the Magiskhide Props Config module
3) Use some app that let's you have access to terminal...I use termux.
4) Type "su" for superuser rights, then type "props" to access configuring the module.
5) Go through the prompts as the OP listed above starting with choice 5 "add/edit custom props" to add net.tethering.noprovisioning with "true" as the value.
6) I don't use the global tether dun line because with Verizon, even when activated without circumvention, it tallies the use toward "tether/hotspot data."

I use other apps that routes traffic through a VPN to avoid detection. Like VPN Tether on the play store.
 
  • Like
Reactions: Lw00d

ss4rob

Senior Member
Sep 4, 2010
208
65
With T-mobile you should just be able to hit the "hotspot" button and have it work, unless you have a super low-level plan. Nothing special in my APN.
My plan is quite old, a grandfathered Sprint plan, but my eSIM is definitely T-Mobile.

That looks correct to me although I use a different terminal....I also don't specify when to activate prop and just use the default (which I believe is 1 instead of you using 2 in your use). But it seems like your props are activated upon boot.



The above basically outlines it.....but here it is summarized:

1) Root your phone with magisk.
2) Install the Magiskhide Props Config module
3) Use some app that let's you have access to terminal...I use termux.
4) Type "su" for superuser rights, then type "props" to access configuring the module.
5) Go through the prompts as the OP listed above starting with choice 5 "add/edit custom props" to add net.tethering.noprovisioning with "true" as the value.
6) I don't use the global tether dun line because with Verizon, even when activated without circumvention, it tallies the use toward "tether/hotspot data."

I use other apps that routes traffic through a VPN to avoid detection. Like VPN Tether on the play store.
I see what you mean about the order of the prop being added, but it is definitely added early enough it shouldn't be an issue. Even to be safe, I added the Magisk module that definitely adds the prop and modifies TTL. I guess adding APNs with ,dun appended doesn't help? Or disabling Tethering Hardware Acceleration?
 

sensui123

Senior Member
Jul 16, 2012
128
44
My plan is quite old, a grandfathered Sprint plan, but my eSIM is definitely T-Mobile.


I see what you mean about the order of the prop being added, but it is definitely added early enough it shouldn't be an issue. Even to be safe, I added the Magisk module that definitely adds the prop and modifies TTL. I guess adding APNs with ,dun appended doesn't help? Or disabling Tethering Hardware Acceleration?

I do disable the tethering hardware acceleration for the apps I use for routing tethering data to the VPN since they don't function properly with this enabled. But the act of tethering itself doesn't seem to be limited by this. Best of luck figuring this out.
 

Lw00d

Senior Member
May 18, 2009
806
113
LA Baby!!!
That looks correct to me although I use a different terminal....I also don't specify when to activate prop and just use the default (which I believe is 1 instead of you using 2 in your use). But it seems like your props are activated upon boot.



The above basically outlines it.....but here it is summarized:

1) Root your phone with magisk.
2) Install the Magiskhide Props Config module
3) Use some app that let's you have access to terminal...I use termux.
4) Type "su" for superuser rights, then type "props" to access configuring the module.
5) Go through the prompts as the OP listed above starting with choice 5 "add/edit custom props" to add net.tethering.noprovisioning with "true" as the value.
6) I don't use the global tether dun line because with Verizon, even when activated without circumvention, it tallies the use toward "tether/hotspot data."

I use other apps that routes traffic through a VPN to avoid detection. Like VPN Tether on the play store.
thanks for that...i am on Verizon grandfather in to unlimited. . i will try this.
 

diesteldorf

Senior Member
Nov 22, 2010
79
51
I'm upgrading from an old Pixel to the 6 on Sprint (now T-Mobile. On my previous phone, rooted with Magisk I used:
settings put global tether_dun_required=0
net.tethering.noprovisioning=true
...to use the hotspot with no problems. Now, I still have the old grandfathered Sprint plan, but I'm on the T-Mobile network via the 6's eSIM. I tried adding the two above items via Magisk Canary (SN passes BTW) and tether but LTE nor 5G work. I also tried making a duplicate of my existing T-Mobile APN, added a ,dun to the type, and tethering still does not work. Has anyone gotten this to work on T-Mobile? Am I missing a step other than the three I outlined above? I don't think this phone works on Sprint, but if it does, any success there?
Having the ability to tether has been extremely helpful over the years - I hope someone can help me get that capability back now that I'm rooted. Thank you.
Did you ever get this to work? You said you are upgrading from an old Pixel? Was your old Pixel running Android 10 or below?

I can activate the hotspot, but when I try to connect to it, it says NO INTERNET.

I am also on Sprint. I think some changes were made in Android 11 and that's when it stopped working.
 
  • Like
Reactions: Rescue9

wroy412

New member
Oct 23, 2017
3
0
Google Pixel 6
I am also having this issue but coming from a Galaxy s20fe on Sprint. Got the new pixel 6 with a TMobile esim on Sprint. With the galaxy I could just add dun to my apn and hotspot would just work natively. With this phone you can turn it on but no data transmits through it. Also on a grandfathered sprint plan. Tried editing the apn with dun with no luck. Tried adb shell dun=0 with no luck. Id prefer not to root the phone but will if I can't eventually figure this out.
 

Brian Tomek

Member
Jan 3, 2008
10
1
Kansas City
Did you ever get this to work? You said you are upgrading from an old Pixel? Was your old Pixel running Android 10 or below?

I can activate the hotspot, but when I try to connect to it, it says NO INTERNET.

I am also on Sprint. I think some changes were made in Android 11 and that's when it stopped working.
I'm on 11 with my Pixel XL getting ready to switch to the 6 Pro (unlocked). Fingers crossed. lol
 

roirraW "edor" ehT

Forum Moderator
Staff member

eloko

Senior Member
Nov 22, 2010
298
61
Try using VPN hotspot app. It bypasses carrier restrictions. Requires root


This app sometimes does not work at all.. When you apply the wlan option, no internet.. It doesn't matter what you do or change it won't work... And without it, it uses regular hotspot data
 
  • Like
Reactions: galaxys

roirraW "edor" ehT

Forum Moderator
Staff member
There's a relevant post by @ajent here (and quoted below):

Thank you for creating this.
I was having a hell of a time getting my Sprint (T-mobile TNX) esim Pixel 6 pro to hotspot properly.
Finally got it working. Rooted & flashed your magnificent kernel. Added "Dun" to Tmobile APN. This allows the hotspot to enable but anything that connects has no internet. The fix was to change the TTL. I added this to the script section of EX Kernel Manager:
Code:
iptables -t mangle -I POSTROUTING -j TTL --ttl-set 64
ip6tables -t mangle -I POSTROUTING -j HL --hl-set 64
The key for me was the ip6 tables since Tmo 5g uses only ipv6 and I'm in a 5G area.
Hope it helps
 

fuzzy8balls

New member
Jun 13, 2010
1
1
That that requires adding a custom kernel along with a special build of iptables. Seems like a bit too much trouble but I found a different workaround for the TTL issue.

I got a P6P recently and I did every step on the first page of this post but I still wasn't able to get the hotspot functionality fully working (thanks to tmobile). I did discover several workarounds though.

Initially when I used VPN Hotspot, my macbook could not reach any websites, but then I figured out that if I modify the TTL to 65 on my macbook as well as override the provided DHCP DNS server to 8.8.8.8 it works! Obviously a client side override is a pain in the ass so I kept on digging.

I used the VPN Hotspot app in conjunction with AdGuard (downloaded from the website not the play store) and configure tun0 as the upstream. VPN Hotspot takes care of the routing and AdGuard acts as a dummy VPN to force all routed hotspot TTLs to 64. This takes care of the IP routing on the hotspot.

What I have left to figure out is why isn't the DNS server (dnsmasq) on the P6P not responding. From DHCP, the gateway IP is also the same as the DNS IP, but does not respond at all (as I watch tcpdump from my macbook). The only way to work around this is to set a static DNS server on the client. This isn't ideal for clients and requires manual (re)configuration.
 
  • Like
Reactions: danii3dot

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    I'm upgrading from an old Pixel to the 6 on Sprint (now T-Mobile. On my previous phone, rooted with Magisk I used:
    settings put global tether_dun_required=0
    net.tethering.noprovisioning=true
    ...to use the hotspot with no problems. Now, I still have the old grandfathered Sprint plan, but I'm on the T-Mobile network via the 6's eSIM. I tried adding the two above items via Magisk Canary (SN passes BTW) and tether but LTE nor 5G work. I also tried making a duplicate of my existing T-Mobile APN, added a ,dun to the type, and tethering still does not work. Has anyone gotten this to work on T-Mobile? Am I missing a step other than the three I outlined above? I don't think this phone works on Sprint, but if it does, any success there?
    Having the ability to tether has been extremely helpful over the years - I hope someone can help me get that capability back now that I'm rooted. Thank you.

    Works fine for me with Verizon adding custom prop of net.tethering.noprovisioning=true with magiskhide props config module.
    2
    With T-mobile you should just be able to hit the "hotspot" button and have it work, unless you have a super low-level plan. Nothing special in my APN.
    1
    I'm upgrading from an old Pixel to the 6 on Sprint (now T-Mobile. On my previous phone, rooted with Magisk I used:
    settings put global tether_dun_required=0
    net.tethering.noprovisioning=true
    ...to use the hotspot with no problems. Now, I still have the old grandfathered Sprint plan, but I'm on the T-Mobile network via the 6's eSIM. I tried adding the two above items via Magisk Canary (SN passes BTW) and tether but LTE nor 5G work. I also tried making a duplicate of my existing T-Mobile APN, added a ,dun to the type, and tethering still does not work. Has anyone gotten this to work on T-Mobile? Am I missing a step other than the three I outlined above? I don't think this phone works on Sprint, but if it does, any success there?
    Having the ability to tether has been extremely helpful over the years - I hope someone can help me get that capability back now that I'm rooted. Thank you.
    1
    What method did you use to insert net.tethering.noprovisioning=true? I followed these steps for here (https://forum.xda-developers.com/goto/post?id=80055304):


    Install Magisk module: MagiskHide Props Config and Reboot
    adb shell
    settings put global tether_dun_required 0
    su props

    Enter 5, Add/edit custom props
    Enter n, New custom prop
    Enter net.tethering.noprovisioning
    Enter true
    Enter 2, post-fs-data
    Enter y
    Enter y to reboot

    If I type "getprop | grep tether" I get:
    [net.tethering.noprovisioning]: [true]

    If I type "settings list global | grep dun" I get:
    tether_dun_required=0

    ...so the values are there. When I duplicate APN, all I added was ,dun to the end to APN type, keeping it a duplicate of the original. I even tried this Magisk module which, after looking at the script directly, does the same thing but also adjusts TTLs:

    My PC connects to the my phone when I tap hotspot and I can ping the IP of the phone, but that's it. On the phone itself in hotspot mode, I can ping external IPs.
    USB tether doesn't work either - I get an IP on my PC but can't reach external sites.

    I really don't know what else to do here. Any other Sprint / T-Mobile folks get this working on Android 12 / Pixel 6 / Pro?

    That looks correct to me although I use a different terminal....I also don't specify when to activate prop and just use the default (which I believe is 1 instead of you using 2 in your use). But it seems like your props are activated upon boot.

    could you post the link to guide how to make this work. please.

    The above basically outlines it.....but here it is summarized:

    1) Root your phone with magisk.
    2) Install the Magiskhide Props Config module
    3) Use some app that let's you have access to terminal...I use termux.
    4) Type "su" for superuser rights, then type "props" to access configuring the module.
    5) Go through the prompts as the OP listed above starting with choice 5 "add/edit custom props" to add net.tethering.noprovisioning with "true" as the value.
    6) I don't use the global tether dun line because with Verizon, even when activated without circumvention, it tallies the use toward "tether/hotspot data."

    I use other apps that routes traffic through a VPN to avoid detection. Like VPN Tether on the play store.
    1
    Try using VPN hotspot app. It bypasses carrier restrictions. Requires root