General Not entering deep sleep when Bluetooth connected to Alpine stereo

Search This thread

Flyview

Senior Member
May 17, 2010
2,511
1,649
Toronto/San Diego
Hi everyone,

I recently got my Pixel 6 Pro and am loving it.

Setup:
Pixel 6 Pro 128GB
Android 13 Sept update
Rooted with Magisk
Kirisakura kernel

Issue:
I discovered an issue when looking through Accubattery. I noticed I had a very low "deep sleep" percentage, aka when the CPU goes to sleep. After a lot of testing I discovered that the phone is not entering deep sleep when Bluetooth is on and connected to a particular Bluetooth device: my Alpine UTE-73BT stereo. Of course, this is without playing anything, as you would expect that to keep it awake. If I simply disconnect from this device, sleeping returns to normal. I can connect to Samsung Galaxy Buds+ and it also sleeps correctly with those.

What I've tried:
Turn off UWB.
Forget/Pair the BT device.
Turn off/on HD Audio for the BT device.
Turn off/on contact sharing for the BT device.
Change BT AVRCP version to 1.6 (default 1.5) in developer options.
Change BT MAP version to 1.4 (default 1.2) in developer options.
Update firmware on the Alpine UTE-73BT to v1.5.

Checked screen-off wakelocks with:
./adb shell dumpsys battery unplug (to simulate it being unplugged)
./adb shell dumpsys power | grep

Didn't see anything keeping it awake, and the same wakelocks with Bluetooth on or off:
DOZE_WAKE_LOCK 'DreamManagerService' ACQ=-8s287ms (uid=1000 pid=1785)

What could I do to get more info on what might be causing this?


When I first started investigating, I found another wakelock issue that others have had with the Pixel 6 Pro where the phone would not sleep until restarted with airplane mode on. I believe that's been fixed? I don't think this is related since I tried restarting in airplane mode and it had no effect.