not mount ext2/3 in ubuntu?

Search This thread

juanolo

Member
Feb 18, 2009
35
0
I have SO ubuntu. And when i connect my phone to the computer, it mountet automatic my ext2 paretition. Also force close overall.
How can i do, not to mount this partition?
Or how did you do?

Thx
 

savethechicken

Senior Member
Jan 5, 2009
244
1
Albuquerque
I have SO ubuntu. And when i connect my phone to the computer, it mountet automatic my ext2 paretition. Also force close overall.
How can i do, not to mount this partition?
Or how did you do?

Thx

i know that this doesn't go here but until it gets moved i will try to answer.
I can tell you that even when mine mounts on ubuntu 9.04 I can still use every program fine so there is something else going on.(Mine is formated now at this point EXT3, still worked the same way on EXT2 also) But an easy way to unmount it is just to right click on the icon on the home screen in ubuntu and select unmount.
I know that should be a way to remove the unmount automatically for this drive I would do a google search. check the ubuntu forums, it is simply a removable drive or external drive so there is going to be instruction on how to stop it from auto mounting.
 

beartard

Senior Member
Jun 20, 2008
484
14
Winter Haven, Florida, USA
Gnome Menu > Administration > Authorizations (or Gnome Menu > System > Authorizations, depending on your setup)
then
org > freedesktop > hal > storage > Mount file systems from removable drives

That's where it's done. You'll have to search the Ubuntu forums and know your hardware fairly well to figure out exactly how it's done, but I think there is an option for you to individually "ok" drives to be mounted as they're plugged in.
 
Last edited:

lbcoder

Senior Member
Jan 21, 2009
2,622
99
The problem leading to the crashing is that the filesystem is mounted in two systems simultaneously. If one system makes a change to the filesystem, then it will not match as expected with the other, and therefore bad things happen.

Now the reason behind the double mount is simple;
the usb-disk component is handled by a part of the system that is not aware of the second filesystem or the fact that it is mounted. It therefore provides the entire disk with both partitions to the other machine.
 

lbcoder

Senior Member
Jan 21, 2009
2,622
99
Gnome Menu > Administration > Authorizations (or Gnome Menu > System > Authorizations, depending on your setup)
then
org > freedesktop > hal > storage > Mount file systems from removable drives

That's where it's done. You'll have to search the Ubuntu forums and know your hardware fairly well to figure out exactly how it's done, but I think there is an option for you to individually "ok" drives to be mounted as they're plugged in.

Right... policykit definitely won't do it. All you are suggesting to do is to deny that user the right to mount ANY external storage device. I am certain that that isn't what he wants to do. More like 'do not mount second partition on device X'.
 
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone