• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

"not registered on network" after installing stock ROM

Search This thread

ottomanhero

Senior Member
Jan 4, 2013
450
247
I decided to update my firmware from "S5360_XXLK1_OXFLK1_XXLH2" to "S5360_XXMC2_OXXMC2_XXMC2" since that ROM is old & laggy in my opinion.After the installation, everything was OK.When I installed merruk kernel (I also tried installing hellfusion 50 etc.), I kept getting 'not registered on network' error.This didn't happen with my old ROM.I don't know if it happens after a reboot or after installing kernels.

Also I could receive messages from my carrier at first boot (where you register google account etc.)

Im from turkey and I also tried installing latest turkey firmware, got the same ****.

I don't know if its a common problem with our phones, but I couldn't find anything useful on this forum and when I google this problem I usually find unsolved problems or galaxy s2 - s3 network breaking.

Solutions I tried so far :
Re-flashing CSC & modem in odin after kernel installation
Taking simcard off and rebooting, turning the phone off and inserting simcard, rebooting (this worked for SGS2 users, not for me though)

My simcard is 64 KB, my carrier is avea, i also experienced this problem with MB1 etc., can it be because of my simcard?
Could anyone suggest me a ROM that would work in my country - Turkey?