Notification sounds stop working randomly - pixel XL android 8.1

Search This thread

Squatrack Curler

Senior Member
Oct 14, 2013
131
19
So this just started a few days ago, I noticed that the notification sounds stopped working. Locking the phone stops making a sound and all notifications are silent. Watching videos and incoming calls are audible however.
A reboot fixes the issue, but it returns soon after.

I didn't install any new apps recently. Updated some, but nothing new.

Any ideas?
 

Cobthaich

Senior Member
May 3, 2012
59
11
Same thing happened to me upon upgrading to 8.1 If I reboot it solves it for a little, but shortly afterwards no notification sounds again. Not sure if anyone has found a solution or are having the same issue?
 
  • Like
Reactions: m1chael0c

Cobthaich

Senior Member
May 3, 2012
59
11
If you do a factory reset let us know if it works, I've been thinking the same, if I do I'll let you know.
 

fiverings

Senior Member
Oct 2, 2014
240
34
I thought I was the only one having this issue. Randomly comes on and off.

I checked the sound settings after updating to 8.1. All of them had changed to silent or something else you couldn't hear. I reset every sound, alarm, ringtone, notifications, etc.
I have to do this after every update. This is due to the fact, that I use the factory image to update.
 

Squatrack Curler

Senior Member
Oct 14, 2013
131
19
So, I think this happens when I use a bluetooth device.

I notice that after I disable Bluetooth after using a headset for a bit, that the sounds stop. Anyone else can test this theory out?
 

jskinvest

Member
Jul 10, 2016
37
3
notification problem

So, I think this happens when I use a bluetooth device.

I notice that after I disable Bluetooth after using a headset for a bit, that the sounds stop. Anyone else can test this theory out?


After 8.1 on my pixel XL notification sounds have stopped working. I determined that it has something to do with the bluetooth. After connecting bluetooth and then turning it off that is when the problem happens. But, oddly enough, notifications sounds do work again when bluetooth is turned back on and connected....but stop again after bluetooth is turned off. A reboot fixes the problem but it happens again once bluetooth is used and turned off again. Please fix it Google.
 

gerrya

Member
Sep 9, 2013
33
3
Same for me but I only lose the Google Voice text message notification and a reboot fixes it.
 

fiffan86

Senior Member
Dec 2, 2010
734
200
Las Vegas, NV
It happened to me connected and not connected to Bluetooth. It would also happen to calls as well, missed some important phone calls because of it.
 

gerrya

Member
Sep 9, 2013
33
3
I rebooted more than a week ago and it hasn't returned and I use a Bluetooth headset and Bluetooth in my car daily. I haven't gotten the January security patch, wondering if they slipped a fix in there?

Sent from my BTV-W09 using Tapatalk
 

string216

Member
Dec 4, 2008
6
0
I was having the same issue. I think it started after one of the security patches. I contacted google's support. they had me put it in safe mode and then see if it comes back. I did that, and it seemed to not break in safe mode. In theory, that means it is not a google issue, (Im sure they will play it that way) but Im not sure if it is caused by bluetooth, or something else. Anyone having the issues using a smart watch connected to it?
 

jskinvest

Member
Jul 10, 2016
37
3
This is very annoying. I am still having this issue that started shortly after 8.1. Notification sounds stop working. A reboot fixes is it but the problem comes back shortly thereafter,,sometimes within 24 hours. Interestingly, the notifications still work while bluetooth is connected...not sure what to make of that. I am loathe to do a factory reset but if anyone has done it with success please let me know. Thank you.
 

saturnhasrings

New member
Jan 16, 2018
1
0
Same thing here. I'm contacting Google regarding the issue. I've noticed a similar symptom since I've been using an android watch:

my watch gets notifications on time but my phone doesn't react. When i clear the notifications from my watch, my phone sets off multiple notifications in a row. Example: text, text, email, email, email, email, email, text, calendar. It's very annoying.

Now my phone makes no notifications. I've changed all notification sounds to full volume, I turn off bluetooth completely and my phone only vibrates for calls and doesn't make notification sounds or turn on the display as they come in.

While connected to a bluetooth device, the notifications come through that device but nothing or vibrate only on my phone.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    So this just started a few days ago, I noticed that the notification sounds stopped working. Locking the phone stops making a sound and all notifications are silent. Watching videos and incoming calls are audible however.
    A reboot fixes the issue, but it returns soon after.

    I didn't install any new apps recently. Updated some, but nothing new.

    Any ideas?
    2
    I have the same issue, it's been going on for about 6 months now. First it was related to bluetooth connectivity. Now it's just randomly not ringing or making sounds for text messages. I am so fed up with Google's lackluster support. The same goes for Google Play Music and Google Home. They have bugs going on now for over 8 months and no fixes.

    I fixed the issue so far for myself by enabling do not disturb when a call comes in and disabling do not disable when the call ends. I used to have to reboot constantly to get my ringer and alerts back, but now it's been 8 days, 18 hours and 5 minutes with no issues. I don't manually toggle do not disturb every call I use Tasker.

    uc


    uc


    uc


    Enable_Do_Not_Disturb.prf.xml
    Code:
    <TaskerData sr="" dvi="1" tv="5.1m">
    	<Profile sr="prof3" ve="2">
    		<cdate>1526953921176</cdate>
    		<clp>true</clp>
    		<edate>1527137954034</edate>
    		<id>3</id>
    		<mid0>4</mid0>
    		<nme>Enable Do Not Disturb</nme>
    		<Event sr="con0" ve="2">
    			<code>2</code>
    			<pri>0</pri>
    		</Event>
    	</Profile>
    	<Task sr="task4">
    		<cdate>1526953950648</cdate>
    		<edate>1527137954034</edate>
    		<id>4</id>
    		<pri>100</pri>
    		<Action sr="act0" ve="7">
    			<code>30</code>
    			<Int sr="arg0" val="0"/>
    			<Int sr="arg1" val="3"/>
    			<Int sr="arg2" val="0"/>
    			<Int sr="arg3" val="0"/>
    			<Int sr="arg4" val="0"/>
    		</Action>
    		<Action sr="act1" ve="7">
    			<code>312</code>
    			<Int sr="arg0" val="0"/>
    		</Action>
    	</Task>
    </TaskerData>

    Disable_Do_Not_Disturb.prf.xml
    Code:
    <TaskerData sr="" dvi="1" tv="5.1m">
    	<Profile sr="prof5" ve="2">
    		<cdate>1526954324084</cdate>
    		<edate>1527137967738</edate>
    		<id>5</id>
    		<mid0>6</mid0>
    		<nme>Disable Do Not Disturb</nme>
    		<Event sr="con0" ve="2">
    			<code>4</code>
    			<pri>0</pri>
    		</Event>
    	</Profile>
    	<Task sr="task6">
    		<cdate>1526954329092</cdate>
    		<edate>1527137967738</edate>
    		<id>6</id>
    		<pri>100</pri>
    		<Action sr="act0" ve="7">
    			<code>30</code>
    			<Int sr="arg0" val="0"/>
    			<Int sr="arg1" val="3"/>
    			<Int sr="arg2" val="0"/>
    			<Int sr="arg3" val="0"/>
    			<Int sr="arg4" val="0"/>
    		</Action>
    		<Action sr="act1" ve="7">
    			<code>312</code>
    			<Int sr="arg0" val="2"/>
    		</Action>
    	</Task>
    </TaskerData>

    Tasker Profiles.zip - Google Drive bit.ly/2J3BysX
    2
    I'm sure that it happens, when you make a long phone call, after that all sounds are lost


    It's a problem with that faint beep that you hear while getting notifications while on a call. That was introduced in 8.1. After a while the software fails to revert the notification sounds back on after a call. Toggle "do not disturb" on during calls. Then toggle it off when the call ends. Try that. It will work. Let me know how it works out.

    Since I've been doing that I haven't had one problem with notification sounds. I notified Google of my findings and they're working on a fix. In the meantime do the DND toggle.
    1
    Same thing happened to me upon upgrading to 8.1 If I reboot it solves it for a little, but shortly afterwards no notification sounds again. Not sure if anyone has found a solution or are having the same issue?
    1
    If it's a software issue, flashing a custom ROM or the newest factory image indeed should fix it.