Notification sounds stop working randomly - pixel XL android 8.1

Search This thread

Vico-c4mx

New member
Jan 29, 2017
4
1
Monterrey, Mx
Same Problem

Hi guys, I have the same problem, any real fix?, I'm actually trying any "fix" that I have seen in another forum, now to see what happen... I hope that works, is:

1 Turn on the bluetooth
2 Restart device
3 Turn bluethoot off
4 Restart device again

and enjoy
 

Micoolef

Senior Member
Jan 24, 2013
151
94
We need to be careful about jumping the gun on these "fixes". After the April update, I thought it was fixed because the issue did not happen until just today (about 1 week). So any fix that involves a reboot should be tested for at least that long... Unless someone knows how to force the issue?

The strange thing is the notification sounds come through when connected to a Bluetooth device. Can anyone else confirm that? This might help us explore a fix, since Google doesn't seem too eager to resolve. With our combined efforts we might be able to figure something out.
 

amirage

Senior Member
I was on the email correspondence with a supposedly "specialist" in Google who later acknowledged the issue and offered to give a new device as a warranty replacement. Mind you, I have been using the phone since 2016 and they offered a warranty replacement for an 18 month old device! I denied their offer and said that I'm not interested in having a piece of tech that's nearly 2 years old and that the issue is not with the phone but with the software itself!

I had plans of moving to the Pixel 3 but have shelved them!
 

Planters76

Senior Member
Aug 7, 2012
263
135
Missouri Valley
Even a product replacement won't fix the issue, so good call on that.

I've had this ongoing sound not working before I sent my device in twice and that was in Feb 2018 and the issue still remains.
My issue was a bad screen burn-in, contacted Google and they sent me a refurbished Pixel XL since it was under warranty. Had the refurbished Pixel XL for 1 week and the speakers started to crackle and the random sound dropping issue was still present. Contacted Google again and they were going to send me another refurbished device but I ask kindly if I could just get a new one and they agreed I could. 2 months later, I still have issues with random sound dropping.

I've always been a Google whore ever since the Nexus days. I've own the Nexus 4, Nexus 5, Nexus 6 & Nexus 6P, when Google came out with the Pixel device I was shock by the price tag but I bought the damn thing anyways because 2 things I can't stand in a phone, bloatware and no damn updates. The only devices in the market that don't have bloatware and give timely updates are the Pixel & iPhone, well I ain't gonna buy another Pixel again because even the Pixel 2 has issues and it appears Google could really give a rats ass about this sound issue, so that leaves me with 1 choice, a ****ing iPhone.
 
Last edited:
  • Like
Reactions: Iambenqazy

smjunaid

Senior Member
May 7, 2010
208
39
hi guys.. i noticed that the notification sound is actually being controlled by the media sound/volume. . like media sound and notification sound is the same in the new update.
i had the same issue but when i turned up the media sound. the notifications came back
i hope this might help a few of you out there,.
 

Doo Doo

Senior Member
May 24, 2008
1,893
427
South Florida
I noticed that I only lose notification sounds after a phone call incoming or outgoing doesn't matter, a reboot is the only thing that fixes it for now

Google if you're reading this take notes and please address this issue
 
  • Like
Reactions: Iambenqazy

Iambenqazy

Member
Sep 7, 2016
22
9
i noticed that not just the messages notification sound that is not working, but the lock screen sound as well, the screenshot sound too, incoming call sound too, i don't know why google still haven't fixed this issues for this basic phone functionality.:confused:
 

danstah

Senior Member
Feb 12, 2011
116
25
So far this issue hasn't happened to me yet on DP2. I was getting the issue all the time before the upgrade
 

Hernd74

New member
Apr 8, 2018
1
0
Notifications fixed

Fixed the problem... It's definitely in 8.1... Joined beta program and have Android p and hasn't happened again. It's been over a week now with no issue at all.
 

thomase00

Senior Member
Sep 25, 2012
57
16
I have a Pixel XL and called Google for support about this issue. I discovered that once this issue occurs, if I switch to one of the built-in ringtones, it works fine. If I switch back to a "custom" one (i.e. selected a file that I manually copied to the Ringtones folder), it is silent again. The only way to get the custom tones working again (at least for a short while) is to reboot.
 

gerrya

Member
Sep 9, 2013
33
3
This issue disappeared for months for me, suddenly returned when I got a Chromebook and use the Bluetooth to unlock the Chromebook. Notifications consistently stop working as soon as the phone notifies that it unlocked the Chromebook.

Sent from my Pixel XL using Tapatalk
 

gquiring

Member
Nov 19, 2012
15
0
Summerville
I have the same issue, it's been going on for about 6 months now. First it was related to bluetooth connectivity. Now it's just randomly not ringing or making sounds for text messages. I am so fed up with Google's lackluster support. The same goes for Google Play Music and Google Home. They have bugs going on now for over 8 months and no fixes.
 

RagingLoon

Member
May 10, 2013
6
4
Google Pixel XL
Google Pixel 6
I have the same issue, it's been going on for about 6 months now. First it was related to bluetooth connectivity. Now it's just randomly not ringing or making sounds for text messages. I am so fed up with Google's lackluster support. The same goes for Google Play Music and Google Home. They have bugs going on now for over 8 months and no fixes.

I fixed the issue so far for myself by enabling do not disturb when a call comes in and disabling do not disable when the call ends. I used to have to reboot constantly to get my ringer and alerts back, but now it's been 8 days, 18 hours and 5 minutes with no issues. I don't manually toggle do not disturb every call I use Tasker.

uc


uc


uc


Enable_Do_Not_Disturb.prf.xml
Code:
<TaskerData sr="" dvi="1" tv="5.1m">
	<Profile sr="prof3" ve="2">
		<cdate>1526953921176</cdate>
		<clp>true</clp>
		<edate>1527137954034</edate>
		<id>3</id>
		<mid0>4</mid0>
		<nme>Enable Do Not Disturb</nme>
		<Event sr="con0" ve="2">
			<code>2</code>
			<pri>0</pri>
		</Event>
	</Profile>
	<Task sr="task4">
		<cdate>1526953950648</cdate>
		<edate>1527137954034</edate>
		<id>4</id>
		<pri>100</pri>
		<Action sr="act0" ve="7">
			<code>30</code>
			<Int sr="arg0" val="0"/>
			<Int sr="arg1" val="3"/>
			<Int sr="arg2" val="0"/>
			<Int sr="arg3" val="0"/>
			<Int sr="arg4" val="0"/>
		</Action>
		<Action sr="act1" ve="7">
			<code>312</code>
			<Int sr="arg0" val="0"/>
		</Action>
	</Task>
</TaskerData>

Disable_Do_Not_Disturb.prf.xml
Code:
<TaskerData sr="" dvi="1" tv="5.1m">
	<Profile sr="prof5" ve="2">
		<cdate>1526954324084</cdate>
		<edate>1527137967738</edate>
		<id>5</id>
		<mid0>6</mid0>
		<nme>Disable Do Not Disturb</nme>
		<Event sr="con0" ve="2">
			<code>4</code>
			<pri>0</pri>
		</Event>
	</Profile>
	<Task sr="task6">
		<cdate>1526954329092</cdate>
		<edate>1527137967738</edate>
		<id>6</id>
		<pri>100</pri>
		<Action sr="act0" ve="7">
			<code>30</code>
			<Int sr="arg0" val="0"/>
			<Int sr="arg1" val="3"/>
			<Int sr="arg2" val="0"/>
			<Int sr="arg3" val="0"/>
			<Int sr="arg4" val="0"/>
		</Action>
		<Action sr="act1" ve="7">
			<code>312</code>
			<Int sr="arg0" val="2"/>
		</Action>
	</Task>
</TaskerData>

Tasker Profiles.zip - Google Drive bit.ly/2J3BysX
 

mariamast1

New member
May 31, 2018
1
0
I will never buy a google phone ever, ever again. This problem is unacceptable. I work in the healthcare field and a patient could die because I didn't get a notification on my phone.

I downloaded Tasker and implemented the do not disturb and hoping that will work. That said that is not ideal either because I need to be able to receive calls and texts during phone calls.
 

RagingLoon

Member
May 10, 2013
6
4
Google Pixel XL
Google Pixel 6
I will never buy a google phone ever, ever again. This problem is unacceptable. I work in the healthcare field and a patient could die because I didn't get a notification on my phone.

I downloaded Tasker and implemented the do not disturb and hoping that will work. That said that is not ideal either because I need to be able to receive calls and texts during phone calls.

You'll still get notified for phone calls just nothing else. If you get a text during a call you'll get a visual in the notification bar and upon hanging up you'll then get the audible alert. After you make a call look at the notification bar and you'll see the do not disturb activate then deactivate after hanging up. Hope it works for you it's solved the problem for me.
 
  • Like
Reactions: Andro Enthusiast

theelizabethjoy

New member
Jun 17, 2018
1
0
I just started having this problem last night or Friday day (June 15/16). There are no new updates pending for anything but rebooting helped and I did use bluetooth on Friday. Does anyone know if this has been fixed permanently?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    So this just started a few days ago, I noticed that the notification sounds stopped working. Locking the phone stops making a sound and all notifications are silent. Watching videos and incoming calls are audible however.
    A reboot fixes the issue, but it returns soon after.

    I didn't install any new apps recently. Updated some, but nothing new.

    Any ideas?
    2
    I have the same issue, it's been going on for about 6 months now. First it was related to bluetooth connectivity. Now it's just randomly not ringing or making sounds for text messages. I am so fed up with Google's lackluster support. The same goes for Google Play Music and Google Home. They have bugs going on now for over 8 months and no fixes.

    I fixed the issue so far for myself by enabling do not disturb when a call comes in and disabling do not disable when the call ends. I used to have to reboot constantly to get my ringer and alerts back, but now it's been 8 days, 18 hours and 5 minutes with no issues. I don't manually toggle do not disturb every call I use Tasker.

    uc


    uc


    uc


    Enable_Do_Not_Disturb.prf.xml
    Code:
    <TaskerData sr="" dvi="1" tv="5.1m">
    	<Profile sr="prof3" ve="2">
    		<cdate>1526953921176</cdate>
    		<clp>true</clp>
    		<edate>1527137954034</edate>
    		<id>3</id>
    		<mid0>4</mid0>
    		<nme>Enable Do Not Disturb</nme>
    		<Event sr="con0" ve="2">
    			<code>2</code>
    			<pri>0</pri>
    		</Event>
    	</Profile>
    	<Task sr="task4">
    		<cdate>1526953950648</cdate>
    		<edate>1527137954034</edate>
    		<id>4</id>
    		<pri>100</pri>
    		<Action sr="act0" ve="7">
    			<code>30</code>
    			<Int sr="arg0" val="0"/>
    			<Int sr="arg1" val="3"/>
    			<Int sr="arg2" val="0"/>
    			<Int sr="arg3" val="0"/>
    			<Int sr="arg4" val="0"/>
    		</Action>
    		<Action sr="act1" ve="7">
    			<code>312</code>
    			<Int sr="arg0" val="0"/>
    		</Action>
    	</Task>
    </TaskerData>

    Disable_Do_Not_Disturb.prf.xml
    Code:
    <TaskerData sr="" dvi="1" tv="5.1m">
    	<Profile sr="prof5" ve="2">
    		<cdate>1526954324084</cdate>
    		<edate>1527137967738</edate>
    		<id>5</id>
    		<mid0>6</mid0>
    		<nme>Disable Do Not Disturb</nme>
    		<Event sr="con0" ve="2">
    			<code>4</code>
    			<pri>0</pri>
    		</Event>
    	</Profile>
    	<Task sr="task6">
    		<cdate>1526954329092</cdate>
    		<edate>1527137967738</edate>
    		<id>6</id>
    		<pri>100</pri>
    		<Action sr="act0" ve="7">
    			<code>30</code>
    			<Int sr="arg0" val="0"/>
    			<Int sr="arg1" val="3"/>
    			<Int sr="arg2" val="0"/>
    			<Int sr="arg3" val="0"/>
    			<Int sr="arg4" val="0"/>
    		</Action>
    		<Action sr="act1" ve="7">
    			<code>312</code>
    			<Int sr="arg0" val="2"/>
    		</Action>
    	</Task>
    </TaskerData>

    Tasker Profiles.zip - Google Drive bit.ly/2J3BysX
    2
    I'm sure that it happens, when you make a long phone call, after that all sounds are lost


    It's a problem with that faint beep that you hear while getting notifications while on a call. That was introduced in 8.1. After a while the software fails to revert the notification sounds back on after a call. Toggle "do not disturb" on during calls. Then toggle it off when the call ends. Try that. It will work. Let me know how it works out.

    Since I've been doing that I haven't had one problem with notification sounds. I notified Google of my findings and they're working on a fix. In the meantime do the DND toggle.
    1
    Same thing happened to me upon upgrading to 8.1 If I reboot it solves it for a little, but shortly afterwards no notification sounds again. Not sure if anyone has found a solution or are having the same issue?
    1
    If it's a software issue, flashing a custom ROM or the newest factory image indeed should fix it.