Notification sounds stop working randomly - pixel XL android 8.1

Search This thread

danstah

Senior Member
Feb 12, 2011
116
25
I'm on DP4 and started seeing this problem again

Update:
I installed the beta version of Google Play Services and haven't had an issue since.
 
Last edited:

Jab11621

New member
Jul 27, 2018
1
0
LADIES AND GENTLEMEN: having this same issue on my Google pixel. Everything goes back to normal when I turn Bluetooth off. I'm only having this issue while my Bluetooth is on but don't have a device connected. Turn the Bluetooth off and and all my notification sounds are working again. Haven't tested it out for a long period of time so it might not be permanent but it's working so far.
 

Bdejesus

New member
Jul 27, 2018
1
0
So I think I figured it out. Open the messages for the text you received with no sound. Click on the 3 dots in the upper left corner and choose people and options. Then click notifications. Next click importance. It will give you 4 options. High or urgent have to be chosen in order for it to make a sound when they text. Everyone in my contacts was set to medium, no sound, so unfortunately I had to change this for every person. But now I have sound with texts.
 

ssb13

Senior Member
Apr 8, 2011
330
65
Los Angeles
I just started having this issue AFTER a factory reset. Up until I did the reset about 10 days ago I had zero issue with my Pixel XL. I did the reset because things were just running like crap and I needed a cleanse. I have the experience that when a BT headset is connected my notifications work. When nothing is connected they do not. Toggling BT on/off makes no difference. It seems to affect phone calls and Allo as well. How annoying.
 

zero-gz

Senior Member
Nov 7, 2014
53
7

mikeosu

Senior Member
Sep 25, 2013
212
10
Been having this same issue for several months, even on the Sept 2018 P update now. I just tried the DND in call trick and it instantly fixed the problem. THANKS to those who discovered that. However, do we know how often that must be done to keep it up?

Really disappointed in Google for not addressing this. Having my PHONE not ring (it is a phone after all) is a major problem that is not acceptable. I love my Pixel 2 phone but this makes me have doubts about getting a Pixel 3 or (future) pixel 4. This problem and the recent "no sim card" bug I've been getting.....
 
  • Like
Reactions: pufferchung

pufferchung

New member
Oct 7, 2018
1
0
I have pixel xl and it just started to have this problem after the latest Oct. 2018 security update. I tried the DND, bluetooth, and none of them work. The only thing that work for me is to adjust the media volume thing, but I don't know how long that would last. Everyone in my family use iphone, except me! None of them have to deal with all these problems with their iphone, and my husband still using his Iphone 6+!! I bought pixel xl when they just came out from google store because i am into photography and Google pixel xl has really good camera. However, my first pixel xl died on me less than 1 year (I am not a heavy cellphone user, rarely talk on the phone, only use for social media when I don't have my laptop with me). Google customer service was really nice, immediately replaced a "refurbished" pixel xl for free.... I was really love my phone and no hard feeling. I did not have any problem for a while. But few months ago, the charger all the sudden stopped working, then the original USB cable won't transfer photos to my Macbook pro because Mac couldn't recognize google photo files. I did find a workaround for the USB cable issue but not getting any notification is the last straw! Unless there is some amazing camera improvements on pixel 3, I am going to ditch android forever and switch to Iphone XS Max!
 

mfkomry

New member
Sep 29, 2018
1
0
I founf the fix!

Hello everyone,
I was facing this problem since weeks, I have tried many things, turned off Bluetooth, turned on Do not disturb while calls and NONE of that worked.
I found the FIX finally, just remove your custom notification in WhatsApp, set all notification in this app to normal, and then restart your device.
This fixed this problem in my case.
Hope that will help you!
 

HaveSpacesuit

New member
Dec 14, 2018
1
0
Using Android 9. For me, it turned out I had Do Not Disturb turned on somehow. There isn't any indication from the sound settings that this was going on. Hope it helps somebody!
 
Nov 17, 2013
42
5
I turned off "Bluethooth autoscanning" (the feature that allows for scanning for bluethooth devices even if it's turned off) and had no issue since then. The problem was that bluethooth was turning on when I was using my headset, even though it's a wired headset.
 

Kyalclem

New member
Feb 4, 2019
1
0
There is a button under the slide down menu (where bluetooth and wifi are) that says do not disturb I found that even when all my sounds where up and I wasn't getting noise that was the problem.
 

OstrichSak

Senior Member
Aug 23, 2010
496
82
44
Colorado, USA
Any official word from Google on this? My wife and I have both been annoyed to no end by this bug for months now and are wondering why we paid so much for Pixel 3's that get the "latest updates and fixes" if we're going to have to endure what ends up being a complete failure of one of the main reasons of owning a mobile phone in the first place. We've owned all three versions of the Pixel at launch and have put up with countless bugs of various impact for years now. I'm pretty fed up with this and when it comes time to get a new phone I will think twice before buying a Google Pixel 4 as this is an unacceptable bug and the lack of urgency on Google's part is appalling and shows just how much they care about supporting those who paid thousands on their phones.
 

user13245

New member
Apr 19, 2019
1
0
Same problem here with my blackberry keyone and my blackberry keytwo after oreo upgrade (had this issue for more than a year)

I'm not having this issue on my blackberry priv (android 6.0)

Blutooth trick did not work and DND trick with tasker did not work.

I'm sure this issue is related to google oreo and pie update.

Google has been silent on this because they don't know how to fix it.

A basic and fondemental issue like this one which hasn't been fixed for 1 year and half is surely related to the incompetence of google techniciens to fix this. I think lot of users will abondon android and go back to Iphone.
 

caraboy

Senior Member
Oct 13, 2007
112
1
I have the same issue on a Xiaomi A1 with Android One, just updated to Android 9. I had this issue with the former Nexus 5S, can`t believe Google is not able to fix this!
Might just turn to a custom ROM...
 

Longhorn Keith

New member
Mar 23, 2020
1
0
the problem is that the Pixel does not disconnect from your Bluetooth device so it doesn't sound. Go in and disconnect from the last device you used.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    So this just started a few days ago, I noticed that the notification sounds stopped working. Locking the phone stops making a sound and all notifications are silent. Watching videos and incoming calls are audible however.
    A reboot fixes the issue, but it returns soon after.

    I didn't install any new apps recently. Updated some, but nothing new.

    Any ideas?
    2
    I have the same issue, it's been going on for about 6 months now. First it was related to bluetooth connectivity. Now it's just randomly not ringing or making sounds for text messages. I am so fed up with Google's lackluster support. The same goes for Google Play Music and Google Home. They have bugs going on now for over 8 months and no fixes.

    I fixed the issue so far for myself by enabling do not disturb when a call comes in and disabling do not disable when the call ends. I used to have to reboot constantly to get my ringer and alerts back, but now it's been 8 days, 18 hours and 5 minutes with no issues. I don't manually toggle do not disturb every call I use Tasker.

    uc


    uc


    uc


    Enable_Do_Not_Disturb.prf.xml
    Code:
    <TaskerData sr="" dvi="1" tv="5.1m">
    	<Profile sr="prof3" ve="2">
    		<cdate>1526953921176</cdate>
    		<clp>true</clp>
    		<edate>1527137954034</edate>
    		<id>3</id>
    		<mid0>4</mid0>
    		<nme>Enable Do Not Disturb</nme>
    		<Event sr="con0" ve="2">
    			<code>2</code>
    			<pri>0</pri>
    		</Event>
    	</Profile>
    	<Task sr="task4">
    		<cdate>1526953950648</cdate>
    		<edate>1527137954034</edate>
    		<id>4</id>
    		<pri>100</pri>
    		<Action sr="act0" ve="7">
    			<code>30</code>
    			<Int sr="arg0" val="0"/>
    			<Int sr="arg1" val="3"/>
    			<Int sr="arg2" val="0"/>
    			<Int sr="arg3" val="0"/>
    			<Int sr="arg4" val="0"/>
    		</Action>
    		<Action sr="act1" ve="7">
    			<code>312</code>
    			<Int sr="arg0" val="0"/>
    		</Action>
    	</Task>
    </TaskerData>

    Disable_Do_Not_Disturb.prf.xml
    Code:
    <TaskerData sr="" dvi="1" tv="5.1m">
    	<Profile sr="prof5" ve="2">
    		<cdate>1526954324084</cdate>
    		<edate>1527137967738</edate>
    		<id>5</id>
    		<mid0>6</mid0>
    		<nme>Disable Do Not Disturb</nme>
    		<Event sr="con0" ve="2">
    			<code>4</code>
    			<pri>0</pri>
    		</Event>
    	</Profile>
    	<Task sr="task6">
    		<cdate>1526954329092</cdate>
    		<edate>1527137967738</edate>
    		<id>6</id>
    		<pri>100</pri>
    		<Action sr="act0" ve="7">
    			<code>30</code>
    			<Int sr="arg0" val="0"/>
    			<Int sr="arg1" val="3"/>
    			<Int sr="arg2" val="0"/>
    			<Int sr="arg3" val="0"/>
    			<Int sr="arg4" val="0"/>
    		</Action>
    		<Action sr="act1" ve="7">
    			<code>312</code>
    			<Int sr="arg0" val="2"/>
    		</Action>
    	</Task>
    </TaskerData>

    Tasker Profiles.zip - Google Drive bit.ly/2J3BysX
    2
    I'm sure that it happens, when you make a long phone call, after that all sounds are lost


    It's a problem with that faint beep that you hear while getting notifications while on a call. That was introduced in 8.1. After a while the software fails to revert the notification sounds back on after a call. Toggle "do not disturb" on during calls. Then toggle it off when the call ends. Try that. It will work. Let me know how it works out.

    Since I've been doing that I haven't had one problem with notification sounds. I notified Google of my findings and they're working on a fix. In the meantime do the DND toggle.
    1
    Same thing happened to me upon upgrading to 8.1 If I reboot it solves it for a little, but shortly afterwards no notification sounds again. Not sure if anyone has found a solution or are having the same issue?
    1
    If it's a software issue, flashing a custom ROM or the newest factory image indeed should fix it.