• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Nova launcher: Widgets not clickable

Search This thread

Sunny2ask

Member
Nov 6, 2017
30
14
Well I figured out the solution:
Go to settings --> Installed apps --> Permissions --> Additional permissions and then Allow 'Start in background' for the apps which are not getting opened. No way to do this for all apps in one click though
 

Attachments

  • Screenshot_2018-10-02-16-02-37-618_com.miui.securitycenter.png
    Screenshot_2018-10-02-16-02-37-618_com.miui.securitycenter.png
    99.8 KB · Views: 2,472

seeingwithsound

New member
Sep 5, 2010
4
25
www.seeingwithsound.com
Fix for non-clickable widgets

After the latest Xiaomi Pocophone F1 firmware updates (MIUI Global 11.0.5), a number of my homescreen widgets today would no longer respond when tapped. Extremely annoying. I could now fix this by explicitly giving the permission "Display pop-up windows while running in the background". For example, for Multicon (obsolete but still worked well for me before the latest firmware updates) and Buienalarm, set

Settings | Apps | Manage apps | Multicon | Other permissions | Display pop-up windows while running in the background
Settings | Apps | Manage apps | Buienalarm | Other permissions | Display pop-up windows while running in the background
etc.

Hope this helps others too!
 

RedKage

Member
Jan 16, 2011
5
2
After the latest Xiaomi Pocophone F1 firmware updates (MIUI Global 11.0.5), a number of my homescreen widgets today would no longer respond when tapped. Extremely annoying. I could now fix this by explicitly giving the permission "Display pop-up windows while running in the background". For example, for Multicon (obsolete but still worked well for me before the latest firmware updates) and Buienalarm, set

Settings | Apps | Manage apps | Multicon | Other permissions | Display pop-up windows while running in the background
Settings | Apps | Manage apps | Buienalarm | Other permissions | Display pop-up windows while running in the background
etc.

Hope this helps others too!

That helped me, dude!
This works!
 
  • Like
Reactions: kiwiindo

Nanolo

Member
Nov 13, 2014
30
9
After the latest Xiaomi Pocophone F1 firmware updates (MIUI Global 11.0.5), a number of my homescreen widgets today would no longer respond when tapped. Extremely annoying. I could now fix this by explicitly giving the permission "Display pop-up windows while running in the background". For example, for Multicon (obsolete but still worked well for me before the latest firmware updates) and Buienalarm, set



Settings | Apps | Manage apps | Multicon | Other permissions | Display pop-up windows while running in the background

Settings | Apps | Manage apps | Buienalarm | Other permissions | Display pop-up windows while running in the background

etc.



Hope this helps others too!
Same problem for me on Mi 7 Note with MIUI 11 and that worked like a charm..I guess this could be useful for every device with MIUI.. Thank you very much! [emoji4]

Inviato dal mio Redmi Note 7
 

ballzak

Senior Member
Feb 27, 2013
410
230
Stockholm
llamalab.com
After the latest Xiaomi Pocophone F1 firmware updates (MIUI Global 11.0.5), a number of my homescreen widgets today would no longer respond when tapped. Extremely annoying. I could now fix this by explicitly giving the permission "Display pop-up windows while running in the background". For example, for Multicon (obsolete but still worked well for me before the latest firmware updates) and Buienalarm, set

Settings | Apps | Manage apps | Multicon | Other permissions | Display pop-up windows while running in the background
Settings | Apps | Manage apps | Buienalarm | Other permissions | Display pop-up windows while running in the background
etc.

Hope this helps others too!

I'm an app developer trying to figure out what the non-standard "Display pop-up windows while running in the background" permission is.
If possible, could you please post the result of running the following adb commands:
adb shell appops get com.urysoft.folder
adb shell cmd package list permissions -f
 

seeingwithsound

New member
Sep 5, 2010
4
25
www.seeingwithsound.com
I'm an app developer trying to figure out what the non-standard "Display pop-up windows while running in the background" permission is.
If possible, could you please post the result of running the following adb commands:
adb shell appops get com.urysoft.folder
adb shell cmd package list permissions -f

I do not have Multicon from UrySoft (com.urysoft.folder) but com.h9kdroid.multicon version 1.6.2 from H9kDroid which is no longer on Google Play AFAIK.

In any case, the difference for "adb shell appops get com.h9kdroid.multicon" lies in "Unknown(10021): ignore". That line shows only when (by default) the permission "Display pop-up windows while running in the background" is denied, and the line disappears entirely when accepted. There is no output line "Unknown(10021): allow" like one might expect.

Curiously, with Buienalarm, the output line for "adb shell appops get org.yoki.android.buienalarm" *does* switch from "Unknown(10021): ignore" to "Unknown(10021): allow" when granting the permission. Perhaps this has something to do with supported Android versions.

Regards,

Peter
 
Last edited:
Nov 21, 2015
5
0
Teplice
After the latest Xiaomi Pocophone F1 firmware updates (MIUI Global 11.0.5), a number of my homescreen widgets today would no longer respond when tapped. Extremely annoying. I could now fix this by explicitly giving the permission "Display pop-up windows while running in the background". For example, for Multicon (obsolete but still worked well for me before the latest firmware updates) and Buienalarm, set

Settings | Apps | Manage apps | Multicon | Other permissions | Display pop-up windows while running in the background
Settings | Apps | Manage apps | Buienalarm | Other permissions | Display pop-up windows while running in the background
etc.

Hope this helps others too!

This works for me for Xiaomi Redmi Note 8 with Nova Launcher.
 

Carlos_EVH

Senior Member
Jul 30, 2013
124
105
Malaga, Sp
After the latest Xiaomi Pocophone F1 firmware updates (MIUI Global 11.0.5), a number of my homescreen widgets today would no longer respond when tapped. Extremely annoying. I could now fix this by explicitly giving the permission "Display pop-up windows while running in the background". For example, for Multicon (obsolete but still worked well for me before the latest firmware updates) and Buienalarm, set

Settings | Apps | Manage apps | Multicon | Other permissions | Display pop-up windows while running in the background
Settings | Apps | Manage apps | Buienalarm | Other permissions | Display pop-up windows while running in the background
etc.

Hope this helps others too!

You are a hero lol. Thanks so much :D
 
  • Like
Reactions: unclnis

Top Liked Posts

  • There are no posts matching your filters.
  • 25
    Fix for non-clickable widgets

    After the latest Xiaomi Pocophone F1 firmware updates (MIUI Global 11.0.5), a number of my homescreen widgets today would no longer respond when tapped. Extremely annoying. I could now fix this by explicitly giving the permission "Display pop-up windows while running in the background". For example, for Multicon (obsolete but still worked well for me before the latest firmware updates) and Buienalarm, set

    Settings | Apps | Manage apps | Multicon | Other permissions | Display pop-up windows while running in the background
    Settings | Apps | Manage apps | Buienalarm | Other permissions | Display pop-up windows while running in the background
    etc.

    Hope this helps others too!
    11
    Well I figured out the solution:
    Go to settings --> Installed apps --> Permissions --> Additional permissions and then Allow 'Start in background' for the apps which are not getting opened. No way to do this for all apps in one click though
    2
    A weird issue is there. Nova launchers' widgets are working but on taping any widget to open the app, nothing happens.
    Any one else facing the same?
    1
    I'm having same issue. Guys do you have a solution?
    Set apps start in background didn't work either for me.

    Make sure they have ALL the permissions they require.
    App won't openif it needs to read/write to storage and doesn't have permission to do so...
    1
    Well I figured out the solution:
    Go to settings --> Installed apps --> Permissions --> Additional permissions and then Allow 'Start in background' for the apps which are not getting opened. No way to do this for all apps in one click though
    Worked for me also on Xiaomi Mi 9.
    Thanks Sunny2ask!