OEM Unlocking Grayed out on non-VZW Pixel 2.

Search This thread

iluvatrix

Senior Member
Aug 23, 2012
511
49
No, I can toggle oem unlock right after factory resetting but it still won't work. I would contact the seller and ask them to take a picture of the "fastboot flashing unlock" command in fastboot to see if it goes through.
Yeah I tried that but the seller doesn't want to go through the trouble.
No worries, I'll just walk away.
Thanks ?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    This looks to be a problem with the "refurbished" Pixel 2s they send out for warranty replacement. After sending me 3 "refurbished" ones, they now said I qualify for an exception to receive a new phone, and got the new one -- which worked immediately without any problems. Notably, in Developer Options, the "OEM Unlocking" slider is off after a factory reset, not on as on the refurbs.

    Also curious: if you do a adb shell getprop ro.boot.cid, you should see VZW__001 on a Verizon phone and 11111111 on a Google phone. My refurbished phones, as well as the new one I just received, all returned 00000000.

    The refurbished phones all shipped with a 3/2018 patch date, whereas the new one shipped with a 9/2017 patch date. That might also be part of the issue.
    2
    Mine was a brand new device. I did update to the June security patch before I finally got it to work. I refused to install my SIM card (which is Verizon) until I managed to get the bootloader unlocked.
    1
    What build number are you on?
    1
    The resale value? For whom, a few XDA users? No one cares about bl unlock any longer and it's going to go away. The resale value is due to it's great support in terms of updates, the camera and the device itself. Don't think that bl unlock will continue for any length of time at this point. Here's an article for you that portends what is coming down the pike. Get used to it, sorry to say.

    https://www.androidpolice.com/2018/05/24/huawei-halts-bootloader-unlock-program-indefinitely/

    Agree that it's probably going away... But disagree "no one cares about BL unlock". I care... LOL:p
    1
    I have the same issue, refurbished replacement from Google. The option is available on first boot after factory reset but fastboot command does nothing. After reboot, option is greyed out. Has there been any developement on this? Or am i stuck in their RMA cycle until they wise up and send a new one... Ive reached out to them and requested a new device based on the info provided here and reddit etc.. its been escalated to management but i highly doubt its going to be resolved to my satisfaction..