General Official Google Assistant For GW4 Available

Search This thread

avdieev

Member
Feb 3, 2018
16
2
25
Odessa
Nice! Will Your trick work with other languages? I'm from Poland.
Yes)
Screenshot_20220524_190121_assistant.png
 

svprm

Senior Member
Dec 17, 2007
1,537
497
Coimbatore
www.cybapps.com
Its working in India too.

Initially I searched for Assitant in the Watch Play Store and I'm unable to find it. Sometimes later it was installed automatically in my Watch.
 
Last edited:

avdieev

Member
Feb 3, 2018
16
2
25
Odessa
Install google assistant to watch (via BugJaeger) and launch it. On phone select 2 assistant languages English and your country language. 1. English 2. Polska.
If you not understand - I record video
 

CKavanagh

Senior Member
Apr 8, 2022
63
25
HOORAY! Google Assistant automatically appeared under apps in Galaxy Wearable and as an icon on the watch today. I followed the prompts between the phone and watch to install. I didn't download it from Google Play or Bugjaeger. I didn't run updates either (last update was May 5). Installed and tested successfully! I usually only use it to turn my bedroom lights/fan (plugged into a Wi-Fi powerbar); however, exploring other actions that the watch can open using the app (some apps also open on phone. There are some intermittent disconnects, stating watch is offline. The watch states not connected to a network, but it is connected to Wi-Fi. The command is actioned from the phone and not the watch. I go into Google Assistant under Galaxy Wearables to Force Stop, then select Open, it opens on the watch it is fine again, but after a few commands and it is completing the command on the phone.

Hey Google:
-Control light/fan plugged into a Wi-Fi powerbar
-Spotify
-YouTube Music (free for 3 months)
-Calendar (Pro Wear Calendar by Thomas Otero on Google Play)
-Photos (Photos-Wear OS Image Gallery by mkApps on Google Play, connects to Google Photos)
-Photo Gallery
-Weather
-Maps
 

Attachments

  • 20220524_123541.jpg
    20220524_123541.jpg
    1.7 MB · Views: 24
Last edited:
  • Like
Reactions: galaxys

cyberon

Senior Member
Jan 4, 2010
1,355
483
Google Pixel
Samsung Galaxy S21 Ultra
I will also add that you can change the "system assistant app" on the default apps from bixby to GAssistant also to let it access the the screen text (same permission has in the phone).



My country (Portugal) is not in the markets selected but I had the update waiting on the store and have it working.
Check for it on the watch play store or for the icon on the apps if it maybe already auto updated.
Do you use your phone in english, it's not showing for me.
 

cyberon

Senior Member
Jan 4, 2010
1,355
483
Google Pixel
Samsung Galaxy S21 Ultra
Install google assistant to watch (via BugJaeger) and launch it. On phone select 2 assistant languages English and your country language. 1. English 2. Polska.
If you not understand - I record video
Already did that and it didn't work, maybe it's also region locked. 😔

Edit: working now, had to remove my language, did the setup with English only, then added my language again.
 
Last edited:

GokberkTunc

Senior Member
Jul 27, 2011
67
18
Ankara
I need to sideload. If you get region error. Change your language to English and delete others. Both from (in order) main settings and google assistant settings.

Music recognize not working. Also reading message is not working. They working on phone.
 

Maxrunner

Senior Member
Aug 4, 2010
148
15
I will also add that you can change the "system assistant app" on the default apps from bixby to GAssistant also to let it access the the screen text (same permission has in the phone).



My country (Portugal) is not in the markets selected but I had the update waiting on the store and have it working.
Check for it on the watch play store or for the icon on the apps if it maybe already auto updated.
How did you do it? i can make mine work with the button, but when i say ok google /hey google it says :
WhatsApp Image 2022-05-24 at 12.04.15 PM.jpeg
 

CKavanagh

Senior Member
Apr 8, 2022
63
25
Do you use your phone in english, it's not showing for me.
It doesn't show Google Assistant as default app, only Bixby. I customized the top button for Google Assistant and also have it as hands free for commands. You will find Google Assistant settings under Google on the watch Settings.
 

Attachments

  • 2.jpg
    2.jpg
    1.1 MB · Views: 31
  • 1.jpg
    1.jpg
    1.1 MB · Views: 29
  • 3.jpg
    3.jpg
    1.2 MB · Views: 31
  • GA not listed.jpg
    GA not listed.jpg
    1.1 MB · Views: 33
  • Like
Reactions: cyberon

motisu

Senior Member
Apr 2, 2006
1,292
104
67
It doesn't show Google Assistant as default app, only Bixby. I customized the top button for Google Assistant and also have it as hands free for commands. You will find Google Assistant settings under Google on the watch Settings.
thanks for the info. I was wondering how to turn off the "hey Google" . I saw that having it on and listening all the time eats up a lot of battery. For me, it is enough that I mapped the button to respond.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Woah that's wild. Delete the extra assistant that you downloaded for your phone. The GA you downloaded off playstore is no different than the one that comes installed and is a system app. You only want the system app assistant and it can't be Uninstalled. So delete whatever GA can be Uninstalled and try again.

    The reason you have to link the GA on your watch and the GA on your phone is because they're technically separate apps. The GA on the play store is the wrong app. It's super confusing I know.
    1
    Can confirm linking to Wear OS worked. I was able to avoid a watch reset. My watch unpaired itself from the Samsung App so I had nothing to lose. I ran the ADB command that removes the GMS and it ended up pairing to my phone without reset.

    The Wear OS by google app, not Samsung.
    1
    Under Watch Settings > Privacy > Customization Service
    Wow, I don't have it there. Only permission manager
    1
    Same here on my Galaxy Watch 4 LTE...
    Same here too, missing
  • 6
    Update your Galaxy Wear app and then go to Play Store on your GW4. Select My Apps and update Assistant. Then go to Watch Settings and set your default assistant app to Google Assistant. Thennnnn, you'll find the GA icon as a launchable app or you can set your press and hold button to Google Assistant to launch it that way and begin activation. Activation requires connection between your watch and phone to link GA. Activation will ask if you want to use personal results and voice match on your watch. Done.

    GA can be launched using voice or hardware keys. To customize GA settings, Go into watch settings or Wear app on phone. Look for the Google settings (it has its own submenu) where your Google account info is located. There's a new setting available for GA there to customize Hey Google and other GA specific settings.

    Turning off Hey Google significantly reduced battery drain I noticed. With the GW4, one day of battery life is the best we can hope for and that's not including sleep. If you want to make it throughout the day, you can have either Health sensors going off continuously or Hey Google on. Not both or you'll never make it. If you want to make it a whole day, including overnight, disable both.

    Other battery saving tips:
    -Turn off "Improve Accuracy" under watch location settings. It's worthless and burns battery.
    -Turn off frequent syncing for samsung health steps data. Tap on steps on your phone. Tap 3 dots in top right corner. You'll see frequent syncing. Unless you actively track your steps religiously, this is an unnecessary battery burner. The level of accuracy you get without it is fine for most people.
    -Turn off notifications on watch you don't care about. Every time a notification from your phone turns on your watch screen, you're burning battery. Indicidual Notifications can be turned off just for watch.
    -Turn NFC off until you're ready to use it. The Google or Samsung Pay app will prompt you to turn it on so why leave it on all the time?
    -If you don't actively use your tiles, get rid of them. Unnecessary battery burners.
    -Make sure you limit location permissions. Very few Apps actually need location "All The Time".
    -Turn off background app usage from Wear App on Phone.
    -Make sure Mobile Network and WiFi are set to automatic. Biggest way to burn through those charges is with a mobile network you're not using actively.
    -Turn on Mobile Battery Saver in Developer Options.
    -Unless you actually use the quick launch gesture, turn it off.
    -Turn off Customization Service. Another worthless Samsung Spyware Tracker that offers nothing of value other than selling your personal information for ad relevance.
    2
    Update your wear app and then go to play store on your GW4. Select My Apps and update Assistant. Then go to Watch Settings and set your default assistant app to Google Assistant. Thennnnn, you'll find the GA icon as a launchable app. Launch it to activate assistant. Thats it! Enjoy.
    you may wanna change that to "general" or even a "how to"
    2
    Anyone else have this issue with GA on the Watch 4:

    My watch is connected to my phone. My phone is bluetooth hooked to my car and my watch. if i ask my watch to "Next song" in the car, the watch says it does not play anything or "i cant play anything on this device".
    The same issue when i'm connected to a bluetooth speaker and try to next song with my watch.
    Im running a bluetooth one 40 mm with spotify on the watch and on my phone.
    2
    Do not forget that he should also unplug Internet connector :D

    there was ROM for my old Pixel 2XL, made by a tinfoil hat type, whose pages listed ways to "avoid big brother", including advice to:

    - wear baseball caps everywhere to avoid cameras

    and my personal favourite ive ever heard from these tinfoilists:

    - when not in use, keep your mobile in a faraday bag

    *sigh*

    found it:

    1
    Same here on my Galaxy Watch 4 LTE...
    Same here too, missing