[OFFICIAL] LineageOS 16.0 for Xperia Z3 Compact

Status
Not open for further replies.
Search This thread

Gelindo67

Member
Apr 4, 2019
9
0
Hi,

Please correct me if I'm wrong, may this work:
https://forum.xda-developers.com/cr...carbomrom-xperia-package-guide-clean-t3816147

If I remember correctly I used it with my previous z2 and worked without camera button. Now I'm stopped interesting and left reading posts cause of XZ1C I got. Also I may try flash it and give feedback after owner solve hardware problem with his z3c and possibly borrow me. Sadly, I don't know when.

Good luck, if you will be trying. Read carefully how to do it. ;)

-------------------------------------
Always do backups!

Thank you so much.
I installed the Xperia Stock Camera Magisk Module and the photos seem to me to be already better than with the lineage os camera. I'd like to understand if it is possible to further improve by installing Cyberian cam or even better Google's GCam
 

pawloland

Senior Member
Jan 23, 2019
178
67
Sometimes I experience random reboots. They occure only while using official reddit app. The screen freezes, none of the buttons (soft&hardware) respond anymore and phone shuts down. It was happening for quite a while, but I've never rememberd how to grabs logs from random reboots. Here is the last_kmsg file.
 

Attachments

  • last_kmsg.txt
    113.8 KB · Views: 19

H4NNE5

Member
Jun 2, 2015
38
5
UPDATE: The problem disappeared after I installed an older version of the TWRP 3.1.1-z3 recoveries(The one from the OP of this thread). Any idea why the newer on was causing this problem???

Hi, I already successfully installed LOS 17.1 on my device but had problems in that way that all my call partners were hearing their own echo :(
So I wanted to try LOS 16. But upon installing the latest available zip file I get an ERROR 7 exit with following content:
Failed to mount /dev/block/bootdevice/byname/system at /system: Device or resource busy

I wiped all relevant data before.
A difference I noticed in the installation log was this:
For LOS17:
'somenumber': user/release-keys
Patching system image unconditionally
script succeeded: result was [1.0000]
For LOS16:
'somenumber': user/release-keys
detected filesystem ext4 for /dev/block/bootdevice/byname/system
mount: Failed to mount....
So apparently the successful installation skipped the file system mount or what does that mean?
Can anybody give me a hint what I could do?

Thank you.
 
Last edited:

blokva

Senior Member
Apr 3, 2012
74
4
Minsk
Hi, I have flashed recovery in the firs post was recommended. The file version looks as 3.3.1, but when I loaded to TWRP on the top I see:
Team Win Recovery Project
3.0.2.0
What this means?

Thanks
 

hchauvet

New member
Oct 29, 2019
3
1
Yes, this seems to fix the audio problems. @Mr.Tom_Tom found the actual typo in the end, so all thanks go to him :D
Together with two other changes, first add the stock dmic acdb id's which should bring the stock fluence configuration in handset mode and second disabling fluence in speaker mode, that should also get the speaker experience inline with stock. However it is not 100% similar to stock yet I think, sometimes I still have an echo on the other end when in speaker mode. But all in all its a huge improvement I think.

Thanks !!! I just install this version and for me it fix the too loud volume :good::good::good: !
 
  • Like
Reactions: NeoArian

blokva

Senior Member
Apr 3, 2012
74
4
Minsk
This means that you did not flash the new twrp in the end.

What can I do in this situation?
All my attempts are finished with OKAY message, but after rebooting in recovery mode, I see title:
"Team Win Recovery Project
3.0.2.0"
 

Attachments

  • TWRP331flash_result.jpg
    TWRP331flash_result.jpg
    21.5 KB · Views: 77

blokva

Senior Member
Apr 3, 2012
74
4
Minsk
From where did you download the twrp?
Have you flashed the latest stock firmware before?

Thanks a lot for care about my problem!
In this time I have customized "Pre-root MOD 291 RU" from 4pda.ru (by russel5 user)
And TWRP from this thread in post #2
May be I need clear stock ROM to be installed? But now I have open boot loader!
 

steve8x8

Senior Member
Jul 7, 2014
389
131
Am I supposed to perform a manual upgrade when a new nightly ROM has been detected?
Rebooting into TWRP 3.3.1-0 from 20200325 didn't do anything, I had to pickup the zip from /data/lineageos_updates and install it manually. What did I miss?

Addition: After successfully upgrading, now even coupling the MiBand4 (with the xDrip app) works flawlessly - this failed before when one of the display details were activated (while the seranoltexx build didn't show this issue). I probably will never find out what exactly has been changed between 0325 and 0421 ...
 
Last edited:

NeoArian

Recognized Developer
Nov 25, 2017
1,227
2,763
Gladbeck
No action on the LOS downloads page since the 21 April 2020 update. Is 16 dead, or is the dev just taking a (well-earned) break ?
Builds are currently paused due to infrastructure work and will be continued as soon as possible.

Am I supposed to perform a manual upgrade when a new nightly ROM has been detected?
Rebooting into TWRP 3.3.1-0 from 20200325 didn't do anything, I had to pickup the zip from /data/lineageos_updates and install it manually. What did I miss?

Addition: After successfully upgrading, now even coupling the MiBand4 (with the xDrip app) works flawlessly - this failed before when one of the display details were activated (while the seranoltexx build didn't show this issue). I probably will never find out what exactly has been changed between 0325 and 0421 ...
OTA updates downloaded through the updater should be installed automatically in twrp.
 

dplasa

Member
Jun 27, 2015
25
4
Still no new builds

Builds are currently paused due to infrastructure work and will be continued as soon as possible.


OTA updates downloaded through the updater should be installed automatically in twrp.

Other devices have recent (today!) builds... the z3c seems to be forgotten. :(
 

steve8x8

Senior Member
Jul 7, 2014
389
131
Indeed - although the order of new builds seems to be random (z3c and bacon already covered; one -but not the 2nd- of the s3ve3g* ones, ...). In the end, all will sort out - and if it doesn't, it's not the end yet.
 

Radiolaria

Member
Oct 13, 2017
8
2
@NeoArian and all belonged developers:

A really big thank you and your really important work. Perhaps the most important work in the smartphone space.
For everyone who is searching for a small smartphone and for me without google, there are no other possibility then stepping back to the z3c.
Do you have a crypto wallet for donation? Because i have no paypal.

Kind regards
Marco
 
Status
Not open for further replies.

Top Liked Posts

  • There are no posts matching your filters.
  • 22
    Code:
    [COLOR="Purple"]#include <std_disclaimer.h>[/COLOR]
    [COLOR="Navy"]/*
     * Your warranty is now void.
     *
     * I am not responsible for bricked devices, dead SD cards,
     * thermonuclear war, or you getting fired because the alarm app failed. Please
     * do some research if you have any concerns about features included in this ROM
     * before flashing it! YOU are choosing to make these modifications, and if
     * you point the finger at me for messing up your device, I will laugh at you.
     */[/COLOR]

    Installation:
    If you are on stock OS, you need a custom recovery first. You can get the recommended TWRP recovery in the official installation instructions link below.
    If you are coming from stock or other ROMs, you need to make a factory reset.
    As always, make sure to backup before installing this ROM.

    More detailed instructions at:
    Install LineageOS on z3c

    Download link:
    LineageOS Downloads for z3c

    Recommended Google Apps package:
    Open GApps (choose ARM as Platform and 9.0 as Android, use the Variant you want. Recommended nano package)

    Required TWRP recovery
    twrp-3.3.1-z3c-20191107.img

    Official root addon
    LineageOS Extras

    Changelog:
    Changes for z3c

    Bug reports:
    How to submit a bug report
    LineageOS GitLab

    Donate to support development:
    Donate via PayPal to NeoArian
    Donate via PayPal to LineageOS

    Thanksgiving
    Thanks to everyone who ever contributed to the custom developement for this device.
    Especially:
    @tomascus
    @Diewi
    @xkeita
    @rcstar6696
    @koron393
    @nailyk
    @SpiritCroc
    @115ek
    @Myself5
    @drakonizer

    Thanks to every LineageOS contributor.

    Source Code
    The source code of LineageOS is available here.
    The kernel source code for this device is available here.
    The used configuration is lineageos_shinano_aries_defconfig available at arch/arm/configs/lineageos_shinano_aries_defconfig in the kernel source.


    XDA:DevDB Information
    LineageOS 16.0 for Xperia Z3 Compact, ROM for the Sony Xperia Z3 Compact

    Contributors
    NeoArian
    Source Code: https://github.com/LineageOS

    ROM OS Version: 9.x Pie
    ROM Kernel: Linux 3.4.x

    Version Information
    Status: Nightly

    Created 2019-11-07
    Last Updated 2019-11-07
    9
    Note that the first build is scheduled but not yet available for download. No need to worry though, the lineage-16.0 project is in nightly state so it should be up in a maximum of 24 hours.
    Also note that the official builds are signed, so you are not able to just flash them over the current unofficial LineageOS 16.0 builds.
    7
    Hi @NeoArian
    I am using Lineage OS 16 for a year now. I have been there from pretty much the beginning. I just tried the latest nightly and the audio while calling in normal mode is just on point and the loudspeaker mode is also significantly louder, than in previous build. I am very happy to see this issue being fixed after that long amount of time. I honestly wasn't believing it would be ever fixed.
    Do you remember the bug when the audio was played super loud and then it was getting quieter and quieter? I think the only problem left now is to make sound in any part of system or any app as loud as it was while this bug was occurring. I think that the maximum loudness of phone in lineage is like 80% of the maximum volume on stock. The same applies for loudspeaker mode - it is now significantly louder, but it steel isn't as loud as stock. It can be also just me imagining the problem, because after all of those audio issues I don't know if I can trust my ears anymore :p.

    Right now the builds are official which would suggest that everything is working. Well I still have some problems:
    -the wfd (wifi display/mirracast) is sometimes WORKING for me. I remember that it wasn't working so it was abandoned, but later on it was again enabled, because it wasn't causing restarts anymore. I don't remember if you did something to solve this issue but it seems that problem solved itself. I tried connecting to my windows laptop and after couple of tries the phone CONNECTED :D. For the first time in year I was able to connect. Here are my observations:
    - the popup on windows is always displayed when device tries to connect to it
    - from that popup I can click to connect to device and the phone either decides to connect or not and then the message appears on the windows that says something like "Secured content can't be played on this device"
    -audio is being send but is little off sync
    -video is sluggish, artifacts can be seen
    -after connection is established phone often disconnects from wifi network. If i try to connect to wifi again it is stuck on "Obtaining IP address". It can also happened that the phone connects to wfd and DOESN'T disconnects from wifi. If that happens the video stream is super, mega, ultra blurry, off sync, artifacts can be observed, video is very choppy and connectivity is going to be lost.
    As the connection can be established nowadays, can you do something to fix the huge lag while using wfd and connected to wifi?

    Next thing is Fm Radio. It doesn't work for me anymore even after manually selecting the frequency (like it was left before).
    That is all what I think is left unpolished on lineage side. The rest is regarding TWRP.
    -the signature verification always fails on official zips. I don't know if it is the problem with TWRP, that can't verify the zip or the zip itself has wrong signature.
    -can't perform OTA updates. I must manually install each update.
    -the time in logs is wrong
    -after any action performed in TWRP I get error saying ~Can't mount storage.
    I attach logs.

    Thanks for all of your work. I am looking forward official Lineage OS 17.1 while it gets out from WIP :eek:
    Hi,
    First of all thanks for the detailed feedback, I appreciate it.
    About the audio stuff, I think it should be comparable to stock, we are pretty much using the stock setup of the mixer settings. I will hear again when I flash stock next time though to make sure. I did not enable Miracast for the Sony msm8974 devices because I don't consider it as really working, I didn't get the heavy wlan speed drop during it fixed. All TV's shown in settings should be available through Google cast which works good on my Z3C and Sony android TV, will also confirm that again within the next days. I don't think your windows laptop is using Google cast though, do you still stream from the settings -> connected devices -> connection settings -> stream?
    What you describe sounds similar to Miracast but that one shouldn't be available in the official build, weird?
    FM radio was working okay for me last time I checked. I will downgrade to 16.0 to confirm that in the official builds.
    About twrp I have some good news :D
    I don't really know about your first problem with zip signature verification, it might be caused by the official builds that are signed with custom created keys.
    I have built a new TWRP with OTA updates fixed. @115ek has shared the fix. I will release it within the next days somewhere. Until now you can download it from here: https://drive.google.com/file/d/12f7WrbpkqmSMC1p3OSfRwG7k2BwlmgWt/view?usp=drivesdk
    ( For Z3 friends: https://drive.google.com/file/d/12eYhVT6-nFGuIlbSiDVEMnODcBUDcMcq/view?usp=drivesdk).
    About the wrong time, there was a problem in the Sony timekeep service, many thanks to MarijnS95 who fixed the problem and helped me out really quick. (https://github.com/sonyxperiadev/timekeep/issues/23)
    I will try to get this fix merged into LineageOS soon. Then the time will be working fine in TWRP, I already have it fixed on my device. I didn't see "Can't mount storage." On my device. Can you see if that still happens with the new TWRP build?

    Greetings, Arian.
    6
    Good evening,
    since some of you seem to have problems with echo during calls i have digged through patches developer previously applied to our devices. I have tranfsformed them into two magisk modules and would ask the ones who have the problems to test both of the modules. In the first row please test them one by one and then you can also combine them (just install both). Good luck!

    Don't get irritated from the OTA for Lineage 17 text during installation, i just missed to change that from my template.
    5
    So I flashed twrp, and I can't perform OTA. When I click Install in updater phone reboots and then hangs at sony logo and led flashes blue. Forcefully turned off the phone, and booted to twrp. Script started executing, but ended up with the error as before. After that I tried to manually install zip, but as you may expect, without success. Here are logs:

    I haven't seen the signature verification failed error myself but could you try to disable the signature verification within TWRP settings (default is not activated by the way)?

    Anyway Good evening everyone, since i am a little bit sick today i have had some time to look into the mystery call volume problem :D I have experimented really much and got a probably pretty good solution.
    The first change is https://review.lineageos.org/c/LineageOS/android_device_sony_z3c/+/264153 where i have updated the mixer_paths from the latest stock ROM and dropped all modifcations we previously had on top of the stock one except the one linked in the commit message. https://review.lineageos.org/c/LineageOS/android_device_sony_shinano-common/+/264152 This commit drops custom acdb id's for dual microphone configurations we previously had. I don't understand why we had these changes but when falling back to the default acdb id's (43 for speaker dmic and 41 for handset dmic) The volume is not that crazy loud anymore and similar to stock i think. I have also enabled Fluence here: https://review.lineageos.org/c/LineageOS/android_device_sony_shinano-common/+/264150 That should enable Qualcomm’s dual-mic echo cancellation technology and seems to work good so far.
    One problem is left, you might now that my bottom speaker is broken so i can't test the speaker mode output myself, so i have not merged the changes yet. Would someone be so kind and test the build i compiled? download: https://drive.google.com/open?id=1r2ipI5gfZpxPTxCSYpyIBEse2Hsr3FF7 Note that you can not flash this build over the official nightly because of the different signing of the official build. Please wipe data. If you are still on my latest unofficial build you can just flash it as always.

    In order to get some impressions how the experience should be i flashed the stock OS today morning myself, i think the calls should be on a similar level now, assumed that the speaker works as intended.

    I have also tested GPS on stock and found out that it can connect to GLONASS and Beidou sattelites, i think on Lineage we are not able to do so currently. I will look into this within the next days and keep you updated on this.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone