[OFFICIAL] LineageOS 16.0 for Xperia Z3 Compact

Not open for further replies.
Search This thread


Jul 3, 2007
Hi guys,
I am on the X Compact at the moment, but the GPS problem seems to be an universal LineageOS problem. For us, GPS stopped working in mid-July, too. Same problem, lots of satillites in view, but none gets locked. In the GitLab of LineageOS there are many issues of different phone users experiencing the same problem on LineageOS 16 and LineageOS 17.

Thanks for the answer.
So my tests are "localization with GPS only". Outdoor a TTF is made but after few minutes, and then without disconnection. So it is working, but not as fast as it should do at first. Strange.


Jul 22, 2019
Thanks for the answer.
So my tests are "localization with GPS only". Outdoor a TTF is made but after few minutes, and then without disconnection. So it is working, but not as fast as it should do at first. Strange.

Today i tested a newly flashed z3c with LOS16-25.8., GPS works but it only locks on Navstar-sats.
Other-sats with good signal are listed but no lock on them.
Another z3c with 23.5.A.1.291 use other Sats beside Navstar...
Not open for further replies.

Top Liked Posts

  • There are no posts matching your filters.
  • 22
    [COLOR="Purple"]#include <std_disclaimer.h>[/COLOR]
     * Your warranty is now void.
     * I am not responsible for bricked devices, dead SD cards,
     * thermonuclear war, or you getting fired because the alarm app failed. Please
     * do some research if you have any concerns about features included in this ROM
     * before flashing it! YOU are choosing to make these modifications, and if
     * you point the finger at me for messing up your device, I will laugh at you.

    If you are on stock OS, you need a custom recovery first. You can get the recommended TWRP recovery in the official installation instructions link below.
    If you are coming from stock or other ROMs, you need to make a factory reset.
    As always, make sure to backup before installing this ROM.

    More detailed instructions at:
    Install LineageOS on z3c

    Download link:
    LineageOS Downloads for z3c

    Recommended Google Apps package:
    Open GApps (choose ARM as Platform and 9.0 as Android, use the Variant you want. Recommended nano package)

    Required TWRP recovery

    Official root addon
    LineageOS Extras

    Changes for z3c

    Bug reports:
    How to submit a bug report
    LineageOS GitLab

    Donate to support development:
    Donate via PayPal to NeoArian
    Donate via PayPal to LineageOS

    Thanks to everyone who ever contributed to the custom developement for this device.

    Thanks to every LineageOS contributor.

    Source Code
    The source code of LineageOS is available here.
    The kernel source code for this device is available here.
    The used configuration is lineageos_shinano_aries_defconfig available at arch/arm/configs/lineageos_shinano_aries_defconfig in the kernel source.

    XDA:DevDB Information
    LineageOS 16.0 for Xperia Z3 Compact, ROM for the Sony Xperia Z3 Compact

    Source Code: https://github.com/LineageOS

    ROM OS Version: 9.x Pie
    ROM Kernel: Linux 3.4.x

    Version Information
    Status: Nightly

    Created 2019-11-07
    Last Updated 2019-11-07
    Note that the first build is scheduled but not yet available for download. No need to worry though, the lineage-16.0 project is in nightly state so it should be up in a maximum of 24 hours.
    Also note that the official builds are signed, so you are not able to just flash them over the current unofficial LineageOS 16.0 builds.
    Hi @NeoArian
    I am using Lineage OS 16 for a year now. I have been there from pretty much the beginning. I just tried the latest nightly and the audio while calling in normal mode is just on point and the loudspeaker mode is also significantly louder, than in previous build. I am very happy to see this issue being fixed after that long amount of time. I honestly wasn't believing it would be ever fixed.
    Do you remember the bug when the audio was played super loud and then it was getting quieter and quieter? I think the only problem left now is to make sound in any part of system or any app as loud as it was while this bug was occurring. I think that the maximum loudness of phone in lineage is like 80% of the maximum volume on stock. The same applies for loudspeaker mode - it is now significantly louder, but it steel isn't as loud as stock. It can be also just me imagining the problem, because after all of those audio issues I don't know if I can trust my ears anymore :p.

    Right now the builds are official which would suggest that everything is working. Well I still have some problems:
    -the wfd (wifi display/mirracast) is sometimes WORKING for me. I remember that it wasn't working so it was abandoned, but later on it was again enabled, because it wasn't causing restarts anymore. I don't remember if you did something to solve this issue but it seems that problem solved itself. I tried connecting to my windows laptop and after couple of tries the phone CONNECTED :D. For the first time in year I was able to connect. Here are my observations:
    - the popup on windows is always displayed when device tries to connect to it
    - from that popup I can click to connect to device and the phone either decides to connect or not and then the message appears on the windows that says something like "Secured content can't be played on this device"
    -audio is being send but is little off sync
    -video is sluggish, artifacts can be seen
    -after connection is established phone often disconnects from wifi network. If i try to connect to wifi again it is stuck on "Obtaining IP address". It can also happened that the phone connects to wfd and DOESN'T disconnects from wifi. If that happens the video stream is super, mega, ultra blurry, off sync, artifacts can be observed, video is very choppy and connectivity is going to be lost.
    As the connection can be established nowadays, can you do something to fix the huge lag while using wfd and connected to wifi?

    Next thing is Fm Radio. It doesn't work for me anymore even after manually selecting the frequency (like it was left before).
    That is all what I think is left unpolished on lineage side. The rest is regarding TWRP.
    -the signature verification always fails on official zips. I don't know if it is the problem with TWRP, that can't verify the zip or the zip itself has wrong signature.
    -can't perform OTA updates. I must manually install each update.
    -the time in logs is wrong
    -after any action performed in TWRP I get error saying ~Can't mount storage.
    I attach logs.

    Thanks for all of your work. I am looking forward official Lineage OS 17.1 while it gets out from WIP :eek:
    First of all thanks for the detailed feedback, I appreciate it.
    About the audio stuff, I think it should be comparable to stock, we are pretty much using the stock setup of the mixer settings. I will hear again when I flash stock next time though to make sure. I did not enable Miracast for the Sony msm8974 devices because I don't consider it as really working, I didn't get the heavy wlan speed drop during it fixed. All TV's shown in settings should be available through Google cast which works good on my Z3C and Sony android TV, will also confirm that again within the next days. I don't think your windows laptop is using Google cast though, do you still stream from the settings -> connected devices -> connection settings -> stream?
    What you describe sounds similar to Miracast but that one shouldn't be available in the official build, weird?
    FM radio was working okay for me last time I checked. I will downgrade to 16.0 to confirm that in the official builds.
    About twrp I have some good news :D
    I don't really know about your first problem with zip signature verification, it might be caused by the official builds that are signed with custom created keys.
    I have built a new TWRP with OTA updates fixed. @115ek has shared the fix. I will release it within the next days somewhere. Until now you can download it from here: https://drive.google.com/file/d/12f7WrbpkqmSMC1p3OSfRwG7k2BwlmgWt/view?usp=drivesdk
    ( For Z3 friends: https://drive.google.com/file/d/12eYhVT6-nFGuIlbSiDVEMnODcBUDcMcq/view?usp=drivesdk).
    About the wrong time, there was a problem in the Sony timekeep service, many thanks to MarijnS95 who fixed the problem and helped me out really quick. (https://github.com/sonyxperiadev/timekeep/issues/23)
    I will try to get this fix merged into LineageOS soon. Then the time will be working fine in TWRP, I already have it fixed on my device. I didn't see "Can't mount storage." On my device. Can you see if that still happens with the new TWRP build?

    Greetings, Arian.
    Good evening,
    since some of you seem to have problems with echo during calls i have digged through patches developer previously applied to our devices. I have tranfsformed them into two magisk modules and would ask the ones who have the problems to test both of the modules. In the first row please test them one by one and then you can also combine them (just install both). Good luck!

    Don't get irritated from the OTA for Lineage 17 text during installation, i just missed to change that from my template.
    So I flashed twrp, and I can't perform OTA. When I click Install in updater phone reboots and then hangs at sony logo and led flashes blue. Forcefully turned off the phone, and booted to twrp. Script started executing, but ended up with the error as before. After that I tried to manually install zip, but as you may expect, without success. Here are logs:

    I haven't seen the signature verification failed error myself but could you try to disable the signature verification within TWRP settings (default is not activated by the way)?

    Anyway Good evening everyone, since i am a little bit sick today i have had some time to look into the mystery call volume problem :D I have experimented really much and got a probably pretty good solution.
    The first change is https://review.lineageos.org/c/LineageOS/android_device_sony_z3c/+/264153 where i have updated the mixer_paths from the latest stock ROM and dropped all modifcations we previously had on top of the stock one except the one linked in the commit message. https://review.lineageos.org/c/LineageOS/android_device_sony_shinano-common/+/264152 This commit drops custom acdb id's for dual microphone configurations we previously had. I don't understand why we had these changes but when falling back to the default acdb id's (43 for speaker dmic and 41 for handset dmic) The volume is not that crazy loud anymore and similar to stock i think. I have also enabled Fluence here: https://review.lineageos.org/c/LineageOS/android_device_sony_shinano-common/+/264150 That should enable Qualcomm’s dual-mic echo cancellation technology and seems to work good so far.
    One problem is left, you might now that my bottom speaker is broken so i can't test the speaker mode output myself, so i have not merged the changes yet. Would someone be so kind and test the build i compiled? download: https://drive.google.com/open?id=1r2ipI5gfZpxPTxCSYpyIBEse2Hsr3FF7 Note that you can not flash this build over the official nightly because of the different signing of the official build. Please wipe data. If you are still on my latest unofficial build you can just flash it as always.

    In order to get some impressions how the experience should be i flashed the stock OS today morning myself, i think the calls should be on a similar level now, assumed that the speaker works as intended.

    I have also tested GPS on stock and found out that it can connect to GLONASS and Beidou sattelites, i think on Lineage we are not able to do so currently. I will look into this within the next days and keep you updated on this.