• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[OFFICIAL] LineageOS 18.1 for D6603 Xperia Z3

Search This thread

Gomeman

Senior Member
Aug 31, 2020
51
16
Hi forum z3.
I have a z3 6603 with 17.1 , and than i put it back in a box, since im not using . Decided to install 18.1 and did it with success. Factory reset , intallled rom and nano gapps.
I thought this was going to be the end of z3, but looks like someone is still working on this device . Someone is still in love with z3, touching the obsession :LOL:. Thanks Mr Tom_Tom for your work.
I havent done much on it . Just a bit of tweaking. Not rooted yet. safetynet passes by default.. Only thing i notice is the camera doesnt work. I remember it worked on 17.1 . But it was failing to be honest sometimes. Other than that , dont know how bluetooth is going on, since i have no bluetooth device to try it.
bye
 
  • Like
Reactions: Mr.Tom_Tom

Gomeman

Senior Member
Aug 31, 2020
51
16
Anybody has issues with SDCards formated as "internal" memory? If so, could you share your issues?

Hi there
Mi experience, here you go.
I formated an 8gb sd card as internal and it looks ok. 16gb internal + 8 gb external , shows 24 gb. But ¿isnt it supposed to format the card? . i went back to external sd card , the phone goes unstable and i had to reboot(software reboot). And all the things i had in Download folder was still there.
I did the process again , as internal , and went back to external and phone just didnt responde so i had to hard reset it(botton). Appeared the messege that the sd card had a problem and i choose format as external and it wiped everything.
Correct me if im wrong : the SD card shouldnt appear , but it does. Also on Pc , only SD card 8gb appears and internal memory doesnt.
I dont know why it displays 407 mb use when it has nothing on it since it got formated.
Attached some screen shots when i format sd card as internal.
Ps: spanish.
Hope give you an idea. Im not using this phone and i usualy dont format sd card as internal.
BYE BYE. good work Sr.
 

Attachments

  • Screenshot_20210928-125646_Trebuchet.png
    Screenshot_20210928-125646_Trebuchet.png
    76.4 KB · Views: 6
  • Screenshot_20210928-125742_Trebuchet.png
    Screenshot_20210928-125742_Trebuchet.png
    82.9 KB · Views: 9
  • Captura.PNG
    Captura.PNG
    43.1 KB · Views: 9
  • Screenshot_20210928-130004_Trebuchet.png
    Screenshot_20210928-130004_Trebuchet.png
    118.2 KB · Views: 9
  • Screenshot_20210928-130047_Trebuchet.png
    Screenshot_20210928-130047_Trebuchet.png
    62.4 KB · Views: 6
  • Like
Reactions: Mr.Tom_Tom

SethGeckoXDA

Senior Member
Feb 19, 2017
134
71
Anybody has issues with SDCards formated as "internal" memory? If so, could you share your issues?

Coming from stock, I performed a clean install of LOS 18.1 with OpenGApps pico and inserted a SanDisk Ultra microSDHC (32 GB). It did ask me to either format as internal or external storage and I went for internal storage. After a couple of days, it showed the message "SD card damaged" and I had to re-format. Again, I chose internal storage and had to re-install some of my apps. This was about two weeks ago. I hope it won't get corrupted again. I have yet to install a LOS update.
 
  • Like
Reactions: Mr.Tom_Tom

Mr.Tom_Tom

Senior Member
Feb 16, 2008
176
220
Munich
OK, let me summarize and check if I understood correctly:

@SethGeckoXDA you experienced an "SD card damaged" a few days after setting it up, and not related to a ROM update

@Gomeman you experienced a problem after formatting it as internal and then as external, right? I would not be worried that the phone shows 407mb used. Also, that windows finds only one drive is OK when you format as internal.

Thanks a lot to both of you for your reports!
 
  • Like
Reactions: Gomeman

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Anybody has issues with SDCards formated as "internal" memory? If so, could you share your issues?

    Hi there
    Mi experience, here you go.
    I formated an 8gb sd card as internal and it looks ok. 16gb internal + 8 gb external , shows 24 gb. But ¿isnt it supposed to format the card? . i went back to external sd card , the phone goes unstable and i had to reboot(software reboot). And all the things i had in Download folder was still there.
    I did the process again , as internal , and went back to external and phone just didnt responde so i had to hard reset it(botton). Appeared the messege that the sd card had a problem and i choose format as external and it wiped everything.
    Correct me if im wrong : the SD card shouldnt appear , but it does. Also on Pc , only SD card 8gb appears and internal memory doesnt.
    I dont know why it displays 407 mb use when it has nothing on it since it got formated.
    Attached some screen shots when i format sd card as internal.
    Ps: spanish.
    Hope give you an idea. Im not using this phone and i usualy dont format sd card as internal.
    BYE BYE. good work Sr.
    1
    Anybody has issues with SDCards formated as "internal" memory? If so, could you share your issues?

    Coming from stock, I performed a clean install of LOS 18.1 with OpenGApps pico and inserted a SanDisk Ultra microSDHC (32 GB). It did ask me to either format as internal or external storage and I went for internal storage. After a couple of days, it showed the message "SD card damaged" and I had to re-format. Again, I chose internal storage and had to re-install some of my apps. This was about two weeks ago. I hope it won't get corrupted again. I have yet to install a LOS update.
    1
    OK, let me summarize and check if I understood correctly:

    @SethGeckoXDA you experienced an "SD card damaged" a few days after setting it up, and not related to a ROM update

    @Gomeman you experienced a problem after formatting it as internal and then as external, right? I would not be worried that the phone shows 407mb used. Also, that windows finds only one drive is OK when you format as internal.

    Thanks a lot to both of you for your reports!
    1
    OK, let me summarize and check if I understood correctly:

    @SethGeckoXDA you experienced an "SD card damaged" a few days after setting it up, and not related to a ROM update

    Correct.

    Actually, it happened again yesterday: I got the "SD card damaged" error after rebooting the device.

    Attached you can find a log. Quickly glancing over it, I can find some crashes as well as suspicious fsck messages. Maybe there is something in it which will help you fix the issue.
    1
    This post in the /e/ OS forums describes a workaround for this problem. The workaround allows you to restore an Android 10 backup on a newly installed Android 11 ROM. It also allows you to 'dirty flash' the Android 11 ROM over the Android 10 data. It has worked for me on several Xperia devices including Z3 Compact. It should also work on Z3.

    These are the steps in TWRP for 'dirty flash' (this refers to /e/ OS ROMs, but should also work for LineageOS
    1. Backup your existing data partition. (This isn’t actually necessary, but it will make you feel better :) )
    2. Flash the new R ROM (I used the test build I have just made e-0.18-r-20210910-UNOFFICIAL-suzuran)
    3. Advanced > File Manager navigate to /data/user_de/0/org.lineageos.lineagesettings/databases/ and delete both files there (lineagesettings.db and lineagesettings.db-journal)
    4. Wipe cache / dalvik
    5. Reboot system

    To restore a backup, after a clean install, then do steps 2 & 3, then restore your backup, then reboot. Good luck!

    (More details in this /e/OS issue, along with some alternative workarounds if you like playing with sqlite 3: https://gitlab.e.foundation/e/backlog/-/issues/3712
  • 7
    lineage_strip_teal-png.5158389

    Introduction

    LineageOS 18.1 is an open-source Android distribution based on the Android Open Source Project (AOSP) version 11 (R). This is the official LineageOS 18.1 thread for the Sony Xperia Z3 (D6603).

    Installation

    If you are on stock OS, you need a custom recovery first. You can get the recommended recovery in the official installation instructions link below. There are also inofficial TWRP recovery builds available - if you want to use TWRP you need to ensure that it is compatible with Android 10 or later.
    If you are coming from stock or other ROMs, you need to make a factory reset. You also will need a factory reset if you come from LineageOS 17.1 with encryption enabled.
    For upgrading from an earlier LineageOS version, please follow the instructions here.
    As always, make sure to backup before installing this ROM.

    Detailed installation instructions

    Install LineageOS on z3

    Downloads


    Source Code

    The source code of LineageOS is available here. If you would like to contribute to LineageOS, please visit out Gerrit Code Review.
    • The z3 device tree is available here.
    • The kernel is based on V3.4 and source code for this device is available here. The used configuration is lineageos_shinano_leo_defconfig available at arch/arm/configs/lineageos_shinano_leo_defconfig in the kernel source.

    Changelog

    Changes for z3

    Bug reports

    How to submit a bug report
    LineageOS GitLab

    Contributors

    NeoArian, Myself5, Mr.Tom_Tom

    If you want to donate to support development:
    Donate via PayPal to NeoArian
    Donate via PayPal to LineageOS
    6
    Remarks, Questions & Answers

    Known Major Issues

    • Thermal throttling of CPU cores: Due to a design issue of the thermal manager ("Thermanager") when used with older kernels like ours you have to expect that the frequency throttling of the CPU cores may fail, especially after(!) the device was getting hot and is recovering. This may lead to performance issues until reboot and other issues. Workaround: reboot device after heavy use.*
    • Currently we are looking into a potential issue with SD cards formated as "internal" memory:
    • Miracast is currently disabled.
    • You tell us (with logs please)...
    * To our knowledge, these are general issues on all AOSP/LineageOS based custom ROMs for this device family (Shinano).

    Further hints
    • This ROM currently does not work with the Z3 Dual SIM variant. Here's a build for the Z3dual.
    • TWRP recovery (inofficial build, optional): TWRP
    • If you need Google Apps we recommend the OpenGApps "nano" package.
    • Magisk - see this post for issues with latest Magisk versions and a workaround
    • If you need to install a lot of apps you may run out of internal DATA storage capacity, especially if you install one of the larger GAPPS packages. These apps are initially placed on the system partition and do not cost you DATA capacity. However, every update which comes over the Play Store then fills up your data partition. Using an SD card formated as "external" storage does not help you much (unless you use a tool like app2sd which is no more recommended) and isn't encrypted. Formating the SD card as "adoptable storage" comes with the drawback that some apps do not allow to be migrated to this storage, and unfortunately this is true for some streaming music/video apps which need to store a lot of data obviously (for offline use). The solution I am using is to partition a SD card as "mixed", which gives you the possibility to offload at least some apps to adoptable storage while you still have a classical external FAT32 partition where e.g. your streaming app can save its offline files:
      1. Find a large (I tested a 400GB microSDXC card) and fast ("A1" or higher) Micro SD card.
      2. Follow this guide to partition your SD card. Note: all data on the card will be lost.
      3. Restart your phone.
      4. When you are notified that a new storage card has been detected, use it as "external". (Your internal partition has been recognized at that point already and does not need interaction.)
      5. Go to settings / Storage. Verify that you see three entries: 1. Your internal phone storage of 16GB. This includes your SYSTEM partition. 2. Your SD card with an SD card symbol. The size shown should be the full capacity of the card. If you click on it, your "external" partition is shown (misleading) as "System" and blocked. Click on migrate data to migrate all possible apps to your adoptable storage. 3. Your sd card partition formated as mobile storage (unencrypted!).

    Follow How To Logcat
    • When creating a log, can you make sure you run the command with the -b option to include kernel messages:
      Code:
      adb logcat -b all
    • If your device randomly reboots:
      Go to Settings -> System -> Advanced -> Developer options -> Store logger data persistently on device. After the reboot occured: Pull the logs from /data/misc/logd/ (root required).
    • If your device crashes during boot and reboots to recovery:
      Code:
      adb pull /proc/last_kmsg
    • Please submit logs from clean systems without "Exposed" or similar modifications in place

    Your feedback is wanted regarding the following topics
    • Reported size of adoptable storage - there was an issue in Lineage 17.1 - does it work in 18.1?
    • Formating SD cards as "internal storage" - there was an issue in Lineage 17.1 - does it work in 18.1?
    3
    Seems like magisk is still not flashable if installed in TWRP.
    The workaround to flash magisk 20.4 first doesn't work anymore, since the installation aborts because it can't mount /vendor.

    Patching a boot.img via magisk manager and flashing it doesn't work either.
    This one should work, see https://github.com/topjohnwu/Magisk/issues/3636
    1
    Does anyone experience a kernel wakelock for SMD like on the Z3 Compact where it prevents deep sleep?
    1
    The interesting part is:

    Code:
    07-31 03:03:34.675  2734  2734 I wpa_supplicant: wlan0: Trying to associate with SSID '[SSID Name]'
    07-31 03:03:34.863  2734  2734 I wpa_supplicant: wlan0: CTRL-EVENT-ASSOC-REJECT bssid=10:bf:48:[...] status_code=18

    Status Code:
    18Association denied due to requesting station not supporting all of the data rates in the
    BSSBasicRateSet parameter
    Will happen if the rates in the assoc request are not in the BasicRateSet in the beacon.

    Hard to tell for me if the root cause for this lies in the handheld device or the access point. I am not 100% sure but I guess my devices connect fine to an 802.11n 2.4GHz network. Look if you have some exotic features enabled in your router, like proprietary bandwidth settings or something like that. If you are interested in digging a bit deeper install this ROM please (just for testing) and send me a log via PM.
    I use the Z3 with a Fritz!Box 7490 and 802.11g+n (Wi-Fi 4) without problems.
    I also use WPA3 with WPA2 fallback (I am not sure at the moment if the Z3 has WPA3 support)