• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[OFFICIAL] LineageOS 18.1 for the Google Pixel 3a

Search This thread

z1gackly

Senior Member
Jul 28, 2012
470
464
London
Hi, firstly thanks to the lineage team for continuing to support this device.

I've been reluctant to switch from 17.1 to 18.1 because for me it's essential that I have a rooted device for the AdGuard and Viper for Android apps, but at the same time I like to use Netflix, which for some reason does not like running on a rooted device.

I was able to get it all working on 17.1 but frankly it was a huge pain in the arse and I had to find some really obscure information to both get viper working and get magisk hide working.

Obviously I can't do a nandroid backup before I make the switch, so whilst I am very keen to use 18.1, I am also reluctant to lose what I have already working!

Has anyone else had any success getting Viper working with magisk on 18.1, and also getting magisk hide to work such that Netflix will still function? If so, can you let me know any specific information I would need before upgrading?

Many thanks in advance.
 

BlueShanka

Member
Mar 22, 2021
6
2
Love Lineage - I'm having one issue with the wifi. Often apps will have issues connecting to the internet/downloading content and images. If I turn the wifi off and on again, it usually fixes it, however it's cumbersome and some apps I need to do this every time I open them.

Have had this issue for a while now, updating doesn't seem to help. I am rooted with Magisk.
 

alexhdkn

Senior Member
Jul 25, 2011
487
58
Is there a way to replace some of the stock apps with the corresponding Gapp? (like google camera, photos, messages, dialer, contacts and calendar) I tried with the gapps-config + stock open gapps package but i always got no free space left on device.

Thx
 

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    lineage-os-logo.png

    Google Pixel 3a

    Code:
    - Your warranty is now void.
    - You have been warned.
    - Use at your own risk.

    Introduction:
    This is the Official Lineage OS 18.1 thread for the Google Pixel 3a .

    Downloads:
    Please follow the install instructions in your device's Wiki page linked below exactly, and make sure your device's firmware matches the required firmware listed.
    If you don't follow these instructions, or use 3rd party add-ons (like Magisk) please don't expect support here.

    Known Bugs:
    • None.
    • Find any? Report them according to this guide.
    Notes:
    • The only supported GApps package at the moment is MindTheGapps, linked on our Wiki page about gapps.
    • Firmware is shipped in the ROM package for this device, so no need to worry about updating it on your own!
    Kernel Source: https://github.com/LineageOS/android_kernel_google_msm-4.9
    1
    Screenshot_20210413-143439_Updater.png

    Does "update recovery" relate to the boot image? In other words, if the switch is off, will Magisk be retained? Either way, I should probably bring my update/Magisk instructions here.
    1
    Unfortunately I get no mobile data after installing gapps. I'm using Telus as my carrier in Canada. This happens on quite a few different ROMs that I've tried. I will be willing to do some testing if there's hope that this can get resolved @npjohnson
    File a bug ticket as the wiki describes pls, can help more there.
    I have never gotten any of the Lineage recoveries to work with my Pixel 3a. TWRP works using the guide, but I thought since it doesn't support Android 10, that LineageOS 18.x cannot be flashed with TWRP. For those that are using 18, how did you end up installing it?
    No clue why that would be - they work for everyone else...
    Just upgraded from 17.1 and Everything works great! (Including the NFC)
    Good to hear!
    Thanks for that, but I already tried something similar. After flashing the A11 factory image, when I start the bootloader and try to flash the recovery, I get the error message " FAILED (remote: 'Not allowed to flash (recovery)')"
    You shouldn't be flashing 'recovery' - read the wiki pls, you may mess up your device.
    No, the LineageOS recoveries that I have been using are all *.img.
    I found a work around finally. I followed the first few initial instructions:
    • fastboot flash boot boot.img
    • fastboot flash dtbo dtbo.img
    • fastboot flash vbmeta vbmeta.img
    And then I was able to successfully flash the lineage recovery by using "fastboot flash boot [LOS recovery file.img]"

    Now my problem in the same as why I switched from the LG G5 to the Pixel 3a, VoLTE and Wifi Calling don't work.
    Oh, well. Thanks for the help.
    Don't do any of this.

    Flash stock Android 11, then as per the wiki guide, fastboot flash boot lineage-recovery.img, and then boot to recovery immeadiately.
    1
    I was waiting for this update. Didn't feel like downgrading from Android 11 to 10.

    I have a dummy question for you guys. When using lineage, if there's an OTA update is it simpler than updating stock Android on an unlocked bootloader? I just like the idea of hitting "update" and actually being able to update without having to do anything additional.

    Just curious, thank you.
    There's an onboard updater that downloads updates at whatever interval you choose, and installs them for you. You only need to take additional steps if you use Magisk or an alternate kernel. Basic steps for that as follows:

    1) Open Magisk and turn off all your modules (don't reboot)
    2) Open the Lineage updater, download and install the update
    3) Reboot
    4) Get the latest recovery img from https://download.lineageos.org/sargo and patch it with the Magisk app
    5) Use your PC or another device to fastboot flash boot the patched image to your phone
    6) Turn all your modules back on, reboot
    7) Flash your preferred alternate kernel, if desired
    1
    thanks man, apologies for not catching the wiki sooner. i was able to go through the steps and get it done. you're the man
    anytime!

    The easier way is just to grab the recovery image from our download portal, as its identical to the boot image in payload.bin.