• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[OFFICIAL] LineageOS 18.1 for the LG V20

Search This thread

Cryovenom

Member
Dec 5, 2020
15
1
I had a practice run with H910 before and I am very experienced with various Android flashing since Donuts days. I will skip the commands and details since it's something you need to know.

I kept a full backup (minus User data) with patched LGUp before everything

I did not touch the aboot, thus I get the corruption message. If someone has a solution for that, I will take it but not a deal breaker.

I used this guide as reference: https://forum.xda-developers.com/t/...sing-dirtysanta-h915-working-signals.3763981/

Which part you run into issue?

Step 1 - 3 are correct
Step 4 - Download and copy the latest v3.5.1.9 TWRP US996 into the device, flash within TWRP w/ Install Image option as Recovery. Reboot Recovery
Step 5 - in TWRP, Format Data and Advanced Wipe System, Dalvik and Cache
Step 6 - Sideload or copy/install Lineage 18.1 H910, I added NikGapps Core and Magisk
Step 7 - Download and copy the Freedom Modem IMG and use Install Image option in TWRP as Modem. (this only needs to be done once)
Step 8 - Restart to System

I am able to get my Fido data SIM working immediately since LOS has the APN already.

If you have Fastboot and TWRP installed, your Bootloader is unlocked. The most confusing part of the guide is the multiple command line windows during the flash of aboot. I tried twice to get the sequence right.

If you need to setup V20 as DAP, this is the mod guide. https://audiodigitale.eu/?p=297

@killer23d you are a gentleman and a scholar! This was exactly what I needed to fix my process! I never would have thought to flash new TWRP from old TWRP, and I wasn't wiping System partition before.

@npjohnson I can confirm that I've loaded the H910 Lineage build on two different H915s and everything works. Getting good speed with LTE, calling works, Wifi, Bluetooth, the works! Think we can have a build that identifies itself as H915?

The process is finicky but totally do-able once you've done it a few times. I don't know what Lineage's process is for their Wiki articles on how to load the OS, but I can write a detailed thread on how to load it onto an H915 (including unlocking the bootloader and whatnot) if you want to link to one that's recent (so the download links aren't broken or buried 30pgs deep). Anyone know any good long-term file hosts?

Jon
 

npjohnson

Recognized Developer
@killer23d you are a gentleman and a scholar! This was exactly what I needed to fix my process! I never would have thought to flash new TWRP from old TWRP, and I wasn't wiping System partition before.

@npjohnson I can confirm that I've loaded the H910 Lineage build on two different H915s and everything works. Getting good speed with LTE, calling works, Wifi, Bluetooth, the works! Think we can have a build that identifies itself as H915?

The process is finicky but totally do-able once you've done it a few times. I don't know what Lineage's process is for their Wiki articles on how to load the OS, but I can write a detailed thread on how to load it onto an H915 (including unlocking the bootloader and whatnot) if you want to link to one that's recent (so the download links aren't broken or buried 30pgs deep). Anyone know any good long-term file hosts?

Jon
No. If you have to convert to us996, it isn't h915 anymore ;p

If someone wants to get a lineage build running on h915 firmware (don't think it's possible due to lack of bootloader unlock on h915 without converting) - then we can.

I'm down to link the instructions in this thread if someone puts them together!
 

killer23d

Senior Member
Jan 5, 2008
413
112
Vancouver
No. If you have to convert to us996, it isn't h915 anymore ;p

If someone wants to get a lineage build running on h915 firmware (don't think it's possible due to lack of bootloader unlock on h915 without converting) - then we can.

I'm down to link the instructions in this thread if someone puts them together!

Technically this is a frankenstein build with H910 ROM and H915 modem. Basically the instructions of the wiki must include cross-flashing and such

TBH I don't care what this is identified as, it doesn't make a difference since TWRP would just ignore the device ID and flash away.
 

killer23d

Senior Member
Jan 5, 2008
413
112
Vancouver
I noticed the DAC would change to 16bit from 24bit if I let the phone sit idle for hours or days. It can be easily fixed by doing a shutdown and it will be back.

I will need more observation.
 

killer23d

Senior Member
Jan 5, 2008
413
112
Vancouver

Ascii3

Senior Member
Sep 17, 2015
197
59
I have freshly installed the lineage-18.1-20210617-nightly-us996-signed.zip official build of LineageOS 18.1 on my LG V20 US996 after coming from stock Android Oreo.

I am having a problems with System UI hanging when either:
  • A wrong password is used to authenticate a WiFi connection; this is when connection to a WPA2-PSK style access point.
  • An access point that presents a captive portal is connected to. After passing the captive portal authentication, System UI hangs. EDIT: Passing captive portal authentication is not really necessary.
Upon reboot (best use adb daemon for this), the System UI typically hangs again after a short while if WiFi is left on. To workaround the issue, the network information for the particular saved networks should be purged (forget). This is easier to do if one first turns off WiFi.

Other than these (somewhat severe) issues, the networking appears to work.

@npjohnson - Please look into this issue or let me know what may be done about the issue.
 
Last edited:

SeongGino

Member
Mar 21, 2012
34
10
Jersey City
Not sure if it's just me, but I'm noticing the WiFi seems to shut itself off after a certain amount of time - inactive or otherwise; I just had it turn itself off while in the middle of streaming video.
Also having issues with Bluetooth, specifically my Pebble Time is disconnecting after some screen off time, and it's unable to reconnect like it should unless I toggle the BT off/on. Said smartwatch works and reconnects as it should on my primary A10 phone.

Using H918, June 10th nightly over top a former Nougat 10P installation.
 

28charro

New member
Dec 4, 2018
3
0
I have LG VS995 verizon i installed lineage-18.1-20210622-nightly-vs995-signed, everything seems to be working allright but phone calls,i can call, but i can barely get phone calls,and if my phone rings it would be after 5 or 6 calling tones on the calling phone,i made no mods stock only,no magisk or anything else.
Anyone else is having the same problem?
 

npjohnson

Recognized Developer
I have freshly installed the lineage-18.1-20210617-nightly-us996-signed.zip official build of LineageOS 18.1 on my LG V20 US996 after coming from stock Android Oreo.

I am having a problems with System UI hanging when either:
  • A wrong password is used to authenticate a WiFi connection; this is when connection to a WPA2-PSK style access point.
  • An access point that presents a captive portal is connected to. After passing the captive portal authentication, System UI hangs.
Upon reboot (best use adb daemon for this), the System UI typically hangs again after a short while if WiFi is left on. To workaround the issue, the network information for the particular saved networks should be purged (forget). This is easier to do if one first turns off WiFi.

Other than these (somewhat severe) issues, the networking appears to work.

@npjohnson - Please look into this issue or let me know what may be done about the issue.
Log like the wiki details pls. The logs will help debug it.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Sorry for pulling this up again...I still have that issue, even with a new SD card.
    I want to try a different GApps package after a fresh install...which one do you folks like most?
    Bitgapps? Nikgapps? Thanks!
    Seeing as this is a kernel crash and not a system ui crash/os reboot, this is probably related to something else although, you can try nikgapps core and see
    1
    Thanks!
    It started after I uninstalled NikGapps and installed MindTheGapps, a couple of months ago. Hence my clue that it seems to be related to MindTheGapps. It worked fine with NikGapps, but GPS lock time was awful...
    Has anyone experiences related to BitGapps and LGV20?
    Gps locktime issues are common for the V20 on custom roms, you can use this to help
    https://github.com/JonasCardoso/optmizedgpsconf
    1
    Can I ask for a feature?

    one hand/single hand mode would be very helpful. :)
    1
    Which is why we won't be officially supporting H915. Again, if someone makes easy to follow instructions, I'll link them in the OP here though!
    @npjohnson I've made a thread here:

    Though I'm still troubleshooting some crashing that I get related to the modem sometimes. Any feedback from anyone here who might have ideas is welcome. I saw someone mention flashing a newer kernel...? but I'm not very sure about how that works at the moment.

    I think that I might actually be able to do this without cross-flashing to US996 first but that's going to take more experimenting.
    1
    Thanks!
    It started after I uninstalled NikGapps and installed MindTheGapps, a couple of months ago. Hence my clue that it seems to be related to MindTheGapps. It worked fine with NikGapps, but GPS lock time was awful...
    Has anyone experiences related to BitGapps and LGV20?
    Try using the stock(h990n) gps.conf file. This fixed the lock time issue for me. Takes about 15 secs to lock when using GPS locker.

    However, the GPS seems to only function when using Google Maps. Other apps like OsmAnd+ can't use the GPS. The little GPS icon doesn't show in the notification area. Anyone knows why?

    @coogans_bluff I had similar issues as you. I'm using a h990ds and my sd card got corrupted twice. But now the problem seems to be gone. You may try formatting the sd card using a computer instead of using the phone. I think that's the source of the issue. You should not have the "tap to fix" message when the sd card is inserted. Also use the sd card as external storage only.

    I have kernel panic only once in a few days which is great. It happens sometimes when copying files to SD card just like what others have stated.

    The biggest problem I face with this rom is the camera. It doesn't work all the time no matter which apps I use, such as whatsapp, signal or gcam. It will show the preview just fine, but when I press the shutter, it will freeze or just take a green photo with no image at all. It does work again after a while.

    Any suggestions?
  • 14
    lineage-os-logo.png

    LG V20

    Code:
    - Your warranty is now void.
    - You have been warned.
    - Use at your own risk.

    Introduction:
    This is the Official Lineage OS 18.1 thread for the LG V20.

    Downloads:
    Please follow the install instructions in your device's Wiki page linked below exactly, and make sure your device's firmware matches the required firmware listed.
    If you don't follow these instructions, or use 3rd party add-ons (like Magisk) please don't expect support here.

    Known Bugs:
    • IMS (VoLTE/Wi-Fi Calling) doesn't work due to framework tie-ins used by the LG proprietary binaries.
    • Find any? Report them according to this guide.
    Notes:
    • The only supported GApps package at the moment is MindTheGapps, linked on our Wiki page about gapps.
    Kernel Source: https://github.com/LineageOS/android_kernel_lge_msm8996
    1
    Спасибо за новую версию ОС Android Linegae!
    В настоящее время я использую Lineage OS 17.1, нужно ли мне вернуться к стандартной прошивке LG перед прошивкой этого ПЗУ?
    Нет. Но нужно удалить гаппсы 17.1. Протрите систему.
    1
    Installed 20210415 version on H918 (previously unofficial 18.1 and official 17.1) after factory reset via TWRP. Runs great! Added Gamma kernel and Magisk. No problems with BT or GPS or camera (both stock and gcam cstark27_GCam_5.1.018_24_v4.2t3.apk).

    Great job developers!

    If you have success or problems please include the LG V20 version in your post. Often the difficulties are version dependent.
    1
    On 04-01, I updated to TWRP 3.5.1 and did a clean install of this ROM (04-01). I wiped & formatted, after making a copy of my internal storage to a PC. The install went great. I reinstalled my apps and then flashed Magisk 22.0. Everything I tried worked well (BT, GPS, quad DAC).

    Today, I updated to TWRP 3.5.2 and Magisk 22.1. Then, I dirty flashed the 04-15 nightly. Magisk patched new boot.img automatically and everything is working well.

    Thanks to npjohnson and x86cpu for keeping my travel device up-to-date. :)
    it was almost all aleasto this cycle!
    1
    Hallo, as there is now an offical LOS 18.1, i am asking here again.

    Does encryption and mounting encrypted volume in LOS 18 work now, or is LOS 16 still the last version, were it works?
    I would try myself but doing an upgrade and than downgrade again, if it still doesnt work, is a big hassle.
    Somebody have encryption on and can mount and decrypt the DATA Volume in TWRP?

    encryption work very good on 18.1 for lg V20 h910 phone i think other versions work too.. i not know about what is mounting. you mean TWRP? i do OTA update in lieageos 18.1 and it remove twrp and make lineage recovery.. i dont no how i install TWRP again... i cant check... sorry