• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[OFFICIAL] LineageOS 18.1 for the LG V20

Search This thread

A.Whit

Member
Jul 11, 2021
20
6
Hate to be like this, but you clearly don't understand the issue if you're saying that.

Devices selecting the wrong microphone in the camera app are very much, device specific bugs, that are almost all different.

Some related to microphone input arrays, such as tri-mic setups that aren't being properly utillized, some are incorrect ACDB tables/ID, some are hardware issues where people have stuck paperclips in the microphone thinking it was the SIM tray (WAY more common than your think), some devices have issues with source built audio HALs due to framework side additions by the OEM - there are x^n more possibilities.

And all of them are different.

So, again, if you'd like help on this, I need logs of the _specific_ situation you've hit.
If you can say YES that you have a lg v20 H910 or a lg v20 h918 and the LOS camera on 18.1 records video with normal sound volume, then I owe you my gratification and appreciation and I will be very happy. thanks....
 

ethansoars

Member
Aug 25, 2020
9
4
LG V20
I bought a used H918 V20 and it came with bootloader unlocked and a stock-based rom installed. I bought it to replace my old H918 that suffered some water damage. It still works, though. On the new phone I wiped everything in TWRP and installed LOS 18.1. The fingerprint sensor doesn't work. Advice? Do I have to downgrade to Nougat? My old phone works fine with LOS 18.1, so is it possible to backup my old phone in TWRP and make a carbon copy on the new one to save the headache altogether?
 

npjohnson

Recognized Developer
If you can say YES that you have a lg v20 H910 or a lg v20 h918 and the LOS camera on 18.1 records video with normal sound volume, then I owe you my gratification and appreciation and I will be very happy. thanks....
I can't! I'm hundreds of miles from my h918. It's at home and I won't be for some weeks... But still willing/able to help. Hence wanting logs of the issue so I can help solve it.

If you'd like to continue pointing at logs from a completely different situation that isn't going to help h918 whatsoever, go ahead - it just won't be productive.
 

A.Whit

Member
Jul 11, 2021
20
6
I bought a used H918 V20 and it came with bootloader unlocked and a stock-based rom installed. I bought it to replace my old H918 that suffered some water damage. It still works, though. On the new phone I wiped everything in TWRP and installed LOS 18.1. The fingerprint sensor doesn't work. Advice? Do I have to downgrade to Nougat? My old phone works fine with LOS 18.1, so is it possible to backup my old phone in TWRP and make a carbon copy on the new one to save the headache altogether?
I have tried twrp backup and restore for 18.1 but get errors on restore. That never happened on stock rom. I am still trying to understand why. maybe i need to use external sdcard, or as i have read others report same problem and its a twrp bug. i can confirm that there are files that twrp never backs up and also LOS is very picky and needs certain correct files to work ok.... example modem/baseband version.

you say your old phone was ok with 18.1 was the camera video record volume ok?
 

A.Whit

Member
Jul 11, 2021
20
6
SO I have been having issues with very low volume of voice messages in Telegram and WhatsApp. As has been said LOS is not using the full potential of LG's V20 triple mic set-up. So the issue is certainly with the Tasha audio files. I thought by flashing files provided by Omar the issue will be resolved. But it did not. So I spent a whole weekend understanding how android and LG hardware work together.

I would like to reference this post for DAC refers engineering as I was using it for understanding how the DAC works with android.

By changing the Tasha file I was able to achieve the result but in the zip file attached I have added additional files which I took from stock LG rooted Oreo software

PLEASE let me know if it works for you and have a great working week.
I have LG v20 H910 (ATT)
Unlocked bootloader, TWRP installed
On STOCK ROM camera video is 100% Perfect volume

1. Boot into TWRP Recovery and FORMATED DATA
2. Installed lineage-18.1-20210722-nightly-h910-signed.zip
3. Booted LOS 18.1, Camera VIDEO record volume extremely low and cannot hear audio

4. Boot into TWRP Recovery and FORMAT DATA
5. Installed lineage-18.1-20210722-nightly-h910-signed.zip
6. Installed YOUR flashable-lge2-v20-tasha-xml-patch6.zip
7. Booted LOS 18.1, Camera will not start. CRASHES

Any help appreciated
 

ethansoars

Member
Aug 25, 2020
9
4
LG V20
I have tried twrp backup and restore for 18.1 but get errors on restore. That never happened on stock rom. I am still trying to understand why. maybe i need to use external sdcard, or as i have read others report same problem and its a twrp bug. i can confirm that there are files that twrp never backs up and also LOS is very picky and needs certain correct files to work ok.... example modem/baseband version.

you say your old phone was ok with 18.1 was the camera video record volume ok?
I managed to fix the issue by wiping completely, flashing an i95swervin nougat downgrade file, wiping completely again, then flashing LOS 18.1. I cannot vouch for this method's safety as I don't really know what it does, but it worked for me so I'll link the file for anyone wanting to try it. It's only for H918.

On my previous phone video audio only worked in certain camera apps like the default camera. I haven't tested on my new one yet.
 

Attachments

  • H91810u-Oreo-Downgrade_Nougat-Firmware.zip
    135.4 MB · Views: 27

A.Whit

Member
Jul 11, 2021
20
6
On my LG v20 H910 with LOS 18.1 lineage-18.1-20210722-nightly-h910-signed.zip
(nothing else installed, no gapps, no mods, no root, etc...) the "LOS SNAP CAMERA" VIDEO record sound volume is almost 0%

SAME ISSUE ON Lg v20 H918 !!!!!!! I have that phone also.

After days of research and playing with mixer_paths_tasha.xml settings I gave up..... PROBLEM VERIFIED: its a LOS snap camera apk issue.

Then I installed ROM [android 11] UNOFFICIAL SuperiorOS-Xcalibur

https://forum.xda-developers.com/t/...96-11-unofficial-superioros-xcalibur.4248255/

COMING FROM LINEAGE/RR:

1. Boot into twrp
2. Do a regular wipe (not format)
3. Flash Superior zip
4. Flash magisk (optional but recommended)
5. Wipe dalvik
6. Reboot

CAMERA VIEDO WORKS PERFECT !!!!
PERFECT SOUND !!!



To LOS maintainers: Fix the LOS SNAP CAMERA apk or quit screwing around with programming android ROMs. Simple as that. I am a MSEE engineering manager and if I cant do my job right I don't do it at all.


The LOS snap camera has been broken for a very long time (years) and many people have had to use GCAM or Open Camera and all these people including myself are sick that LOS maintainers can't fix a simple but very important apk in LOS (CAMERA video sound issue). This is well documented all over LOS wiki and github etc.....

FROM: bernardobas, Senior Member


"Hi @npjohnson
Open Camera (and BSG GCam 8.1) uses unprocessed-mic by default to get audio while recording video."


I am done with LOS until this is fixed. YOU ARE WASTING MY TIME
 

npjohnson

Recognized Developer
On my LG v20 H910 with LOS 18.1 lineage-18.1-20210722-nightly-h910-signed.zip
(nothing else installed, no gapps, no mods, no root, etc...) the "LOS SNAP CAMERA" VIDEO record sound volume is almost 0%

SAME ISSUE ON Lg v20 H918 !!!!!!! I have that phone also.

After days of research and playing with mixer_paths_tasha.xml settings I gave up..... PROBLEM VERIFIED: its a LOS snap camera apk issue.

Then I installed ROM [android 11] UNOFFICIAL SuperiorOS-Xcalibur

https://forum.xda-developers.com/t/...96-11-unofficial-superioros-xcalibur.4248255/

COMING FROM LINEAGE/RR:

1. Boot into twrp
2. Do a regular wipe (not format)
3. Flash Superior zip
4. Flash magisk (optional but recommended)
5. Wipe dalvik
6. Reboot

CAMERA VIEDO WORKS PERFECT !!!!
PERFECT SOUND !!!



To LOS maintainers: Fix the LOS SNAP CAMERA apk or quit screwing around with programming android ROMs. Simple as that. I am a MSEE engineering manager and if I cant do my job right I don't do it at all.


The LOS snap camera has been broken for a very long time (years) and many people have had to use GCAM or Open Camera and all these people including myself are sick that LOS maintainers can't fix a simple but very important apk in LOS (CAMERA video sound issue). This is well documented all over LOS wiki and github etc.....

FROM: bernardobas, Senior Member


"Hi @npjohnson
Open Camera (and BSG GCam 8.1) uses unprocessed-mic by default to get audio while recording video."


I am done with LOS until this is fixed. YOU ARE WASTING MY TIME
Yeah, considering h910/h918 are near identical, makes sense that they both suffer.

By your own statement, you're an engineer, and should be able to discern based on the info you gave me that it is _not_ an issue with the "Snap Camera apk", instead that we are using compressed audio path, and clearly it isn't processing right (likely a codec issue like I mentioned several posts ago). We could swap it to unprocessed mic input, but that will be garbled and awful - only using that as a last resort as opposed to actually fixing the compressed audio route.

As for the insults launched - k, stop using lineage then. I literally have not a care in the world whether you use it. I'm doing hard work for free, which, as an engineer, you should understand is often thankless, and your naggy/attacking comments only make me want to never touch the device again :)

I'll be looking at it sometime this week, but for everyone else on this thread who has been kind and supportive lol.
 

BloodyIron

Member
Feb 25, 2017
34
4
Not hard to implement, just built our common solution for it - it should work fine.

If it doesn't though, probably means we'll have to use the proximity sensor which would suck.

Yeah I believe I tried the proximity sensor a bunch of months ago and it really was not reliable like the magnetic sensor. I'm likely to wipe and reflash my phone maybe this weekend, or next. I'll have to check if a release version has been put out yet, and I'm going to do that closer to when I can put the time aside as there's a lot of steps involved in my provisioning process (as you can imagine it's a critical tool for me).

I'm REALLY hoping it works though! Because the amount of times I double-tap the power button by mistake just to lock, and instead get the camera, is annoying. But the thing is I actually really want the double-tap function too because it gets me to the camera fastest in moments that time is of the essence, so it's a necessary evil, hehee. But if the magnetic sensor works, then I just flip closed, or open, to turn off/on the screen, etc, and that'd be rad!

I'm both excited for this, and also not looking forward to all the steps I need to take to do it, heehe. I really do appreciate your work though! Thanks dude! Even if it doesn't work, this is still appreciated. It's not like LG is going to help me ;P
 
  • Like
Reactions: MaverickNextDoor

npjohnson

Recognized Developer
Yeah I believe I tried the proximity sensor a bunch of months ago and it really was not reliable like the magnetic sensor. I'm likely to wipe and reflash my phone maybe this weekend, or next. I'll have to check if a release version has been put out yet, and I'm going to do that closer to when I can put the time aside as there's a lot of steps involved in my provisioning process (as you can imagine it's a critical tool for me).

I'm REALLY hoping it works though! Because the amount of times I double-tap the power button by mistake just to lock, and instead get the camera, is annoying. But the thing is I actually really want the double-tap function too because it gets me to the camera fastest in moments that time is of the essence, so it's a necessary evil, hehee. But if the magnetic sensor works, then I just flip closed, or open, to turn off/on the screen, etc, and that'd be rad!

I'm both excited for this, and also not looking forward to all the steps I need to take to do it, heehe. I really do appreciate your work though! Thanks dude! Even if it doesn't work, this is still appreciated. It's not like LG is going to help me ;P
Hopefully it works!

We don't do "release" versions, only weekly rolling builds.
 
  • Like
Reactions: BloodyIron

iTzFeRReTTi

Senior Member
Jun 14, 2012
1,434
387
Boston
LG V20
On my LG v20 H910 with LOS 18.1 lineage-18.1-20210722-nightly-h910-signed.zip
(nothing else installed, no gapps, no mods, no root, etc...) the "LOS SNAP CAMERA" VIDEO record sound volume is almost 0%

SAME ISSUE ON Lg v20 H918 !!!!!!! I have that phone also.

After days of research and playing with mixer_paths_tasha.xml settings I gave up..... PROBLEM VERIFIED: its a LOS snap camera apk issue.

Then I installed ROM [android 11] UNOFFICIAL SuperiorOS-Xcalibur

https://forum.xda-developers.com/t/...96-11-unofficial-superioros-xcalibur.4248255/

COMING FROM LINEAGE/RR:

1. Boot into twrp
2. Do a regular wipe (not format)
3. Flash Superior zip
4. Flash magisk (optional but recommended)
5. Wipe dalvik
6. Reboot

CAMERA VIEDO WORKS PERFECT !!!!
PERFECT SOUND !!!



To LOS maintainers: Fix the LOS SNAP CAMERA apk or quit screwing around with programming android ROMs. Simple as that. I am a MSEE engineering manager and if I cant do my job right I don't do it at all.


The LOS snap camera has been broken for a very long time (years) and many people have had to use GCAM or Open Camera and all these people including myself are sick that LOS maintainers can't fix a simple but very important apk in LOS (CAMERA video sound issue). This is well documented all over LOS wiki and github etc.....

FROM: bernardobas, Senior Member


"Hi @npjohnson
Open Camera (and BSG GCam 8.1) uses unprocessed-mic by default to get audio while recording video."


I am done with LOS until this is fixed. YOU ARE WASTING MY TIME
Maybe you should go back to stock? You do realize we do this for free and on our own time? If there are any issues we try to fix them ASAP but with your comments I doubt @npjohnson is going to want to support the device anymore. If there is any issue I would recommend reporting it in a less-hostile way and it might be a simple fix rather than insulting the primary dev for LOS on the device who may now not want to support the device anymore...
 

npjohnson

Recognized Developer
On my LG v20 H910 with LOS 18.1 lineage-18.1-20210722-nightly-h910-signed.zip
(nothing else installed, no gapps, no mods, no root, etc...) the "LOS SNAP CAMERA" VIDEO record sound volume is almost 0%

SAME ISSUE ON Lg v20 H918 !!!!!!! I have that phone also.

After days of research and playing with mixer_paths_tasha.xml settings I gave up..... PROBLEM VERIFIED: its a LOS snap camera apk issue.

Then I installed ROM [android 11] UNOFFICIAL SuperiorOS-Xcalibur

https://forum.xda-developers.com/t/...96-11-unofficial-superioros-xcalibur.4248255/

COMING FROM LINEAGE/RR:

1. Boot into twrp
2. Do a regular wipe (not format)
3. Flash Superior zip
4. Flash magisk (optional but recommended)
5. Wipe dalvik
6. Reboot

CAMERA VIEDO WORKS PERFECT !!!!
PERFECT SOUND !!!



To LOS maintainers: Fix the LOS SNAP CAMERA apk or quit screwing around with programming android ROMs. Simple as that. I am a MSEE engineering manager and if I cant do my job right I don't do it at all.


The LOS snap camera has been broken for a very long time (years) and many people have had to use GCAM or Open Camera and all these people including myself are sick that LOS maintainers can't fix a simple but very important apk in LOS (CAMERA video sound issue). This is well documented all over LOS wiki and github etc.....

FROM: bernardobas, Senior Member


"Hi @npjohnson
Open Camera (and BSG GCam 8.1) uses unprocessed-mic by default to get audio while recording video."


I am done with LOS until this is fixed. YOU ARE WASTING MY TIME
So, my girlfriend is at home, asked her to try it - and surprise surprise, Snap Camera's video recorded audio works just fine lol. Front and rear camera.

I did pick the patchset we merged on g5-common though afterwards, and merged it - it sounds to loud to me tbh, but enough people seem to like it better, lets go with it.
 
Last edited:

MrKartupelis

Senior Member
Jan 12, 2015
92
33
Riga
Xiaomi Poco X3 Pro
I have an issue on my friends phone. (H990DS)

after trying to install this, and after booting the phone for the first time and during the setup, it asked for the password! like the phone new that rom has changed and it is not a clean setup!!! I wiped everything and installed this. can you help me what is the fix?!?!

I mean how can I make a clean slate?!
not dirty flash!

TWRP wipes, then install from memory. what else? what am I missing?!
Format data partition, instead wiping it in TWRP. In my experiences, LG V20 can easily corrupt its data partition.
 

BloodyIron

Member
Feb 25, 2017
34
4
Hopefully it works!

We don't do "release" versions, only weekly rolling builds.

Duly noted! That being said, I think I'm going to do it next weekend. I just spent like 16hrs wrestling with an upgrade to my main compie gaming rig, and I want to spend some time of today actually gaming, hehe. But I can at least take notes and plan my steps for redoing my phone.
 
  • Like
Reactions: npjohnson

cyberspectre

Member
Oct 2, 2018
21
3
H918, firmware version 10k. I successfully unlocked the bootloader but cannot flash recovery.

Code:
target reported max download size of 536870912 bytes
sending 'recovery' (26852 KB)...
OKAY [  0.767s]
writing 'recovery'...
FAILED (remote: unknown command)

Googling suggested I should use an older version of platform-tools, tried it but that didn't change anything. Ideas?

Edit: With more research, I'm beginning to believe the official LOS guide is incomplete. According to many on the interwebs, LG removed flashing commands from the H918's fastboot entirely, meaning the only way to flash recovery is to use lafsploit. The thing is, lafsploit requires you to be on 10p or 10q, which are Oreo firmware versions, but this thread makes it very clear that a lot of things won't work correctly in LOS unless you're on Nougat firmware. Yet, if you are on Nougat firmware, you can't flash recovery...

Could someone from the Lineage team weigh in on this?
 
Last edited:

ethansoars

Member
Aug 25, 2020
9
4
LG V20
My test was simply moving the LOS18 rom from internal to external and it happens every time time... Start transfer... Gets to about 70-80%... Shows crash screen... Reboot and sd card needs fixed... Instead of android fixing its way since it just thinks "oh let's just delete all content that fixes stuff" I stick SD card in pc and run chkdisk on it and fixes the Los file partial copy to not read as corrupt but not complete for me to delete it and try again with same result :p

Known that copying through twrp in recovery works just fine
I was having the exact same issue. Using gamma kernel now and I think that fixes it.
 

A.Whit

Member
Jul 11, 2021
20
6
H918, firmware version 10k. I successfully unlocked the bootloader but cannot flash recovery.

Code:
target reported max download size of 536870912 bytes
sending 'recovery' (26852 KB)...
OKAY [  0.767s]
writing 'recovery'...
FAILED (remote: unknown command)

Googling suggested I should use an older version of platform-tools, tried it but that didn't change anything. Ideas?

Edit: With more research, I'm beginning to believe the official LOS guide is incomplete. According to many on the interwebs, LG removed flashing commands from the H918's fastboot entirely, meaning the only way to flash recovery is to use lafsploit. The thing is, lafsploit requires you to be on 10p or 10q, which are Oreo firmware versions, but this thread makes it very clear that a lot of things won't work correctly in LOS unless you're on Nougat firmware. Yet, if you are on Nougat firmware, you can't flash recovery...

Could someone from the Lineage team weigh in on this?

Its been 9 months since I unlocked and installed twrp on H918, but I did it and have notes to help.

SUMMARY: I installed a bootable USB for my windows computer using FWUL_v3.2_x86_64_forgetful.iso

see: https://forum.xda-developers.com/t/...-and-including-20h-now-n00b-friendly.3773443/

additional info: https://forum.xda-developers.com/t/...-installation-and-driver-issues-v3-2.3526755/

This is a LINUX OS for booting up on computer via USB boot and getting what you want done on your H918

Side Note: If you flash H915 firmware on an H918 -- you WILL brick it. So dont ever do that

FWUL_v3.2_x86_64_forgetful
>>>>>> flash usb using rufus program and >>>> select dd method

Boot FWUL
Login with username/password: android / linux

lglaf.zip
If you use Firefox in FWUL the file will be in the Downloads folder just like on Windows.

Open the runningnak3d prompt and type:
Code:
cd ~/Downloads
unzip lglaf.zip
./step1.sh

THATS IT !
..................................................

Also see:




The rest is up to you. GREAT LEARNING ! Was an experience for me
 
  • Like
Reactions: MaverickNextDoor

kodoq

Member
Aug 19, 2008
36
0
I doubt that feature is in LOS. It's on crDroid though.
Cheers mate, in that case I need to install one from the app store then.

One more thing, I'm having problem with "Google wont run without Google Play Services, which are missing from your device "

I tried reinstall Lineage with mindthegapps, open gapps (both installed after Lineage and reboot after that), clearing cache and storage and also manually install google play services, still the problem exist everytime I restart the phone. Any ideas? Cheers
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Still having huge issues with my H918 on Google Fi. Missing 50% of calls, and any calls I make consistently drop connection after 2-3 minutes. But I'm wondering if Fi is the cause of the problem, since it has automatic APN settings and network switching capabilities that depend on Google's knowledge of the handset. I'm going to uninstall the Fi app and try to configure the network manually. How should I set it up?

    Fi is the cause of the problem - It just doesn't support this phone - you can try a pure T-Mobile APN maybe? Or just a Fi APN?
    Is there a hack/mod to configure the amplifier to function like it does in a stock rom? In stock, the phone detects the impedance of the headphones and automatically switches between normal and high impedance mode. I don't have high impedance phones and it's really annoying to have the volume level so high.
    We don't have the smart handling, but we have a Quad-DAC toggle you can toggle in the quick-settings.
    1
    i've been using the dac toggle since los17 and it's what made me ditch the stock os. how hard would it be to impliment the "smart handling"? are we talking about a config file or is there serious coding involved? would it be possible to copy something fromt the stock rom to los and make it work?
    Nah it's framework side and a lot of code.
    1
    Just read that the LG V20 has no LED notification light?..?
    I could swear that I had LED notifications after a fresh install...*confused*
    yep. no lights. you should have known that. BUT, GOOD NEWS

    I use MISSED NOTIFICATIONS REMINDER apk on play store. free. works great


  • 17
    lineage-os-logo.png

    LG V20

    Code:
    - Your warranty is now void.
    - You have been warned.
    - Use at your own risk.

    Introduction:
    This is the Official Lineage OS 18.1 thread for the LG V20.

    Downloads:
    Please follow the install instructions in your device's Wiki page linked below exactly, and make sure your device's firmware matches the required firmware listed.
    If you don't follow these instructions, or use 3rd party add-ons (like Magisk) please don't expect support here.

    Known Bugs:
    • IMS (VoLTE/Wi-Fi Calling) doesn't work due to framework tie-ins used by the LG proprietary binaries.
    • Find any? Report them according to this guide.
    Notes:
    • The only supported GApps package at the moment is MindTheGapps, linked on our Wiki page about gapps.
    Kernel Source: https://github.com/LineageOS/android_kernel_lge_msm8996
    6
    On my LG v20 H910 with LOS 18.1 lineage-18.1-20210722-nightly-h910-signed.zip
    (nothing else installed, no gapps, no mods, no root, etc...) the "LOS SNAP CAMERA" VIDEO record sound volume is almost 0%

    SAME ISSUE ON Lg v20 H918 !!!!!!! I have that phone also.

    After days of research and playing with mixer_paths_tasha.xml settings I gave up..... PROBLEM VERIFIED: its a LOS snap camera apk issue.

    Then I installed ROM [android 11] UNOFFICIAL SuperiorOS-Xcalibur

    https://forum.xda-developers.com/t/...96-11-unofficial-superioros-xcalibur.4248255/

    COMING FROM LINEAGE/RR:

    1. Boot into twrp
    2. Do a regular wipe (not format)
    3. Flash Superior zip
    4. Flash magisk (optional but recommended)
    5. Wipe dalvik
    6. Reboot

    CAMERA VIEDO WORKS PERFECT !!!!
    PERFECT SOUND !!!



    To LOS maintainers: Fix the LOS SNAP CAMERA apk or quit screwing around with programming android ROMs. Simple as that. I am a MSEE engineering manager and if I cant do my job right I don't do it at all.


    The LOS snap camera has been broken for a very long time (years) and many people have had to use GCAM or Open Camera and all these people including myself are sick that LOS maintainers can't fix a simple but very important apk in LOS (CAMERA video sound issue). This is well documented all over LOS wiki and github etc.....

    FROM: bernardobas, Senior Member


    "Hi @npjohnson
    Open Camera (and BSG GCam 8.1) uses unprocessed-mic by default to get audio while recording video."


    I am done with LOS until this is fixed. YOU ARE WASTING MY TIME
    Yeah, considering h910/h918 are near identical, makes sense that they both suffer.

    By your own statement, you're an engineer, and should be able to discern based on the info you gave me that it is _not_ an issue with the "Snap Camera apk", instead that we are using compressed audio path, and clearly it isn't processing right (likely a codec issue like I mentioned several posts ago). We could swap it to unprocessed mic input, but that will be garbled and awful - only using that as a last resort as opposed to actually fixing the compressed audio route.

    As for the insults launched - k, stop using lineage then. I literally have not a care in the world whether you use it. I'm doing hard work for free, which, as an engineer, you should understand is often thankless, and your naggy/attacking comments only make me want to never touch the device again :)

    I'll be looking at it sometime this week, but for everyone else on this thread who has been kind and supportive lol.
    5
    On my LG v20 H910 with LOS 18.1 lineage-18.1-20210722-nightly-h910-signed.zip
    (nothing else installed, no gapps, no mods, no root, etc...) the "LOS SNAP CAMERA" VIDEO record sound volume is almost 0%

    SAME ISSUE ON Lg v20 H918 !!!!!!! I have that phone also.

    After days of research and playing with mixer_paths_tasha.xml settings I gave up..... PROBLEM VERIFIED: its a LOS snap camera apk issue.

    Then I installed ROM [android 11] UNOFFICIAL SuperiorOS-Xcalibur

    https://forum.xda-developers.com/t/...96-11-unofficial-superioros-xcalibur.4248255/

    COMING FROM LINEAGE/RR:

    1. Boot into twrp
    2. Do a regular wipe (not format)
    3. Flash Superior zip
    4. Flash magisk (optional but recommended)
    5. Wipe dalvik
    6. Reboot

    CAMERA VIEDO WORKS PERFECT !!!!
    PERFECT SOUND !!!



    To LOS maintainers: Fix the LOS SNAP CAMERA apk or quit screwing around with programming android ROMs. Simple as that. I am a MSEE engineering manager and if I cant do my job right I don't do it at all.


    The LOS snap camera has been broken for a very long time (years) and many people have had to use GCAM or Open Camera and all these people including myself are sick that LOS maintainers can't fix a simple but very important apk in LOS (CAMERA video sound issue). This is well documented all over LOS wiki and github etc.....

    FROM: bernardobas, Senior Member


    "Hi @npjohnson
    Open Camera (and BSG GCam 8.1) uses unprocessed-mic by default to get audio while recording video."


    I am done with LOS until this is fixed. YOU ARE WASTING MY TIME
    Maybe you should go back to stock? You do realize we do this for free and on our own time? If there are any issues we try to fix them ASAP but with your comments I doubt @npjohnson is going to want to support the device anymore. If there is any issue I would recommend reporting it in a less-hostile way and it might be a simple fix rather than insulting the primary dev for LOS on the device who may now not want to support the device anymore...
    2
    On my LG v20 H910 with LOS 18.1 lineage-18.1-20210722-nightly-h910-signed.zip
    (nothing else installed, no gapps, no mods, no root, etc...) the "LOS SNAP CAMERA" VIDEO record sound volume is almost 0%

    SAME ISSUE ON Lg v20 H918 !!!!!!! I have that phone also.

    After days of research and playing with mixer_paths_tasha.xml settings I gave up..... PROBLEM VERIFIED: its a LOS snap camera apk issue.

    Then I installed ROM [android 11] UNOFFICIAL SuperiorOS-Xcalibur

    https://forum.xda-developers.com/t/...96-11-unofficial-superioros-xcalibur.4248255/

    COMING FROM LINEAGE/RR:

    1. Boot into twrp
    2. Do a regular wipe (not format)
    3. Flash Superior zip
    4. Flash magisk (optional but recommended)
    5. Wipe dalvik
    6. Reboot

    CAMERA VIEDO WORKS PERFECT !!!!
    PERFECT SOUND !!!



    To LOS maintainers: Fix the LOS SNAP CAMERA apk or quit screwing around with programming android ROMs. Simple as that. I am a MSEE engineering manager and if I cant do my job right I don't do it at all.


    The LOS snap camera has been broken for a very long time (years) and many people have had to use GCAM or Open Camera and all these people including myself are sick that LOS maintainers can't fix a simple but very important apk in LOS (CAMERA video sound issue). This is well documented all over LOS wiki and github etc.....

    FROM: bernardobas, Senior Member


    "Hi @npjohnson
    Open Camera (and BSG GCam 8.1) uses unprocessed-mic by default to get audio while recording video."


    I am done with LOS until this is fixed. YOU ARE WASTING MY TIME
    So, my girlfriend is at home, asked her to try it - and surprise surprise, Snap Camera's video recorded audio works just fine lol. Front and rear camera.

    I did pick the patchset we merged on g5-common though afterwards, and merged it - it sounds to loud to me tbh, but enough people seem to like it better, lets go with it.
    2
    I am running LOS 18.1 for h910 on a h910 (unlocked via dirtySanta). Since i have reproducable kernel panics when searching for a carrier/mobile provider (don't know the exact english phrase), my questions are
    1. What modem do you use, the original h915 or us996?
    2. Would you say this modem would be worth a try on a h910 with kernel panics and LOS 18.1 (for h910)?
    3. Would cross flashing h910 to us996 be an option?
    answer to both your questions.

    1st you need to go back to stock ver US96610f_00_1205.kdz.

    Why? My understanding is that partition structure and certain opcodes changed after that point and all this is tied into ARB0 to ARB1. This affects custom ROMs

    When your all done you MUST USE h910 modem so flash that when your done and don't use a ver 20x modem.

    If you follow all the correct steps and rules everything works perfect, no kernal panics and no performance issues.

    If you want more tech explanation, go googling. It's out there.

    Here is some good reading on other topics. https://lineageos.org/engineering/Qualcomm-Firmware/