• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[OFFICIAL] LineageOS 18.1 for the LG V20

Search This thread

A nsgar

New member
May 10, 2017
4
1
Hi, first thanks for maintaining LG V20 LineageOS.

I have a LG V20 H910 and crossflashed US99620f_00_1120.kdz.

Has somebody experience which firmware works, or should I just downgrade modem?

I tried:
Lineage for H910 as recommended
Lineage for US996.
 
Last edited:

A.Whit

Member
Jul 11, 2021
20
6
Hi, first thanks for maintaining LG V20 LineageOS.

I have a LG V20 H910 and crossflashed US99620f_00_1120.kdz.
Now I am getting different purple/black kernel panics on LineageOS as seen in the image.

Has somebody experience which firmware works, or should I just downgrade modem?
Don't know what exactly is the problem, but seems problem with Display and sometimes something with a sensor.

I tried:
Lineage for H910 as recommended
Lineage for US996.

Many people get caught with wrong modem installed and cannot figure out whats the problem and why something is not working AND they get kernal crash.

WHAT MODEM DO YOU HAVE INSTALLED ?

BELOW / ATTACHED for LgV20 H910 (Att)
 

Attachments

  • data.png
    data.png
    20.1 KB · Views: 25
  • data-1.png
    data-1.png
    21.4 KB · Views: 26
  • Like
Reactions: A nsgar

A.Whit

Member
Jul 11, 2021
20
6
@npjohnson

Just updated LOS nightly.

I think you fixed the sound issue on the los snap camera apk.

Volume sounds good. Was shocked how this basic standard main feature sliped by for so long but happy you took action.

I dont complain if more advance features dont work or can never work due to lack of LG code access.

Congrats and thank you.
 

npjohnson

Recognized Developer
@npjohnson

Just updated LOS nightly.

I think you fixed the sound issue on the los snap camera apk.

Volume sounds good. Was shocked how this basic standard main feature sliped by for so long but happy you took action.

I dont complain if more advance features dont work or can never work due to lack of LG code access.

Congrats and thank you.
As I said above - it didn't slip.

It worked fine. all I did was turn the volume up a little.
 
  • Like
Reactions: A.Whit

A nsgar

New member
May 10, 2017
4
1
Many people get caught with wrong modem installed and cannot figure out whats the problem and why something is not working AND they get kernal crash.

WHAT MODEM DO YOU HAVE INSTALLED ?

BELOW / ATTACHED for LgV20 H910 (Att)
Hi,
thanks for quick reply.

Modem is the one from US99620f_00_1120.kdz, will try tonight some modems, suddenly fastboot can't show me quickly my version..

Where do you have your modem from? Looks like from some 996 variant?
Edit: I see u have H910 modem from h910 v10u.
Will try and update my post.

Can somebody tell me what the other firmware partitions are for?
Couldn't find anything till basic stuff like 'system', 'modem', 'aboot', 'boot' ...


Thanks.
 
Last edited:

A.Whit

Member
Jul 11, 2021
20
6
Hi,
thanks for quick reply.

Modem is the one from US99620f_00_1120.kdz, will try tonight some modems, suddenly fastboot can't show me quick my version..
What makes me wondering is, that the people who had kernel panics with the modem always had some sort of modem related errors at the panic screen. But yes I also think modem will be the problem.

Where do you have your modem from? Looks like from some 996 variant?
Edit: I see u have H910 modem from h910 v10u.
Will try and update my post.

Can somebody tell me what the other firmware partitions are for?
Couldn't find anything till basic stuff like 'system', 'modem', 'aboot', 'boot' ...
What I mean is, does it update something at all, if I use newer firmware except modem for example?

Thanks.
good modem to flash via TWRP unzip 1st and then flash img >>> set as MODEM in twrp
 

Attachments

  • LG v20 H910 GOOD baseband modem.rar
    32.7 MB · Views: 11
  • Like
Reactions: A nsgar

npjohnson

Recognized Developer
Hi, first thanks for maintaining LG V20 LineageOS.

I have a LG V20 H910 and crossflashed US99620f_00_1120.kdz.
Now I am getting different purple/black kernel panics on LineageOS as seen in the image.

Has somebody experience which firmware works, or should I just downgrade modem?
Don't know what exactly is the problem, but seems problem with Display and sometimes something with a sensor.

I tried:
Lineage for H910 as recommended
Lineage for US996.
why... Just unlock it on h910 firmware and use the h910 build?
 
  • Like
Reactions: A.Whit

MaverickNextDoor

Senior Member
Oct 28, 2016
216
72
Warri
Verizon LG G3
LG V20
Cheers mate, in that case I need to install one from the app store then.
... I'm having problem with "Google wont run without Google Play Services, which are missing from your device "

I tried reinstall Lineage with mindthegapps, open gapps (both installed after Lineage and reboot after that), clearing cache and storage and also manually install google play services, still the problem exist everytime I restart the phone. Any ideas? Cheers
I think using the search function for this thread may yield better results here. I might have seen this issue being mentioned on this thread.
 

A.Whit

Member
Jul 11, 2021
20
6
Hi,
thanks for quick reply.

Modem is the one from US99620f_00_1120.kdz, will try tonight some modems, suddenly fastboot can't show me quick my version..
What makes me wondering is, that the people who had kernel panics with the modem always had some sort of modem related errors at the panic screen. But yes I also think modem will be the problem.

Where do you have your modem from? Looks like from some 996 variant?
Edit: I see u have H910 modem from h910 v10u.
Will try and update my post.

Can somebody tell me what the other firmware partitions are for?
Couldn't find anything till basic stuff like 'system', 'modem', 'aboot', 'boot' ...
What I mean is, does it update something at all, if I use newer firmware except modem for example?

Thanks.
system is the ROM

boot is the bootloader which must be unlocked. If you forced unlocked using dirtysanta then you have a "patched engineering bootloader"

aboot is your laf or downloader mode, you can keep default laf/aboot for LGUP usage or you can install twrp in laf partition thus have twrp in both revovery and laf...... your choice

QUESTION: Did ATT unlock your bootloader, or did you by using dirtysanta ?

also you must use LOS h910 version and a h910 modem. no exceptions
 

desesc

Member
Aug 7, 2021
6
1
LG G5
LG V20
Hi guys, either I'm blind or miss it, I couldn't find the option to turn on network traffic monitor for the status bar? Cheers

I doubt that feature is in LOS. It's on crDroid though.
I have LineageOS 18.1 on a LG G5 (h850) and on a LG V20 (h910). On the G5 (LOS 18.1) that feature is activatable in Settings->System->Status Bar. It's not present on the V20 though. I already used it in LOS 14.1 on the G5.

At least it is in some builds of LOS.
 
  • Like
Reactions: MaverickNextDoor

cyberspectre

Member
Oct 2, 2018
22
3
Its been 9 months since I unlocked and installed twrp on H918, but I did it and have notes to help.

SUMMARY: I installed a bootable USB for my windows computer using FWUL_v3.2_x86_64_forgetful.iso

see: https://forum.xda-developers.com/t/...-and-including-20h-now-n00b-friendly.3773443/

additional info: https://forum.xda-developers.com/t/...-installation-and-driver-issues-v3-2.3526755/

This is a LINUX OS for booting up on computer via USB boot and getting what you want done on your H918

Side Note: If you flash H915 firmware on an H918 -- you WILL brick it. So dont ever do that

FWUL_v3.2_x86_64_forgetful
>>>>>> flash usb using rufus program and >>>> select dd method

Boot FWUL
Login with username/password: android / linux

lglaf.zip
If you use Firefox in FWUL the file will be in the Downloads folder just like on Windows.

Open the runningnak3d prompt and type:
Code:
cd ~/Downloads
unzip lglaf.zip
./step1.sh

THATS IT !
..................................................

Also see:




The rest is up to you. GREAT LEARNING ! Was an experience for me

Thanks.

Basically none of that works, especially not in a "noob friendly" way. Lightdm doesn't even start on my x86 machine and therefore boot hangs, which completely negates the value of FWUL. But I digress. Ctrl+alt+f2 will get you in.

Checkout of the h918-miscwrte branch doesn't work, I think because it's archived. As a workaround, I did it like this:

Code:
wget https://gitlab.com/runningnak3d/lglaf/-/archive/h918-miscwrte/lglaf-h918-miscwrte.zip && unzip lglaf-h918-miscwrte.zip && cd ./lglaf-h918-miscwrte/ && ./step1.sh

The script fails. However, TWRP was installed, just not to the recovery partition.... it replaced download mode instead. No idea why, but I don't care as long as I can get Lineage going. For the moment, it won't install. The reason stated is a TZ mismatch. Is that the firmware? I need to flash 10P first, right?

EDIT:

Okay, I think I understand what I did. The script replaced download mode with TWRP on purpose. But it's supposed to install TWRP to both download mode and recovery partitions, and the reason it didn't is because I didn't flash the 10p KDZ first.

I didn't flash 10p because the Uppercut / LGUP / whatever combination of softwares didn't run at all. Got a dialogue that said "cannot run" every time. I was hoping that having a firmware version earlier than 10p (I'm on 10d) would make this step unnecessary, but it's apparently very necessary. I assume 10p is the only firmware version without a neutered fastboot mode?

Since I can't run the KDZ flash software, I don't see a path forward at this point.

SECOND EDIT:

I can't believe this but the phone actually decided to update to 10p on its own via OTA and this also restored download mode! Talk about dumb luck. Was able to run the script again and successfully install TWRP to both download and recovery partitions!
 
Last edited:

antropenko

New member
Jan 24, 2011
4
1
Hello guys, I have been recently having issue with updating to the new nighties.
I am running H990DS with TWRP-3.5.2_0-0 and every time I dirty flash the new update on top, followed by the cache wipes I get a boot loop. In other words lineage os tries to boot and stays at the lineage LOS logo until after a while the phone automatically reboots into the recovery. In the past I had to just reinstall it from fresh but it is becoming annoying.

Thank you in advance guys.
 

desesc

Member
Aug 7, 2021
6
1
LG G5
LG V20
good modem to flash via TWRP unzip 1st and then flash img >>> set as MODEM in twrp

Thanks for sharing LG v20 H910 GOOD baseband modem.rar

Just compared the file with those I have, and it's the same I backuped from my stock h910 (sorry did not check the stock version). And it's the same you find inside the famous h910-10r.zip used in DirtySanta unlock procedures (runningnak3d unroot h910, ctrl+f v10r).

It corresponds to the right picture in #302.
 

jailedmike

Senior Member
May 2, 2018
64
6
Moto E 2015
LG V20
system is the ROM

boot is the bootloader which must be unlocked. If you forced unlocked using dirtysanta then you have a "patched engineering bootloader"

aboot is your laf or downloader mode, you can keep default laf/aboot for LGUP usage or you can install twrp in laf partition thus have twrp in both revovery and laf...... your choice

QUESTION: Did ATT unlock your bootloader, or did you by using dirtysanta ?

also you must use LOS h910 version and a h910 modem. no exceptions
Why I'm running h915 crossflashed to us996... No kennel panics here. It's the canadian h910. I just run us996 roms. It has static on boot but who cares. Wait tell full booted then turn screen off then on and it's gone. If you really do you just need kennel from any other model since they use debug kernel. At&t never unlocked bootloader and you can't put at&t modern back on unless you saved it during unlock. Plus if you were on Oreo your screwed for custom roms then. Only option is use h915 modern or us996... I guess vs995 would technically work but it would be missing many bands.
 
  • Like
Reactions: A nsgar

desesc

Member
Aug 7, 2021
6
1
LG G5
LG V20
Why I'm running h915 crossflashed to us996... No kennel panics here. It's the canadian h910. I just run us996 roms. ... Only option is use h915 modern or us996... I guess vs995 would technically work but it would be missing many bands.
I am running LOS 18.1 for h910 on a h910 (unlocked via dirtySanta). Since i have reproducable kernel panics when searching for a carrier/mobile provider (don't know the exact english phrase), my questions are
  1. What modem do you use, the original h915 or us996?
  2. Would you say this modem would be worth a try on a h910 with kernel panics and LOS 18.1 (for h910)?
  3. Would cross flashing h910 to us996 be an option?
 

A.Whit

Member
Jul 11, 2021
20
6
I am running LOS 18.1 for h910 on a h910 (unlocked via dirtySanta). Since i have reproducable kernel panics when searching for a carrier/mobile provider (don't know the exact english phrase), my questions are
  1. What modem do you use, the original h915 or us996?
  2. Would you say this modem would be worth a try on a h910 with kernel panics and LOS 18.1 (for h910)?
  3. Would cross flashing h910 to us996 be an option?
answer to both your questions.

1st you need to go back to stock ver US96610f_00_1205.kdz.

Why? My understanding is that partition structure and certain opcodes changed after that point and all this is tied into ARB0 to ARB1. This affects custom ROMs

When your all done you MUST USE h910 modem so flash that when your done and don't use a ver 20x modem.

If you follow all the correct steps and rules everything works perfect, no kernal panics and no performance issues.

If you want more tech explanation, go googling. It's out there.

Here is some good reading on other topics. https://lineageos.org/engineering/Qualcomm-Firmware/
 
Last edited:
  • Like
Reactions: A nsgar and desesc

jailedmike

Senior Member
May 2, 2018
64
6
Moto E 2015
LG V20
answer to both your questions.

1st you need to go back to stock ver 10p. Use 996 NOT 915.

Why? My understanding is that partition structure and certain opcodes changed after that point and all this is tied into ARB0 to ARB1. This affects custom ROMs

When your all done you MUST USE h910 modem so flash that when your done and don't use a ver 20x modem.

If you follow all the correct steps and rules everything works perfect, no kernal panics and no performance issues.

If you want more tech explanation, go googling. It's out there.

Here is some good reading on other topics. https://lineageos.org/engineering/Qualcomm-Firmware/
So if h910 is on Oreo you can use h915 or us996. You don't need at&t... h915 used all the same bands if that's your worry. Never fully tested if all at&t bands worked on us996 modern... Never used it for anything but a toy. It did connect to both at&t and t mobile for data though. Not sure why they don't make it work with Oreo modem but that's how they roll. They updated it for lg G6 but the h918 can't be updated or something so the rest of us get less updated modern firmware. Something to do with automated build servers. I used to help test new builds.
  1. What modem do you use, the original h915 or us996?
  2. Would you say this modem would be worth a try on a h910 with kernel panics and LOS 18.1 (for h910)?
  3. Would cross flashing h910 to us996 be an option?
In my experience with this phone this is probably caused my corruption in modem partion( that's where bootloader is)... One of the dirty Santa methods did that twice to me. So I used to tell people to use the other one but people didn't want to read comments so I stopped caring. Either way replace the modem partion with patched lg up, in twrp, or with fast boot. This is the same as cross flashing in respect to lineage. @Vortell had I write up in one of the lineage threads on these things. I think lineage 15.1. Either way just Choose h915 or us996 they are super easy to change. So if one didn't work the way you want change it to the other. You don't even have to reinstall lineage. In the past both worked fine. I have in the past played with this quite a bit. Keep in mind if you use us996 you will get static on start. Just let it boot all the way up then turn. Screen off and on. To fix that just steal the kernel from any if the other lineage builds from US minutes sprint(ls993 I think sprint one sucked) or TMobile (h918). All but us996 use a debug kernel. There used to be a nice thread with all the movement in twrp flash package but it was taken down not sure if it was ever put back up. The guy got hassled with dumb repeating questions. Plus lgup partion dl method is so easy.
 
  • Like
Reactions: Vortell

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Still having huge issues with my H918 on Google Fi. Missing 50% of calls, and any calls I make consistently drop connection after 2-3 minutes. But I'm wondering if Fi is the cause of the problem, since it has automatic APN settings and network switching capabilities that depend on Google's knowledge of the handset. I'm going to uninstall the Fi app and try to configure the network manually. How should I set it up?

    Fi is the cause of the problem - It just doesn't support this phone - you can try a pure T-Mobile APN maybe? Or just a Fi APN?
    Is there a hack/mod to configure the amplifier to function like it does in a stock rom? In stock, the phone detects the impedance of the headphones and automatically switches between normal and high impedance mode. I don't have high impedance phones and it's really annoying to have the volume level so high.
    We don't have the smart handling, but we have a Quad-DAC toggle you can toggle in the quick-settings.
    1
    i've been using the dac toggle since los17 and it's what made me ditch the stock os. how hard would it be to impliment the "smart handling"? are we talking about a config file or is there serious coding involved? would it be possible to copy something fromt the stock rom to los and make it work?
    Nah it's framework side and a lot of code.
    1
    Just read that the LG V20 has no LED notification light?..?
    I could swear that I had LED notifications after a fresh install...*confused*
    yep. no lights. you should have known that. BUT, GOOD NEWS

    I use MISSED NOTIFICATIONS REMINDER apk on play store. free. works great


  • 17
    lineage-os-logo.png

    LG V20

    Code:
    - Your warranty is now void.
    - You have been warned.
    - Use at your own risk.

    Introduction:
    This is the Official Lineage OS 18.1 thread for the LG V20.

    Downloads:
    Please follow the install instructions in your device's Wiki page linked below exactly, and make sure your device's firmware matches the required firmware listed.
    If you don't follow these instructions, or use 3rd party add-ons (like Magisk) please don't expect support here.

    Known Bugs:
    • IMS (VoLTE/Wi-Fi Calling) doesn't work due to framework tie-ins used by the LG proprietary binaries.
    • Find any? Report them according to this guide.
    Notes:
    • The only supported GApps package at the moment is MindTheGapps, linked on our Wiki page about gapps.
    Kernel Source: https://github.com/LineageOS/android_kernel_lge_msm8996
    6
    On my LG v20 H910 with LOS 18.1 lineage-18.1-20210722-nightly-h910-signed.zip
    (nothing else installed, no gapps, no mods, no root, etc...) the "LOS SNAP CAMERA" VIDEO record sound volume is almost 0%

    SAME ISSUE ON Lg v20 H918 !!!!!!! I have that phone also.

    After days of research and playing with mixer_paths_tasha.xml settings I gave up..... PROBLEM VERIFIED: its a LOS snap camera apk issue.

    Then I installed ROM [android 11] UNOFFICIAL SuperiorOS-Xcalibur

    https://forum.xda-developers.com/t/...96-11-unofficial-superioros-xcalibur.4248255/

    COMING FROM LINEAGE/RR:

    1. Boot into twrp
    2. Do a regular wipe (not format)
    3. Flash Superior zip
    4. Flash magisk (optional but recommended)
    5. Wipe dalvik
    6. Reboot

    CAMERA VIEDO WORKS PERFECT !!!!
    PERFECT SOUND !!!



    To LOS maintainers: Fix the LOS SNAP CAMERA apk or quit screwing around with programming android ROMs. Simple as that. I am a MSEE engineering manager and if I cant do my job right I don't do it at all.


    The LOS snap camera has been broken for a very long time (years) and many people have had to use GCAM or Open Camera and all these people including myself are sick that LOS maintainers can't fix a simple but very important apk in LOS (CAMERA video sound issue). This is well documented all over LOS wiki and github etc.....

    FROM: bernardobas, Senior Member


    "Hi @npjohnson
    Open Camera (and BSG GCam 8.1) uses unprocessed-mic by default to get audio while recording video."


    I am done with LOS until this is fixed. YOU ARE WASTING MY TIME
    Yeah, considering h910/h918 are near identical, makes sense that they both suffer.

    By your own statement, you're an engineer, and should be able to discern based on the info you gave me that it is _not_ an issue with the "Snap Camera apk", instead that we are using compressed audio path, and clearly it isn't processing right (likely a codec issue like I mentioned several posts ago). We could swap it to unprocessed mic input, but that will be garbled and awful - only using that as a last resort as opposed to actually fixing the compressed audio route.

    As for the insults launched - k, stop using lineage then. I literally have not a care in the world whether you use it. I'm doing hard work for free, which, as an engineer, you should understand is often thankless, and your naggy/attacking comments only make me want to never touch the device again :)

    I'll be looking at it sometime this week, but for everyone else on this thread who has been kind and supportive lol.
    5
    On my LG v20 H910 with LOS 18.1 lineage-18.1-20210722-nightly-h910-signed.zip
    (nothing else installed, no gapps, no mods, no root, etc...) the "LOS SNAP CAMERA" VIDEO record sound volume is almost 0%

    SAME ISSUE ON Lg v20 H918 !!!!!!! I have that phone also.

    After days of research and playing with mixer_paths_tasha.xml settings I gave up..... PROBLEM VERIFIED: its a LOS snap camera apk issue.

    Then I installed ROM [android 11] UNOFFICIAL SuperiorOS-Xcalibur

    https://forum.xda-developers.com/t/...96-11-unofficial-superioros-xcalibur.4248255/

    COMING FROM LINEAGE/RR:

    1. Boot into twrp
    2. Do a regular wipe (not format)
    3. Flash Superior zip
    4. Flash magisk (optional but recommended)
    5. Wipe dalvik
    6. Reboot

    CAMERA VIEDO WORKS PERFECT !!!!
    PERFECT SOUND !!!



    To LOS maintainers: Fix the LOS SNAP CAMERA apk or quit screwing around with programming android ROMs. Simple as that. I am a MSEE engineering manager and if I cant do my job right I don't do it at all.


    The LOS snap camera has been broken for a very long time (years) and many people have had to use GCAM or Open Camera and all these people including myself are sick that LOS maintainers can't fix a simple but very important apk in LOS (CAMERA video sound issue). This is well documented all over LOS wiki and github etc.....

    FROM: bernardobas, Senior Member


    "Hi @npjohnson
    Open Camera (and BSG GCam 8.1) uses unprocessed-mic by default to get audio while recording video."


    I am done with LOS until this is fixed. YOU ARE WASTING MY TIME
    Maybe you should go back to stock? You do realize we do this for free and on our own time? If there are any issues we try to fix them ASAP but with your comments I doubt @npjohnson is going to want to support the device anymore. If there is any issue I would recommend reporting it in a less-hostile way and it might be a simple fix rather than insulting the primary dev for LOS on the device who may now not want to support the device anymore...
    2
    On my LG v20 H910 with LOS 18.1 lineage-18.1-20210722-nightly-h910-signed.zip
    (nothing else installed, no gapps, no mods, no root, etc...) the "LOS SNAP CAMERA" VIDEO record sound volume is almost 0%

    SAME ISSUE ON Lg v20 H918 !!!!!!! I have that phone also.

    After days of research and playing with mixer_paths_tasha.xml settings I gave up..... PROBLEM VERIFIED: its a LOS snap camera apk issue.

    Then I installed ROM [android 11] UNOFFICIAL SuperiorOS-Xcalibur

    https://forum.xda-developers.com/t/...96-11-unofficial-superioros-xcalibur.4248255/

    COMING FROM LINEAGE/RR:

    1. Boot into twrp
    2. Do a regular wipe (not format)
    3. Flash Superior zip
    4. Flash magisk (optional but recommended)
    5. Wipe dalvik
    6. Reboot

    CAMERA VIEDO WORKS PERFECT !!!!
    PERFECT SOUND !!!



    To LOS maintainers: Fix the LOS SNAP CAMERA apk or quit screwing around with programming android ROMs. Simple as that. I am a MSEE engineering manager and if I cant do my job right I don't do it at all.


    The LOS snap camera has been broken for a very long time (years) and many people have had to use GCAM or Open Camera and all these people including myself are sick that LOS maintainers can't fix a simple but very important apk in LOS (CAMERA video sound issue). This is well documented all over LOS wiki and github etc.....

    FROM: bernardobas, Senior Member


    "Hi @npjohnson
    Open Camera (and BSG GCam 8.1) uses unprocessed-mic by default to get audio while recording video."


    I am done with LOS until this is fixed. YOU ARE WASTING MY TIME
    So, my girlfriend is at home, asked her to try it - and surprise surprise, Snap Camera's video recorded audio works just fine lol. Front and rear camera.

    I did pick the patchset we merged on g5-common though afterwards, and merged it - it sounds to loud to me tbh, but enough people seem to like it better, lets go with it.
    2
    I am running LOS 18.1 for h910 on a h910 (unlocked via dirtySanta). Since i have reproducable kernel panics when searching for a carrier/mobile provider (don't know the exact english phrase), my questions are
    1. What modem do you use, the original h915 or us996?
    2. Would you say this modem would be worth a try on a h910 with kernel panics and LOS 18.1 (for h910)?
    3. Would cross flashing h910 to us996 be an option?
    answer to both your questions.

    1st you need to go back to stock ver US96610f_00_1205.kdz.

    Why? My understanding is that partition structure and certain opcodes changed after that point and all this is tied into ARB0 to ARB1. This affects custom ROMs

    When your all done you MUST USE h910 modem so flash that when your done and don't use a ver 20x modem.

    If you follow all the correct steps and rules everything works perfect, no kernal panics and no performance issues.

    If you want more tech explanation, go googling. It's out there.

    Here is some good reading on other topics. https://lineageos.org/engineering/Qualcomm-Firmware/