• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[OFFICIAL] LineageOS 18.1 for the LG V20

Search This thread

andruyd

Senior Member
Dec 14, 2011
129
10
LG V20
Huawei MediaPad T5
test
If you plug in your headphone then turn off the DAC with Lineage's toggle it should remain off even if you replug the headphone.
interesting. i didn't know it works like that. is that how the lg v20 stock rom worked? i always found the sound quality to be subpar when the option was off in stock or lineage. i thought the toggle is actually for the dac/amp combo. i use pretty good iems too (moondrop blessing 2, jh13v2).
 

npjohnson

Recognized Developer
Downloaded the latest Sept. 30th build this morning for h918, and it errored out, had to do a factory reset. Come to find out, it also replaced my TWRP with it's own LineageOS recovery (thought I had that disabled). Was not expecting that, and it's pretty clunky and awful. Not happy.

Edit: So I'm still using the Sept. 30th build and my phone really seems to be struggling to get location data, and my net speeds seem to be on the slow side. I have 1Gbps fiber, and typically get about 450 down on 5 Ghz, I'm pulling about 130 currently. In Google Maps, it puts me in the middle of the ocean, GPS errors in Pokemon Go and GasBuddy (which I use to find the cheapest fuel around me). Never had any issues like this until this build. I may go back to the one I had from about 2 weeks ago and see if my issues persist now; that one seemed perfectly fine then.
I don't know what you're doing - but builds DO NOT replace recovery - the only case it does this is if you enable it in SUW to do so. It defaults to off.

It does what a recovery needs to do - update your phone and let you reflash in emergencies - security in mind so as not to be able to access user-data.
 

megamorphg

Senior Member
May 28, 2012
181
44
Orange County, California
Any foolproof instructions to go from LOS 17.1 official to 18.1 official? Dirty flash + MindtheGapps, permissive and root ?
I really want to be able to keep my data and current functionality without starting fresh.

Is there any major things broken in 18.1? And any important things fixed? Camera only my 17.1 really sucks, freezes up frequently.

Wish the author of the thread would update the 1st thread with the nuggets, hard to go through 20 pages.
 

A.Whit

Senior Member
Jul 11, 2021
50
11
On LG v20 H910 and H918, current LOS 18.1, no root, no added/changed kernel, problem:

When placing or receiving a phone call and selecting SPEAKER on LG v20 speaker sound from call is OK on LG v20 but sound on other end (landline or cell) there is too HIGH of base and hardly no treble thus other person can not understand conversation. Distortion/noise also present. Quality is horrible and cannot use SPEAKER mode on phone call.

This is a MIC problem on the LG v20. Yes there are several MICs on LG v20 and from what everyone is posting from LOS 18 and even LOS 17 this has been a problem for a very long time. Possible that SPEAKER function is using top MIC rather than MIC at bottom of phone or MICs not working as designed with stock ROM.

I am guessing possible affected files are:
/system/build.prop file
and or
/sysyem/vender/etc/mixer_paths_tasha.xml file
or other files

Anyone has same experience ? ? ?
 

itt533

Member
Nov 12, 2020
25
1
chennai
is there a way to get stereo while recording video?

gamma kernel will allow IR blaster for both emitting and receiving? It should be mentioned that this device also records IR codes from other remote controls.

Is there any feature that will be lost with gamma kernel? greater power draining?
 

Draknodd

Member
Aug 5, 2019
41
7
Am I the only one who gets crazy high battery draw in idle? I lost 30% of battery over night, from battery stats the only cause was "Android system"
 

A.Whit

Senior Member
Jul 11, 2021
50
11
UPDATE: "phone call using SPEAKER icon during a call":

I decided to backtrack and verify if LOS 18.1 has broken phone call speaker feature. VERIFIED !

On my LG v20 H910 this is what I did:

- Cross-Flash: US99610f_00_1205.kdz using PARTITION DL using LGUP. Select ALL. 100% stock
- After flash, factory reset via POWER and VOL up key (necessary to boot up)
- To get cell and data to work on your H910, after booting fix this by going to the dialer, and dialing *#546368#*996#, SVC Menu, and doing the Factory Reset. After another boot and setup cell and data now works.
- Place a phone call and put SPEAKER ON
- Sound quality on both ends are PERFECT !
Note: STOCK ROM in speakerphone mode uses TOP MIC on LGv20; non speakphone mode it uses BOTTOM MIC

Where things break:

after above...
1) Unlock bootloader
2) Install/flash TWRP
3) Iinstall/flash lineage-18.1-20210930-nightly-h910-signed.zip
4) Install/flash compatible modem MPSS.TH.2.0.1.c3-00045-M8996FAAAANAZM-1 (absolutly necessary to prevent kernal crash)
4) Boot up and setup LOS

When placing or receiving a phone call and selecting SPEAKER on LG v20, speaker sound from call is OK on LG v20; but sound on other end (landline or cell) there is too HIGH of base and hardly no treble thus other person can not understand conversation. Distortion/noise also present. Quality is horrible and thus cannot use SPEAKER mode on phone call.

This is a MIC problem on the LG v20. Yes there are several MICs on LG v20 and from what everyone is posting from LOS 18 and even LOS 17 this has been a problem for a very long time. Possible that SPEAKER function is using incorrect MIC. (Unverified: One dev engineer said LG uses TOP speaker/Ear Speaker for MIC if on a SPEAKER CALL. maybe ????)

Anyone has same problem?

-------------------

Solution for LOS ( it worked for camera audio apk )

reference:
reddit.com/r/lgv20/comments/dqfskw/i_finally_found_how_to_record_clean_stereo_audio/

1) Verify speakerphone in LOS uses TOP MIC
I just verified speakerphone is using all 3 MICs. Thats a problem = Lots of NOISE ! Make changes to use TOP MIC only.

2) SET PHONE/DIALER apk to use UNPROCESSED mode for TOP MIC when using speakerphone mode. ALL Programs (in this case phone DIALER) "which use the UNPROCESSED mode (MIC input) give superior audio quality. Note that this mode is pretty quiet, as the other modes do some adjustable gain. Since the V20's mic has a wider dynamic range than usual, and it doesn't actually let you capture at 24-bit, you would get a higher noise floor than on another phone with 16-bit recording, assuming the same quality of mic, amp, etc. just a different gain before the ADC."
 
Last edited:

npjohnson

Recognized Developer
is there a way to get stereo while recording video?

gamma kernel will allow IR blaster for both emitting and receiving? It should be mentioned that this device also records IR codes from other remote controls.

Is there any feature that will be lost with gamma kernel? greater power draining?
I'll say it again, if anyone just links me the changes needed, I can get them put into the official kernel.
 
  • Like
Reactions: jailedmike

A.Whit

Senior Member
Jul 11, 2021
50
11
I'll say it again, if anyone just links me the changes needed, I can get them put into the official kernel.

Speakerphone mode while in a phone call:

Solution for LOS ( it worked for camera audio apk )

reference:
reddit.com/r/lgv20/comments/dqfskw/i_finally_found_how_to_record_clean_stereo_audio/

1) Verify speakerphone in LOS uses TOP MIC
I just verified speakerphone is using all 3 MICs. Thats a problem = Lots of NOISE ! Make changes to use TOP MIC only.

2) SET PHONE/DIALER apk to use UNPROCESSED mode for TOP MIC when using speakerphone mode. ALL Programs (in this case phone DIALER) "which use the UNPROCESSED mode (MIC input) give superior audio quality. Note that this mode is pretty quiet, as the other modes do some adjustable gain. Since the V20's mic has a wider dynamic range than usual, and it doesn't actually let you capture at 24-bit, you would get a higher noise floor than on another phone with 16-bit recording, assuming the same quality of mic, amp, etc. just a different gain before the ADC."
 

npjohnson

Recognized Developer
Speakerphone mode while in a phone call:

Solution for LOS ( it worked for camera audio apk )

reference:
reddit.com/r/lgv20/comments/dqfskw/i_finally_found_how_to_record_clean_stereo_audio/

1) Verify speakerphone in LOS uses TOP MIC
I just verified speakerphone is using all 3 MICs. Thats a problem = Lots of NOISE ! Make changes to use TOP MIC only.

2) SET PHONE/DIALER apk to use UNPROCESSED mode for TOP MIC when using speakerphone mode. ALL Programs (in this case phone DIALER) "which use the UNPROCESSED mode (MIC input) give superior audio quality. Note that this mode is pretty quiet, as the other modes do some adjustable gain. Since the V20's mic has a wider dynamic range than usual, and it doesn't actually let you capture at 24-bit, you would get a higher noise floor than on another phone with 16-bit recording, assuming the same quality of mic, amp, etc. just a different gain before the ADC."
Feel free to push up a patch, the wiki has great detail on how to do so.

ButI was referring to the IR changes in Gamma kernel.
 
  • Like
Reactions: aCIDsLAM

mehsme

Member
Jun 16, 2020
8
2
Having issues with VS995 (Verizon) with connecting & staying on LTE networks with the default APN settings.
When my "preferred network type" is set to the default (LTE/CDMA/EvDo/GSM/WCDMA), it only connects to 3G.
When set to "LTE", it connects to the 4G/LTE network just fine, BUT, my mobile connection (phonecalls/texts etc. ) stops working.

Tried resetting APN settings, re-seating the SIM card, etc., but I seem to forever be stuck with a slower network speed.

Wondering if anyone else has had similar issues, or if anyone has any tips on resolution.
 

A.Whit

Senior Member
Jul 11, 2021
50
11
Having issues with VS995 (Verizon) with connecting & staying on LTE networks with the default APN settings.
When my "preferred network type" is set to the default (LTE/CDMA/EvDo/GSM/WCDMA), it only connects to 3G.
When set to "LTE", it connects to the 4G/LTE network just fine, BUT, my mobile connection (phonecalls/texts etc. ) stops working.

Tried resetting APN settings, re-seating the SIM card, etc., but I seem to forever be stuck with a slower network speed.

Wondering if anyone else has had similar issues, or if anyone has any tips on resolution.

Yes, I have had same issue on H910
and
- speakerphone not working
- phone getting too warm / hot
- phone reboots randomly (not often but once in a while)
- other issues

So I flashed stock US99620f_00_1120 on my H910 and now very happy with no ATT garbage apks and everything on phone works perfect.

LOS is not even close to being ready for daily use. {Mod edit} And I understand that some orrigional source code is not available which I being an engineer understand is a huge problem.

Only reason why I have 5 LG v20 phones (H910 and H918) is because I like the ability to change battery to larger size and I dont need or want the "newer phones".
 
Last edited by a moderator:
Did a fresh install on an h918 of lineage-18.1-20210408-nightly-h918 with TWRP 3.5.2_9-0-h918, MindTheGapps-11.0.0-arm-20210328_143701, and Magisk v.22.1 and everything is working smoothly.
do you have root access also?

Having issues with VS995 (Verizon) with connecting & staying on LTE networks with the default APN settings.
When my "preferred network type" is set to the default (LTE/CDMA/EvDo/GSM/WCDMA), it only connects to 3G.
When set to "LTE", it connects to the 4G/LTE network just fine, BUT, my mobile connection (phonecalls/texts etc. ) stops working.

Tried resetting APN settings, re-seating the SIM card, etc., but I seem to forever be stuck with a slower network speed.

Wondering if anyone else has had similar issues, or if anyone has any tips on resolution.
Its a compatibility issue. I had a similar problem running a certain version of lineage on my SM-N910T. You can try a different version but other than that I know of no way to fix it
 

mehsme

Member
Jun 16, 2020
8
2
Its a compatibility issue. I had a similar problem running a certain version of lineage on my SM-N910T. You can try a different version but other than that I know of no way to fix it
For other readers out there, its worth noting I've had zero issues with mobile/data settings for months up until during a brief vacation. I wouldn't call it a compatibility issue quite yet. Feels like it's fixable, I could go nuclear and start from scratch I suppose.
Yes, I have had same issue on H910
and
- speakerphone not working
- phone getting too warm / hot
- phone reboots randomly (not often but once in a while)
- other issues

So I flashed stock US99620f_00_1120 on my H910 and now very happy with no ATT garbage apks and everything on phone works perfect.

LOS is not even close to being ready for daily use. And I understand that some orrigional source code is not available which I being an engineer understand is a huge problem.

Only reason why I have 5 LG v20 phones (H910 and H918) is because I like the ability to change battery to larger size and I dont need or want the "newer phones".
I've been daily driving LOS for several months, its been relatively stable as far as a 6 year old device goes. I'm quite pleased with it!

No offense A. Whit, but you seem to have mentioned great displeasure in the work of FOSS developers more than once in this post (and that you're an engineer?). Maybe its time you move on from the community or consider contributing back?
 
Last edited by a moderator:

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Sad to say that unfortunately due to persistent crashes I had to give up on LOS 18.1 on my h918. I started from scratch after flashing stock KDZ numerous times and no matter what LOS would start crashing. The most recent episode after the latest LOS update started occurring seemingly for no reason in the middle of the night when the phone just kept booting and crashing over and over. Wiping Dalvik/cache had no effect. I simply couldn't take it any more. I never experienced repeated crashes like this on stock.

    I'm on rooted stock 20h now and it is very stable and it's nice to have wifi calling and a few other features also.

    If anyone wants to know how I got to rooted 20h I first flashed 10p using LGUP, then using lafsploit on mAID system installed TWRP. From there I flashed H91820h.zip image (which doesn't overwrite bootloader) and Magisk.
    2
    how do you switch the 2 cameras in Open Camera?
    there is a small button on the top right corner of the main shutter button
    1
    i am attempting to build on a debian 11 machine with 32GB of memory, Threadripper 1950x, Linux 5.14.
    adding -j 1 to repo sync changes the error to

    fatal: missing blob object '556a1d6d9a8b7e78201c41b353020202da431890'
    error: remote did not send all necessary objects
    error: Cannot fetch platform/prebuilts/misc from https://android.googlesource.com/platform/prebuilts/misc
    Fetching: 68% (582/855) platform/external/google-fonts/dancing-scriptfatal: missing blob object '556a1d6d9a8b7e78201c41b353020202da431890'
    error: remote did not send all necessary objects

    is there a way i can make the github website create me a massive .zip file i can download with my web browser?
    Definitely not a spec problem since i build it in a laptop with 8GB of RAM (using ZRAM) and a i5 8250U, besides, repo sync isn't even RAM intensive, only the build commands are. I suppose it must be something in their server.

    And unfortunately no, the github address only stores lineage's pointers to the actual files, not the files themselves (github has a repository size limit, and lineage can very well use around 100GB on disk just for the 18.1 branch). I will try a repo sync here just to check if it really is their server.
    1
    i am attempting to build on a debian 11 machine with 32GB of memory, Threadripper 1950x, Linux 5.14.
    adding -j 1 to repo sync changes the error to

    fatal: missing blob object '556a1d6d9a8b7e78201c41b353020202da431890'
    error: remote did not send all necessary objects
    error: Cannot fetch platform/prebuilts/misc from https://android.googlesource.com/platform/prebuilts/misc
    Fetching: 68% (582/855) platform/external/google-fonts/dancing-scriptfatal: missing blob object '556a1d6d9a8b7e78201c41b353020202da431890'
    error: remote did not send all necessary objects

    is there a way i can make the github website create me a massive .zip file i can download with my web browser?
    guide works fine - the accusatory tone won't get you anywhere.

    Delete the build tree, check your internet connection, and restart the guide.

    Those errors mean you've been rate limited by google's site for some reason, and the latter one means the .git folder of that repo is corrupted. Like I said, just restart.
    1
    pls dont!!! it's working fine for me and I use it daily
    Oh? Interesting, my Miracast dingle doesn't like v20. I'll leave it then
  • 19
    lineage-os-logo.png

    LG V20

    Code:
    - Your warranty is now void.
    - You have been warned.
    - Use at your own risk.

    Introduction:
    This is the Official Lineage OS 18.1 thread for the LG V20.

    Downloads:
    Please follow the install instructions in your device's Wiki page linked below exactly, and make sure your device's firmware matches the required firmware listed.
    If you don't follow these instructions, or use 3rd party add-ons (like Magisk) please don't expect support here.

    Known Bugs:
    • IMS (VoLTE/Wi-Fi Calling) doesn't work due to framework tie-ins used by the LG proprietary binaries.
    • Find any? Report them according to this guide.
    Notes:
    • The only supported GApps package at the moment is MindTheGapps, linked on our Wiki page about gapps.
    Kernel Source: https://github.com/LineageOS/android_kernel_lge_msm8996
    6
    On my LG v20 H910 with LOS 18.1 lineage-18.1-20210722-nightly-h910-signed.zip
    (nothing else installed, no gapps, no mods, no root, etc...) the "LOS SNAP CAMERA" VIDEO record sound volume is almost 0%

    SAME ISSUE ON Lg v20 H918 !!!!!!! I have that phone also.

    After days of research and playing with mixer_paths_tasha.xml settings I gave up..... PROBLEM VERIFIED: its a LOS snap camera apk issue.

    Then I installed ROM [android 11] UNOFFICIAL SuperiorOS-Xcalibur

    https://forum.xda-developers.com/t/...96-11-unofficial-superioros-xcalibur.4248255/

    COMING FROM LINEAGE/RR:

    1. Boot into twrp
    2. Do a regular wipe (not format)
    3. Flash Superior zip
    4. Flash magisk (optional but recommended)
    5. Wipe dalvik
    6. Reboot

    CAMERA VIEDO WORKS PERFECT !!!!
    PERFECT SOUND !!!



    To LOS maintainers: Fix the LOS SNAP CAMERA apk or quit screwing around with programming android ROMs. Simple as that. I am a MSEE engineering manager and if I cant do my job right I don't do it at all.


    The LOS snap camera has been broken for a very long time (years) and many people have had to use GCAM or Open Camera and all these people including myself are sick that LOS maintainers can't fix a simple but very important apk in LOS (CAMERA video sound issue). This is well documented all over LOS wiki and github etc.....

    FROM: bernardobas, Senior Member


    "Hi @npjohnson
    Open Camera (and BSG GCam 8.1) uses unprocessed-mic by default to get audio while recording video."


    I am done with LOS until this is fixed. YOU ARE WASTING MY TIME
    Yeah, considering h910/h918 are near identical, makes sense that they both suffer.

    By your own statement, you're an engineer, and should be able to discern based on the info you gave me that it is _not_ an issue with the "Snap Camera apk", instead that we are using compressed audio path, and clearly it isn't processing right (likely a codec issue like I mentioned several posts ago). We could swap it to unprocessed mic input, but that will be garbled and awful - only using that as a last resort as opposed to actually fixing the compressed audio route.

    As for the insults launched - k, stop using lineage then. I literally have not a care in the world whether you use it. I'm doing hard work for free, which, as an engineer, you should understand is often thankless, and your naggy/attacking comments only make me want to never touch the device again :)

    I'll be looking at it sometime this week, but for everyone else on this thread who has been kind and supportive lol.
    5
    On my LG v20 H910 with LOS 18.1 lineage-18.1-20210722-nightly-h910-signed.zip
    (nothing else installed, no gapps, no mods, no root, etc...) the "LOS SNAP CAMERA" VIDEO record sound volume is almost 0%

    SAME ISSUE ON Lg v20 H918 !!!!!!! I have that phone also.

    After days of research and playing with mixer_paths_tasha.xml settings I gave up..... PROBLEM VERIFIED: its a LOS snap camera apk issue.

    Then I installed ROM [android 11] UNOFFICIAL SuperiorOS-Xcalibur

    https://forum.xda-developers.com/t/...96-11-unofficial-superioros-xcalibur.4248255/

    COMING FROM LINEAGE/RR:

    1. Boot into twrp
    2. Do a regular wipe (not format)
    3. Flash Superior zip
    4. Flash magisk (optional but recommended)
    5. Wipe dalvik
    6. Reboot

    CAMERA VIEDO WORKS PERFECT !!!!
    PERFECT SOUND !!!



    To LOS maintainers: Fix the LOS SNAP CAMERA apk or quit screwing around with programming android ROMs. Simple as that. I am a MSEE engineering manager and if I cant do my job right I don't do it at all.


    The LOS snap camera has been broken for a very long time (years) and many people have had to use GCAM or Open Camera and all these people including myself are sick that LOS maintainers can't fix a simple but very important apk in LOS (CAMERA video sound issue). This is well documented all over LOS wiki and github etc.....

    FROM: bernardobas, Senior Member


    "Hi @npjohnson
    Open Camera (and BSG GCam 8.1) uses unprocessed-mic by default to get audio while recording video."


    I am done with LOS until this is fixed. YOU ARE WASTING MY TIME
    Maybe you should go back to stock? You do realize we do this for free and on our own time? If there are any issues we try to fix them ASAP but with your comments I doubt @npjohnson is going to want to support the device anymore. If there is any issue I would recommend reporting it in a less-hostile way and it might be a simple fix rather than insulting the primary dev for LOS on the device who may now not want to support the device anymore...
    4
    Moderator Announcement

    Thread slightly cleaned!

    This is a development site and people contribute work as a fun hobby, NOT A JOB! They don't owe you anything but you owe the developers respect!
    If a ROM does not work for you, what did you do to contribute? Did you clean flash? More important, did you run a log of errors to help the developer? Just remember what you would expect in your profession. Or were you just too lazy to help and prefer to leech and complain?
    This world will only get better if we all learn to give instead of always taking! Please do not comment on rude posts, please report and a moderator will help.
    Thank you all for your cooperation.

    Regards
    Oswald Boelcke
    Senior Moderator
    2
    On my LG v20 H910 with LOS 18.1 lineage-18.1-20210722-nightly-h910-signed.zip
    (nothing else installed, no gapps, no mods, no root, etc...) the "LOS SNAP CAMERA" VIDEO record sound volume is almost 0%

    SAME ISSUE ON Lg v20 H918 !!!!!!! I have that phone also.

    After days of research and playing with mixer_paths_tasha.xml settings I gave up..... PROBLEM VERIFIED: its a LOS snap camera apk issue.

    Then I installed ROM [android 11] UNOFFICIAL SuperiorOS-Xcalibur

    https://forum.xda-developers.com/t/...96-11-unofficial-superioros-xcalibur.4248255/

    COMING FROM LINEAGE/RR:

    1. Boot into twrp
    2. Do a regular wipe (not format)
    3. Flash Superior zip
    4. Flash magisk (optional but recommended)
    5. Wipe dalvik
    6. Reboot

    CAMERA VIEDO WORKS PERFECT !!!!
    PERFECT SOUND !!!



    To LOS maintainers: Fix the LOS SNAP CAMERA apk or quit screwing around with programming android ROMs. Simple as that. I am a MSEE engineering manager and if I cant do my job right I don't do it at all.


    The LOS snap camera has been broken for a very long time (years) and many people have had to use GCAM or Open Camera and all these people including myself are sick that LOS maintainers can't fix a simple but very important apk in LOS (CAMERA video sound issue). This is well documented all over LOS wiki and github etc.....

    FROM: bernardobas, Senior Member


    "Hi @npjohnson
    Open Camera (and BSG GCam 8.1) uses unprocessed-mic by default to get audio while recording video."


    I am done with LOS until this is fixed. YOU ARE WASTING MY TIME
    So, my girlfriend is at home, asked her to try it - and surprise surprise, Snap Camera's video recorded audio works just fine lol. Front and rear camera.

    I did pick the patchset we merged on g5-common though afterwards, and merged it - it sounds to loud to me tbh, but enough people seem to like it better, lets go with it.