• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[OFFICIAL] LineageOS 18.1 for the LG V20

Search This thread
lineage-os-logo.png

LG V20

Code:
- Your warranty is now void.
- You have been warned.
- Use at your own risk.

Introduction:
This is the Official Lineage OS 18.1 thread for the LG V20.

Downloads:
Please follow the install instructions in your device's Wiki page linked below exactly, and make sure your device's firmware matches the required firmware listed.
If you don't follow these instructions, or use 3rd party add-ons (like Magisk) please don't expect support here.

Known Bugs:
  • IMS (VoLTE/Wi-Fi Calling) doesn't work due to framework tie-ins used by the LG proprietary binaries.
  • Find any? Report them according to this guide.
Notes:
  • The only supported GApps package at the moment is MindTheGapps, linked on our Wiki page about gapps.
Kernel Source: https://github.com/LineageOS/android_kernel_lge_msm8996

lineage-os-logo.png

LG V20

Code:
- Your warranty is now void.
- You have been warned.
- Use at your own risk.

Introduction:
This is the Official Lineage OS 18.1 thread for the LG V20.

Downloads:
Please follow the install instructions in your device's Wiki page linked below exactly, and make sure your device's firmware matches the required firmware listed.
If you don't follow these instructions, or use 3rd party add-ons (like Magisk) please don't expect support here.

Known Bugs:
  • IMS (VoLTE/Wi-Fi Calling) doesn't work due to framework tie-ins used by the LG proprietary binaries.
  • Find any? Report them according to this guide.
Notes:
  • The only supported GApps package at the moment is MindTheGapps, linked on our Wiki page about gapps.
Kernel Source: https://github.com/LineageOS/android_kernel_lge_msm8996
There's a problem. My fingerprint recognition doesn't work.
Brush back to the original system can be used.
 

itt533

Member
Nov 12, 2020
25
1
chennai
I'm surprised that it is not what LOS devs were doing already. I thought that support for the IR blaster wasn't included in LOS because it is reverse engineered and not well working. I've indeed read that the blaster works one time and hangs during some time afterwards.
As for me I've never dug into linux-android kernel sources, I can try locating the files for IR support but it sounds too simple thus i'm not sure that's really what you want.
 

askermk2000

Senior Member
Jul 9, 2015
1,183
2,628
Moto G
LG G5
@npjohnson I will be looking into the issue with IR. If I find a solution I'll share it.
I'm working on kernel for custom rom now, here is repo: mk2000-custom

Is AP/HotSpot working on stock lineage kernel? It wasn't on my kernel at first. If you see the latest commits in my git,
there are fixes to quite a lot of issues with the bcmdhd driver (from nvidia engineers). I should mention I'm using newer
driver from latest LG sources, so it's a bit more updated even without the nvidia patches.

A G5 dev has tested my kernel and got approx 1,5 h extra SOT doing youtube playback test, from 5 1/2 to 7 hours.

Is it ok by you if I post a few beta builds here? I don't want to maintain a separate thread for this, I don't even have a V20.
 

npjohnson

Recognized Developer
@npjohnson I will be looking into the issue with IR. If I find a solution I'll share it.
I'm working on kernel for custom rom now, here is repo: mk2000-custom

Is AP/HotSpot working on stock lineage kernel? It wasn't on my kernel at first. If you see the latest commits in my git,
there are fixes to quite a lot of issues with the bcmdhd driver (from nvidia engineers). I should mention I'm using newer
driver from latest LG sources, so it's a bit more updated even without the nvidia patches.

A G5 dev has tested my kernel and got approx 1,5 h extra SOT doing youtube playback test, from 5 1/2 to 7 hours.

Is it ok by you if I post a few beta builds here? I don't want to maintain a separate thread for this, I don't even have a V20.
hotspot works fine, and no - please don't - it complicates getting logs from people to have mods like that in the thread - it's own thread would be more appropriate.
 

askermk2000

Senior Member
Jul 9, 2015
1,183
2,628
Moto G
LG G5
hotspot works fine, and no - please don't - it complicates getting logs from people to have mods like that in the thread - it's own thread would be more appropriate.

Ok. My previous thread here is closed so that's why I asked.
Do you get a "HotSpot" icon in the quick settings? If not then is because of a problem with the kernel driver, which there is a fix for:
 

npjohnson

Recognized Developer
Ok. My previous thread here is closed so that's why I asked.
Do you get a "HotSpot" icon in the quick settings? If not then is because of a problem with the kernel driver, which there is a fix for:
I do get the tile.
 

askermk2000

Senior Member
Jul 9, 2015
1,183
2,628
Moto G
LG G5

Uh I see. I got the wrong impression because that icon just popped up in my rom after applying some fixes to kernel.
I got panic while enabling AP at first. The reason is either because I'm using new compiler vs gcc4.9 or that some other parts is updated (I'm on 3.18.140).
In any case one of those patches from nvidia addressed the problem exactly.
 

Electrolite_XYZ

Senior Member
Feb 6, 2018
125
15
test

interesting. i didn't know it works like that. is that how the lg v20 stock rom worked? i always found the sound quality to be subpar when the option was off in stock or lineage. i thought the toggle is actually for the dac/amp combo. i use pretty good iems too (moondrop blessing 2, jh13v2).

Sorry for the late reply.

On the stock rom it detected the impedance of the headphone and then turned the amplifier on or off (high-impedance mode), there was no stock way to force the amplifier. The toggle was for the Quad-Dac only.

I'm not sure how it works on Lineage, if it's using the Quad-Dac at all times and the toggles only forces the amplifier or if the toggles turn both the amp and the DAC on.
 
Last edited:

mehsme

Member
Jun 16, 2020
8
2
Having issues with VS995 (Verizon) with connecting & staying on LTE networks with the default APN settings.
When my "preferred network type" is set to the default (LTE/CDMA/EvDo/GSM/WCDMA), it only connects to 3G.
When set to "LTE", it connects to the 4G/LTE network just fine, BUT, my mobile connection (phonecalls/texts etc. ) stops working.

Tried resetting APN settings, re-seating the SIM card, etc., but I seem to forever be stuck with a slower network speed.

Wondering if anyone else has had similar issues, or if anyone has any tips on resolution.
New SIM solved this for me. Carry on & keep up the great work ya'll.
 

Aethera

Senior Member
Feb 18, 2012
209
45
Bay Area
Looks like the reboot problem is solved. I changed the SIM card and the current SIM card is also activated and have not had and reboot issues. Has anyone ever experienced an issue with phone rebooting due to a bad SIM?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Sad to say that unfortunately due to persistent crashes I had to give up on LOS 18.1 on my h918. I started from scratch after flashing stock KDZ numerous times and no matter what LOS would start crashing. The most recent episode after the latest LOS update started occurring seemingly for no reason in the middle of the night when the phone just kept booting and crashing over and over. Wiping Dalvik/cache had no effect. I simply couldn't take it any more. I never experienced repeated crashes like this on stock.

    I'm on rooted stock 20h now and it is very stable and it's nice to have wifi calling and a few other features also.

    If anyone wants to know how I got to rooted 20h I first flashed 10p using LGUP, then using lafsploit on mAID system installed TWRP. From there I flashed H91820h.zip image (which doesn't overwrite bootloader) and Magisk.
    2
    how do you switch the 2 cameras in Open Camera?
    there is a small button on the top right corner of the main shutter button
    1
    The LAF method is what has to be used to get root + recovery on the h918. That is the method I used.
    from stock 8.0, reboot to bootloader, fastboot oem unlock, then you can use dirtycow (unpatched on newest firmwares) to get root and flash your recovery - there are a plethora of other exploits that work to root the device.

    You can alternatively simplify all of this with lglaf (https://gitlab.com/runningnak3d/lglaf) - but the point is, a lot of the guides here on XDA needlessly complicate this whole process.
    1
    Google Camera [5.1.018.177470874]

    Mentioned and posted a few pages back
    I think I've found the unicorn of gcam apps. For LG V20/LOS 18.1. MGC_8.1.101_A9_GV1u_ENG.apk from here: https://www.celsoazevedo.com/files/android/google-camera/dev-bsg/f/dl55/
    Video works on Selfie and back cam. Photos work on Selfie and back cam. No special files needed to make things work.
    1
    pls dont!!! it's working fine for me and I use it daily
    Oh? Interesting, my Miracast dingle doesn't like v20. I'll leave it then
  • 19
    lineage-os-logo.png

    LG V20

    Code:
    - Your warranty is now void.
    - You have been warned.
    - Use at your own risk.

    Introduction:
    This is the Official Lineage OS 18.1 thread for the LG V20.

    Downloads:
    Please follow the install instructions in your device's Wiki page linked below exactly, and make sure your device's firmware matches the required firmware listed.
    If you don't follow these instructions, or use 3rd party add-ons (like Magisk) please don't expect support here.

    Known Bugs:
    • IMS (VoLTE/Wi-Fi Calling) doesn't work due to framework tie-ins used by the LG proprietary binaries.
    • Find any? Report them according to this guide.
    Notes:
    • The only supported GApps package at the moment is MindTheGapps, linked on our Wiki page about gapps.
    Kernel Source: https://github.com/LineageOS/android_kernel_lge_msm8996
    6
    On my LG v20 H910 with LOS 18.1 lineage-18.1-20210722-nightly-h910-signed.zip
    (nothing else installed, no gapps, no mods, no root, etc...) the "LOS SNAP CAMERA" VIDEO record sound volume is almost 0%

    SAME ISSUE ON Lg v20 H918 !!!!!!! I have that phone also.

    After days of research and playing with mixer_paths_tasha.xml settings I gave up..... PROBLEM VERIFIED: its a LOS snap camera apk issue.

    Then I installed ROM [android 11] UNOFFICIAL SuperiorOS-Xcalibur

    https://forum.xda-developers.com/t/...96-11-unofficial-superioros-xcalibur.4248255/

    COMING FROM LINEAGE/RR:

    1. Boot into twrp
    2. Do a regular wipe (not format)
    3. Flash Superior zip
    4. Flash magisk (optional but recommended)
    5. Wipe dalvik
    6. Reboot

    CAMERA VIEDO WORKS PERFECT !!!!
    PERFECT SOUND !!!



    To LOS maintainers: Fix the LOS SNAP CAMERA apk or quit screwing around with programming android ROMs. Simple as that. I am a MSEE engineering manager and if I cant do my job right I don't do it at all.


    The LOS snap camera has been broken for a very long time (years) and many people have had to use GCAM or Open Camera and all these people including myself are sick that LOS maintainers can't fix a simple but very important apk in LOS (CAMERA video sound issue). This is well documented all over LOS wiki and github etc.....

    FROM: bernardobas, Senior Member


    "Hi @npjohnson
    Open Camera (and BSG GCam 8.1) uses unprocessed-mic by default to get audio while recording video."


    I am done with LOS until this is fixed. YOU ARE WASTING MY TIME
    Yeah, considering h910/h918 are near identical, makes sense that they both suffer.

    By your own statement, you're an engineer, and should be able to discern based on the info you gave me that it is _not_ an issue with the "Snap Camera apk", instead that we are using compressed audio path, and clearly it isn't processing right (likely a codec issue like I mentioned several posts ago). We could swap it to unprocessed mic input, but that will be garbled and awful - only using that as a last resort as opposed to actually fixing the compressed audio route.

    As for the insults launched - k, stop using lineage then. I literally have not a care in the world whether you use it. I'm doing hard work for free, which, as an engineer, you should understand is often thankless, and your naggy/attacking comments only make me want to never touch the device again :)

    I'll be looking at it sometime this week, but for everyone else on this thread who has been kind and supportive lol.
    5
    On my LG v20 H910 with LOS 18.1 lineage-18.1-20210722-nightly-h910-signed.zip
    (nothing else installed, no gapps, no mods, no root, etc...) the "LOS SNAP CAMERA" VIDEO record sound volume is almost 0%

    SAME ISSUE ON Lg v20 H918 !!!!!!! I have that phone also.

    After days of research and playing with mixer_paths_tasha.xml settings I gave up..... PROBLEM VERIFIED: its a LOS snap camera apk issue.

    Then I installed ROM [android 11] UNOFFICIAL SuperiorOS-Xcalibur

    https://forum.xda-developers.com/t/...96-11-unofficial-superioros-xcalibur.4248255/

    COMING FROM LINEAGE/RR:

    1. Boot into twrp
    2. Do a regular wipe (not format)
    3. Flash Superior zip
    4. Flash magisk (optional but recommended)
    5. Wipe dalvik
    6. Reboot

    CAMERA VIEDO WORKS PERFECT !!!!
    PERFECT SOUND !!!



    To LOS maintainers: Fix the LOS SNAP CAMERA apk or quit screwing around with programming android ROMs. Simple as that. I am a MSEE engineering manager and if I cant do my job right I don't do it at all.


    The LOS snap camera has been broken for a very long time (years) and many people have had to use GCAM or Open Camera and all these people including myself are sick that LOS maintainers can't fix a simple but very important apk in LOS (CAMERA video sound issue). This is well documented all over LOS wiki and github etc.....

    FROM: bernardobas, Senior Member


    "Hi @npjohnson
    Open Camera (and BSG GCam 8.1) uses unprocessed-mic by default to get audio while recording video."


    I am done with LOS until this is fixed. YOU ARE WASTING MY TIME
    Maybe you should go back to stock? You do realize we do this for free and on our own time? If there are any issues we try to fix them ASAP but with your comments I doubt @npjohnson is going to want to support the device anymore. If there is any issue I would recommend reporting it in a less-hostile way and it might be a simple fix rather than insulting the primary dev for LOS on the device who may now not want to support the device anymore...
    4
    Moderator Announcement

    Thread slightly cleaned!

    This is a development site and people contribute work as a fun hobby, NOT A JOB! They don't owe you anything but you owe the developers respect!
    If a ROM does not work for you, what did you do to contribute? Did you clean flash? More important, did you run a log of errors to help the developer? Just remember what you would expect in your profession. Or were you just too lazy to help and prefer to leech and complain?
    This world will only get better if we all learn to give instead of always taking! Please do not comment on rude posts, please report and a moderator will help.
    Thank you all for your cooperation.

    Regards
    Oswald Boelcke
    Senior Moderator
    2
    On my LG v20 H910 with LOS 18.1 lineage-18.1-20210722-nightly-h910-signed.zip
    (nothing else installed, no gapps, no mods, no root, etc...) the "LOS SNAP CAMERA" VIDEO record sound volume is almost 0%

    SAME ISSUE ON Lg v20 H918 !!!!!!! I have that phone also.

    After days of research and playing with mixer_paths_tasha.xml settings I gave up..... PROBLEM VERIFIED: its a LOS snap camera apk issue.

    Then I installed ROM [android 11] UNOFFICIAL SuperiorOS-Xcalibur

    https://forum.xda-developers.com/t/...96-11-unofficial-superioros-xcalibur.4248255/

    COMING FROM LINEAGE/RR:

    1. Boot into twrp
    2. Do a regular wipe (not format)
    3. Flash Superior zip
    4. Flash magisk (optional but recommended)
    5. Wipe dalvik
    6. Reboot

    CAMERA VIEDO WORKS PERFECT !!!!
    PERFECT SOUND !!!



    To LOS maintainers: Fix the LOS SNAP CAMERA apk or quit screwing around with programming android ROMs. Simple as that. I am a MSEE engineering manager and if I cant do my job right I don't do it at all.


    The LOS snap camera has been broken for a very long time (years) and many people have had to use GCAM or Open Camera and all these people including myself are sick that LOS maintainers can't fix a simple but very important apk in LOS (CAMERA video sound issue). This is well documented all over LOS wiki and github etc.....

    FROM: bernardobas, Senior Member


    "Hi @npjohnson
    Open Camera (and BSG GCam 8.1) uses unprocessed-mic by default to get audio while recording video."


    I am done with LOS until this is fixed. YOU ARE WASTING MY TIME
    So, my girlfriend is at home, asked her to try it - and surprise surprise, Snap Camera's video recorded audio works just fine lol. Front and rear camera.

    I did pick the patchset we merged on g5-common though afterwards, and merged it - it sounds to loud to me tbh, but enough people seem to like it better, lets go with it.