[OFFICIAL] LineageOS 18.1 for the LG V20

Search This thread

nostupidthing

Senior Member
Nov 1, 2012
1,102
269
I mean, you can if you really want to. But do a backup first, as you will have to format it because the label is used for the sdcard's UUID within the Filesystem, so just renaming it on a PC through Windows or whatever won't work (at least it didn't here).
Thx! How so? have been trying to find a "rename" option in settings to no avail...
 

AShiningRay

Senior Member
Sep 1, 2021
119
48
Xiaomi Redmi Note 4
LG V20
Thx! How so? have been trying to find a "rename" option in settings to no avail...
Don't remember exactly how i did it to rename mine, i think i used Gparted on my linux distro to format it to a suitable partition format and renamed it before the UUID was calculated, then i just inserted into my phone and it recognized the renamed SD right away. Not sure if android 11 has such a feature, or even windows for that matter.
 

mathew2214

Member
Mar 31, 2019
22
5
still cant get the fingerprint scanner to work. us996

anybody able to get it to work on this ROM? what workaround did you use?

nvmd. downgraded to nougat and reflashed. it works now.

any way to force more than 5 fingerprints?
 
Last edited:

hamid_valad

Senior Member
Dec 30, 2009
290
31
Tehran
Hi

It's been a while since I was here, because I could not find ANY solution for my issues and I learned the hard way not to have hope for any fix and live with what I have.

I was passing by this forum and thought to ask if any of them got fixed

my device:
LG v20! h990-DS

my problems:

1. kernel crash on mobile data almost every 20minutes. (wont happen if I'm on wifi)
2. gps takes more than 10 minutes to find my accurate location.
3. camera....... #$#[email protected]#$
4. infrared is not working
5. screen cast is not working
6. apps not working here (while they worked flawlessly in unofficial version)
7. no clipboard
8. no one-hand operation mode

and the fun part is that in the OP, the only issue is the VoLTE!

so, if any one has any recommendation for any of the above issues (specially number 1 and 2) I would love to hear

PS. GCAM is not a fix, for 2 reasons.
1. it does not work properly
2. I cant video call with it! can I?!
 

npjohnson

Recognized Developer
Hi

It's been a while since I was here, because I could not find ANY solution for my issues and I learned the hard way not to have hope for any fix and live with what I have.

I was passing by this forum and thought to ask if any of them got fixed

my device:
LG v20! h990-DS

my problems:

1. kernel crash on mobile data almost every 20minutes. (wont happen if I'm on wifi)
2. gps takes more than 10 minutes to find my accurate location.
3. camera....... #$#[email protected]#$
4. infrared is not working
5. screen cast is not working
6. apps not working here (while they worked flawlessly in unofficial version)
7. no clipboard
8. no one-hand operation mode

and the fun part is that in the OP, the only issue is the VoLTE!

so, if any one has any recommendation for any of the above issues (specially number 1 and 2) I would love to hear

PS. GCAM is not a fix, for 2 reasons.
1. it does not work properly
2. I cant video call with it! can I?!
Did you start on Nougat firmware? It sounds like you started on Oreo.

1. Are you running the normal lineage kernel? I don't see such crashes on H918 - maybe it's the dual SIM stuff that makes it happen?
2. GPS should be fine on Nougat firmware
3. Again, camera works on Nougat firmware
4. IR is a known issue - it works once, trying to figure out what kernel commit fixes it - as gamma kernel apparently fixes it
5. Screen cast works fine, miricast isn't available for this device, I'll hide the toggle.
6. Something is seriously wrong with your install
7. Again, something is seriously wrong, all this works for everyone else for hte ost part
8. Yeah, LineageOS doesn't have that feature on 18.1
 
  • Like
Reactions: hamid_valad

hamid_valad

Senior Member
Dec 30, 2009
290
31
Tehran
Did you start on Nougat firmware? It sounds like you started on Oreo.

1. Are you running the normal lineage kernel? I don't see such crashes on H918 - maybe it's the dual SIM stuff that makes it happen?
2. GPS should be fine on Nougat firmware
3. Again, camera works on Nougat firmware
4. IR is a known issue - it works once, trying to figure out what kernel commit fixes it - as gamma kernel apparently fixes it
5. Screen cast works fine, miricast isn't available for this device, I'll hide the toggle.
6. Something is seriously wrong with your install
7. Again, something is seriously wrong, all this works for everyone else for hte ost part
8. Yeah, LineageOS doesn't have that feature on 18.1

Yup.

I had oreo when I went to 17.1 and fingerprint scanner didn't work. so I went back to Nougat to make it work. when 18.1 unofficial got released i went from 17.1 to 18.1, and when official 18.1 released, I clean installed 18.1

1. I'm using official kernel now. I tried Gamma before, and it was worse! it would heat up, freeze and etc... I don't know the reason, but I think when signal is low and phone switches between 4g and 3g it crashes. not sure though. I read in the forum that installing the modem may fix this issue, but I have no idea where I can find the files nor how to install it!
2. GPS takes almost 10 minutes or more (some times forever!) to get my exact location.
3. How is camera fine? sometimes it takes plain green pictures, sometimes it fails to take a picture, video is frame by frame!
4. I heard that IR works on some Gamma kernels, but haven't tried myself.
5. can't share my screen to my Samsung TV, something that I was able to do on stock rom.
6. :) I really don'y know what is going on, I tried to contact the app developers but haven't had any luck yet.
7. My bad, I don't have clipboard "history" (I forgot to mention history. sorry). very useful function, available on stock rom.
8. again another miss from stock rom.

but thank you for responding to me. I have this device as my daily driver and re-installing all apps and redoing settings and logins is so frustrating that I just can't go through with it for a factory reset or another clean install.

I had another issue on my friends device. I installed TWRP and did all the wipes and formats available, (data, cache, etc).

but after installing the rom and first boot, the phone asked for a password! and entering his old password worked!

How is that possible? shouldn't a clean install make a clean slate? like new device?
maybe there are residues from old roms that I had before that create these issues. not sure how his device is working though.
 
Last edited:

npjohnson

Recognized Developer
Yup. I came from Nougat to unofficial 18.1, then when official 18.1 released, I clean installed 18.1

1. I'm using official kernel now. I tried Gamma before, and it was worse! it would heat up, freeze and etc... I don't know the reason, but I think when signal is low and phone switches between 4g and 3g it crashes. not sure though. I read in the forum that installing the modem may fix this issue, but I have no idea where I can find the files nor how to install it!
2. GPS takes almost 10 minutes or more (some times forever!) to get my exact location.
3. How is camera fine? sometimes it takes plain green pictures, sometimes it fails to take a picture, video is frame by frame!
4. I heard that IR works on some Gamma kernels, but haven't tried myself.
5. can't share my screen to my Samsung TV, something that I was able to do on stock rom.
6. :) I really don'y know what is going on, I tried to contact the app developers but haven't had any luck yet.
7. My bad, I don't have clipboard "history" (I forgot to mention history. sorry). very useful function, available on stock rom.
8. again another miss from stock rom.

but thank you for responding to me. I have this device as my daily driver and re-installing all apps and redoing settings and logins is so frustrating that I just can't go through with it for a factory reset or another clean install.

I had another issue on my friends device. I installed TWRP and did all the wipes and formats available, (data, cache, etc).

but after installing the rom and first boot, the phone asked for a password! and entering his old password worked!

How is that possible? shouldn't a clean install make a clean slate? like new device?
maybe there are residuals from old roms that create these issues. not sure how his device is working though.
If it asked for a password you're not doing a format. You're wiping files.

And it's why your experience is so poor.

Stop using TWRP for install, and use Lineage Recovery, fully format the partitions instead of leaving stuff behind, your experience will be wayyy better. You probably still have data from the unofficial and others.
 
  • Like
Reactions: hamid_valad

hamid_valad

Senior Member
Dec 30, 2009
290
31
Tehran
If it asked for a password you're not doing a format. You're wiping files.

And it's why your experience is so poor.

Stop using TWRP for install, and use Lineage Recovery, fully format the partitions instead of leaving stuff behind, your experience will be wayyy better. You probably still have data from the unofficial and others.
I use lineage recovery on my device.

as I said it was my friends phone that I used TWRP and I did all the formats and wipes like I said.
I don't know if his device is working fine or not. I haven't heard from him since. maybe thats a good sign :)

on my device, all I did was having a clean install. no MODs, no Volcan, no XMLs, no zips. just a clean install.

maybe you install some thing along side it that helps?

any idea is welcomed here. (just not a hard reset :( )
 

josephww

Member
Nov 11, 2021
7
1
System UI crashes one per day at least. This was a clean install from 7.0.
System UI often crashes due to connecting to a VPN or wifi issues or SIM card issues (System always crashes with a sim card in at boot.)

Something else that makes this unusable and annoying this that WIFI does not automatically reconnect and the fact I have to click "connect away" and that "connect anyway" is not remembered.
 
Last edited:
  • Like
Reactions: hamid_valad

A.Whit

Senior Member
Jul 11, 2021
57
13
System UI crashes one per day at least. This was a clean install from 7.0.
System UI often crashes due to connecting to a VPN or wifi issues or SIM card issues (System always crashes with a sim card in at boot.)

Something else that makes this unusable and annoying this that WIFI does not automatically reconnect and the fact I have to click "connect away" and that "connect anyway" is not remembered.
What v20 model do you have
 

josephww

Member
Nov 11, 2021
7
1
What v20 model do you have
H910. Tried Old TWRP new TWRP and Lineage OS Recovery. Installed about 10 times.

Tried H91010r and H91010q after the fingerprint didn't work after installing from Oreo (but wifi did)

The wifi connects for a split second, says limited connection, and then disconnects and then tried to reconnect unlimited times. If I tick the wifi debugging the connection the wifi stays connected and I can browse the internet but after that, all wifi connections are not visible and then the system UI will crash.

*Update*
After I did a new install from Oreo now both the Fingerprint reader and wifi are non-working.

I switched over to LighthouseOS and now everything works perfect :)
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Does anyone know if LOS 19.1 will be available for the LG V20?
    1
    Does anyone know if LOS 19.1 will be available for the LG V20?
    Nope. Kernel is 3.18 which can't ever properly work with android S.
    1
    18 is bad. does not work correctly. i was stupid and jumped the gun & made my edc 18. now i am dieing to get back to what worked correctly (17 works) . but 17 just reboots back to the os over and over since i put 18 on it
    Then you're doing something wrong. It works for everyone else. Follow the guide from 0 and it will work.
    1
    Just got an urgent text notification from my carrier Metro By T-Mobile (formerly MetroPCS):


    Does anyone recommend a good carrier in the USA that doesn't require VoLTE?
    if you haven't noticed by now, everyone will be requiring VoLTE but that and VoWiFi both are industry hot messes for the last decade (this has been causing so many problems for me through supporting my parents in the last couple months).

    my recommendation is move your phone number to a voip service, like google voice (for americans), then you can at least avoid some of the hassles, but still may potentially be issues calling 911 as that is not really clear (and likely also broken by ATT whitelist crap).
  • 23
    lineage-os-logo.png

    LG V20

    Code:
    - Your warranty is now void.
    - You have been warned.
    - Use at your own risk.

    Introduction:
    This is the Official Lineage OS 18.1 thread for the LG V20.

    Downloads:
    Please follow the install instructions in your device's Wiki page linked below exactly, and make sure your device's firmware matches the required firmware listed.
    If you don't follow these instructions, or use 3rd party add-ons (like Magisk) please don't expect support here.

    Known Bugs:
    • IMS (VoLTE/Wi-Fi Calling) doesn't work due to framework tie-ins used by the LG proprietary binaries.
    • Find any? Report them according to this guide.
    Notes:
    • The only supported GApps package at the moment is MindTheGapps, linked on our Wiki page about gapps.
    Kernel Source: https://github.com/LineageOS/android_kernel_lge_msm8996
    6
    On my LG v20 H910 with LOS 18.1 lineage-18.1-20210722-nightly-h910-signed.zip
    (nothing else installed, no gapps, no mods, no root, etc...) the "LOS SNAP CAMERA" VIDEO record sound volume is almost 0%

    SAME ISSUE ON Lg v20 H918 !!!!!!! I have that phone also.

    After days of research and playing with mixer_paths_tasha.xml settings I gave up..... PROBLEM VERIFIED: its a LOS snap camera apk issue.

    Then I installed ROM [android 11] UNOFFICIAL SuperiorOS-Xcalibur

    https://forum.xda-developers.com/t/...96-11-unofficial-superioros-xcalibur.4248255/

    COMING FROM LINEAGE/RR:

    1. Boot into twrp
    2. Do a regular wipe (not format)
    3. Flash Superior zip
    4. Flash magisk (optional but recommended)
    5. Wipe dalvik
    6. Reboot

    CAMERA VIEDO WORKS PERFECT !!!!
    PERFECT SOUND !!!



    To LOS maintainers: Fix the LOS SNAP CAMERA apk or quit screwing around with programming android ROMs. Simple as that. I am a MSEE engineering manager and if I cant do my job right I don't do it at all.


    The LOS snap camera has been broken for a very long time (years) and many people have had to use GCAM or Open Camera and all these people including myself are sick that LOS maintainers can't fix a simple but very important apk in LOS (CAMERA video sound issue). This is well documented all over LOS wiki and github etc.....

    FROM: bernardobas, Senior Member


    "Hi @npjohnson
    Open Camera (and BSG GCam 8.1) uses unprocessed-mic by default to get audio while recording video."


    I am done with LOS until this is fixed. YOU ARE WASTING MY TIME
    Yeah, considering h910/h918 are near identical, makes sense that they both suffer.

    By your own statement, you're an engineer, and should be able to discern based on the info you gave me that it is _not_ an issue with the "Snap Camera apk", instead that we are using compressed audio path, and clearly it isn't processing right (likely a codec issue like I mentioned several posts ago). We could swap it to unprocessed mic input, but that will be garbled and awful - only using that as a last resort as opposed to actually fixing the compressed audio route.

    As for the insults launched - k, stop using lineage then. I literally have not a care in the world whether you use it. I'm doing hard work for free, which, as an engineer, you should understand is often thankless, and your naggy/attacking comments only make me want to never touch the device again :)

    I'll be looking at it sometime this week, but for everyone else on this thread who has been kind and supportive lol.
    5
    On my LG v20 H910 with LOS 18.1 lineage-18.1-20210722-nightly-h910-signed.zip
    (nothing else installed, no gapps, no mods, no root, etc...) the "LOS SNAP CAMERA" VIDEO record sound volume is almost 0%

    SAME ISSUE ON Lg v20 H918 !!!!!!! I have that phone also.

    After days of research and playing with mixer_paths_tasha.xml settings I gave up..... PROBLEM VERIFIED: its a LOS snap camera apk issue.

    Then I installed ROM [android 11] UNOFFICIAL SuperiorOS-Xcalibur

    https://forum.xda-developers.com/t/...96-11-unofficial-superioros-xcalibur.4248255/

    COMING FROM LINEAGE/RR:

    1. Boot into twrp
    2. Do a regular wipe (not format)
    3. Flash Superior zip
    4. Flash magisk (optional but recommended)
    5. Wipe dalvik
    6. Reboot

    CAMERA VIEDO WORKS PERFECT !!!!
    PERFECT SOUND !!!



    To LOS maintainers: Fix the LOS SNAP CAMERA apk or quit screwing around with programming android ROMs. Simple as that. I am a MSEE engineering manager and if I cant do my job right I don't do it at all.


    The LOS snap camera has been broken for a very long time (years) and many people have had to use GCAM or Open Camera and all these people including myself are sick that LOS maintainers can't fix a simple but very important apk in LOS (CAMERA video sound issue). This is well documented all over LOS wiki and github etc.....

    FROM: bernardobas, Senior Member


    "Hi @npjohnson
    Open Camera (and BSG GCam 8.1) uses unprocessed-mic by default to get audio while recording video."


    I am done with LOS until this is fixed. YOU ARE WASTING MY TIME
    Maybe you should go back to stock? You do realize we do this for free and on our own time? If there are any issues we try to fix them ASAP but with your comments I doubt @npjohnson is going to want to support the device anymore. If there is any issue I would recommend reporting it in a less-hostile way and it might be a simple fix rather than insulting the primary dev for LOS on the device who may now not want to support the device anymore...
    4
    Moderator Announcement

    Thread slightly cleaned!

    This is a development site and people contribute work as a fun hobby, NOT A JOB! They don't owe you anything but you owe the developers respect!
    If a ROM does not work for you, what did you do to contribute? Did you clean flash? More important, did you run a log of errors to help the developer? Just remember what you would expect in your profession. Or were you just too lazy to help and prefer to leech and complain?
    This world will only get better if we all learn to give instead of always taking! Please do not comment on rude posts, please report and a moderator will help.
    Thank you all for your cooperation.

    Regards
    Oswald Boelcke
    Senior Moderator
    3
    Will you working on Lineage OS 19?
    Lineage OS 19 is based on Android 12, so the chance of it even booting on the current 3.18 kernel is very slim, we'll need to update a lot of things including a major kernel version bump to reach a reasonable state to port anything Android 12 so it will likely take a while. Even kernel 4.4 still requires a ton of patching to be able to boot android 12