[OFFICIAL] LineageOS 18.1 for the LG V20

Search This thread

Camboozle

Member
Apr 24, 2013
48
11
Phoenix
LG V20
OnePlus 9 Pro
Have you cleared out all the memory using twrp? I sometimes have issues when I don't reformat the data, but be sure to back everything up first if needed.

I basically clear all memory except the external sdcard and it fixes any issues I had.

Edit: After reading your other posts one thing worth mentioning is I never touch the boot when I install lineageOS. I let it install it's own boot. I only change the boot.img when I flash the patched one for magisk. Maybe using the other boot.img is you problem, so I suggest backing up, clearing all memory esp data in twrp, flashing lineage, and stop flashing the boot and let lineage boot up on its own. You can then pull the boot.img from lineage if you need it.
 
Last edited:

ugoplatamia

Member
May 14, 2021
11
0
Have you cleared out all the memory using twrp? I sometimes have issues when I don't reformat the data, but be sure to back everything up first if needed.

I basically clear all memory except the external sdcard and it fixes any issues I had.

Edit: After reading your other posts one thing worth mentioning is I never touch the boot when I install lineageOS. I let it install it's own boot. I only change the boot.img when I flash the patched one for magisk. Maybe using the other boot.img is you problem, so I suggest backing up, clearing all memory esp data in twrp, flashing lineage, and stop flashing the boot and let lineage boot up on its own. You can then pull the boot.img from lineage if you need it.
This is what I do:
1. Wipe > Format Data
2. Wipe > Advanced Wipe > Dalvik, System, Data, Internal, Cache
3. Install LineageOS + MindTheGapps

And it still throws error 1 on TWRP.

Also for the boot.img thing, that never worked anyways so I abandoned that and just tried to install the OS without any modifications.
 

Camboozle

Member
Apr 24, 2013
48
11
Phoenix
LG V20
OnePlus 9 Pro
I've always used the twrp method, so I've never troubleshot that method. But I have only had those errors when I didn't clear something out. Typically the data clear works. I also like to start the phone up prior to installing gapps. I don't install gapps prior or i have had issues.
 

ugoplatamia

Member
May 14, 2021
11
0
Yeah just tried having only LineageOS and it still kernel panics. I'm just gonna leave this picture of the screen when it kernel panics and see what happens.
 

Attachments

  • IMG_20210515_234143.jpg
    IMG_20210515_234143.jpg
    2.3 MB · Views: 28

zack1175

Senior Member
Feb 19, 2014
89
31
room's nice, snappy and simple
I especially love the 2nd screen as status bar feature, but now it acts as a part of the main screen, which makes youtube unfortunately scratched and some part cannot be showed.

how can i fix that?
 

andruyd

Senior Member
Dec 14, 2011
112
9
Does h990 mean that it works for h990DS?
Might be a noobie question, but I just moved from my G5 to a V20 and I don't know if h990 is like an "umbrella term" for all h990 variants or not.
And I only need to downgrade to Nougat, unlock the bootloader and flash lineageOS 18.1 for it to work?
I'm asking because the G5 had an issue where you had to clean flash LOS 15 and then dirty flash 16, then 17 etc. to get sensors and camera working and I understand that these devices are quite similar.
Sorry if these seem to be stupid questions. I'm just trying to figure everything out and sometimes it's not easy to find potentially obvious answers to some questions.
Did you figure your stuff out? I have an H990N and I flashed the official H990 LOS 18.1 and almost everything works except that almost all the GCAM apps I tried kept crashing.
 

Rom1995

Member
Jul 5, 2012
17
4
Did you figure your stuff out? I have an H990N and I flashed the official H990 LOS 18.1 and almost everything works except that almost all the GCAM apps I tried kept crashing.
Does the cam work on stock app? I tried the old gcam bt it works fine. Nt sure if its cause i flash the magisk pie camera driver
 

andruyd

Senior Member
Dec 14, 2011
112
9
Does the cam work on stock app? I tried the old gcam bt it works fine. Nt sure if its cause i flash the magisk pie camera driver
Yes, stock LOS cam works. Open Camera works. The device specific GCAM modded apps are the ones not working on H990N (HW/FW), latest LOS18.1-H990.

One more thing is that the dirtysanta directions for H990* variants are instructed to flash a kernel. I think that might have something to do with this. See: https://forum.xda-developers.com/t/root-dirtysanta-comes-for-the-h990.3624296/

FYI: if you're on H990N (maybe all H990 variants) don't flash to twrp-3.5.2_9-0-h990.img. This version does not work. twrp-3.3.0-0-h990.img up to twrp-3.5.1_9-0-h990.img works as I installed them one by one in increasing versions.
 
Last edited:

Epifistu

Member
Oct 28, 2013
32
4
Did you figure your stuff out? I have an H990N and I flashed the official H990 LOS 18.1 and almost everything works except that almost all the GCAM apps I tried kept crashing.
I'm still hesitant to root my H990DS because 1. I don't have so much time at the moment and 2. somebody potentially bricked their H990DS recently.
That sucks with the GCAM, my G5 had issues with GCAM as well and I couldn't find anybody else with the same issues. I hoped that the V20 wouldn't have these issues... Seems like I bought the "wrong" V20 variant to have it easy :D

Which guide did you follow to root your H990N? Did you run into any problems or deviations from the guide?

FYI: if you're on H990N (maybe all H990 variants) don't flash to twrp-3.5.2_9-0-h990.img. This version does not work. twrp-3.3.0-0-h990.img up to twrp-3.5.1_9-0-h990.img works as I installed them one by one in increasing versions.

Did you directly flash TWRP 3.3.0-0 during the rooting procedure or the older version which is mentioned in the guide? Same for Magisk, did you use an old version or the up to date one?
I've seen different reports of RUNMEFIRST.BAT not prompting for step2, did you encounter this issue as well?

Probably it's too off-topic for this thread, but it would be great if you could answer me in the dirtysanta thread (or PM me, but I guess other people could take advantage as well).
 
Last edited:

andruyd

Senior Member
Dec 14, 2011
112
9
I'm still hesitant to root my H990DS because 1. I don't have so much time at the moment and 2. somebody potentially bricked their H990DS recently.
That sucks with the GCAM, my G5 had issues with GCAM as well and I couldn't find anybody else with the same issues. I hoped that the V20 wouldn't have these issues... Seems like I bought the "wrong" V20 variant to have it easy :D

Which guide did you follow to root your H990N? Did you run into any problems or deviations from the guide?



Did you directly flash TWRP 3.3.0-0 during the rooting procedure or the older version which is mentioned in the guide? Same for Magisk, did you use an old version or the up to date one?
I've seen different reports of RUNMEFIRST.BAT not prompting for step2, did you encounter this issue as well?

Probably it's too off-topic for this thread, but it would be great if you could answer me in the dirtysanta thread (or PM me, but I guess other people could take advantage as well).
It looked daunting at first but after doing this dirtysanta process for my H915 and H990N, I can say it's super easy and as long as you can read and follow directions without deviating you shouldn't brick your phone. It takes less than 30 minutes to do everything (conservative estimate) and if you've got it down maybe 15 minutes. The key thing is having your computer setup for ADB.
I'm still hesitant to root my H990DS because 1. I don't have so much time at the moment and 2. somebody potentially bricked their H990DS recently.
That sucks with the GCAM, my G5 had issues with GCAM as well and I couldn't find anybody else with the same issues. I hoped that the V20 wouldn't have these issues... Seems like I bought the "wrong" V20 variant to have it easy :D

Which guide did you follow to root your H990N? Did you run into any problems or deviations from the guide?



Did you directly flash TWRP 3.3.0-0 during the rooting procedure or the older version which is mentioned in the guide? Same for Magisk, did you use an old version or the up to date one?
I've seen different reports of RUNMEFIRST.BAT not prompting for step2, did you encounter this issue as well?

Probably it's too off-topic for this thread, but it would be great if you could answer me in the dirtysanta thread (or PM me, but I guess other people could take advantage as well).
Assuming you have a Windows PC, this (
) is the instruction I used and it works for my H915 and H990N. It's covers everything you need and the links for the files are also provided.

If you get stuck just make a post here and I can answer or someone else. It takes me less than 15 minutes to do the whole thing now that I have ran through it several times.
 

andruyd

Senior Member
Dec 14, 2011
112
9
I'm still hesitant to root my H990DS because 1. I don't have so much time at the moment and 2. somebody potentially bricked their H990DS recently.
That sucks with the GCAM, my G5 had issues with GCAM as well and I couldn't find anybody else with the same issues. I hoped that the V20 wouldn't have these issues... Seems like I bought the "wrong" V20 variant to have it easy :D

Which guide did you follow to root your H990N? Did you run into any problems or deviations from the guide?



Did you directly flash TWRP 3.3.0-0 during the rooting procedure or the older version which is mentioned in the guide? Same for Magisk, did you use an old version or the up to date one?
I've seen different reports of RUNMEFIRST.BAT not prompting for step2, did you encounter this issue as well?

Probably it's too off-topic for this thread, but it would be great if you could answer me in the dirtysanta thread (or PM me, but I guess other people could take advantage as well).
A this point (
) is key because you need to modify the script from this:
fastboot flash boot boot
fastboot flash recovery twrp-3.0.2-1-us996.img
fastboot flash boot boot
fastboot flash recovery twrp-3.0.2-1-us996.img
fastboot flash boot boot
fastboot flash recovery twrp-3.0.2-1-us996.img
fastboot flash boot boot
fastboot flash recovery twrp-3.0.2-1-us996.img
fastboot flash boot boot
fastboot reboot
to this (https://dl.twrp.me/h990/twrp-3.3.0-0-h990.img.html):
fastboot flash boot boot.img
fastboot flash recovery twrp-3.3.0-0-h990.img
fastboot flash boot boot.img
fastboot flash recovery twrp-3.3.0-0-h990.img
fastboot flash boot boot.img
fastboot flash recovery twrp-3.3.0-0-h990.img
fastboot flash boot boot.img
fastboot flash recovery twrp-3.3.0-0-h990.img
fastboot flash boot boot.img
fastboot reboot
 

andruyd

Senior Member
Dec 14, 2011
112
9
I'm still hesitant to root my H990DS because 1. I don't have so much time at the moment and 2. somebody potentially bricked their H990DS recently.
That sucks with the GCAM, my G5 had issues with GCAM as well and I couldn't find anybody else with the same issues. I hoped that the V20 wouldn't have these issues... Seems like I bought the "wrong" V20 variant to have it easy :D

Which guide did you follow to root your H990N? Did you run into any problems or deviations from the guide?



Did you directly flash TWRP 3.3.0-0 during the rooting procedure or the older version which is mentioned in the guide? Same for Magisk, did you use an old version or the up to date one?
I've seen different reports of RUNMEFIRST.BAT not prompting for step2, did you encounter this issue as well?

Probably it's too off-topic for this thread, but it would be great if you could answer me in the dirtysanta thread (or PM me, but I guess other people could take advantage as well).
Another important thing is to download the right KDZ image. This is what I used for H990N (https://lg-firmwares.com/downloads-file/4065/H990N10b_00_OPEN_HK_DS_OP_1017)
 

andruyd

Senior Member
Dec 14, 2011
112
9
I'm still hesitant to root my H990DS because 1. I don't have so much time at the moment and 2. somebody potentially bricked their H990DS recently.
That sucks with the GCAM, my G5 had issues with GCAM as well and I couldn't find anybody else with the same issues. I hoped that the V20 wouldn't have these issues... Seems like I bought the "wrong" V20 variant to have it easy :D

Which guide did you follow to root your H990N? Did you run into any problems or deviations from the guide?



Did you directly flash TWRP 3.3.0-0 during the rooting procedure or the older version which is mentioned in the guide? Same for Magisk, did you use an old version or the up to date one?
I've seen different reports of RUNMEFIRST.BAT not prompting for step2, did you encounter this issue as well?

Probably it's too off-topic for this thread, but it would be great if you could answer me in the dirtysanta thread (or PM me, but I guess other people could take advantage as well).
Since the video is for H910, you have to pay attention to the steps where it's talking about H910 because you're going to need to replace that with H990N specific files. The key is using the right files for your device.

If you're nervous at all and about to **** your pants while attempting this, don't do it LOL. Better to be stock than bricked.
 

dilligaf56

Senior Member
Feb 22, 2011
146
23
SoCal, USA
18.1 worked fine on my US996, except for fingerprint sensor, so I did a TWRP backup (was on the 2021-04-29 nightly), then flashed Nougat (10n) KDZ and re-rooted. All good; phone booted into stock rooted Nougat fine. Re-booted to TWRP, wiped, restored my 18.1 setup and Magisk 23.0, then dirty-flashed the 2021-05-13 update. It boots up fine, but I can't unlock the phone (PIN won't work). Is there a default PIN on Lineage? Another way to remove the PIN lock? Or do I have to start over with a clean flash of the new ROM?
Maybe wipe, restore previous setup (2021-04-29) again, remove PIN lock, then dirty flash?

TIA!
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    room's nice, snappy and simple
    I especially love the 2nd screen as status bar feature, but now it acts as a part of the main screen, which makes youtube unfortunately scratched and some part cannot be showed.

    how can i fix that?
    You can disable the notch in developer settings.
    1
    Can i dirty flash this over unofficial?
    1
    Tried the last (wiped, restored /system, /data, and cache from my backup). PIN still doesn't work. Do I need to restore another partition to fix it?
    You may have not had a PIN previously, but it sounds like your backup /data was encrypted. A big headache. You may get access if you can restore the matching partitions, which may include /firmware but most certainly /boot...i don't know. I'd also have TWRP up to 3.5.1_9-0

    See this post for a possible solution for you:

    Attached here is a .zip I pulled from our V20 forum that may work. I've flashed both from recovery with no issues.

    Bottom line:
    Any new system >=Oreo with encryption by default, I flash a decryption disabler and check security settings after first boot, and if it's still encrypted: Hard Pass
    1
    @ssurell:
    Neither one of the .zips was able to unlock my old backup (04-30), but using yours on the latest clean flash DID prevent it from becoming locked - I was able to back up and restore the 05-13 version, with a PIN lock, then unlock it after the restore with no issues. The prior setup (04-30) DID have a PIN in place before being backed up.

    SO, it appears that the answer is installing one of the .zip files immediately after clean-flashing a ROM - this prevents the issue.

    Thanks again!
    1
    I tried different version of TWRP and its now giving me a error 1 when I try to install LIneageOS.
    Means your download was bad - hence why it panicked. Redownload LineageOS/Gapps.
    Can i dirty flash this over unofficial?
    No, it will boot-loop.
    18.1 worked fine on my US996, except for fingerprint sensor, so I did a TWRP backup (was on the 2021-04-29 nightly), then flashed Nougat (10n) KDZ and re-rooted. All good; phone booted into stock rooted Nougat fine. Re-booted to TWRP, wiped, restored my 18.1 setup and Magisk 23.0, then dirty-flashed the 2021-05-13 update. It boots up fine, but I can't unlock the phone (PIN won't work). Is there a default PIN on Lineage? Another way to remove the PIN lock? Or do I have to start over with a clean flash of the new ROM?
    Maybe wipe, restore previous setup (2021-04-29) again, remove PIN lock, then dirty flash?

    TIA!
    Just format data and set it back up, all should work fine!
  • 10
    lineage-os-logo.png

    LG V20

    Code:
    - Your warranty is now void.
    - You have been warned.
    - Use at your own risk.

    Introduction:
    This is the Official Lineage OS 18.1 thread for the LG V20.

    Downloads:
    Please follow the install instructions in your device's Wiki page linked below exactly, and make sure your device's firmware matches the required firmware listed.
    If you don't follow these instructions, or use 3rd party add-ons (like Magisk) please don't expect support here.

    Known Bugs:
    • IMS (VoLTE/Wi-Fi Calling) doesn't work due to framework tie-ins used by the LG proprietary binaries.
    • Find any? Report them according to this guide.
    Notes:
    • The only supported GApps package at the moment is MindTheGapps, linked on our Wiki page about gapps.
    Kernel Source: https://github.com/LineageOS/android_kernel_lge_msm8996
    1
    Спасибо за новую версию ОС Android Linegae!
    В настоящее время я использую Lineage OS 17.1, нужно ли мне вернуться к стандартной прошивке LG перед прошивкой этого ПЗУ?
    Нет. Но нужно удалить гаппсы 17.1. Протрите систему.
    1
    On 04-01, I updated to TWRP 3.5.1 and did a clean install of this ROM (04-01). I wiped & formatted, after making a copy of my internal storage to a PC. The install went great. I reinstalled my apps and then flashed Magisk 22.0. Everything I tried worked well (BT, GPS, quad DAC).

    Today, I updated to TWRP 3.5.2 and Magisk 22.1. Then, I dirty flashed the 04-15 nightly. Magisk patched new boot.img automatically and everything is working well.

    Thanks to npjohnson and x86cpu for keeping my travel device up-to-date. :)
    it was almost all aleasto this cycle!
    1
    Hallo, as there is now an offical LOS 18.1, i am asking here again.

    Does encryption and mounting encrypted volume in LOS 18 work now, or is LOS 16 still the last version, were it works?
    I would try myself but doing an upgrade and than downgrade again, if it still doesnt work, is a big hassle.
    Somebody have encryption on and can mount and decrypt the DATA Volume in TWRP?

    encryption work very good on 18.1 for lg V20 h910 phone i think other versions work too.. i not know about what is mounting. you mean TWRP? i do OTA update in lieageos 18.1 and it remove twrp and make lineage recovery.. i dont no how i install TWRP again... i cant check... sorry
    1
    maybe make latest available version firmware? maybe 2019... i not know what is last version, my phone vendor security is 2017... how i upgrade to 2018 or 2019 if possible to make? thx :) soryr for bad engglish
    we support the G5/v20/G6 all in one common tree. This means we can use most Oreo blobs (and do) on v20.

    But we have to use a few Nougat blobs for the G5 as it never got Oreo.

    I'll be updating the vendor date for the v20 to reflect the latest Oreo build, and G5 for Nougat soon.

    Bootstacks/firmware will remain whatever you're on. I'm not touching that, as each variant is different and there are too many to account for.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone